]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- sample how to bind additional socket
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
5febf716
ER
6# - lighttpd writes early startup messages to stderr, and if started from
7# rc-scripts the stderr is closed which causes lighttpd to abort():
8# 2006-07-20 21:05:52: (server.c.1233) WARNING: unknown config-key: url.rewrite-final (ignored)
05f8c491 9#
79404238 10# NOTES:
79404238
ER
11# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
12# see http://article.gmane.org/gmane.comp.web.lighttpd:722
13#
4f968063 14# Conditional build for lighttpd:
8d377a51 15%bcond_without xattr # support of extended attributes
16%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
17%bcond_without largefile # largefile support (see notes above)
18%bcond_without ssl # ssl support
5febf716 19%bcond_without mysql # mysql support in mod_mysql_vhost
8d377a51 20%bcond_with ldap # ldap support in mod_auth
26843c13 21%bcond_without lua # LUA support in mod_cml (needs LUA >= 5.1)
8d377a51 22%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
2a732f8a 23%bcond_with gamin # gamin for reducing number of stat() calls.
8d377a51 24 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
25%bcond_with gdbm # gdbm in mod_trigger_b4_dl
26%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
15bf768a 27%bcond_with webdav_locks # webdav locks with extra efsprogs deps
8d377a51 28%bcond_with valgrind # compile code with valgrind support.
5febf716 29%bcond_with deflate # build deflate module (needs patch update with current svn)
79404238 30
5febf716
ER
31# SVN snapshot
32#define _svn 1277
21d3dba8 33# Prerelease
47abd4ea 34#define _snap r1332
2abd0792 35
7e95562d 36%if %{with webdav_locks}
15bf768a 37%define webdav_progs 1
38%endif
39
a800d9b6 40%define _rel 6.2
027853cc 41Summary: Fast and light HTTP server
42Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 43Name: lighttpd
48986775 44Version: 1.4.13
5febf716 45Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
4241e769 46License: BSD
0296e68a 47Group: Networking/Daemons
47abd4ea 48Source0: http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
48986775 49# Source0-md5: d775d6478391b95d841a1018c8db0b95
bee4f74e 50Source1: %{name}.init
2f7162ab
AM
51Source2: %{name}.conf
52Source3: %{name}.user
607835c0 53Source4: %{name}.logrotate
c54ca3d2 54Source5: %{name}.sysconfig
87c01276 55Source6: %{name}-mime.types.sh
9647a089
ER
56Source7: http://www.lighttpd.net/favicon.ico
57# Source7-md5: a358994becabd4060393a5454bde505d
58Source8: http://www.lighttpd.net/light_button.png
59# Source8-md5: 02330e2313fadc29144edfd6000879f8
60Source9: http://www.lighttpd.net/light_logo.png
61# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
c4128c50
ER
62Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
63# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
66f5ed22 64Source11: %{name}-pld.html
ac4cc36e 65Source12: %{name}.monitrc
5febf716
ER
66Source100: %{name}-mod_access.conf
67Source101: %{name}-mod_accesslog.conf
68Source102: %{name}-mod_alias.conf
69Source103: %{name}-mod_auth.conf
70Source104: %{name}-mod_cgi.conf
71Source105: %{name}-mod_cml.conf
72Source106: %{name}-mod_compress.conf
73Source107: %{name}-mod_deflate.conf
74Source108: %{name}-mod_dirlisting.conf
75Source109: %{name}-mod_evasive.conf
76Source110: %{name}-mod_evhost.conf
77Source111: %{name}-mod_expire.conf
78Source112: %{name}-mod_fastcgi.conf
79Source113: %{name}-mod_flv_streaming.conf
80Source114: %{name}-mod_indexfile.conf
81Source115: %{name}-mod_proxy.conf
82Source116: %{name}-mod_redirect.conf
83Source117: %{name}-mod_rewrite.conf
84Source118: %{name}-mod_rrdtool.conf
85Source119: %{name}-mod_scgi.conf
86Source120: %{name}-mod_secdownload.conf
87Source121: %{name}-mod_setenv.conf
88Source122: %{name}-mod_simple_vhost.conf
89Source123: %{name}-mod_ssi.conf
90Source124: %{name}-mod_staticfile.conf
91Source125: %{name}-mod_status.conf
92Source126: %{name}-mod_trigger_b4_dl.conf
93Source127: %{name}-mod_userdir.conf
94Source128: %{name}-mod_usertrack.conf
95Source129: %{name}-mod_webdav.conf
96Source130: %{name}-php-spawned.conf
97Source131: %{name}-php-external.conf
98Source132: %{name}-ssl.conf
0f9dfecb
ER
99Source133: %{name}-mod_mysql_vhost.conf
100Source134: %{name}-mod_magnet.conf
9d166fb8 101Source135: %{name}-mod_extforward.conf
13e3ef3b 102#Patch100: %{name}-branch.diff
48986775
ER
103Patch0: %{name}-use_bin_sh.patch
104Patch1: %{name}-mod_evasive-status_code.patch
105Patch2: %{name}-mod_deflate.patch
93347afb 106Patch3: %{name}-mod_extforward-v2.patch
a800d9b6 107Patch4: %{name}-mod_expire-weeks.patch
70373b58 108URL: http://www.lighttpd.net/
cc769ac6 109%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
110BuildRequires: autoconf
111BuildRequires: automake
112BuildRequires: bzip2-devel
a800d9b6 113BuildRequires: fcgi-devel
9c336869 114%{?with_gamin:BuildRequires: gamin-devel}
6ec064d6
KK
115%{?with_gdbm:BuildRequires: gdbm-devel}
116%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 117BuildRequires: libtool
5febf716 118BuildRequires: libuuid-devel
6ec064d6 119%{?with_webdav_props:BuildRequires: libxml2-devel}
26843c13 120%{?with_lua:BuildRequires: lua51-devel}
6ec064d6 121BuildRequires: mailcap >= 2.1.14-4.4
cc769ac6 122%{?with_mysql:BuildRequires: mysql-devel}
6ec064d6 123%{?with_ldap:BuildRequires: openldap-devel}
49163762 124%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 125BuildRequires: pcre-devel
6ec064d6 126BuildRequires: pkgconfig
2a732f8a 127BuildRequires: rpmbuild(macros) >= 1.268
66f5ed22 128%{?with_webdav_props:BuildRequires: sqlite3-devel}
83ca4b2b 129%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 130BuildRequires: zlib-devel
66f5ed22
ER
131Requires(post,preun): /sbin/chkconfig
132Requires(postun): /usr/sbin/groupdel
133Requires(postun): /usr/sbin/userdel
bee4f74e
AM
134Requires(pre): /bin/id
135Requires(pre): /usr/bin/getgid
5febf716 136Requires(pre): /usr/lib/rpm/user_group.sh
bee4f74e
AM
137Requires(pre): /usr/sbin/groupadd
138Requires(pre): /usr/sbin/useradd
28537382 139Requires(pre): /usr/sbin/usermod
5febf716
ER
140Requires: %{name}-mod_dirlisting
141Requires: %{name}-mod_indexfile
142Requires: %{name}-mod_staticfile
66f5ed22 143Requires: rc-scripts
5180cbd5 144Requires: webapps
6230924e 145Provides: group(http)
e68efba2 146Provides: group(lighttpd)
e68efba2 147Provides: user(lighttpd)
1a75d3e1 148Provides: webserver
0296e68a
ER
149# for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
150Conflicts: rpm < 4.4.2-0.2
bee4f74e
AM
151BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
152
153%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 154%define _lighttpddir /home/services/%{name}
bee4f74e
AM
155%define _sysconfdir /etc/%{name}
156
157%description
f655b1fd 158lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
159which has been optimized for high-performance environments. It has a
160very low memory footprint compared to other webservers and takes care
161of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
162Output-Compression, URL-Rewriting and many more) make lighttpd the
163perfect webserver-software for every server that is suffering load
164problems.
165
f655b1fd
MC
166%description -l pl
167lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 168