]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- patch is back: always use /bin/sh when executing subshell
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
5febf716
ER
6# - lighttpd writes early startup messages to stderr, and if started from
7# rc-scripts the stderr is closed which causes lighttpd to abort():
8# 2006-07-20 21:05:52: (server.c.1233) WARNING: unknown config-key: url.rewrite-final (ignored)
05f8c491 9#
79404238
ER
10# NOTES:
11# - fcgi-devel is only used for the test-scripts
12# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
13# see http://article.gmane.org/gmane.comp.web.lighttpd:722
14#
4f968063 15# Conditional build for lighttpd:
8d377a51 16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
5febf716 20%bcond_without mysql # mysql support in mod_mysql_vhost
8d377a51 21%bcond_with ldap # ldap support in mod_auth
59d721a3 22%bcond_without lua # LUA support in mod_cml (needs LUA >= 5.1)
8d377a51 23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
2a732f8a 24%bcond_with gamin # gamin for reducing number of stat() calls.
8d377a51 25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
28%bcond_with valgrind # compile code with valgrind support.
5febf716 29%bcond_with deflate # build deflate module (needs patch update with current svn)
79404238 30
5febf716
ER
31# SVN snapshot
32#define _svn 1277
21d3dba8
ER
33# Prerelease
34%define _snap r1309
2abd0792 35
0f9dfecb 36%define _rel 0.60
027853cc 37Summary: Fast and light HTTP server
38Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 39Name: lighttpd
5febf716
ER
40Version: 1.4.12
41Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
4241e769 42License: BSD
0296e68a 43Group: Networking/Daemons
5febf716 44Source0: http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
21d3dba8 45# Source0-md5: a887b075858cb28bf9fd11d86556509e
bee4f74e 46Source1: %{name}.init
2f7162ab
AM
47Source2: %{name}.conf
48Source3: %{name}.user
607835c0 49Source4: %{name}.logrotate
c54ca3d2 50Source5: %{name}.sysconfig
87c01276 51Source6: %{name}-mime.types.sh
9647a089
ER
52Source7: http://www.lighttpd.net/favicon.ico
53# Source7-md5: a358994becabd4060393a5454bde505d
54Source8: http://www.lighttpd.net/light_button.png
55# Source8-md5: 02330e2313fadc29144edfd6000879f8
56Source9: http://www.lighttpd.net/light_logo.png
57# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
c4128c50
ER
58Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
59# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
66f5ed22 60Source11: %{name}-pld.html
5febf716
ER
61Source100: %{name}-mod_access.conf
62Source101: %{name}-mod_accesslog.conf
63Source102: %{name}-mod_alias.conf
64Source103: %{name}-mod_auth.conf
65Source104: %{name}-mod_cgi.conf
66Source105: %{name}-mod_cml.conf
67Source106: %{name}-mod_compress.conf
68Source107: %{name}-mod_deflate.conf
69Source108: %{name}-mod_dirlisting.conf
70Source109: %{name}-mod_evasive.conf
71Source110: %{name}-mod_evhost.conf
72Source111: %{name}-mod_expire.conf
73Source112: %{name}-mod_fastcgi.conf
74Source113: %{name}-mod_flv_streaming.conf
75Source114: %{name}-mod_indexfile.conf
76Source115: %{name}-mod_proxy.conf
77Source116: %{name}-mod_redirect.conf
78Source117: %{name}-mod_rewrite.conf
79Source118: %{name}-mod_rrdtool.conf
80Source119: %{name}-mod_scgi.conf
81Source120: %{name}-mod_secdownload.conf
82Source121: %{name}-mod_setenv.conf
83Source122: %{name}-mod_simple_vhost.conf
84Source123: %{name}-mod_ssi.conf
85Source124: %{name}-mod_staticfile.conf
86Source125: %{name}-mod_status.conf
87Source126: %{name}-mod_trigger_b4_dl.conf
88Source127: %{name}-mod_userdir.conf
89Source128: %{name}-mod_usertrack.conf
90Source129: %{name}-mod_webdav.conf
91Source130: %{name}-php-spawned.conf
92Source131: %{name}-php-external.conf
93Source132: %{name}-ssl.conf
0f9dfecb
ER
94Source133: %{name}-mod_mysql_vhost.conf
95Source134: %{name}-mod_magnet.conf
96#Patch100: %{name}-branch.diff
5ef9311f 97Patch0: %{name}-mod_deflate.patch
507f6bc1 98Patch2: %{name}-initgroups.patch
5febf716
ER
99Patch3: http://trac.lighttpd.net/trac/attachment/ticket/444/%{name}-apr1.patch?format=txt
100Patch4: %{name}-mod_evasive-status_code.patch
59d721a3 101Patch5: %{name}-lua-version.patch
70373b58 102URL: http://www.lighttpd.net/
cc769ac6 103%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
104BuildRequires: autoconf
105BuildRequires: automake
106BuildRequires: bzip2-devel
9c336869 107%{?with_gamin:BuildRequires: gamin-devel}
6ec064d6
KK
108%{?with_gdbm:BuildRequires: gdbm-devel}
109%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 110BuildRequires: libtool
5febf716 111BuildRequires: libuuid-devel
6ec064d6 112%{?with_webdav_props:BuildRequires: libxml2-devel}
6ec064d6
KK
113%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-5.1}
114BuildRequires: mailcap >= 2.1.14-4.4
cc769ac6 115%{?with_mysql:BuildRequires: mysql-devel}
6ec064d6 116%{?with_ldap:BuildRequires: openldap-devel}
49163762 117%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 118BuildRequires: pcre-devel
6ec064d6 119BuildRequires: pkgconfig
2a732f8a 120BuildRequires: rpmbuild(macros) >= 1.268
66f5ed22 121%{?with_webdav_props:BuildRequires: sqlite3-devel}
83ca4b2b 122%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 123BuildRequires: zlib-devel
66f5ed22
ER
124Requires(post,preun): /sbin/chkconfig
125Requires(postun): /usr/sbin/groupdel
126Requires(postun): /usr/sbin/userdel
bee4f74e
AM
127Requires(pre): /bin/id
128Requires(pre): /usr/bin/getgid
5febf716 129Requires(pre): /usr/lib/rpm/user_group.sh
bee4f74e
AM
130Requires(pre): /usr/sbin/groupadd
131Requires(pre): /usr/sbin/useradd
28537382 132Requires(pre): /usr/sbin/usermod
5febf716
ER
133Requires: %{name}-mod_dirlisting
134Requires: %{name}-mod_indexfile
135Requires: %{name}-mod_staticfile
66f5ed22 136Requires: rc-scripts
6230924e 137Provides: group(http)
e68efba2 138Provides: group(lighttpd)
e68efba2 139Provides: user(lighttpd)
1a75d3e1 140Provides: webserver
0296e68a
ER
141# for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
142Conflicts: rpm < 4.4.2-0.2
bee4f74e
AM
143BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
144
145%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 146%define _lighttpddir /home/services/%{name}
bee4f74e
AM
147%define _sysconfdir /etc/%{name}
148
149%description
f655b1fd 150lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
151which has been optimized for high-performance environments. It has a
152very low memory footprint compared to other webservers and takes care
153of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
154Output-Compression, URL-Rewriting and many more) make lighttpd the
155perfect webserver-software for every server that is suffering load
156problems.
157
f655b1fd
MC
158%description -l pl
159lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 160