]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- merged with 1.4.7
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
05f8c491 6#
79404238
ER
7# NOTES:
8# - fcgi-devel is only used for the test-scripts
9# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10# see http://article.gmane.org/gmane.comp.web.lighttpd:722
3a4d459f
ER
11# - please make subpackages of modules that depend other modules than:
12# - pcre (core binary needs it too)
13# - openssl (core binary needs it too)
79404238 14#
4f968063 15# Conditional build for lighttpd:
8d377a51 16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
20%bcond_with mysql # mysql support in mod_mysql_vhost
21%bcond_with ldap # ldap support in mod_auth
22%bcond_with lua # LUA support in mod_cml
23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
24%bcond_with gamin # gamin for reducing number of stat() calls.
25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
28%bcond_with valgrind # compile code with valgrind support.
79404238 29
2abd0792 30# Prerelease snapshot: DATE-TIME
79404238 31#define _snap 20050116-1743
2abd0792
ER
32
33%if 0%{?_snap}
34%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
35%else
36%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
37%endif
38
87c01276 39%define _rel 1.2
2abd0792 40
027853cc 41Summary: Fast and light HTTP server
42Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 43Name: lighttpd
e7b42085 44Version: 1.4.7
2abd0792 45Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 46Group: Networking/Daemons
4241e769 47License: BSD
2abd0792 48Source0: %{_source}
e7b42085 49# Source0-md5: 4d1b02e2008e5f35e4df7defee186fdd
bee4f74e 50Source1: %{name}.init
2f7162ab
AM
51Source2: %{name}.conf
52Source3: %{name}.user
607835c0 53Source4: %{name}.logrotate
c54ca3d2 54Source5: %{name}.sysconfig
87c01276 55Source6: %{name}-mime.types.sh
70373b58 56URL: http://www.lighttpd.net/
cc769ac6 57%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
58BuildRequires: autoconf
59BuildRequires: automake
60BuildRequires: bzip2-devel
9c336869
ER
61%{?with_gamin:BuildRequires: gamin-devel}
62%{?with_webdav_props:BuildRequires: sqlite3-devel}
63%{?with_webdav_props:BuildRequires: libxml2-devel}
1a75d3e1 64BuildRequires: libtool
cc769ac6
ER
65%{?with_mysql:BuildRequires: mysql-devel}
66%{?with_ldap:BuildRequires: openldap-devel}
49163762 67%{?with_ssl:BuildRequires: openssl-devel}
ffe2fc3c 68%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-5.1}
fda87005 69%{?with_memcache:BuildRequires: libmemcache-devel}
9c336869 70%{?with_gdbm:BuildRequires: gdbm-devel}
1a75d3e1 71BuildRequires: pcre-devel
417e0665 72BuildRequires: rpmbuild(macros) >= 1.202
83ca4b2b 73%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 74BuildRequires: zlib-devel
87c01276 75BuildRequires: mailcap >= 2.1.14-4.4
bee4f74e
AM
76PreReq: rc-scripts
77Requires(pre): sh-utils
78Requires(pre): /bin/id
79Requires(pre): /usr/bin/getgid
80Requires(pre): /usr/sbin/groupadd
81Requires(pre): /usr/sbin/useradd
82Requires(post,preun): /sbin/chkconfig
bee4f74e 83Requires(postun): /usr/sbin/groupdel
e68efba2 84Requires(postun): /usr/sbin/userdel
85Provides: group(lighttpd)
1a75d3e1 86Provides: httpd
e68efba2 87Provides: user(lighttpd)
1a75d3e1 88Provides: webserver
bee4f74e
AM
89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 92%define _lighttpddir /home/services/%{name}
bee4f74e
AM
93%define _sysconfdir /etc/%{name}
94
95%description
f655b1fd 96lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
97which has been optimized for high-performance environments. It has a
98very low memory footprint compared to other webservers and takes care
99of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
100Output-Compression, URL-Rewriting and many more) make lighttpd the
101perfect webserver-software for every server that is suffering load
102problems.
103
f655b1fd
MC
104%description -l pl
105lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 106