]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- reenable xattr
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
fda87005 4# - gdbm for mod_trigger_b4_dl http://www.lighttpd.net/documentation/trigger_b4_dl.html
05f8c491 5#
79404238
ER
6# NOTES:
7# - fcgi-devel is only used for the test-scripts
8# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
9# see http://article.gmane.org/gmane.comp.web.lighttpd:722
10#
4f968063 11# Conditional build for lighttpd:
c2bf8739 12%bcond_without xattr # with support of extended attributes (doesn't compile in 1.4.0)
1da5e2ed 13%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
79404238 14%bcond_without largefile # without largefile support (see notes above)
fda87005
ER
15%bcond_without ssl # disable ssl support
16%bcond_without mysql # without mysql
ce8f06ab 17%bcond_with ldap # with ldap
fda87005
ER
18%bcond_with lua # enable LUA support in mod_cml
19%bcond_with memcache # enable memcached support in mod_cml / mod_trigger_b4_dl
f0f1c74c 20%bcond_with valgrind # compile code with valgrind support.
dae5a344 21%bcond_with dirhide # with 'hide from dirlisting' hack
79404238 22
2abd0792 23# Prerelease snapshot: DATE-TIME
79404238 24#define _snap 20050116-1743
2abd0792
ER
25
26%if 0%{?_snap}
27%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
28%else
29%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
30%endif
31
902aa7b5 32%define _rel 1
2abd0792 33
027853cc 34Summary: Fast and light HTTP server
35Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 36Name: lighttpd
7be1c9f7 37Version: 1.4.0
2abd0792 38Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 39Group: Networking/Daemons
4241e769 40License: BSD
2abd0792 41Source0: %{_source}
7be1c9f7 42# Source0-md5: 926a3603615c9edf5859977f1b8b6033
bee4f74e 43Source1: %{name}.init
2f7162ab
AM
44Source2: %{name}.conf
45Source3: %{name}.user
607835c0 46Source4: %{name}.logrotate
c54ca3d2 47Source5: %{name}.sysconfig
e22eff1c 48Patch0: http://minghetti.ch/blob/dirlist-hide.patch
dae5a344 49Patch1: %{name}-fcgi-verbose.patch
dd7b985c 50Patch2: %{name}-ssl-redirect-fix.patch
70373b58 51URL: http://www.lighttpd.net/
cc769ac6 52%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
53BuildRequires: autoconf
54BuildRequires: automake
55BuildRequires: bzip2-devel
56BuildRequires: libtool
cc769ac6
ER
57%{?with_mysql:BuildRequires: mysql-devel}
58%{?with_ldap:BuildRequires: openldap-devel}
49163762 59%{?with_ssl:BuildRequires: openssl-devel}
fda87005
ER
60%{?with_lua:BuildRequires: lua50-devel}
61%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 62BuildRequires: pcre-devel
417e0665 63BuildRequires: rpmbuild(macros) >= 1.202
cc769ac6
ER
64%{?debug:BuildRequires: valgrind}
65BuildRequires: zlib-devel
bee4f74e
AM
66PreReq: rc-scripts
67Requires(pre): sh-utils
68Requires(pre): /bin/id
69Requires(pre): /usr/bin/getgid
70Requires(pre): /usr/sbin/groupadd
71Requires(pre): /usr/sbin/useradd
72Requires(post,preun): /sbin/chkconfig
bee4f74e 73Requires(postun): /usr/sbin/groupdel
e68efba2 74Requires(postun): /usr/sbin/userdel
75Provides: group(lighttpd)
1a75d3e1 76Provides: httpd
e68efba2 77Provides: user(lighttpd)
1a75d3e1 78Provides: webserver
bee4f74e
AM
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 82%define _lighttpddir /home/services/%{name}
bee4f74e
AM
83%define _sysconfdir /etc/%{name}
84
85%description
f655b1fd 86lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
87which has been optimized for high-performance environments. It has a
88very low memory footprint compared to other webservers and takes care
89of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
90Output-Compression, URL-Rewriting and many more) make lighttpd the
91perfect webserver-software for every server that is suffering load
92problems.
93
f655b1fd
MC
94%description -l pl
95lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 96