]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- separate modules which require extra deps to subpackages
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
fda87005 4# - gdbm for mod_trigger_b4_dl http://www.lighttpd.net/documentation/trigger_b4_dl.html
05f8c491 5#
4f968063 6# Conditional build for lighttpd:
ce8f06ab 7%bcond_without xattr # without support of extended attributes
1da5e2ed 8%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
dae5a344
ER
9# use it if you have 2.4 kernel to get sendfile() support,
10# and don't need > 2GB file requests,
11# see http://article.gmane.org/gmane.comp.web.lighttpd:722
1da5e2ed 12%bcond_without largefile # without largefile support
fda87005
ER
13%bcond_without ssl # disable ssl support
14%bcond_without mysql # without mysql
ce8f06ab 15%bcond_with ldap # with ldap
fda87005
ER
16%bcond_with lua # enable LUA support in mod_cml
17%bcond_with memcache # enable memcached support in mod_cml / mod_trigger_b4_dl
f0f1c74c 18%bcond_with valgrind # compile code with valgrind support.
dae5a344 19%bcond_with dirhide # with 'hide from dirlisting' hack
d20e182e 20#
2abd0792 21# Prerelease snapshot: DATE-TIME
c1b34484 22##define _snap 20050116-1743
2abd0792
ER
23
24%if 0%{?_snap}
25%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
26%else
27%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
28%endif
29
fda87005 30%define _rel 1.12
2abd0792 31
027853cc 32Summary: Fast and light HTTP server
33Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 34Name: lighttpd
58cbbc7f 35Version: 1.3.15
2abd0792 36Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 37Group: Networking/Daemons
4241e769 38License: BSD
2abd0792 39Source0: %{_source}
58cbbc7f 40# Source0-md5: e605ade1071f25dec9001730ec753112
bee4f74e 41Source1: %{name}.init
2f7162ab
AM
42Source2: %{name}.conf
43Source3: %{name}.user
607835c0 44Source4: %{name}.logrotate
c54ca3d2 45Source5: %{name}.sysconfig
e22eff1c 46Patch0: http://minghetti.ch/blob/dirlist-hide.patch
dae5a344 47Patch1: %{name}-fcgi-verbose.patch
dd7b985c 48Patch2: %{name}-ssl-redirect-fix.patch
70373b58 49URL: http://www.lighttpd.net/
cc769ac6 50%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
51BuildRequires: autoconf
52BuildRequires: automake
53BuildRequires: bzip2-devel
54BuildRequires: libtool
cc769ac6
ER
55%{?with_mysql:BuildRequires: mysql-devel}
56%{?with_ldap:BuildRequires: openldap-devel}
49163762 57%{?with_ssl:BuildRequires: openssl-devel}
fda87005
ER
58%{?with_lua:BuildRequires: lua50-devel}
59%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 60BuildRequires: pcre-devel
417e0665 61BuildRequires: rpmbuild(macros) >= 1.202
cc769ac6
ER
62%{?debug:BuildRequires: valgrind}
63BuildRequires: zlib-devel
bee4f74e
AM
64PreReq: rc-scripts
65Requires(pre): sh-utils
66Requires(pre): /bin/id
67Requires(pre): /usr/bin/getgid
68Requires(pre): /usr/sbin/groupadd
69Requires(pre): /usr/sbin/useradd
70Requires(post,preun): /sbin/chkconfig
bee4f74e 71Requires(postun): /usr/sbin/groupdel
e68efba2 72Requires(postun): /usr/sbin/userdel
73Provides: group(lighttpd)
1a75d3e1 74Provides: httpd
e68efba2 75Provides: user(lighttpd)
1a75d3e1 76Provides: webserver
bee4f74e
AM
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 80%define _lighttpddir /home/services/%{name}
bee4f74e
AM
81%define _sysconfdir /etc/%{name}
82
83%description
f655b1fd 84lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
85which has been optimized for high-performance environments. It has a
86very low memory footprint compared to other webservers and takes care
87of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
88Output-Compression, URL-Rewriting and many more) make lighttpd the
89perfect webserver-software for every server that is suffering load
90problems.
91
f655b1fd
MC
92%description -l pl
93lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 94