]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- valgrind bcond removed and enabled if debug is on
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8d734bed 1#
05f8c491 2# TODO
0ab57655 3# - test ldap and mysql (failed at this time)
ddfaf124 4# - documentroot specified in config doesn't exist
fcae54a7 5# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
05f8c491 6#
4f968063 7# Conditional build for lighttpd:
ce8f06ab 8%bcond_without xattr # without support of extended attributes
1da5e2ed 9%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
dae5a344
ER
10# use it if you have 2.4 kernel to get sendfile() support,
11# and don't need > 2GB file requests,
12# see http://article.gmane.org/gmane.comp.web.lighttpd:722
1da5e2ed 13%bcond_without largefile # without largefile support
1da5e2ed 14%bcond_without ssl # disable ssl support
ce8f06ab
KK
15%bcond_with mysql # with mysql
16%bcond_with ldap # with ldap
dae5a344 17%bcond_with dirhide # with 'hide from dirlisting' hack
d20e182e 18#
2abd0792 19# Prerelease snapshot: DATE-TIME
c1b34484 20##define _snap 20050116-1743
2abd0792
ER
21
22%if 0%{?_snap}
23%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
24%else
25%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
26%endif
27
dae5a344 28%define _rel 3.1
2abd0792 29
027853cc 30Summary: Fast and light HTTP server
31Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 32Name: lighttpd
14979de5 33Version: 1.3.13
2abd0792 34Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 35Group: Networking/Daemons
4241e769 36License: BSD
2abd0792 37Source0: %{_source}
14979de5 38# Source0-md5: 2f017b936be376ad6f6c2ee26db93467
bee4f74e 39Source1: %{name}.init
2f7162ab
AM
40Source2: %{name}.conf
41Source3: %{name}.user
607835c0 42Source4: %{name}.logrotate
c54ca3d2 43Source5: %{name}.sysconfig
e22eff1c 44Patch0: http://minghetti.ch/blob/dirlist-hide.patch
dae5a344
ER
45Patch1: %{name}-fcgi-verbose.patch
46Patch2: %{name}-proxy-error-handler.patch
47Patch3: %{name}-fcgi-retry-timeout.patch
70373b58 48URL: http://www.lighttpd.net/
1a75d3e1
JB
49BuildRequires: autoconf
50BuildRequires: automake
51BuildRequires: bzip2-devel
52BuildRequires: libtool
49163762 53%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 54BuildRequires: pcre-devel
e68efba2 55BuildRequires: rpmbuild(macros) >= 1.159
1a75d3e1 56BuildRequires: zlib-devel
d20e182e 57%if %{with xattr}
58BuildRequires: attr-devel
59%endif
05f8c491
ER
60%{?with_ldap:BuildRequires: openldap-devel}
61%{?with_mysql:BuildRequires: mysql-devel}
dae5a344 62%{?debug:BuildRequires: valgrind}
bee4f74e
AM
63PreReq: rc-scripts
64Requires(pre): sh-utils
65Requires(pre): /bin/id
66Requires(pre): /usr/bin/getgid
67Requires(pre): /usr/sbin/groupadd
68Requires(pre): /usr/sbin/useradd
69Requires(post,preun): /sbin/chkconfig
bee4f74e 70Requires(postun): /usr/sbin/groupdel
e68efba2 71Requires(postun): /usr/sbin/userdel
72Provides: group(lighttpd)
1a75d3e1 73Provides: httpd
e68efba2 74Provides: user(lighttpd)
1a75d3e1 75Provides: webserver
bee4f74e
AM
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 79%define _lighttpddir /home/services/%{name}
bee4f74e
AM
80%define _sysconfdir /etc/%{name}
81
82%description
f655b1fd 83lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
84which has been optimized for high-performance environments. It has a
85very low memory footprint compared to other webservers and takes care
86of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
87Output-Compression, URL-Rewriting and many more) make lighttpd the
88perfect webserver-software for every server that is suffering load
89problems.
90
f655b1fd
MC
91%description -l pl
92lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 93