]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- use pkgconfig first to find lua, this way configure is able to pick up lua libs
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869
ER
4# - fam over gamin is possible, just configure doesn't check other than gamin
5# - lua50 isn't properly detected
05f8c491 6#
79404238
ER
7# NOTES:
8# - fcgi-devel is only used for the test-scripts
9# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10# see http://article.gmane.org/gmane.comp.web.lighttpd:722
11#
4f968063 12# Conditional build for lighttpd:
9c336869
ER
13%bcond_without xattr # support of extended attributes
14%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
15%bcond_without largefile # largefile support (see notes above)
16%bcond_without ssl # ssl support
17%bcond_with mysql # mysql support in mod_mysql_vhost
18%bcond_with ldap # ldap support in mod_auth
19%bcond_with lua # LUA support in mod_cml
20%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
21%bcond_without gamin # gamin for reducing number of stat() calls. NOTE: must be enabled in config: server.stat-cache-engine = "fam"
22%bcond_with gdbm # gdbm in mod_trigger_b4_dl
23%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
24%bcond_with valgrind # compile code with valgrind support.
25%bcond_with dirhide # with 'hide from dirlisting' hack
79404238 26
2abd0792 27# Prerelease snapshot: DATE-TIME
79404238 28#define _snap 20050116-1743
2abd0792
ER
29
30%if 0%{?_snap}
31%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
32%else
33%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
34%endif
35
9c336869 36%define _rel 0.1
2abd0792 37
027853cc 38Summary: Fast and light HTTP server
39Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 40Name: lighttpd
9c336869 41Version: 1.4.1
2abd0792 42Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 43Group: Networking/Daemons
4241e769 44License: BSD
2abd0792 45Source0: %{_source}
9c336869 46# Source0-md5: 3abffbe574fd835721760a37c00d3714
bee4f74e 47Source1: %{name}.init
2f7162ab
AM
48Source2: %{name}.conf
49Source3: %{name}.user
607835c0 50Source4: %{name}.logrotate
c54ca3d2 51Source5: %{name}.sysconfig
e22eff1c 52Patch0: http://minghetti.ch/blob/dirlist-hide.patch
dae5a344 53Patch1: %{name}-fcgi-verbose.patch
dd7b985c 54Patch2: %{name}-ssl-redirect-fix.patch
70373b58 55URL: http://www.lighttpd.net/
cc769ac6 56%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
57BuildRequires: autoconf
58BuildRequires: automake
59BuildRequires: bzip2-devel
9c336869
ER
60%{?with_gamin:BuildRequires: gamin-devel}
61%{?with_webdav_props:BuildRequires: sqlite3-devel}
62%{?with_webdav_props:BuildRequires: libxml2-devel}
1a75d3e1 63BuildRequires: libtool
cc769ac6
ER
64%{?with_mysql:BuildRequires: mysql-devel}
65%{?with_ldap:BuildRequires: openldap-devel}
49163762 66%{?with_ssl:BuildRequires: openssl-devel}
fda87005
ER
67%{?with_lua:BuildRequires: lua50-devel}
68%{?with_memcache:BuildRequires: libmemcache-devel}
9c336869 69%{?with_gdbm:BuildRequires: gdbm-devel}
1a75d3e1 70BuildRequires: pcre-devel
417e0665 71BuildRequires: rpmbuild(macros) >= 1.202
cc769ac6
ER
72%{?debug:BuildRequires: valgrind}
73BuildRequires: zlib-devel
bee4f74e
AM
74PreReq: rc-scripts
75Requires(pre): sh-utils
76Requires(pre): /bin/id
77Requires(pre): /usr/bin/getgid
78Requires(pre): /usr/sbin/groupadd
79Requires(pre): /usr/sbin/useradd
80Requires(post,preun): /sbin/chkconfig
bee4f74e 81Requires(postun): /usr/sbin/groupdel
e68efba2 82Requires(postun): /usr/sbin/userdel
83Provides: group(lighttpd)
1a75d3e1 84Provides: httpd
e68efba2 85Provides: user(lighttpd)
1a75d3e1 86Provides: webserver
bee4f74e
AM
87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 90%define _lighttpddir /home/services/%{name}
bee4f74e
AM
91%define _sysconfdir /etc/%{name}
92
93%description
f655b1fd 94lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
95which has been optimized for high-performance environments. It has a
96very low memory footprint compared to other webservers and takes care
97of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
98Output-Compression, URL-Rewriting and many more) make lighttpd the
99perfect webserver-software for every server that is suffering load
100problems.
101
f655b1fd
MC
102%description -l pl
103lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 104