]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- use socket that php-fcgi-init has by default
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
05f8c491 6#
79404238
ER
7# NOTES:
8# - fcgi-devel is only used for the test-scripts
9# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10# see http://article.gmane.org/gmane.comp.web.lighttpd:722
3a4d459f
ER
11# - please make subpackages of modules that depend other modules than:
12# - pcre (core binary needs it too)
13# - openssl (core binary needs it too)
79404238 14#
4f968063 15# Conditional build for lighttpd:
8d377a51 16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
20%bcond_with mysql # mysql support in mod_mysql_vhost
21%bcond_with ldap # ldap support in mod_auth
2a732f8a 22%bcond_without lua # LUA support in mod_cml
8d377a51 23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
2a732f8a 24%bcond_with gamin # gamin for reducing number of stat() calls.
8d377a51 25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
28%bcond_with valgrind # compile code with valgrind support.
79404238 29
2abd0792 30# Prerelease snapshot: DATE-TIME
6e8945ec 31#define _snap 20060104-1523
2abd0792
ER
32
33%if 0%{?_snap}
34%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
35%else
36%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
37%endif
38
66d0d5d6 39%define _rel 3.1
2abd0792 40
027853cc 41Summary: Fast and light HTTP server
42Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 43Name: lighttpd
2c24d201 44Version: 1.4.11
2abd0792 45Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
4241e769 46License: BSD
0296e68a 47Group: Networking/Daemons
2abd0792 48Source0: %{_source}
2c24d201 49# Source0-md5: f55eebb9815c94a7de35906bb557ecd3
bee4f74e 50Source1: %{name}.init
2f7162ab
AM
51Source2: %{name}.conf
52Source3: %{name}.user
607835c0 53Source4: %{name}.logrotate
c54ca3d2 54Source5: %{name}.sysconfig
87c01276 55Source6: %{name}-mime.types.sh
9647a089
ER
56Source7: http://www.lighttpd.net/favicon.ico
57# Source7-md5: a358994becabd4060393a5454bde505d
58Source8: http://www.lighttpd.net/light_button.png
59# Source8-md5: 02330e2313fadc29144edfd6000879f8
60Source9: http://www.lighttpd.net/light_logo.png
61# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
c4128c50
ER
62Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
63# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
66f5ed22 64Source11: %{name}-pld.html
5ef9311f 65Patch0: %{name}-mod_deflate.patch
507f6bc1
ER
66Patch1: %{name}-use_bin_sh.patch
67Patch2: %{name}-initgroups.patch
66d0d5d6 68Patch3: %{name}-mod_evasive-status_code.patch
70373b58 69URL: http://www.lighttpd.net/
cc769ac6 70%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
71BuildRequires: autoconf
72BuildRequires: automake
73BuildRequires: bzip2-devel
9c336869 74%{?with_gamin:BuildRequires: gamin-devel}
6ec064d6
KK
75%{?with_gdbm:BuildRequires: gdbm-devel}
76%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 77BuildRequires: libtool
6ec064d6 78%{?with_webdav_props:BuildRequires: libxml2-devel}
6ec064d6
KK
79%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-5.1}
80BuildRequires: mailcap >= 2.1.14-4.4
cc769ac6 81%{?with_mysql:BuildRequires: mysql-devel}
6ec064d6 82%{?with_ldap:BuildRequires: openldap-devel}
49163762 83%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 84BuildRequires: pcre-devel
6ec064d6 85BuildRequires: pkgconfig
2a732f8a 86BuildRequires: rpmbuild(macros) >= 1.268
66f5ed22 87%{?with_webdav_props:BuildRequires: sqlite3-devel}
83ca4b2b 88%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 89BuildRequires: zlib-devel
66f5ed22
ER
90Requires(post,preun): /sbin/chkconfig
91Requires(postun): /usr/sbin/groupdel
92Requires(postun): /usr/sbin/userdel
bee4f74e
AM
93Requires(pre): /bin/id
94Requires(pre): /usr/bin/getgid
95Requires(pre): /usr/sbin/groupadd
96Requires(pre): /usr/sbin/useradd
66f5ed22 97Requires: rc-scripts
6230924e 98Provides: group(http)
e68efba2 99Provides: group(lighttpd)
e68efba2 100Provides: user(lighttpd)
1a75d3e1 101Provides: webserver
0296e68a
ER
102# for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
103Conflicts: rpm < 4.4.2-0.2
bee4f74e
AM
104BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 107%define _lighttpddir /home/services/%{name}
bee4f74e
AM
108%define _sysconfdir /etc/%{name}
109
110%description
f655b1fd 111lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
112which has been optimized for high-performance environments. It has a
113very low memory footprint compared to other webservers and takes care
114of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
115Output-Compression, URL-Rewriting and many more) make lighttpd the
116perfect webserver-software for every server that is suffering load
117problems.
118
f655b1fd
MC
119%description -l pl
120lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 121