]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- include webapps configs
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
05f8c491 6#
79404238
ER
7# NOTES:
8# - fcgi-devel is only used for the test-scripts
9# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10# see http://article.gmane.org/gmane.comp.web.lighttpd:722
3a4d459f
ER
11# - please make subpackages of modules that depend other modules than:
12# - pcre (core binary needs it too)
13# - openssl (core binary needs it too)
79404238 14#
4f968063 15# Conditional build for lighttpd:
8d377a51 16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
20%bcond_with mysql # mysql support in mod_mysql_vhost
21%bcond_with ldap # ldap support in mod_auth
22%bcond_with lua # LUA support in mod_cml
23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
24%bcond_with gamin # gamin for reducing number of stat() calls.
25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
28%bcond_with valgrind # compile code with valgrind support.
79404238 29
2abd0792 30# Prerelease snapshot: DATE-TIME
79404238 31#define _snap 20050116-1743
2abd0792
ER
32
33%if 0%{?_snap}
34%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
35%else
36%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
37%endif
38
805c187a 39%define _rel 3
2abd0792 40
027853cc 41Summary: Fast and light HTTP server
42Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 43Name: lighttpd
cf5e8b55 44Version: 1.4.8
2abd0792 45Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 46Group: Networking/Daemons
4241e769 47License: BSD
2abd0792 48Source0: %{_source}
cf5e8b55 49# Source0-md5: 7d7790ef95ff5755f73bfcda4f13696d
bee4f74e 50Source1: %{name}.init
2f7162ab
AM
51Source2: %{name}.conf
52Source3: %{name}.user
607835c0 53Source4: %{name}.logrotate
c54ca3d2 54Source5: %{name}.sysconfig
87c01276 55Source6: %{name}-mime.types.sh
9647a089
ER
56Source7: http://www.lighttpd.net/favicon.ico
57# Source7-md5: a358994becabd4060393a5454bde505d
58Source8: http://www.lighttpd.net/light_button.png
59# Source8-md5: 02330e2313fadc29144edfd6000879f8
60Source9: http://www.lighttpd.net/light_logo.png
61# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
c4128c50
ER
62Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
63# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
64Source11: lighttpd-pld.html
70373b58 65URL: http://www.lighttpd.net/
cc769ac6 66%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
67BuildRequires: autoconf
68BuildRequires: automake
69BuildRequires: bzip2-devel
9c336869 70%{?with_gamin:BuildRequires: gamin-devel}
6ec064d6
KK
71%{?with_gdbm:BuildRequires: gdbm-devel}
72%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 73BuildRequires: libtool
6ec064d6
KK
74%{?with_webdav_props:BuildRequires: libxml2-devel}
75%{?with_webdav_props:BuildRequires: sqlite3-devel}
76%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-5.1}
77BuildRequires: mailcap >= 2.1.14-4.4
cc769ac6 78%{?with_mysql:BuildRequires: mysql-devel}
6ec064d6 79%{?with_ldap:BuildRequires: openldap-devel}
49163762 80%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 81BuildRequires: pcre-devel
6ec064d6 82BuildRequires: pkgconfig
417e0665 83BuildRequires: rpmbuild(macros) >= 1.202
83ca4b2b 84%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 85BuildRequires: zlib-devel
bee4f74e
AM
86PreReq: rc-scripts
87Requires(pre): sh-utils
88Requires(pre): /bin/id
89Requires(pre): /usr/bin/getgid
90Requires(pre): /usr/sbin/groupadd
91Requires(pre): /usr/sbin/useradd
92Requires(post,preun): /sbin/chkconfig
bee4f74e 93Requires(postun): /usr/sbin/groupdel
e68efba2 94Requires(postun): /usr/sbin/userdel
6230924e 95Provides: group(http)
e68efba2 96Provides: group(lighttpd)
1a75d3e1 97Provides: httpd
e68efba2 98Provides: user(lighttpd)
1a75d3e1 99Provides: webserver
bee4f74e
AM
100BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 103%define _lighttpddir /home/services/%{name}
bee4f74e
AM
104%define _sysconfdir /etc/%{name}
105
106%description
f655b1fd 107lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
108which has been optimized for high-performance environments. It has a
109very low memory footprint compared to other webservers and takes care
110of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
111Output-Compression, URL-Rewriting and many more) make lighttpd the
112perfect webserver-software for every server that is suffering load
113problems.
114
f655b1fd
MC
115%description -l pl
116lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 117