]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- rel 6
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8c865192 1# TODO:
0ab57655 2# - test ldap and mysql (failed at this time)
fcae54a7 3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
9c336869 4# - fam over gamin is possible, just configure doesn't check other than gamin
ffe2fc3c 5# - feature stat-cache-fam (doesn't work)
5febf716
ER
6# - lighttpd writes early startup messages to stderr, and if started from
7# rc-scripts the stderr is closed which causes lighttpd to abort():
8# 2006-07-20 21:05:52: (server.c.1233) WARNING: unknown config-key: url.rewrite-final (ignored)
05f8c491 9#
79404238
ER
10# NOTES:
11# - fcgi-devel is only used for the test-scripts
12# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
13# see http://article.gmane.org/gmane.comp.web.lighttpd:722
14#
4f968063 15# Conditional build for lighttpd:
8d377a51 16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
5febf716 20%bcond_without mysql # mysql support in mod_mysql_vhost
8d377a51 21%bcond_with ldap # ldap support in mod_auth
26843c13 22%bcond_without lua # LUA support in mod_cml (needs LUA >= 5.1)
8d377a51 23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
2a732f8a 24%bcond_with gamin # gamin for reducing number of stat() calls.
8d377a51 25 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26%bcond_with gdbm # gdbm in mod_trigger_b4_dl
27%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
15bf768a 28%bcond_with webdav_locks # webdav locks with extra efsprogs deps
8d377a51 29%bcond_with valgrind # compile code with valgrind support.
5febf716 30%bcond_with deflate # build deflate module (needs patch update with current svn)
79404238 31
5febf716
ER
32# SVN snapshot
33#define _svn 1277
21d3dba8 34# Prerelease
47abd4ea 35#define _snap r1332
2abd0792 36
7e95562d 37%if %{with webdav_locks}
15bf768a 38%define webdav_progs 1
39%endif
40
99e172bd 41%define _rel 6
027853cc 42Summary: Fast and light HTTP server
43Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 44Name: lighttpd
48986775 45Version: 1.4.13
5febf716 46Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}%{?_svn:.%{_svn}}
4241e769 47License: BSD
0296e68a 48Group: Networking/Daemons
47abd4ea 49Source0: http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
48986775 50# Source0-md5: d775d6478391b95d841a1018c8db0b95
bee4f74e 51Source1: %{name}.init
2f7162ab
AM
52Source2: %{name}.conf
53Source3: %{name}.user
607835c0 54Source4: %{name}.logrotate
c54ca3d2 55Source5: %{name}.sysconfig
87c01276 56Source6: %{name}-mime.types.sh
9647a089
ER
57Source7: http://www.lighttpd.net/favicon.ico
58# Source7-md5: a358994becabd4060393a5454bde505d
59Source8: http://www.lighttpd.net/light_button.png
60# Source8-md5: 02330e2313fadc29144edfd6000879f8
61Source9: http://www.lighttpd.net/light_logo.png
62# Source9-md5: ac20784510e420d5cbe5fc1cdb53d7a7
c4128c50
ER
63Source10: http://gdl.hopto.org/~spider/pldstats/gfx/pld1.png
64# Source10-md5: 486ecec3f6f4fe7f9bf7cee757b864f4
66f5ed22 65Source11: %{name}-pld.html
ac4cc36e 66Source12: %{name}.monitrc
5febf716
ER
67Source100: %{name}-mod_access.conf
68Source101: %{name}-mod_accesslog.conf
69Source102: %{name}-mod_alias.conf
70Source103: %{name}-mod_auth.conf
71Source104: %{name}-mod_cgi.conf
72Source105: %{name}-mod_cml.conf
73Source106: %{name}-mod_compress.conf
74Source107: %{name}-mod_deflate.conf
75Source108: %{name}-mod_dirlisting.conf
76Source109: %{name}-mod_evasive.conf
77Source110: %{name}-mod_evhost.conf
78Source111: %{name}-mod_expire.conf
79Source112: %{name}-mod_fastcgi.conf
80Source113: %{name}-mod_flv_streaming.conf
81Source114: %{name}-mod_indexfile.conf
82Source115: %{name}-mod_proxy.conf
83Source116: %{name}-mod_redirect.conf
84Source117: %{name}-mod_rewrite.conf
85Source118: %{name}-mod_rrdtool.conf
86Source119: %{name}-mod_scgi.conf
87Source120: %{name}-mod_secdownload.conf
88Source121: %{name}-mod_setenv.conf
89Source122: %{name}-mod_simple_vhost.conf
90Source123: %{name}-mod_ssi.conf
91Source124: %{name}-mod_staticfile.conf
92Source125: %{name}-mod_status.conf
93Source126: %{name}-mod_trigger_b4_dl.conf
94Source127: %{name}-mod_userdir.conf
95Source128: %{name}-mod_usertrack.conf
96Source129: %{name}-mod_webdav.conf
97Source130: %{name}-php-spawned.conf
98Source131: %{name}-php-external.conf
99Source132: %{name}-ssl.conf
0f9dfecb
ER
100Source133: %{name}-mod_mysql_vhost.conf
101Source134: %{name}-mod_magnet.conf
9d166fb8 102Source135: %{name}-mod_extforward.conf
13e3ef3b 103#Patch100: %{name}-branch.diff
48986775
ER
104Patch0: %{name}-use_bin_sh.patch
105Patch1: %{name}-mod_evasive-status_code.patch
106Patch2: %{name}-mod_deflate.patch
93347afb 107Patch3: %{name}-mod_extforward-v2.patch
70373b58 108URL: http://www.lighttpd.net/
cc769ac6 109%{?with_xattr:BuildRequires: attr-devel}
1a75d3e1
JB
110BuildRequires: autoconf
111BuildRequires: automake
112BuildRequires: bzip2-devel
9c336869 113%{?with_gamin:BuildRequires: gamin-devel}
6ec064d6
KK
114%{?with_gdbm:BuildRequires: gdbm-devel}
115%{?with_memcache:BuildRequires: libmemcache-devel}
1a75d3e1 116BuildRequires: libtool
5febf716 117BuildRequires: libuuid-devel
6ec064d6 118%{?with_webdav_props:BuildRequires: libxml2-devel}
26843c13 119%{?with_lua:BuildRequires: lua51-devel}
6ec064d6 120BuildRequires: mailcap >= 2.1.14-4.4
cc769ac6 121%{?with_mysql:BuildRequires: mysql-devel}
6ec064d6 122%{?with_ldap:BuildRequires: openldap-devel}
49163762 123%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 124BuildRequires: pcre-devel
6ec064d6 125BuildRequires: pkgconfig
2a732f8a 126BuildRequires: rpmbuild(macros) >= 1.268
66f5ed22 127%{?with_webdav_props:BuildRequires: sqlite3-devel}
83ca4b2b 128%{?with_valgrind:BuildRequires: valgrind}
cc769ac6 129BuildRequires: zlib-devel
66f5ed22
ER
130Requires(post,preun): /sbin/chkconfig
131Requires(postun): /usr/sbin/groupdel
132Requires(postun): /usr/sbin/userdel
bee4f74e
AM
133Requires(pre): /bin/id
134Requires(pre): /usr/bin/getgid
5febf716 135Requires(pre): /usr/lib/rpm/user_group.sh
bee4f74e
AM
136Requires(pre): /usr/sbin/groupadd
137Requires(pre): /usr/sbin/useradd
28537382 138Requires(pre): /usr/sbin/usermod
5febf716
ER
139Requires: %{name}-mod_dirlisting
140Requires: %{name}-mod_indexfile
141Requires: %{name}-mod_staticfile
66f5ed22 142Requires: rc-scripts
5180cbd5 143Requires: webapps
6230924e 144Provides: group(http)
e68efba2 145Provides: group(lighttpd)
e68efba2 146Provides: user(lighttpd)
1a75d3e1 147Provides: webserver
0296e68a
ER
148# for the posttrans scriptlet, conflicts because in vserver environment rpm package is not installed.
149Conflicts: rpm < 4.4.2-0.2
bee4f74e
AM
150BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
151
152%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 153%define _lighttpddir /home/services/%{name}
bee4f74e
AM
154%define _sysconfdir /etc/%{name}
155
156%description
f655b1fd 157lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
158which has been optimized for high-performance environments. It has a
159very low memory footprint compared to other webservers and takes care
160of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
161Output-Compression, URL-Rewriting and many more) make lighttpd the
162perfect webserver-software for every server that is suffering load
163problems.
164
f655b1fd
MC
165%description -l pl
166lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 167