]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- fix patching
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
c64d9529
JB
5# - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6# - rasterlite2
7# - sfcgal >= 1.2.2
d3d190a4 8# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 9# - libkml (1.3.0 needed, not released yet)
954ec354 10# - wait for newer pcidsk, switch to external again
d3d190a4 11# - csharp, java
9b4989ae
JB
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
c64d9529 18# - LuraTech JP2Lura
9b4989ae 19# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 20# - Ingres (--with-ingres=/path)
0316feee 21# - Informix DB (--with-idb)
9b4989ae
JB
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
c64d9529 24# - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
655672e5 25#
26# Conditional build:
d3d190a4 27%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 28%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 29%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 30%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 31%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 32%bcond_without gta # GTA format support
77dfc6fa 33%bcond_without kea # KEA format support
d3d190a4 34%bcond_without mysql # MySQL DB support
0316feee 35%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
36%bcond_without odbc # ODBC DB support
37%bcond_without opencl # OpenCL (GPU) support
c9c08280 38%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
39%bcond_with podofo # PDF support via podofo instead of poppler
40%bcond_without poppler # PDF support via poppler
16d32926 41%bcond_with rasdaman # Rasdaman support
45593023 42%bcond_with spatialite # SpatiaLite support
d3d190a4
JB
43%bcond_without xerces # Xerces support
44%bcond_without java # Java and MDB support
315a1c4a 45
fac7da6f
JB
46%if %{with podofo}
47%undefine with_poppler
48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
a707ba6a
JR
52Version: 3.0.1
53Release: 1
faf5649c
JB
54License: BSD-like
55Group: Libraries
a707ba6a
JR
56Source0: https://github.com/OSGeo/gdal/releases/download/v%{version}/%{name}-%{version}.tar.gz
57# Source0-md5: 2b397c041e6b0b10ec7c49fd76e9fa99
f5a12c65 58Patch0: %{name}-perl.patch
957f985a
JR
59Patch1: %{name}-pc.patch
60Patch2: %{name}-dds.patch
61Patch3: %{name}-rasdaman.patch
62Patch4: %{name}-pluginsdir.patch
63Patch5: libx32.patch
64Patch6: poppler-0.82.patch
9b5c0fd4 65URL: http://www.gdal.org/
c64d9529
JB
66# 1.x or 2.x supported
67BuildRequires: CharLS-devel
d3d190a4
JB
68%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
69%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
70BuildRequires: autoconf >= 2.52
71BuildRequires: automake
6b59fa88 72BuildRequires: cfitsio-devel
6a3158ac 73%{?with_crnlib:BuildRequires: crnlib-devel}
c64d9529 74BuildRequires: cryptopp-devel
9b4989ae 75BuildRequires: curl-devel
9d161bc4 76BuildRequires: doxygen >= 1.4.2
209aac6b 77%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 78BuildRequires: expat-devel >= 1.95.0
779b0eec 79%{?with_fyba:BuildRequires: fyba-devel}
4537079d 80BuildRequires: freexl-devel >= 1.0
0316feee
JB
81BuildRequires: gcc >= 6:4.1
82BuildRequires: geos-devel >= 3.1.0
b459f4d7 83BuildRequires: giflib-devel >= 4.0
779b0eec 84%{?with_grass:BuildRequires: grass-devel >= 6.4}
c64d9529 85BuildRequires: hdf-devel >= 4.2.5
69051332 86BuildRequires: hdf5-devel
6b59fa88 87BuildRequires: jasper-devel
9b4989ae
JB
88%{?with_java:BuildRequires: jdk}
89%{?with_java:BuildRequires: jpackage-utils}
0316feee 90BuildRequires: json-c-devel >= 0.11
77dfc6fa 91%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 92BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 93BuildRequires: libdap-devel >= 3.10
b3cbf6a3 94BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 95%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 96BuildRequires: libjpeg-devel >= 6b
9b4989ae 97#BuildRequires: libkml-devel >= 1.3.0
e354fe40 98BuildRequires: libpng-devel >= 2:1.2.8
4537079d 99%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 100BuildRequires: libstdc++-devel
954ec354 101BuildRequires: libtiff-devel >= 4.0
957f985a 102BuildRequires: libtirpc-devel
69051332 103BuildRequires: libtool
e2b089e1 104BuildRequires: libuuid-devel
9b4989ae 105BuildRequires: libwebp-devel
0316feee 106BuildRequires: libxml2-devel >= 2
c64d9529 107#%{?with_mysql:BuildRequires: mysql-devel >= 4}
952dc496 108%{?with_mysql:BuildRequires: /usr/bin/mysql_config}
80114ba8 109BuildRequires: netcdf-devel >= 4.1
6b59fa88 110BuildRequires: ogdi-devel >= 3.1
c64d9529 111%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
0316feee
JB
112# 8.1.7 for DB support, 10.0.1 for georaster
113%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 114#BuildRequires: pcidsk-devel > 0.3
c64d9529 115BuildRequires: pcre-devel
a0ffd9c4 116BuildRequires: perl-devel
c64d9529 117BuildRequires: pkgconfig >= 1:0.21
fac7da6f 118%{?with_podofo:BuildRequires: podofo-devel}
0077f857 119%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
120# ensure it's compiled with PQescapeStringConn support
121BuildRequires: postgresql-backend-devel >= 8.1.4
122BuildRequires: postgresql-devel >= 8.1.4
123BuildRequires: proj-devel >= 4
9a2dbbce 124BuildRequires: python-devel >= 1:2.5
017b03bb 125BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 126BuildRequires: python-setuptools
c64d9529 127BuildRequires: qhull-devel >= 2012
779b0eec 128%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 129BuildRequires: rpm-pythonprov
9b4989ae 130BuildRequires: rpmbuild(macros) >= 1.344
b88bb9ef 131BuildRequires: sed >= 4.0
9b4989ae 132BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 133BuildRequires: swig-perl
9a2dbbce 134BuildRequires: swig-python >= 1.3
479cb83c 135BuildRequires: texlive-dvips
136BuildRequires: texlive-latex
9831286f 137%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
c64d9529 138%{?with_xerces:BuildRequires: xerces-c-devel >= 3.1.0}
9b4989ae 139BuildRequires: xz-devel
faf5649c 140BuildRequires: zlib-devel >= 1.1.4
c64d9529
JB
141# for ZSTD compression in TIFF
142BuildRequires: zstd-devel
4537079d 143Requires: freexl >= 1.0
0316feee 144Requires: geos >= 3.1.0
c64d9529 145Requires: hdf >= 4.2.5
b3cbf6a3 146Requires: libgeotiff >= 1.2.1
e354fe40 147Requires: libpng >= 2:1.2.8
954ec354 148Requires: libtiff >= 4.0
c64d9529
JB
149%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
150Requires: qhull >= 2012
151%{?with_xerces:Requires: xerces-c >= 3.1.0}
faf5649c
JB
152BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154%description
155GDAL is a translator library for raster geospatial data formats that
156is released under an Open Source license. As a library, it presents a
157single abstract data model to the calling application for all
158supported formats. The related OGR library (which lives within the
159GDAL source tree) provides a similar capability for simple features
160vector data.
f05c79e8 161
d34f2ec8
JR
162%description -l pl.UTF-8
163GDAL to biblioteka konwertująca między formatami rastrowych danych
164dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
165Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
166do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
167(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
168możliwości dla danych wektorowych.
faf5649c 169
6b59fa88
JB
170%package devel
171Summary: GDAL library header files
a28c1bee 172Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 173Group: Development/Libraries
1673a634 174Requires: %{name} = %{version}-%{release}
c64d9529 175Requires: CharLS-devel
d3d190a4
JB
176%{?with_opencl:Requires: OpenCL-devel >= 1.0}
177%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 178Requires: cfitsio-devel
6a3158ac 179%{?with_crnlib:Requires: crnlib-devel}
c64d9529 180Requires: cryptopp-devel
209aac6b
JB
181Requires: curl-devel
182%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 183%{?with_fyba:Requires: fyba-devel}
69051332 184Requires: expat-devel >= 1.95.0
4537079d 185Requires: freexl-devel >= 1.0
0316feee 186Requires: geos-devel >= 3.1.0
209aac6b 187Requires: giflib-devel >= 4.0
c64d9529 188Requires: hdf-devel >= 4.2.5
69051332 189Requires: hdf5-devel
b3cbf6a3 190Requires: jasper-devel
0316feee 191Requires: json-c-devel >= 0.11
77dfc6fa 192%{?with_kea:Requires: kealib-devel}
d4d7a2c6 193Requires: libcsf-devel
4058fbc3 194Requires: libdap-devel >= 3.10
b3cbf6a3 195Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
196%{?with_gta:Requires: libgta-devel}
197Requires: libjpeg-devel >= 6b
e354fe40 198Requires: libpng-devel >= 2:1.2.8
4537079d 199%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 200Requires: libstdc++-devel
954ec354 201Requires: libtiff-devel >= 4.0
209aac6b
JB
202Requires: libuuid-devel
203Requires: libwebp-devel
0316feee 204Requires: libxml2-devel >= 2
952dc496 205%{?with_mysql:Requires: /usr/bin/mysql_config}
9b4989ae 206Requires: netcdf-devel >= 4
b3cbf6a3 207Requires: ogdi-devel >= 3.1
c64d9529 208%{?with_openjpeg:Requires: openjpeg2-devel >= 2.1.0}
954ec354 209#Requires: pcidsk-devel > 0.3
c64d9529 210Requires: pcre-devel
209aac6b 211%{?with_podofo:Requires: podofo-devel}
0077f857 212%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 213Requires: postgresql-devel
209aac6b 214Requires: proj-devel >= 4
c64d9529 215Requires: qhull-devel >= 2012
779b0eec 216%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 217Requires: sqlite3-devel >= 3.0.0
655672e5 218%{?with_odbc:Requires: unixODBC-devel}
c64d9529 219%{?with_xerces:Requires: xerces-c-devel >= 3.1.0}
209aac6b
JB
220Requires: xz-devel
221Requires: zlib-devel >= 1.1.4
c64d9529 222Requires: zstd-devel
6b59fa88
JB
223
224%description devel
225GDAL library header files.
226
d34f2ec8
JR
227%description devel -l pl.UTF-8
228Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
229
230%package static
231Summary: GDAL static libraries
a28c1bee 232Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 233Group: Development/Libraries
1673a634 234Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
235
236%description static
237GDAL static libraries.
238
d34f2ec8 239%description static -l pl.UTF-8
6b59fa88
JB
240Statyczne biblioteki GDAL.
241
a0ffd9c4
JB
242%package -n perl-gdal
243Summary: Perl bindings for GDAL
244Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
245Group: Development/Languages/Perl
246Requires: %{name} = %{version}-%{release}
247
248%description -n perl-gdal
249Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
250
251%description -n perl-gdal -l pl.UTF-8
017b03bb 252Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 253
6b59fa88
JB
254%package -n python-gdal
255Summary: GDAL Python module
a28c1bee 256Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 257Group: Libraries/Python
1673a634 258Requires: %{name} = %{version}-%{release}
315a1c4a 259Requires: python-libs
6b59fa88
JB
260
261%description -n python-gdal
262GDAL Python module.
263
d34f2ec8
JR
264%description -n python-gdal -l pl.UTF-8
265Moduł Pythona GDAL.
6b59fa88 266
faf5649c
JB
267%prep
268%setup -q
269%patch0 -p1
957f985a 270%patch1 -p1
f1b5abea 271%patch2 -p1
957f985a
JR
272%patch3 -p1
273%patch4 -p1
274%patch5 -p1
f905262c 275%patch6 -p2
0316feee 276
c64d9529
JB
277# need to regenerate (old ones don't support perl 5.10)
278%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
315a1c4a 279
f4952e6f 280# our man path
be8ee7be 281sed -i -e 's#^mandir=.*##g' configure.ac
f4952e6f 282
4058fbc3 283%{__rm} -r man
4ed54fac 284
be8ee7be 285%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
b88bb9ef 286
faf5649c 287%build
e6e33a1a
JR
288%ifarch %{x8664}
289jvm_arch=amd64
290%endif
291%ifarch %{ix86}
292jvm_arch=i386
293%endif
294%ifarch x32
295jvm_arch=x32
296%endif
297
69051332 298%{__libtoolize}
69051332 299%{__aclocal} -I m4
faf5649c 300%{__autoconf}
0a5f35eb 301%{__autoheader}
6b59fa88 302%configure \
e582c3b1 303 --includedir=%{_includedir}/gdal \
5014b82a 304 --datadir=%{_datadir}/gdal \
d4d7a2c6 305 --with-dods-root=/usr \
d3d190a4 306 %{?with_armadillo:--with-armadillo} \
6f52dc7d 307 %{?with_crnlib:--with-dds} \
209aac6b 308 %{?with_epsilon:--with-epsilon} \
0316feee 309 %{?with_grass:--with-grass} \
b88bb9ef 310 %{!?with_gta:--without-gta} \
69051332 311 --with-hide-internal-symbols \
9b4989ae
JB
312 %{?with_java:--with-java=%{java_home}} \
313 --with-liblzma \
77dfc6fa 314 %{!?with_kea:--without-kea} \
fffcf251 315 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 316 %{?with_mysql:--with-mysql} \
0316feee 317 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 318 %{?with_opencl:--with-opencl} \
a0ffd9c4 319 --with-perl \
fac7da6f
JB
320 %{?with_podofo:--with-podofo} \
321 %{?with_poppler:--with-poppler} \
69051332 322 --with-python \
779b0eec 323 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
779b0eec 324 %{?with_fyba:--with-sosi} \
4537079d 325 %{?with_spatialite:--with-spatialite} \
69051332 326 --with-sqlite3 \
9b4989ae 327 --with-webp \
655672e5 328 %{?with_xerces:--with-xerces} \
c64d9529 329 --with-xerces-inc=/usr/include \
80faacbe 330 --with-xerces-lib="-lxerces-c" \
69051332 331 --without-libgrass
954ec354 332# --with-pcidsk=/usr (needs > 0.3)
779b0eec 333# csharp builds, but has no configure option nor install target
faf5649c 334
69051332 335# regenerate where needed
825dc3dc 336%{__make} -j1 -C swig/perl generate
69051332 337
45593023 338%{__make} \
779b0eec
JB
339 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
340 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 341
825dc3dc 342%{__make} -j1 docs
3a591acf 343
f5a12c65
JK
344%{__make} -j1 man
345
faf5649c
JB
346%install
347rm -rf $RPM_BUILD_ROOT
faf5649c 348
825dc3dc 349%{__make} -j1 install install-man \
3a591acf
JB
350 DESTDIR=$RPM_BUILD_ROOT
351
c64d9529
JB
352# TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
353
388b39cb
ER
354rm -rf _html
355cp -a html _html
faf5649c 356
374370d5
JB
357%py_comp $RPM_BUILD_ROOT%{py_sitedir}
358%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
359%py_postclean
5014b82a 360
017b03bb
ER
361%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
362%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
363%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
364%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
365%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
366
faf5649c
JB
367%clean
368rm -rf $RPM_BUILD_ROOT
369
6b59fa88
JB
370%post -p /sbin/ldconfig
371%postun -p /sbin/ldconfig
372
faf5649c
JB
373%files
374%defattr(644,root,root,755)
c0a384ef 375%doc NEWS PROVENANCE.TXT
4058fbc3
JB
376%attr(755,root,root) %{_bindir}/epsg_tr.py
377%attr(755,root,root) %{_bindir}/esri2wkt.py
378%attr(755,root,root) %{_bindir}/gcps2vec.py
379%attr(755,root,root) %{_bindir}/gcps2wld.py
380%attr(755,root,root) %{_bindir}/gdal2tiles.py
381%attr(755,root,root) %{_bindir}/gdal2xyz.py
4058fbc3 382%attr(755,root,root) %{_bindir}/gdaladdo
6f52dc7d 383%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 384%attr(755,root,root) %{_bindir}/gdalbuildvrt
6f52dc7d 385%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3 386%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 387%attr(755,root,root) %{_bindir}/gdalcompare.py
6f52dc7d 388%attr(755,root,root) %{_bindir}/gdal_contour
4058fbc3 389%attr(755,root,root) %{_bindir}/gdaldem
6f52dc7d 390%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3 391%attr(755,root,root) %{_bindir}/gdalenhance
6f52dc7d
JR
392%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
393%attr(755,root,root) %{_bindir}/gdal_grid
4058fbc3
JB
394%attr(755,root,root) %{_bindir}/gdalident.py
395%attr(755,root,root) %{_bindir}/gdalimport.py
396%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 397%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 398%attr(755,root,root) %{_bindir}/gdalmanage
6f52dc7d 399%attr(755,root,root) %{_bindir}/gdal_merge.py
f4952e6f 400%attr(755,root,root) %{_bindir}/gdalmove.py
6f52dc7d
JR
401%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
402%attr(755,root,root) %{_bindir}/gdal_polygonize.py
403%attr(755,root,root) %{_bindir}/gdal_proximity.py
404%attr(755,root,root) %{_bindir}/gdal_rasterize
405%attr(755,root,root) %{_bindir}/gdal_retile.py
f4952e6f 406%attr(755,root,root) %{_bindir}/gdalserver
6f52dc7d 407%attr(755,root,root) %{_bindir}/gdal_sieve.py
9b4989ae 408%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
409%attr(755,root,root) %{_bindir}/gdaltindex
410%attr(755,root,root) %{_bindir}/gdaltransform
6f52dc7d 411%attr(755,root,root) %{_bindir}/gdal_translate
4058fbc3 412%attr(755,root,root) %{_bindir}/gdalwarp
6f52dc7d
JR
413%attr(755,root,root) %{_bindir}/gnmanalyse
414%attr(755,root,root) %{_bindir}/gnmmanage
4058fbc3
JB
415%attr(755,root,root) %{_bindir}/mkgraticule.py
416%attr(755,root,root) %{_bindir}/nearblack
417%attr(755,root,root) %{_bindir}/ogr2ogr
418%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 419%attr(755,root,root) %{_bindir}/ogrlineref
6f52dc7d 420%attr(755,root,root) %{_bindir}/ogrmerge.py
4058fbc3
JB
421%attr(755,root,root) %{_bindir}/ogrtindex
422%attr(755,root,root) %{_bindir}/pct2rgb.py
423%attr(755,root,root) %{_bindir}/rgb2pct.py
424%attr(755,root,root) %{_bindir}/testepsg
5014b82a 425%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
a707ba6a 426%attr(755,root,root) %ghost %{_libdir}/libgdal.so.26
0a5f35eb 427%dir %{_libdir}/gdalplugins
6b59fa88 428%{_datadir}/gdal
4058fbc3 429%{_mandir}/man1/gdal2tiles.1*
0316feee 430%{_mandir}/man1/gdal_calc.1*
4058fbc3 431%{_mandir}/man1/gdal_contour.1*
f4952e6f 432%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
433%{_mandir}/man1/gdal_fillnodata.1*
434%{_mandir}/man1/gdal_grid.1*
435%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
436%{_mandir}/man1/gdal_polygonize.1*
437%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
438%{_mandir}/man1/gdal_rasterize.1*
439%{_mandir}/man1/gdal_retile.1*
440%{_mandir}/man1/gdal_sieve.1*
441%{_mandir}/man1/gdal_translate.1*
442%{_mandir}/man1/gdal_utilities.1*
443%{_mandir}/man1/gdaladdo.1*
444%{_mandir}/man1/gdalbuildvrt.1*
0316feee 445%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
446%{_mandir}/man1/gdaldem.1*
447%{_mandir}/man1/gdalinfo.1*
954ec354 448%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
449%{_mandir}/man1/gdalmanage.1*
450%{_mandir}/man1/gdalmove.1*
9b4989ae 451%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
452%{_mandir}/man1/gdaltindex.1*
453%{_mandir}/man1/gdaltransform.1*
454%{_mandir}/man1/gdalwarp.1*
455%{_mandir}/man1/nearblack.1*
456%{_mandir}/man1/ogr2ogr.1*
457%{_mandir}/man1/ogr_utilities.1*
458%{_mandir}/man1/ogrinfo.1*
0316feee 459%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
460%{_mandir}/man1/ogrtindex.1*
461%{_mandir}/man1/pct2rgb.1*
462%{_mandir}/man1/rgb2pct.1*
6f52dc7d
JR
463%{_mandir}/man1/gdal_pansharpen.1*
464%{_mandir}/man1/gnm_utilities.1*
465%{_mandir}/man1/gnmanalyse.1*
466%{_mandir}/man1/gnmmanage.1*
467%{_mandir}/man1/ogrmerge.1*
6b59fa88
JB
468
469%files devel
470%defattr(644,root,root,755)
388b39cb 471%doc _html/*
5014b82a 472%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 473%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 474%{_libdir}/libgdal.la
0316feee 475%{_pkgconfigdir}/gdal.pc
e582c3b1 476%{_includedir}/gdal
5014b82a 477%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
478
479%files static
480%defattr(644,root,root,755)
9b5c0fd4 481%{_libdir}/libgdal.a
6b59fa88 482
a0ffd9c4
JB
483%files -n perl-gdal
484%defattr(644,root,root,755)
485%dir %{perl_vendorarch}/Geo
486%{perl_vendorarch}/Geo/GDAL.pm
487%dir %{perl_vendorarch}/Geo/GDAL
488%{perl_vendorarch}/Geo/GDAL/Const.pm
489%{perl_vendorarch}/Geo/OGR.pm
490%{perl_vendorarch}/Geo/OSR.pm
491%dir %{perl_vendorarch}/auto/Geo
492%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
493%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
494%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4 495%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
6f52dc7d
JR
496%dir %{perl_vendorarch}/auto/Geo/GNM
497%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
a0ffd9c4 498%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
499%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
500%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 501%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 502%{_mandir}/man3/Geo::GDAL.3pm*
6f52dc7d 503%{perl_vendorarch}/Geo/GNM.pm
a0ffd9c4 504
6b59fa88
JB
505%files -n python-gdal
506%defattr(644,root,root,755)
9a2dbbce
JB
507%{py_sitedir}/gdal.py[co]
508%{py_sitedir}/gdalconst.py[co]
509%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
510%{py_sitedir}/ogr.py[co]
511%{py_sitedir}/osr.py[co]
69051332
JB
512%{py_sitedir}/GDAL-*.egg-info
513%dir %{py_sitedir}/osgeo
514%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
515%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
516%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
6f52dc7d 517%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
69051332
JB
518%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
519%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
520%{py_sitedir}/osgeo/*.py[co]
This page took 0.175842 seconds and 4 git commands to generate.