]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- added freexl and spatialite support
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
9b4989ae
JB
5# - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6# - armadillo (--with-armadillo; http://arma.sourceforge.net/)
f3ccaa46 7# - openjpeg (unreleased post-1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.5)
9b4989ae
JB
8# - libjpeg12 (needs patching to use system one)
9# - libkml (1.3.0 needed, not released yet)
954ec354
JB
10# - wait for newer pcidsk, switch to external again
11# - csharp, java, mysql
9b4989ae
JB
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
18# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
19# - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
20# - Ingres (--with-ingres=/path)
21# - Informix DB
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24# - OpenCL (--with-opencl; no free Linux implementation yet?)
655672e5 25#
26# Conditional build:
4537079d
JB
27%bcond_without epsilon # EPSILON wavelet compression support
28%bcond_without gta # GTA format support
29%bcond_without odbc # disable ODBC DB support
30%bcond_with podofo # PDF support via podofo instead of poppler
31%bcond_without poppler # PDF support via poppler
32%bcond_without spatialite # SpatiaLite support
33%bcond_without xerces # disable xerces support
34%bcond_without java # disable Java and MDB support
35%bcond_without php # disable PHP binding
36%bcond_without ruby # disable ruby binding
655672e5 37#
fac7da6f
JB
38%if %{with podofo}
39%undefine with_poppler
40%endif
faf5649c 41Summary: Geospatial Data Abstraction Library
a28c1bee 42Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 43Name: gdal
52423e08 44Version: 1.9.1
91bb28ec 45Release: 6
faf5649c
JB
46License: BSD-like
47Group: Libraries
c82ea5ef 48Source0: ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
52423e08 49# Source0-md5: c5cf09b92dac1f5775db056e165b34f5
f5a12c65 50Patch0: %{name}-perl.patch
9b4989ae 51Patch1: %{name}-python_install.patch
52423e08
AM
52Patch2: gdal-1.9.1-poppler020.patch
53
9b4989ae 54Patch4: %{name}-php.patch
d7f652d4 55Patch5: %{name}-fpic.patch
9b5c0fd4 56URL: http://www.gdal.org/
69051332
JB
57BuildRequires: autoconf >= 2.52
58BuildRequires: automake
6b59fa88 59BuildRequires: cfitsio-devel
9b4989ae 60BuildRequires: curl-devel
9d161bc4 61BuildRequires: doxygen >= 1.4.2
209aac6b 62%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 63BuildRequires: expat-devel >= 1.95.0
4537079d 64BuildRequires: freexl-devel >= 1.0
9b4989ae 65BuildRequires: geos-devel >= 2.2.0
b459f4d7 66BuildRequires: giflib-devel >= 4.0
6b59fa88 67BuildRequires: hdf-devel >= 4.0
69051332 68BuildRequires: hdf5-devel
6b59fa88 69BuildRequires: jasper-devel
9b4989ae
JB
70%{?with_java:BuildRequires: jdk}
71%{?with_java:BuildRequires: jpackage-utils}
d4d7a2c6 72BuildRequires: libcsf-devel
4058fbc3 73BuildRequires: libdap-devel >= 3.10
b3cbf6a3 74BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 75%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 76BuildRequires: libjpeg-devel >= 6b
9b4989ae 77#BuildRequires: libkml-devel >= 1.3.0
e354fe40 78BuildRequires: libpng-devel >= 2:1.2.8
4537079d 79%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 80BuildRequires: libstdc++-devel
954ec354 81BuildRequires: libtiff-devel >= 4.0
69051332 82BuildRequires: libtool
e2b089e1 83BuildRequires: libuuid-devel
9b4989ae 84BuildRequires: libwebp-devel
e2b089e1 85BuildRequires: libxml2-devel
80114ba8 86BuildRequires: netcdf-devel >= 4.1
6b59fa88 87BuildRequires: ogdi-devel >= 3.1
954ec354 88#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 89BuildRequires: perl-devel
9b4989ae 90%{?with_php:BuildRequires: php-devel}
fac7da6f
JB
91%{?with_podofo:BuildRequires: podofo-devel}
92%{?with_poppler:BuildRequires: poppler-devel}
9b4989ae
JB
93# ensure it's compiled with PQescapeStringConn support
94BuildRequires: postgresql-backend-devel >= 8.1.4
95BuildRequires: postgresql-devel >= 8.1.4
96BuildRequires: proj-devel >= 4
9a2dbbce 97BuildRequires: python-devel >= 1:2.5
017b03bb 98BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 99BuildRequires: python-setuptools
479cb83c 100BuildRequires: rpm-pythonprov
9b4989ae 101BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 102%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 103BuildRequires: sed >= 4.0
9b4989ae 104BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 105BuildRequires: swig-perl
9a2dbbce 106BuildRequires: swig-python >= 1.3
017b03bb 107%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 108BuildRequires: texlive-dvips
109BuildRequires: texlive-latex
9831286f 110%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
111%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
112BuildRequires: xz-devel
faf5649c 113BuildRequires: zlib-devel >= 1.1.4
4537079d 114Requires: freexl >= 1.0
9b4989ae 115Requires: geos >= 2.2.0
b3cbf6a3 116Requires: libgeotiff >= 1.2.1
e354fe40 117Requires: libpng >= 2:1.2.8
954ec354 118Requires: libtiff >= 4.0
faf5649c
JB
119BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121%description
122GDAL is a translator library for raster geospatial data formats that
123is released under an Open Source license. As a library, it presents a
124single abstract data model to the calling application for all
125supported formats. The related OGR library (which lives within the
126GDAL source tree) provides a similar capability for simple features
127vector data.
f05c79e8 128
d34f2ec8
JR
129%description -l pl.UTF-8
130GDAL to biblioteka konwertująca między formatami rastrowych danych
131dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
132Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
133do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
134(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
135możliwości dla danych wektorowych.
faf5649c 136
6b59fa88
JB
137%package devel
138Summary: GDAL library header files
a28c1bee 139Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 140Group: Development/Libraries
1673a634 141Requires: %{name} = %{version}-%{release}
b3cbf6a3 142Requires: cfitsio-devel
209aac6b
JB
143Requires: curl-devel
144%{?with_epsilon:Requires: epsilon-compressor-devel}
69051332 145Requires: expat-devel >= 1.95.0
4537079d 146Requires: freexl-devel >= 1.0
9b4989ae 147Requires: geos-devel >= 2.2.0
209aac6b 148Requires: giflib-devel >= 4.0
b3cbf6a3 149Requires: hdf-devel >= 4.0
69051332 150Requires: hdf5-devel
b3cbf6a3 151Requires: jasper-devel
d4d7a2c6 152Requires: libcsf-devel
4058fbc3 153Requires: libdap-devel >= 3.10
b3cbf6a3 154Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
155%{?with_gta:Requires: libgta-devel}
156Requires: libjpeg-devel >= 6b
e354fe40 157Requires: libpng-devel >= 2:1.2.8
4537079d 158%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 159Requires: libstdc++-devel
954ec354 160Requires: libtiff-devel >= 4.0
209aac6b
JB
161Requires: libuuid-devel
162Requires: libwebp-devel
163Requires: libxml2-devel
9b4989ae 164Requires: netcdf-devel >= 4
b3cbf6a3 165Requires: ogdi-devel >= 3.1
954ec354 166#Requires: pcidsk-devel > 0.3
209aac6b
JB
167%{?with_podofo:Requires: podofo-devel}
168%{?with_poppler:Requires: poppler-devel}
b3cbf6a3 169Requires: postgresql-devel
209aac6b 170Requires: proj-devel >= 4
9b4989ae 171Requires: sqlite3-devel >= 3.0.0
655672e5 172%{?with_odbc:Requires: unixODBC-devel}
69051332 173%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
174Requires: xz-devel
175Requires: zlib-devel >= 1.1.4
6b59fa88
JB
176
177%description devel
178GDAL library header files.
179
d34f2ec8
JR
180%description devel -l pl.UTF-8
181Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
182
183%package static
184Summary: GDAL static libraries
a28c1bee 185Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 186Group: Development/Libraries
1673a634 187Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
188
189%description static
190GDAL static libraries.
191
d34f2ec8 192%description static -l pl.UTF-8
6b59fa88
JB
193Statyczne biblioteki GDAL.
194
a0ffd9c4
JB
195%package -n perl-gdal
196Summary: Perl bindings for GDAL
197Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
198Group: Development/Languages/Perl
199Requires: %{name} = %{version}-%{release}
200
201%description -n perl-gdal
202Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
203
204%description -n perl-gdal -l pl.UTF-8
017b03bb 205Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 206
9b4989ae
JB
207%package -n php-gdal
208Summary: PHP bindings for GDAL library
209Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
210Group: Development/Languages/PHP
211Requires: %{name} = %{version}-%{release}
212%{?requires_php_extension}
213
214%description -n php-gdal
215PHP bindings for GDAL library
216
217%description -n php-gdal -l pl.UTF-8
218Wiązania PHP do biblioteki GDAL.
219
6b59fa88
JB
220%package -n python-gdal
221Summary: GDAL Python module
a28c1bee 222Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 223Group: Libraries/Python
1673a634 224Requires: %{name} = %{version}-%{release}
faf2b39a 225%pyrequires_eq python-libs
6b59fa88
JB
226
227%description -n python-gdal
228GDAL Python module.
229
d34f2ec8
JR
230%description -n python-gdal -l pl.UTF-8
231Moduł Pythona GDAL.
6b59fa88 232
a0ffd9c4
JB
233%package -n ruby-gdal
234Summary: Ruby bindings for GDAL
235Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
236Group: Development/Languages
237Requires: %{name} = %{version}-%{release}
238%{?ruby_mod_ver_requires_eq}
239
240%description -n ruby-gdal
241Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
242
243%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
244Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
245osr.
a0ffd9c4 246
faf5649c
JB
247%prep
248%setup -q
249%patch0 -p1
250%patch1 -p1
52423e08
AM
251%patch2 -p4
252
4058fbc3 253%patch4 -p1
d7f652d4 254%patch5 -p1
69051332
JB
255
256# need to regenerate (old ones don't support perl 5.10)
4058fbc3 257%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
f5a12c65 258
4058fbc3 259%{__rm} -r man
4ed54fac 260
b88bb9ef
JB
261%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
262
faf5649c 263%build
69051332 264%{__libtoolize}
69051332 265%{__aclocal} -I m4
faf5649c 266%{__autoconf}
69051332 267# disable grass/libgrass here, it can be built from separate gdal-grass package
6b59fa88 268%configure \
5014b82a 269 --datadir=%{_datadir}/gdal \
d4d7a2c6 270 --with-dods-root=/usr \
209aac6b 271 %{?with_epsilon:--with-epsilon} \
b88bb9ef 272 %{!?with_gta:--without-gta} \
69051332 273 --with-hide-internal-symbols \
9b4989ae
JB
274 %{?with_java:--with-java=%{java_home}} \
275 --with-liblzma \
209aac6b 276 %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
a0ffd9c4 277 --with-perl \
9b4989ae 278 %{?with_php:--with-php} \
fac7da6f
JB
279 %{?with_podofo:--with-podofo} \
280 %{?with_poppler:--with-poppler} \
69051332 281 --with-python \
4aafe7c0 282 %{?with_ruby:--with-ruby} \
4537079d 283 %{?with_spatialite:--with-spatialite} \
69051332 284 --with-sqlite3 \
9b4989ae 285 --with-webp \
655672e5 286 %{?with_xerces:--with-xerces} \
6b59fa88 287 --with-xerces-inc=/usr/include/xercesc \
80faacbe 288 --with-xerces-lib="-lxerces-c" \
a3027d62 289 --without-grass \
69051332 290 --without-libgrass
954ec354 291# --with-pcidsk=/usr (needs > 0.3)
69051332 292# csharp builds, but has no configure option
faf5649c 293
69051332 294# regenerate where needed
825dc3dc 295%{__make} -j1 -C swig/perl generate
961f0000 296%{?with_ruby:%{__make} -j1 -C swig/ruby generate}
69051332 297
825dc3dc 298%{__make} -j1
a0ffd9c4 299
825dc3dc 300%{__make} -j1 docs
3a591acf 301
f5a12c65
JK
302%{__make} -j1 man
303
faf5649c
JB
304%install
305rm -rf $RPM_BUILD_ROOT
faf5649c 306
825dc3dc 307%{__make} -j1 install install-man \
3a591acf
JB
308 DESTDIR=$RPM_BUILD_ROOT
309
388b39cb
ER
310rm -rf _html
311cp -a html _html
312cp -a ogr/html _html/ogr
faf5649c 313
9b4989ae
JB
314%if %{with php}
315# missing in make install
316install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
317install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
318install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
319install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
320install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
321cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
322; Enable gdal extension module
323extension=gdal.so
324extension=gdalconst.so
325extension=ogr.so
326extension=osr.so
327EOF
328%endif
329
374370d5
JB
330%py_comp $RPM_BUILD_ROOT%{py_sitedir}
331%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
332%py_postclean
5014b82a 333
017b03bb
ER
334%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
335%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
336%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
337%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
338%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
339
340# some doxygen trash
954ec354 341%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
9b4989ae 342%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
954ec354 343%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
017b03bb 344
faf5649c
JB
345%clean
346rm -rf $RPM_BUILD_ROOT
347
6b59fa88
JB
348%post -p /sbin/ldconfig
349%postun -p /sbin/ldconfig
350
faf5649c
JB
351%files
352%defattr(644,root,root,755)
c0a384ef 353%doc NEWS PROVENANCE.TXT
4058fbc3
JB
354%attr(755,root,root) %{_bindir}/epsg_tr.py
355%attr(755,root,root) %{_bindir}/esri2wkt.py
356%attr(755,root,root) %{_bindir}/gcps2vec.py
357%attr(755,root,root) %{_bindir}/gcps2wld.py
358%attr(755,root,root) %{_bindir}/gdal2tiles.py
359%attr(755,root,root) %{_bindir}/gdal2xyz.py
360%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 361%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3
JB
362%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
363%attr(755,root,root) %{_bindir}/gdal_grid
364%attr(755,root,root) %{_bindir}/gdal_merge.py
365%attr(755,root,root) %{_bindir}/gdal_polygonize.py
366%attr(755,root,root) %{_bindir}/gdal_proximity.py
367%attr(755,root,root) %{_bindir}/gdal_rasterize
368%attr(755,root,root) %{_bindir}/gdal_retile.py
369%attr(755,root,root) %{_bindir}/gdal_sieve.py
370%attr(755,root,root) %{_bindir}/gdal_translate
371%attr(755,root,root) %{_bindir}/gdaladdo
372%attr(755,root,root) %{_bindir}/gdalbuildvrt
373%attr(755,root,root) %{_bindir}/gdalchksum.py
374%attr(755,root,root) %{_bindir}/gdaldem
375%attr(755,root,root) %{_bindir}/gdalenhance
376%attr(755,root,root) %{_bindir}/gdalident.py
377%attr(755,root,root) %{_bindir}/gdalimport.py
378%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 379%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 380%attr(755,root,root) %{_bindir}/gdalmanage
9b4989ae 381%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
382%attr(755,root,root) %{_bindir}/gdaltindex
383%attr(755,root,root) %{_bindir}/gdaltransform
384%attr(755,root,root) %{_bindir}/gdalwarp
385%attr(755,root,root) %{_bindir}/mkgraticule.py
386%attr(755,root,root) %{_bindir}/nearblack
387%attr(755,root,root) %{_bindir}/ogr2ogr
388%attr(755,root,root) %{_bindir}/ogrinfo
389%attr(755,root,root) %{_bindir}/ogrtindex
390%attr(755,root,root) %{_bindir}/pct2rgb.py
391%attr(755,root,root) %{_bindir}/rgb2pct.py
392%attr(755,root,root) %{_bindir}/testepsg
5014b82a 393%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
017b03bb 394%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
6b59fa88 395%{_datadir}/gdal
4058fbc3
JB
396%{_mandir}/man1/gdal2tiles.1*
397%{_mandir}/man1/gdal_contour.1*
398%{_mandir}/man1/gdal_fillnodata.1*
399%{_mandir}/man1/gdal_grid.1*
400%{_mandir}/man1/gdal_merge.1*
401%{_mandir}/man1/gdal_rasterize.1*
402%{_mandir}/man1/gdal_retile.1*
403%{_mandir}/man1/gdal_sieve.1*
404%{_mandir}/man1/gdal_translate.1*
405%{_mandir}/man1/gdal_utilities.1*
406%{_mandir}/man1/gdaladdo.1*
407%{_mandir}/man1/gdalbuildvrt.1*
408%{_mandir}/man1/gdaldem.1*
409%{_mandir}/man1/gdalinfo.1*
954ec354 410%{_mandir}/man1/gdallocationinfo.1*
9b4989ae 411%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
412%{_mandir}/man1/gdaltindex.1*
413%{_mandir}/man1/gdaltransform.1*
414%{_mandir}/man1/gdalwarp.1*
415%{_mandir}/man1/nearblack.1*
416%{_mandir}/man1/ogr2ogr.1*
417%{_mandir}/man1/ogr_utilities.1*
418%{_mandir}/man1/ogrinfo.1*
419%{_mandir}/man1/ogrtindex.1*
420%{_mandir}/man1/pct2rgb.1*
421%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
422
423%files devel
424%defattr(644,root,root,755)
388b39cb 425%doc _html/*
5014b82a 426%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 427%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 428%{_libdir}/libgdal.la
4058fbc3
JB
429%{_includedir}/cpl_*.h
430%{_includedir}/cplkeywordparser.h
431%{_includedir}/gdal*.h
432%{_includedir}/gvgcpfit.h
433%{_includedir}/memdataset.h
434%{_includedir}/ogr_*.h
435%{_includedir}/ogrsf_frmts.h
436%{_includedir}/rawdataset.h
437%{_includedir}/thinplatespline.h
438%{_includedir}/vrtdataset.h
5014b82a 439%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
440
441%files static
442%defattr(644,root,root,755)
9b5c0fd4 443%{_libdir}/libgdal.a
6b59fa88 444
a0ffd9c4
JB
445%files -n perl-gdal
446%defattr(644,root,root,755)
447%dir %{perl_vendorarch}/Geo
448%{perl_vendorarch}/Geo/GDAL.pm
449%dir %{perl_vendorarch}/Geo/GDAL
450%{perl_vendorarch}/Geo/GDAL/Const.pm
451%{perl_vendorarch}/Geo/OGR.pm
452%{perl_vendorarch}/Geo/OSR.pm
453%dir %{perl_vendorarch}/auto/Geo
454%dir %{perl_vendorarch}/auto/Geo/GDAL
455%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
456%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
457%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
458%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
459%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
460%dir %{perl_vendorarch}/auto/Geo/OGR
461%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
462%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
463%dir %{perl_vendorarch}/auto/Geo/OSR
464%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
465%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
466
9b4989ae
JB
467%if %{with php}
468%files -n php-gdal
469%defattr(644,root,root,755)
470%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
471%attr(755,root,root) %{php_extensiondir}/gdal.so
472%attr(755,root,root) %{php_extensiondir}/gdalconst.so
473%attr(755,root,root) %{php_extensiondir}/ogr.so
474%attr(755,root,root) %{php_extensiondir}/osr.so
475%endif
476
6b59fa88
JB
477%files -n python-gdal
478%defattr(644,root,root,755)
9a2dbbce
JB
479%{py_sitedir}/gdal.py[co]
480%{py_sitedir}/gdalconst.py[co]
481%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
482%{py_sitedir}/ogr.py[co]
483%{py_sitedir}/osr.py[co]
69051332
JB
484%{py_sitedir}/GDAL-*.egg-info
485%dir %{py_sitedir}/osgeo
486%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
487%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
488%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
489%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
490%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
491%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 492
4aafe7c0 493%if %{with ruby}
a0ffd9c4
JB
494%files -n ruby-gdal
495%defattr(644,root,root,755)
496%dir %{ruby_sitearchdir}/gdal
497%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
498%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
499%attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
500%attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
4aafe7c0 501%endif
This page took 0.162952 seconds and 4 git commands to generate.