]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- added pluginsdir patch (fix gdalplugins dir location for lib64/libx32 ABIs)
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 27%bcond_without gta # GTA format support
d3d190a4 28%bcond_without mysql # MySQL DB support
0316feee 29%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
30%bcond_without odbc # ODBC DB support
31%bcond_without opencl # OpenCL (GPU) support
c9c08280 32%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
33%bcond_with podofo # PDF support via podofo instead of poppler
34%bcond_without poppler # PDF support via poppler
779b0eec 35%bcond_without rasdaman # Rasdaman support
4537079d 36%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
37%bcond_without xerces # Xerces support
38%bcond_without java # Java and MDB support
0316feee 39%bcond_without php # PHP binding
315a1c4a
ER
40%bcond_without ruby # Ruby binding
41
fac7da6f
JB
42%if %{with podofo}
43%undefine with_poppler
44%endif
66daf0b1 45%if 0%{!?php_name:1}
ead243f9 46%define php_name php55
66daf0b1 47%endif
faf5649c 48Summary: Geospatial Data Abstraction Library
a28c1bee 49Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 50Name: gdal
ce035715
JB
51Version: 1.11.2
52Release: 1
faf5649c
JB
53License: BSD-like
54Group: Libraries
84501866 55Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
ce035715 56# Source0-md5: 90221810dd9ca656ee23d434d4266ef6
f5a12c65 57Patch0: %{name}-perl.patch
9b4989ae 58Patch1: %{name}-python_install.patch
f1b5abea
JB
59Patch2: %{name}-php.patch
60Patch3: %{name}-fpic.patch
75b2e515 61Patch4: %{name}-format-security.patch
0316feee
JB
62Patch5: %{name}-grass.patch
63Patch6: %{name}-sse.patch
64Patch7: %{name}-link.patch
779b0eec
JB
65Patch8: %{name}-fyba.patch
66Patch9: %{name}-dds.patch
779b0eec 67Patch11: %{name}-armadillo.patch
ce035715 68Patch12: %{name}-rasdaman.patch
0a5f35eb 69Patch13: %{name}-pluginsdir.patch
9b5c0fd4 70URL: http://www.gdal.org/
ead243f9 71%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
72%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
73%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
74BuildRequires: autoconf >= 2.52
75BuildRequires: automake
6b59fa88 76BuildRequires: cfitsio-devel
6a3158ac 77%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 78BuildRequires: curl-devel
9d161bc4 79BuildRequires: doxygen >= 1.4.2
209aac6b 80%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 81BuildRequires: expat-devel >= 1.95.0
779b0eec 82%{?with_fyba:BuildRequires: fyba-devel}
4537079d 83BuildRequires: freexl-devel >= 1.0
0316feee
JB
84BuildRequires: gcc >= 6:4.1
85BuildRequires: geos-devel >= 3.1.0
b459f4d7 86BuildRequires: giflib-devel >= 4.0
779b0eec 87%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 88BuildRequires: hdf-devel >= 4.0
69051332 89BuildRequires: hdf5-devel
6b59fa88 90BuildRequires: jasper-devel
9b4989ae
JB
91%{?with_java:BuildRequires: jdk}
92%{?with_java:BuildRequires: jpackage-utils}
0316feee 93BuildRequires: json-c-devel >= 0.11
d4d7a2c6 94BuildRequires: libcsf-devel
4058fbc3 95BuildRequires: libdap-devel >= 3.10
b3cbf6a3 96BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 97%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 98BuildRequires: libjpeg-devel >= 6b
9b4989ae 99#BuildRequires: libkml-devel >= 1.3.0
e354fe40 100BuildRequires: libpng-devel >= 2:1.2.8
4537079d 101%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 102BuildRequires: libstdc++-devel
954ec354 103BuildRequires: libtiff-devel >= 4.0
69051332 104BuildRequires: libtool
e2b089e1 105BuildRequires: libuuid-devel
9b4989ae 106BuildRequires: libwebp-devel
0316feee 107BuildRequires: libxml2-devel >= 2
d3d190a4 108%{?with_mysql:BuildRequires: mysql-devel}
80114ba8 109BuildRequires: netcdf-devel >= 4.1
6b59fa88 110BuildRequires: ogdi-devel >= 3.1
c9c08280 111%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
112# 8.1.7 for DB support, 10.0.1 for georaster
113%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 114#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 115BuildRequires: perl-devel
fac7da6f 116%{?with_podofo:BuildRequires: podofo-devel}
0077f857 117%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
118# ensure it's compiled with PQescapeStringConn support
119BuildRequires: postgresql-backend-devel >= 8.1.4
120BuildRequires: postgresql-devel >= 8.1.4
121BuildRequires: proj-devel >= 4
9a2dbbce 122BuildRequires: python-devel >= 1:2.5
017b03bb 123BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 124BuildRequires: python-setuptools
779b0eec 125%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 126BuildRequires: rpm-pythonprov
315a1c4a 127%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 128BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 129%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 130BuildRequires: sed >= 4.0
9b4989ae 131BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 132BuildRequires: swig-perl
0316feee 133BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 134BuildRequires: swig-python >= 1.3
017b03bb 135%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 136BuildRequires: texlive-dvips
137BuildRequires: texlive-latex
9831286f 138%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
139%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
140BuildRequires: xz-devel
faf5649c 141BuildRequires: zlib-devel >= 1.1.4
4537079d 142Requires: freexl >= 1.0
0316feee 143Requires: geos >= 3.1.0
b3cbf6a3 144Requires: libgeotiff >= 1.2.1
e354fe40 145Requires: libpng >= 2:1.2.8
954ec354 146Requires: libtiff >= 4.0
faf5649c
JB
147BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149%description
150GDAL is a translator library for raster geospatial data formats that
151is released under an Open Source license. As a library, it presents a
152single abstract data model to the calling application for all
153supported formats. The related OGR library (which lives within the
154GDAL source tree) provides a similar capability for simple features
155vector data.
f05c79e8 156
d34f2ec8
JR
157%description -l pl.UTF-8
158GDAL to biblioteka konwertująca między formatami rastrowych danych
159dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
160Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
161do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
162(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
163możliwości dla danych wektorowych.
faf5649c 164
6b59fa88
JB
165%package devel
166Summary: GDAL library header files
a28c1bee 167Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 168Group: Development/Libraries
1673a634 169Requires: %{name} = %{version}-%{release}
d3d190a4
JB
170%{?with_opencl:Requires: OpenCL-devel >= 1.0}
171%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 172Requires: cfitsio-devel
6a3158ac 173%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
174Requires: curl-devel
175%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 176%{?with_fyba:Requires: fyba-devel}
69051332 177Requires: expat-devel >= 1.95.0
4537079d 178Requires: freexl-devel >= 1.0
0316feee 179Requires: geos-devel >= 3.1.0
209aac6b 180Requires: giflib-devel >= 4.0
b3cbf6a3 181Requires: hdf-devel >= 4.0
69051332 182Requires: hdf5-devel
b3cbf6a3 183Requires: jasper-devel
0316feee 184Requires: json-c-devel >= 0.11
d4d7a2c6 185Requires: libcsf-devel
4058fbc3 186Requires: libdap-devel >= 3.10
b3cbf6a3 187Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
188%{?with_gta:Requires: libgta-devel}
189Requires: libjpeg-devel >= 6b
e354fe40 190Requires: libpng-devel >= 2:1.2.8
4537079d 191%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 192Requires: libstdc++-devel
954ec354 193Requires: libtiff-devel >= 4.0
209aac6b
JB
194Requires: libuuid-devel
195Requires: libwebp-devel
0316feee 196Requires: libxml2-devel >= 2
d3d190a4 197%{?with_mysql:Requires: mysql-devel}
9b4989ae 198Requires: netcdf-devel >= 4
b3cbf6a3 199Requires: ogdi-devel >= 3.1
c9c08280 200%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 201#Requires: pcidsk-devel > 0.3
209aac6b 202%{?with_podofo:Requires: podofo-devel}
0077f857 203%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 204Requires: postgresql-devel
209aac6b 205Requires: proj-devel >= 4
779b0eec 206%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 207Requires: sqlite3-devel >= 3.0.0
655672e5 208%{?with_odbc:Requires: unixODBC-devel}
69051332 209%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
210Requires: xz-devel
211Requires: zlib-devel >= 1.1.4
6b59fa88
JB
212
213%description devel
214GDAL library header files.
215
d34f2ec8
JR
216%description devel -l pl.UTF-8
217Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
218
219%package static
220Summary: GDAL static libraries
a28c1bee 221Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 222Group: Development/Libraries
1673a634 223Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
224
225%description static
226GDAL static libraries.
227
d34f2ec8 228%description static -l pl.UTF-8
6b59fa88
JB
229Statyczne biblioteki GDAL.
230
a0ffd9c4
JB
231%package -n perl-gdal
232Summary: Perl bindings for GDAL
233Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
234Group: Development/Languages/Perl
235Requires: %{name} = %{version}-%{release}
236
237%description -n perl-gdal
238Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
239
240%description -n perl-gdal -l pl.UTF-8
017b03bb 241Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 242
ead243f9 243%package -n %{php_name}-gdal
9b4989ae
JB
244Summary: PHP bindings for GDAL library
245Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
246Group: Development/Languages/PHP
247Requires: %{name} = %{version}-%{release}
248%{?requires_php_extension}
249
ead243f9 250%description -n %{php_name}-gdal
9b4989ae
JB
251PHP bindings for GDAL library
252
ead243f9 253%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
254Wiązania PHP do biblioteki GDAL.
255
6b59fa88
JB
256%package -n python-gdal
257Summary: GDAL Python module
a28c1bee 258Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 259Group: Libraries/Python
1673a634 260Requires: %{name} = %{version}-%{release}
315a1c4a 261Requires: python-libs
6b59fa88
JB
262
263%description -n python-gdal
264GDAL Python module.
265
d34f2ec8
JR
266%description -n python-gdal -l pl.UTF-8
267Moduł Pythona GDAL.
6b59fa88 268
a0ffd9c4
JB
269%package -n ruby-gdal
270Summary: Ruby bindings for GDAL
271Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
272Group: Development/Languages
273Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
274
275%description -n ruby-gdal
276Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
277
278%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
279Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
280osr.
a0ffd9c4 281
faf5649c
JB
282%prep
283%setup -q
284%patch0 -p1
285%patch1 -p1
f1b5abea
JB
286%patch2 -p1
287%patch3 -p1
c9c08280 288%patch4 -p1
0316feee
JB
289%patch5 -p1
290%patch6 -p1
291%patch7 -p1
779b0eec
JB
292%patch8 -p1
293%patch9 -p1
779b0eec
JB
294%patch11 -p1
295%patch12 -p1
0a5f35eb 296%patch13 -p1
0316feee
JB
297
298# need to regenerate (old ones don't support perl 5.10 or php 5.5)
299%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
300
301%{__sed} -i \
302 -e 's/^CC=gcc/CC=%{__cc}/' \
303 -e 's/^CXX=g++/CXX=%{__cxx}/' \
304 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
305 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
306 swig/php/GNUmakefile
315a1c4a
ER
307# Build with fPIC to allow Ruby bindings
308# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
309# http://trac.osgeo.org/gdal/ticket/1994
310sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
311# Install Ruby bindings to distribution specific directory
312sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
313
314# Install Ruby bindings into the proper place
315sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
316sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
317
f4952e6f
AM
318# our man path
319sed -i -e 's#^mandir=.*##g' configure.in
320
4058fbc3 321%{__rm} -r man
4ed54fac 322
b88bb9ef
JB
323%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
324
faf5649c 325%build
69051332 326%{__libtoolize}
69051332 327%{__aclocal} -I m4
faf5649c 328%{__autoconf}
0a5f35eb 329%{__autoheader}
6b59fa88 330%configure \
e582c3b1 331 --includedir=%{_includedir}/gdal \
5014b82a 332 --datadir=%{_datadir}/gdal \
d4d7a2c6 333 --with-dods-root=/usr \
d3d190a4 334 %{?with_armadillo:--with-armadillo} \
779b0eec 335 %{?with_crnlib:--with-dds} \
209aac6b 336 %{?with_epsilon:--with-epsilon} \
0316feee 337 %{?with_grass:--with-grass} \
b88bb9ef 338 %{!?with_gta:--without-gta} \
69051332 339 --with-hide-internal-symbols \
9b4989ae
JB
340 %{?with_java:--with-java=%{java_home}} \
341 --with-liblzma \
209aac6b 342 %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
d3d190a4 343 %{?with_mysql:--with-mysql} \
0316feee 344 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 345 %{?with_opencl:--with-opencl} \
a0ffd9c4 346 --with-perl \
9b4989ae 347 %{?with_php:--with-php} \
fac7da6f
JB
348 %{?with_podofo:--with-podofo} \
349 %{?with_poppler:--with-poppler} \
69051332 350 --with-python \
779b0eec 351 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 352 %{?with_ruby:--with-ruby} \
779b0eec 353 %{?with_fyba:--with-sosi} \
4537079d 354 %{?with_spatialite:--with-spatialite} \
69051332 355 --with-sqlite3 \
9b4989ae 356 --with-webp \
655672e5 357 %{?with_xerces:--with-xerces} \
6b59fa88 358 --with-xerces-inc=/usr/include/xercesc \
80faacbe 359 --with-xerces-lib="-lxerces-c" \
69051332 360 --without-libgrass
954ec354 361# --with-pcidsk=/usr (needs > 0.3)
779b0eec 362# csharp builds, but has no configure option nor install target
faf5649c 363
69051332 364# regenerate where needed
825dc3dc 365%{__make} -j1 -C swig/perl generate
3df9ed7f 366%if %{with ruby}
02b013b1 367%{__make} -j1 -C swig/ruby generate
3df9ed7f 368%endif
69051332 369
779b0eec
JB
370%{__make} -j1 \
371 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
372 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 373
825dc3dc 374%{__make} -j1 docs
3a591acf 375
f5a12c65
JK
376%{__make} -j1 man
377
faf5649c
JB
378%install
379rm -rf $RPM_BUILD_ROOT
faf5649c 380
825dc3dc 381%{__make} -j1 install install-man \
3a591acf
JB
382 DESTDIR=$RPM_BUILD_ROOT
383
388b39cb
ER
384rm -rf _html
385cp -a html _html
386cp -a ogr/html _html/ogr
faf5649c 387
9b4989ae
JB
388%if %{with php}
389# missing in make install
ead243f9
ER
390install -d $RPM_BUILD_ROOT%{php_extensiondir}
391install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
392install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
393install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
394install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
395install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
396cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 397; Enable gdal extension modules
9b4989ae
JB
398extension=gdal.so
399extension=gdalconst.so
400extension=ogr.so
401extension=osr.so
402EOF
403%endif
404
374370d5
JB
405%py_comp $RPM_BUILD_ROOT%{py_sitedir}
406%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
407%py_postclean
5014b82a 408
017b03bb
ER
409%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
410%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
411%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
412%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
413%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
414
415# some doxygen trash
0316feee
JB
416%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
417%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 418
faf5649c
JB
419%clean
420rm -rf $RPM_BUILD_ROOT
421
6b59fa88
JB
422%post -p /sbin/ldconfig
423%postun -p /sbin/ldconfig
424
faf5649c
JB
425%files
426%defattr(644,root,root,755)
c0a384ef 427%doc NEWS PROVENANCE.TXT
4058fbc3
JB
428%attr(755,root,root) %{_bindir}/epsg_tr.py
429%attr(755,root,root) %{_bindir}/esri2wkt.py
430%attr(755,root,root) %{_bindir}/gcps2vec.py
431%attr(755,root,root) %{_bindir}/gcps2wld.py
432%attr(755,root,root) %{_bindir}/gdal2tiles.py
433%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 434%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 435%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 436%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 437%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
438%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
439%attr(755,root,root) %{_bindir}/gdal_grid
440%attr(755,root,root) %{_bindir}/gdal_merge.py
441%attr(755,root,root) %{_bindir}/gdal_polygonize.py
442%attr(755,root,root) %{_bindir}/gdal_proximity.py
443%attr(755,root,root) %{_bindir}/gdal_rasterize
444%attr(755,root,root) %{_bindir}/gdal_retile.py
445%attr(755,root,root) %{_bindir}/gdal_sieve.py
446%attr(755,root,root) %{_bindir}/gdal_translate
447%attr(755,root,root) %{_bindir}/gdaladdo
448%attr(755,root,root) %{_bindir}/gdalbuildvrt
449%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 450%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
451%attr(755,root,root) %{_bindir}/gdaldem
452%attr(755,root,root) %{_bindir}/gdalenhance
453%attr(755,root,root) %{_bindir}/gdalident.py
454%attr(755,root,root) %{_bindir}/gdalimport.py
455%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 456%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 457%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
458%attr(755,root,root) %{_bindir}/gdalmove.py
459%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 460%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
461%attr(755,root,root) %{_bindir}/gdaltindex
462%attr(755,root,root) %{_bindir}/gdaltransform
463%attr(755,root,root) %{_bindir}/gdalwarp
464%attr(755,root,root) %{_bindir}/mkgraticule.py
465%attr(755,root,root) %{_bindir}/nearblack
466%attr(755,root,root) %{_bindir}/ogr2ogr
467%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 468%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
469%attr(755,root,root) %{_bindir}/ogrtindex
470%attr(755,root,root) %{_bindir}/pct2rgb.py
471%attr(755,root,root) %{_bindir}/rgb2pct.py
472%attr(755,root,root) %{_bindir}/testepsg
5014b82a 473%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
017b03bb 474%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
0a5f35eb 475%dir %{_libdir}/gdalplugins
6b59fa88 476%{_datadir}/gdal
4058fbc3 477%{_mandir}/man1/gdal2tiles.1*
0316feee 478%{_mandir}/man1/gdal_calc.1*
4058fbc3 479%{_mandir}/man1/gdal_contour.1*
f4952e6f 480%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
481%{_mandir}/man1/gdal_fillnodata.1*
482%{_mandir}/man1/gdal_grid.1*
483%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
484%{_mandir}/man1/gdal_polygonize.1*
485%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
486%{_mandir}/man1/gdal_rasterize.1*
487%{_mandir}/man1/gdal_retile.1*
488%{_mandir}/man1/gdal_sieve.1*
489%{_mandir}/man1/gdal_translate.1*
490%{_mandir}/man1/gdal_utilities.1*
491%{_mandir}/man1/gdaladdo.1*
492%{_mandir}/man1/gdalbuildvrt.1*
0316feee 493%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
494%{_mandir}/man1/gdaldem.1*
495%{_mandir}/man1/gdalinfo.1*
954ec354 496%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
497%{_mandir}/man1/gdalmanage.1*
498%{_mandir}/man1/gdalmove.1*
9b4989ae 499%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
500%{_mandir}/man1/gdaltindex.1*
501%{_mandir}/man1/gdaltransform.1*
502%{_mandir}/man1/gdalwarp.1*
503%{_mandir}/man1/nearblack.1*
504%{_mandir}/man1/ogr2ogr.1*
505%{_mandir}/man1/ogr_utilities.1*
506%{_mandir}/man1/ogrinfo.1*
0316feee 507%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
508%{_mandir}/man1/ogrtindex.1*
509%{_mandir}/man1/pct2rgb.1*
510%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
511
512%files devel
513%defattr(644,root,root,755)
388b39cb 514%doc _html/*
5014b82a 515%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 516%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 517%{_libdir}/libgdal.la
0316feee 518%{_pkgconfigdir}/gdal.pc
e582c3b1 519%{_includedir}/gdal
5014b82a 520%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
521
522%files static
523%defattr(644,root,root,755)
9b5c0fd4 524%{_libdir}/libgdal.a
6b59fa88 525
a0ffd9c4
JB
526%files -n perl-gdal
527%defattr(644,root,root,755)
528%dir %{perl_vendorarch}/Geo
529%{perl_vendorarch}/Geo/GDAL.pm
530%dir %{perl_vendorarch}/Geo/GDAL
531%{perl_vendorarch}/Geo/GDAL/Const.pm
532%{perl_vendorarch}/Geo/OGR.pm
533%{perl_vendorarch}/Geo/OSR.pm
534%dir %{perl_vendorarch}/auto/Geo
535%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
536%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
537%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4
JB
538%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
539%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
540%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
541%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4
JB
542%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
543
9b4989ae 544%if %{with php}
ead243f9 545%files -n %{php_name}-gdal
9b4989ae
JB
546%defattr(644,root,root,755)
547%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
548%attr(755,root,root) %{php_extensiondir}/gdal.so
549%attr(755,root,root) %{php_extensiondir}/gdalconst.so
550%attr(755,root,root) %{php_extensiondir}/ogr.so
551%attr(755,root,root) %{php_extensiondir}/osr.so
552%endif
553
6b59fa88
JB
554%files -n python-gdal
555%defattr(644,root,root,755)
9a2dbbce
JB
556%{py_sitedir}/gdal.py[co]
557%{py_sitedir}/gdalconst.py[co]
558%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
559%{py_sitedir}/ogr.py[co]
560%{py_sitedir}/osr.py[co]
69051332
JB
561%{py_sitedir}/GDAL-*.egg-info
562%dir %{py_sitedir}/osgeo
563%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
564%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
565%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
566%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
567%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
568%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 569
4aafe7c0 570%if %{with ruby}
a0ffd9c4
JB
571%files -n ruby-gdal
572%defattr(644,root,root,755)
315a1c4a
ER
573%dir %{ruby_vendorarchdir}/gdal
574%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
575%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
576%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
577%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 578%endif
This page took 0.123741 seconds and 4 git commands to generate.