]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- enabled GTA support by default
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
2a1ee42f 2# - epsilon (--with-epsilon; http://sourceforge.net/projects/epsilon-project/)
9b4989ae
JB
3# - libgta (http://gta.nongnu.org/libgta.html)
4# - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
5# - freexl (http://www.gaia-gis.it/FreeXL/)
6# - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
7# - armadillo (--with-armadillo; http://arma.sourceforge.net/)
6313731c 8# - openjpeg (unreleased 1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.4)
9b4989ae
JB
9# - libjpeg12 (needs patching to use system one)
10# - libkml (1.3.0 needed, not released yet)
954ec354
JB
11# - wait for newer pcidsk, switch to external again
12# - csharp, java, mysql
9b4989ae
JB
13# - additional, proprietary(?) formats support:
14# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
15# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
16# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
17# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
18# - MrSID (http://www.lizardtech.com/developer/)
19# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20# - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
21# - Ingres (--with-ingres=/path)
22# - Informix DB
23# - DWGdirect (members only? http://www.opendwg.org/)
24# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
25# - OpenCL (--with-opencl; no free Linux implementation yet?)
655672e5 26#
27# Conditional build:
b88bb9ef
JB
28%bcond_without gta # GTA format support
29%bcond_without odbc # disable ODBC DB support
fac7da6f
JB
30%bcond_with podofo # PDF support via podofo instead of poppler
31%bcond_without poppler # PDF support via poppler
655672e5 32%bcond_without xerces # disable xerces support
9b4989ae 33%bcond_without java # disable Java and MDB support
b88bb9ef 34%bcond_without php # disable PHP binding
9b4989ae 35%bcond_without ruby # disable ruby binding
655672e5 36#
fac7da6f
JB
37%if %{with podofo}
38%undefine with_poppler
39%endif
faf5649c 40Summary: Geospatial Data Abstraction Library
a28c1bee 41Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 42Name: gdal
9b4989ae 43Version: 1.9.0
954ec354 44Release: 1
faf5649c
JB
45License: BSD-like
46Group: Libraries
c82ea5ef 47Source0: ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
9b4989ae 48# Source0-md5: 1853f3d8eb5232ae030abe007840cade
f5a12c65 49Patch0: %{name}-perl.patch
9b4989ae
JB
50Patch1: %{name}-python_install.patch
51Patch2: %{name}-doxy.patch
52Patch3: %{name}-sh.patch
53Patch4: %{name}-php.patch
9b5c0fd4 54URL: http://www.gdal.org/
69051332
JB
55BuildRequires: autoconf >= 2.52
56BuildRequires: automake
6b59fa88 57BuildRequires: cfitsio-devel
9b4989ae 58BuildRequires: curl-devel
9d161bc4 59BuildRequires: doxygen >= 1.4.2
69051332 60BuildRequires: expat-devel >= 1.95.0
9b4989ae 61BuildRequires: geos-devel >= 2.2.0
b459f4d7 62BuildRequires: giflib-devel >= 4.0
6b59fa88 63BuildRequires: hdf-devel >= 4.0
69051332 64BuildRequires: hdf5-devel
6b59fa88 65BuildRequires: jasper-devel
9b4989ae
JB
66%{?with_java:BuildRequires: jdk}
67%{?with_java:BuildRequires: jpackage-utils}
d4d7a2c6 68BuildRequires: libcsf-devel
4058fbc3 69BuildRequires: libdap-devel >= 3.10
b3cbf6a3 70BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 71%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 72BuildRequires: libjpeg-devel >= 6b
9b4989ae 73#BuildRequires: libkml-devel >= 1.3.0
e354fe40 74BuildRequires: libpng-devel >= 2:1.2.8
b3cbf6a3 75BuildRequires: libstdc++-devel
954ec354 76BuildRequires: libtiff-devel >= 4.0
69051332 77BuildRequires: libtool
e2b089e1 78BuildRequires: libuuid-devel
9b4989ae 79BuildRequires: libwebp-devel
e2b089e1 80BuildRequires: libxml2-devel
9b4989ae 81BuildRequires: netcdf-devel >= 4
6b59fa88 82BuildRequires: ogdi-devel >= 3.1
954ec354 83#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 84BuildRequires: perl-devel
9b4989ae 85%{?with_php:BuildRequires: php-devel}
fac7da6f
JB
86%{?with_podofo:BuildRequires: podofo-devel}
87%{?with_poppler:BuildRequires: poppler-devel}
9b4989ae
JB
88# ensure it's compiled with PQescapeStringConn support
89BuildRequires: postgresql-backend-devel >= 8.1.4
90BuildRequires: postgresql-devel >= 8.1.4
91BuildRequires: proj-devel >= 4
9a2dbbce 92BuildRequires: python-devel >= 1:2.5
017b03bb 93BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 94BuildRequires: python-setuptools
479cb83c 95BuildRequires: rpm-pythonprov
9b4989ae 96BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 97%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 98BuildRequires: sed >= 4.0
9b4989ae 99BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 100BuildRequires: swig-perl
9a2dbbce 101BuildRequires: swig-python >= 1.3
017b03bb 102%{?with_ruby:BuildRequires: swig-ruby}
db38e4ab 103%if "%{pld_release}" == "ti"
104BuildRequires: tetex-format-latex
105BuildRequires: tetex-dvips
106%else
479cb83c 107BuildRequires: texlive-dvips
108BuildRequires: texlive-latex
db38e4ab 109%endif
9831286f 110%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
111%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
112BuildRequires: xz-devel
faf5649c 113BuildRequires: zlib-devel >= 1.1.4
9b4989ae 114Requires: geos >= 2.2.0
b3cbf6a3 115Requires: libgeotiff >= 1.2.1
e354fe40 116Requires: libpng >= 2:1.2.8
954ec354 117Requires: libtiff >= 4.0
faf5649c
JB
118BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120%description
121GDAL is a translator library for raster geospatial data formats that
122is released under an Open Source license. As a library, it presents a
123single abstract data model to the calling application for all
124supported formats. The related OGR library (which lives within the
125GDAL source tree) provides a similar capability for simple features
126vector data.
f05c79e8 127
d34f2ec8
JR
128%description -l pl.UTF-8
129GDAL to biblioteka konwertująca między formatami rastrowych danych
130dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
131Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
132do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
133(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
134możliwości dla danych wektorowych.
faf5649c 135
6b59fa88
JB
136%package devel
137Summary: GDAL library header files
a28c1bee 138Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 139Group: Development/Libraries
1673a634 140Requires: %{name} = %{version}-%{release}
b3cbf6a3 141Requires: cfitsio-devel
69051332 142Requires: expat-devel >= 1.95.0
9b4989ae 143Requires: geos-devel >= 2.2.0
b459f4d7 144Requires: giflib-devel
b3cbf6a3 145Requires: hdf-devel >= 4.0
69051332 146Requires: hdf5-devel
b3cbf6a3 147Requires: jasper-devel
d4d7a2c6 148Requires: libcsf-devel
4058fbc3 149Requires: libdap-devel >= 3.10
b3cbf6a3
JB
150Requires: libgeotiff-devel >= 1.2.1
151Requires: libjpeg-devel
e354fe40 152Requires: libpng-devel >= 2:1.2.8
b3cbf6a3 153Requires: libstdc++-devel
954ec354 154Requires: libtiff-devel >= 4.0
9b4989ae 155Requires: netcdf-devel >= 4
b3cbf6a3 156Requires: ogdi-devel >= 3.1
954ec354 157#Requires: pcidsk-devel > 0.3
b3cbf6a3 158Requires: postgresql-devel
9b4989ae 159Requires: sqlite3-devel >= 3.0.0
655672e5 160%{?with_odbc:Requires: unixODBC-devel}
69051332 161%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
6b59fa88
JB
162
163%description devel
164GDAL library header files.
165
d34f2ec8
JR
166%description devel -l pl.UTF-8
167Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
168
169%package static
170Summary: GDAL static libraries
a28c1bee 171Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 172Group: Development/Libraries
1673a634 173Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
174
175%description static
176GDAL static libraries.
177
d34f2ec8 178%description static -l pl.UTF-8
6b59fa88
JB
179Statyczne biblioteki GDAL.
180
a0ffd9c4
JB
181%package -n perl-gdal
182Summary: Perl bindings for GDAL
183Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
184Group: Development/Languages/Perl
185Requires: %{name} = %{version}-%{release}
186
187%description -n perl-gdal
188Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
189
190%description -n perl-gdal -l pl.UTF-8
017b03bb 191Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 192
9b4989ae
JB
193%package -n php-gdal
194Summary: PHP bindings for GDAL library
195Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
196Group: Development/Languages/PHP
197Requires: %{name} = %{version}-%{release}
198%{?requires_php_extension}
199
200%description -n php-gdal
201PHP bindings for GDAL library
202
203%description -n php-gdal -l pl.UTF-8
204Wiązania PHP do biblioteki GDAL.
205
6b59fa88
JB
206%package -n python-gdal
207Summary: GDAL Python module
a28c1bee 208Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 209Group: Libraries/Python
1673a634 210Requires: %{name} = %{version}-%{release}
faf2b39a 211%pyrequires_eq python-libs
6b59fa88
JB
212
213%description -n python-gdal
214GDAL Python module.
215
d34f2ec8
JR
216%description -n python-gdal -l pl.UTF-8
217Moduł Pythona GDAL.
6b59fa88 218
a0ffd9c4
JB
219%package -n ruby-gdal
220Summary: Ruby bindings for GDAL
221Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
222Group: Development/Languages
223Requires: %{name} = %{version}-%{release}
224%{?ruby_mod_ver_requires_eq}
225
226%description -n ruby-gdal
227Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
228
229%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
230Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
231osr.
a0ffd9c4 232
faf5649c
JB
233%prep
234%setup -q
235%patch0 -p1
236%patch1 -p1
a0ffd9c4 237%patch2 -p1
69051332 238%patch3 -p1
4058fbc3 239%patch4 -p1
69051332
JB
240
241# need to regenerate (old ones don't support perl 5.10)
4058fbc3 242%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
f5a12c65 243
4058fbc3 244%{__rm} -r man
4ed54fac 245
b88bb9ef
JB
246%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
247
faf5649c 248%build
69051332 249%{__libtoolize}
69051332 250%{__aclocal} -I m4
faf5649c 251%{__autoconf}
69051332 252# disable grass/libgrass here, it can be built from separate gdal-grass package
6b59fa88 253%configure \
5014b82a 254 --datadir=%{_datadir}/gdal \
d4d7a2c6 255 --with-dods-root=/usr \
b88bb9ef 256 %{!?with_gta:--without-gta} \
69051332 257 --with-hide-internal-symbols \
9b4989ae
JB
258 %{?with_java:--with-java=%{java_home}} \
259 --with-liblzma \
260 %{?with_java:--with-mdb} \
a0ffd9c4 261 --with-perl \
9b4989ae 262 %{?with_php:--with-php} \
fac7da6f
JB
263 %{?with_podofo:--with-podofo} \
264 %{?with_poppler:--with-poppler} \
69051332 265 --with-python \
4aafe7c0 266 %{?with_ruby:--with-ruby} \
69051332 267 --with-sqlite3 \
9b4989ae 268 --with-webp \
655672e5 269 %{?with_xerces:--with-xerces} \
6b59fa88 270 --with-xerces-inc=/usr/include/xercesc \
80faacbe 271 --with-xerces-lib="-lxerces-c" \
a3027d62 272 --without-grass \
69051332 273 --without-libgrass
954ec354 274# --with-pcidsk=/usr (needs > 0.3)
69051332 275# csharp builds, but has no configure option
faf5649c 276
69051332 277# regenerate where needed
825dc3dc 278%{__make} -j1 -C swig/perl generate
961f0000 279%{?with_ruby:%{__make} -j1 -C swig/ruby generate}
69051332 280
825dc3dc 281%{__make} -j1
a0ffd9c4 282
825dc3dc 283%{__make} -j1 docs
3a591acf 284
f5a12c65
JK
285%{__make} -j1 man
286
faf5649c
JB
287%install
288rm -rf $RPM_BUILD_ROOT
faf5649c 289
825dc3dc 290%{__make} -j1 install install-man \
3a591acf
JB
291 DESTDIR=$RPM_BUILD_ROOT
292
388b39cb
ER
293rm -rf _html
294cp -a html _html
295cp -a ogr/html _html/ogr
faf5649c 296
9b4989ae
JB
297%if %{with php}
298# missing in make install
299install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
300install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
301install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
302install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
303install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
304cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
305; Enable gdal extension module
306extension=gdal.so
307extension=gdalconst.so
308extension=ogr.so
309extension=osr.so
310EOF
311%endif
312
374370d5
JB
313%py_comp $RPM_BUILD_ROOT%{py_sitedir}
314%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
315%py_postclean
5014b82a 316
017b03bb
ER
317%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
318%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
319%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
320%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
321%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
322
323# some doxygen trash
954ec354 324%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
9b4989ae 325%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
954ec354 326%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
017b03bb 327
faf5649c
JB
328%clean
329rm -rf $RPM_BUILD_ROOT
330
6b59fa88
JB
331%post -p /sbin/ldconfig
332%postun -p /sbin/ldconfig
333
faf5649c
JB
334%files
335%defattr(644,root,root,755)
c0a384ef 336%doc NEWS PROVENANCE.TXT
4058fbc3
JB
337%attr(755,root,root) %{_bindir}/epsg_tr.py
338%attr(755,root,root) %{_bindir}/esri2wkt.py
339%attr(755,root,root) %{_bindir}/gcps2vec.py
340%attr(755,root,root) %{_bindir}/gcps2wld.py
341%attr(755,root,root) %{_bindir}/gdal2tiles.py
342%attr(755,root,root) %{_bindir}/gdal2xyz.py
343%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 344%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3
JB
345%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
346%attr(755,root,root) %{_bindir}/gdal_grid
347%attr(755,root,root) %{_bindir}/gdal_merge.py
348%attr(755,root,root) %{_bindir}/gdal_polygonize.py
349%attr(755,root,root) %{_bindir}/gdal_proximity.py
350%attr(755,root,root) %{_bindir}/gdal_rasterize
351%attr(755,root,root) %{_bindir}/gdal_retile.py
352%attr(755,root,root) %{_bindir}/gdal_sieve.py
353%attr(755,root,root) %{_bindir}/gdal_translate
354%attr(755,root,root) %{_bindir}/gdaladdo
355%attr(755,root,root) %{_bindir}/gdalbuildvrt
356%attr(755,root,root) %{_bindir}/gdalchksum.py
357%attr(755,root,root) %{_bindir}/gdaldem
358%attr(755,root,root) %{_bindir}/gdalenhance
359%attr(755,root,root) %{_bindir}/gdalident.py
360%attr(755,root,root) %{_bindir}/gdalimport.py
361%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 362%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 363%attr(755,root,root) %{_bindir}/gdalmanage
9b4989ae 364%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
365%attr(755,root,root) %{_bindir}/gdaltindex
366%attr(755,root,root) %{_bindir}/gdaltransform
367%attr(755,root,root) %{_bindir}/gdalwarp
368%attr(755,root,root) %{_bindir}/mkgraticule.py
369%attr(755,root,root) %{_bindir}/nearblack
370%attr(755,root,root) %{_bindir}/ogr2ogr
371%attr(755,root,root) %{_bindir}/ogrinfo
372%attr(755,root,root) %{_bindir}/ogrtindex
373%attr(755,root,root) %{_bindir}/pct2rgb.py
374%attr(755,root,root) %{_bindir}/rgb2pct.py
375%attr(755,root,root) %{_bindir}/testepsg
5014b82a 376%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
017b03bb 377%attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
6b59fa88 378%{_datadir}/gdal
4058fbc3
JB
379%{_mandir}/man1/gdal2tiles.1*
380%{_mandir}/man1/gdal_contour.1*
381%{_mandir}/man1/gdal_fillnodata.1*
382%{_mandir}/man1/gdal_grid.1*
383%{_mandir}/man1/gdal_merge.1*
384%{_mandir}/man1/gdal_rasterize.1*
385%{_mandir}/man1/gdal_retile.1*
386%{_mandir}/man1/gdal_sieve.1*
387%{_mandir}/man1/gdal_translate.1*
388%{_mandir}/man1/gdal_utilities.1*
389%{_mandir}/man1/gdaladdo.1*
390%{_mandir}/man1/gdalbuildvrt.1*
391%{_mandir}/man1/gdaldem.1*
392%{_mandir}/man1/gdalinfo.1*
954ec354 393%{_mandir}/man1/gdallocationinfo.1*
9b4989ae 394%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
395%{_mandir}/man1/gdaltindex.1*
396%{_mandir}/man1/gdaltransform.1*
397%{_mandir}/man1/gdalwarp.1*
398%{_mandir}/man1/nearblack.1*
399%{_mandir}/man1/ogr2ogr.1*
400%{_mandir}/man1/ogr_utilities.1*
401%{_mandir}/man1/ogrinfo.1*
402%{_mandir}/man1/ogrtindex.1*
403%{_mandir}/man1/pct2rgb.1*
404%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
405
406%files devel
407%defattr(644,root,root,755)
388b39cb 408%doc _html/*
5014b82a 409%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 410%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 411%{_libdir}/libgdal.la
4058fbc3
JB
412%{_includedir}/cpl_*.h
413%{_includedir}/cplkeywordparser.h
414%{_includedir}/gdal*.h
415%{_includedir}/gvgcpfit.h
416%{_includedir}/memdataset.h
417%{_includedir}/ogr_*.h
418%{_includedir}/ogrsf_frmts.h
419%{_includedir}/rawdataset.h
420%{_includedir}/thinplatespline.h
421%{_includedir}/vrtdataset.h
5014b82a 422%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
423
424%files static
425%defattr(644,root,root,755)
9b5c0fd4 426%{_libdir}/libgdal.a
6b59fa88 427
a0ffd9c4
JB
428%files -n perl-gdal
429%defattr(644,root,root,755)
430%dir %{perl_vendorarch}/Geo
431%{perl_vendorarch}/Geo/GDAL.pm
432%dir %{perl_vendorarch}/Geo/GDAL
433%{perl_vendorarch}/Geo/GDAL/Const.pm
434%{perl_vendorarch}/Geo/OGR.pm
435%{perl_vendorarch}/Geo/OSR.pm
436%dir %{perl_vendorarch}/auto/Geo
437%dir %{perl_vendorarch}/auto/Geo/GDAL
438%{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
439%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
440%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
441%{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
442%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
443%dir %{perl_vendorarch}/auto/Geo/OGR
444%{perl_vendorarch}/auto/Geo/OGR/OGR.bs
445%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
446%dir %{perl_vendorarch}/auto/Geo/OSR
447%{perl_vendorarch}/auto/Geo/OSR/OSR.bs
448%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
449
9b4989ae
JB
450%if %{with php}
451%files -n php-gdal
452%defattr(644,root,root,755)
453%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
454%attr(755,root,root) %{php_extensiondir}/gdal.so
455%attr(755,root,root) %{php_extensiondir}/gdalconst.so
456%attr(755,root,root) %{php_extensiondir}/ogr.so
457%attr(755,root,root) %{php_extensiondir}/osr.so
458%endif
459
6b59fa88
JB
460%files -n python-gdal
461%defattr(644,root,root,755)
9a2dbbce
JB
462%{py_sitedir}/gdal.py[co]
463%{py_sitedir}/gdalconst.py[co]
464%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
465%{py_sitedir}/ogr.py[co]
466%{py_sitedir}/osr.py[co]
69051332
JB
467%{py_sitedir}/GDAL-*.egg-info
468%dir %{py_sitedir}/osgeo
469%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
470%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
471%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
472%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
473%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
474%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 475
4aafe7c0 476%if %{with ruby}
a0ffd9c4
JB
477%files -n ruby-gdal
478%defattr(644,root,root,755)
479%dir %{ruby_sitearchdir}/gdal
480%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
481%attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
482%attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
483%attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
4aafe7c0 484%endif
This page took 0.13921 seconds and 4 git commands to generate.