]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
- enabled GTA support by default
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - epsilon (--with-epsilon; http://sourceforge.net/projects/epsilon-project/)
3 # - libgta (http://gta.nongnu.org/libgta.html)
4 # - spatialite (--with-spatialite; libspatialite: http://www.gaia-gis.it/gaia-sins/)
5 # - freexl (http://www.gaia-gis.it/FreeXL/)
6 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
7 # - armadillo (--with-armadillo; http://arma.sourceforge.net/)
8 # - openjpeg (unreleased 1.5 or 2? needs opj_decode_tile_data symbol, not available in 1.3-1.4)
9 # - libjpeg12 (needs patching to use system one)
10 # - libkml (1.3.0 needed, not released yet)
11 # - wait for newer pcidsk, switch to external again
12 # - csharp, java, mysql
13 # - additional, proprietary(?) formats support:
14 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
15 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
16 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
17 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
18 #   - MrSID (http://www.lizardtech.com/developer/)
19 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
20 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
21 #   - Ingres (--with-ingres=/path)
22 #   - Informix DB
23 #   - DWGdirect (members only? http://www.opendwg.org/)
24 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
25 #   - OpenCL (--with-opencl; no free Linux implementation yet?)
26 #
27 # Conditional build:
28 %bcond_without  gta     # GTA format support
29 %bcond_without  odbc    # disable ODBC DB support
30 %bcond_with     podofo  # PDF support via podofo instead of poppler
31 %bcond_without  poppler # PDF support via poppler
32 %bcond_without  xerces  # disable xerces support
33 %bcond_without  java    # disable Java and MDB support
34 %bcond_without  php     # disable PHP binding
35 %bcond_without  ruby    # disable ruby binding
36 #
37 %if %{with podofo}
38 %undefine       with_poppler
39 %endif
40 Summary:        Geospatial Data Abstraction Library
41 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
42 Name:           gdal
43 Version:        1.9.0
44 Release:        1
45 License:        BSD-like
46 Group:          Libraries
47 Source0:        ftp://ftp.remotesensing.org/gdal/%{name}-%{version}.tar.gz
48 # Source0-md5:  1853f3d8eb5232ae030abe007840cade
49 Patch0:         %{name}-perl.patch
50 Patch1:         %{name}-python_install.patch
51 Patch2:         %{name}-doxy.patch
52 Patch3:         %{name}-sh.patch
53 Patch4:         %{name}-php.patch
54 URL:            http://www.gdal.org/
55 BuildRequires:  autoconf >= 2.52
56 BuildRequires:  automake
57 BuildRequires:  cfitsio-devel
58 BuildRequires:  curl-devel
59 BuildRequires:  doxygen >= 1.4.2
60 BuildRequires:  expat-devel >= 1.95.0
61 BuildRequires:  geos-devel >= 2.2.0
62 BuildRequires:  giflib-devel >= 4.0
63 BuildRequires:  hdf-devel >= 4.0
64 BuildRequires:  hdf5-devel
65 BuildRequires:  jasper-devel
66 %{?with_java:BuildRequires:     jdk}
67 %{?with_java:BuildRequires:     jpackage-utils}
68 BuildRequires:  libcsf-devel
69 BuildRequires:  libdap-devel >= 3.10
70 BuildRequires:  libgeotiff-devel >= 1.2.1
71 %{?with_gta:BuildRequires:      libgta-devel}
72 BuildRequires:  libjpeg-devel >= 6b
73 #BuildRequires: libkml-devel >= 1.3.0
74 BuildRequires:  libpng-devel >= 2:1.2.8
75 BuildRequires:  libstdc++-devel
76 BuildRequires:  libtiff-devel >= 4.0
77 BuildRequires:  libtool
78 BuildRequires:  libuuid-devel
79 BuildRequires:  libwebp-devel
80 BuildRequires:  libxml2-devel
81 BuildRequires:  netcdf-devel >= 4
82 BuildRequires:  ogdi-devel >= 3.1
83 #BuildRequires: pcidsk-devel > 0.3
84 BuildRequires:  perl-devel
85 %{?with_php:BuildRequires:      php-devel}
86 %{?with_podofo:BuildRequires:   podofo-devel}
87 %{?with_poppler:BuildRequires:  poppler-devel}
88 # ensure it's compiled with PQescapeStringConn support
89 BuildRequires:  postgresql-backend-devel >= 8.1.4
90 BuildRequires:  postgresql-devel >= 8.1.4
91 BuildRequires:  proj-devel >= 4
92 BuildRequires:  python-devel >= 1:2.5
93 BuildRequires:  python-numpy-devel >= 1:1.0.0
94 BuildRequires:  python-setuptools
95 BuildRequires:  rpm-pythonprov
96 BuildRequires:  rpmbuild(macros) >= 1.344
97 %{?with_ruby:BuildRequires:     ruby-devel}
98 BuildRequires:  sed >= 4.0
99 BuildRequires:  sqlite3-devel >= 3.0.0
100 BuildRequires:  swig-perl
101 BuildRequires:  swig-python >= 1.3
102 %{?with_ruby:BuildRequires:     swig-ruby}
103 %if "%{pld_release}" == "ti"
104 BuildRequires:  tetex-format-latex
105 BuildRequires:  tetex-dvips
106 %else
107 BuildRequires:  texlive-dvips
108 BuildRequires:  texlive-latex
109 %endif
110 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
111 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
112 BuildRequires:  xz-devel
113 BuildRequires:  zlib-devel >= 1.1.4
114 Requires:       geos >= 2.2.0
115 Requires:       libgeotiff >= 1.2.1
116 Requires:       libpng >= 2:1.2.8
117 Requires:       libtiff >= 4.0
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %description
121 GDAL is a translator library for raster geospatial data formats that
122 is released under an Open Source license. As a library, it presents a
123 single abstract data model to the calling application for all
124 supported formats. The related OGR library (which lives within the
125 GDAL source tree) provides a similar capability for simple features
126 vector data.
127
128 %description -l pl.UTF-8
129 GDAL to biblioteka konwertująca między formatami rastrowych danych
130 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
131 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
132 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
133 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
134 możliwości dla danych wektorowych.
135
136 %package devel
137 Summary:        GDAL library header files
138 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
139 Group:          Development/Libraries
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       cfitsio-devel
142 Requires:       expat-devel >= 1.95.0
143 Requires:       geos-devel >= 2.2.0
144 Requires:       giflib-devel
145 Requires:       hdf-devel >= 4.0
146 Requires:       hdf5-devel
147 Requires:       jasper-devel
148 Requires:       libcsf-devel
149 Requires:       libdap-devel >= 3.10
150 Requires:       libgeotiff-devel >= 1.2.1
151 Requires:       libjpeg-devel
152 Requires:       libpng-devel >= 2:1.2.8
153 Requires:       libstdc++-devel
154 Requires:       libtiff-devel >= 4.0
155 Requires:       netcdf-devel >= 4
156 Requires:       ogdi-devel >= 3.1
157 #Requires:      pcidsk-devel > 0.3
158 Requires:       postgresql-devel
159 Requires:       sqlite3-devel >= 3.0.0
160 %{?with_odbc:Requires:  unixODBC-devel}
161 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
162
163 %description devel
164 GDAL library header files.
165
166 %description devel -l pl.UTF-8
167 Pliki nagłówkowe biblioteki GDAL.
168
169 %package static
170 Summary:        GDAL static libraries
171 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 GDAL static libraries.
177
178 %description static -l pl.UTF-8
179 Statyczne biblioteki GDAL.
180
181 %package -n perl-gdal
182 Summary:        Perl bindings for GDAL
183 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
184 Group:          Development/Languages/Perl
185 Requires:       %{name} = %{version}-%{release}
186
187 %description -n perl-gdal
188 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
189
190 %description -n perl-gdal -l pl.UTF-8
191 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
192
193 %package -n php-gdal
194 Summary:        PHP bindings for GDAL library
195 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
196 Group:          Development/Languages/PHP
197 Requires:       %{name} = %{version}-%{release}
198 %{?requires_php_extension}
199
200 %description -n php-gdal
201 PHP bindings for GDAL library
202
203 %description -n php-gdal -l pl.UTF-8
204 Wiązania PHP do biblioteki GDAL.
205
206 %package -n python-gdal
207 Summary:        GDAL Python module
208 Summary(pl.UTF-8):      Moduł Pythona GDAL
209 Group:          Libraries/Python
210 Requires:       %{name} = %{version}-%{release}
211 %pyrequires_eq  python-libs
212
213 %description -n python-gdal
214 GDAL Python module.
215
216 %description -n python-gdal -l pl.UTF-8
217 Moduł Pythona GDAL.
218
219 %package -n ruby-gdal
220 Summary:        Ruby bindings for GDAL
221 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
222 Group:          Development/Languages
223 Requires:       %{name} = %{version}-%{release}
224 %{?ruby_mod_ver_requires_eq}
225
226 %description -n ruby-gdal
227 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
228
229 %description -n ruby-gdal -l pl.UTF-8
230 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
231 osr.
232
233 %prep
234 %setup -q
235 %patch0 -p1
236 %patch1 -p1
237 %patch2 -p1
238 %patch3 -p1
239 %patch4 -p1
240
241 # need to regenerate (old ones don't support perl 5.10)
242 %{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
243
244 %{__rm} -r man
245
246 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
247
248 %build
249 %{__libtoolize}
250 %{__aclocal} -I m4
251 %{__autoconf}
252 # disable grass/libgrass here, it can be built from separate gdal-grass package
253 %configure \
254         --datadir=%{_datadir}/gdal \
255         --with-dods-root=/usr \
256         %{!?with_gta:--without-gta} \
257         --with-hide-internal-symbols \
258         %{?with_java:--with-java=%{java_home}} \
259         --with-liblzma \
260         %{?with_java:--with-mdb} \
261         --with-perl \
262         %{?with_php:--with-php} \
263         %{?with_podofo:--with-podofo} \
264         %{?with_poppler:--with-poppler} \
265         --with-python \
266         %{?with_ruby:--with-ruby} \
267         --with-sqlite3 \
268         --with-webp \
269         %{?with_xerces:--with-xerces} \
270         --with-xerces-inc=/usr/include/xercesc \
271         --with-xerces-lib="-lxerces-c" \
272         --without-grass \
273         --without-libgrass
274 #       --with-pcidsk=/usr (needs > 0.3)
275 # csharp builds, but has no configure option
276
277 # regenerate where needed
278 %{__make} -j1 -C swig/perl generate
279 %{?with_ruby:%{__make} -j1 -C swig/ruby generate}
280
281 %{__make} -j1
282
283 %{__make} -j1 docs
284
285 %{__make} -j1 man
286
287 %install
288 rm -rf $RPM_BUILD_ROOT
289
290 %{__make} -j1 install install-man \
291         DESTDIR=$RPM_BUILD_ROOT
292
293 rm -rf _html
294 cp -a html _html
295 cp -a ogr/html _html/ogr
296
297 %if %{with php}
298 # missing in make install
299 install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
300 install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
301 install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
302 install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
303 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
304 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
305 ; Enable gdal extension module
306 extension=gdal.so
307 extension=gdalconst.so
308 extension=ogr.so
309 extension=osr.so
310 EOF
311 %endif
312
313 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
314 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
315 %py_postclean
316
317 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
318 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
319 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
320 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
321 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
322
323 # some doxygen trash
324 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/{GDAL.dox,GDAL/Const.dox,OGR.dox,OSR.dox}
325 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Geo/check_dox.pl
326 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{fillnodata,sieve}.dox
327
328 %clean
329 rm -rf $RPM_BUILD_ROOT
330
331 %post   -p /sbin/ldconfig
332 %postun -p /sbin/ldconfig
333
334 %files
335 %defattr(644,root,root,755)
336 %doc NEWS PROVENANCE.TXT
337 %attr(755,root,root) %{_bindir}/epsg_tr.py
338 %attr(755,root,root) %{_bindir}/esri2wkt.py
339 %attr(755,root,root) %{_bindir}/gcps2vec.py
340 %attr(755,root,root) %{_bindir}/gcps2wld.py
341 %attr(755,root,root) %{_bindir}/gdal2tiles.py
342 %attr(755,root,root) %{_bindir}/gdal2xyz.py
343 %attr(755,root,root) %{_bindir}/gdal_contour
344 %attr(755,root,root) %{_bindir}/gdal_calc.py
345 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
346 %attr(755,root,root) %{_bindir}/gdal_grid
347 %attr(755,root,root) %{_bindir}/gdal_merge.py
348 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
349 %attr(755,root,root) %{_bindir}/gdal_proximity.py
350 %attr(755,root,root) %{_bindir}/gdal_rasterize
351 %attr(755,root,root) %{_bindir}/gdal_retile.py
352 %attr(755,root,root) %{_bindir}/gdal_sieve.py
353 %attr(755,root,root) %{_bindir}/gdal_translate
354 %attr(755,root,root) %{_bindir}/gdaladdo
355 %attr(755,root,root) %{_bindir}/gdalbuildvrt
356 %attr(755,root,root) %{_bindir}/gdalchksum.py
357 %attr(755,root,root) %{_bindir}/gdaldem
358 %attr(755,root,root) %{_bindir}/gdalenhance
359 %attr(755,root,root) %{_bindir}/gdalident.py
360 %attr(755,root,root) %{_bindir}/gdalimport.py
361 %attr(755,root,root) %{_bindir}/gdalinfo
362 %attr(755,root,root) %{_bindir}/gdallocationinfo
363 %attr(755,root,root) %{_bindir}/gdalmanage
364 %attr(755,root,root) %{_bindir}/gdalsrsinfo
365 %attr(755,root,root) %{_bindir}/gdaltindex
366 %attr(755,root,root) %{_bindir}/gdaltransform
367 %attr(755,root,root) %{_bindir}/gdalwarp
368 %attr(755,root,root) %{_bindir}/mkgraticule.py
369 %attr(755,root,root) %{_bindir}/nearblack
370 %attr(755,root,root) %{_bindir}/ogr2ogr
371 %attr(755,root,root) %{_bindir}/ogrinfo
372 %attr(755,root,root) %{_bindir}/ogrtindex
373 %attr(755,root,root) %{_bindir}/pct2rgb.py
374 %attr(755,root,root) %{_bindir}/rgb2pct.py
375 %attr(755,root,root) %{_bindir}/testepsg
376 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
377 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
378 %{_datadir}/gdal
379 %{_mandir}/man1/gdal2tiles.1*
380 %{_mandir}/man1/gdal_contour.1*
381 %{_mandir}/man1/gdal_fillnodata.1*
382 %{_mandir}/man1/gdal_grid.1*
383 %{_mandir}/man1/gdal_merge.1*
384 %{_mandir}/man1/gdal_rasterize.1*
385 %{_mandir}/man1/gdal_retile.1*
386 %{_mandir}/man1/gdal_sieve.1*
387 %{_mandir}/man1/gdal_translate.1*
388 %{_mandir}/man1/gdal_utilities.1*
389 %{_mandir}/man1/gdaladdo.1*
390 %{_mandir}/man1/gdalbuildvrt.1*
391 %{_mandir}/man1/gdaldem.1*
392 %{_mandir}/man1/gdalinfo.1*
393 %{_mandir}/man1/gdallocationinfo.1*
394 %{_mandir}/man1/gdalsrsinfo.1*
395 %{_mandir}/man1/gdaltindex.1*
396 %{_mandir}/man1/gdaltransform.1*
397 %{_mandir}/man1/gdalwarp.1*
398 %{_mandir}/man1/nearblack.1*
399 %{_mandir}/man1/ogr2ogr.1*
400 %{_mandir}/man1/ogr_utilities.1*
401 %{_mandir}/man1/ogrinfo.1*
402 %{_mandir}/man1/ogrtindex.1*
403 %{_mandir}/man1/pct2rgb.1*
404 %{_mandir}/man1/rgb2pct.1*
405
406 %files devel
407 %defattr(644,root,root,755)
408 %doc _html/*
409 %attr(755,root,root) %{_bindir}/gdal-config
410 %attr(755,root,root) %{_libdir}/libgdal.so
411 %{_libdir}/libgdal.la
412 %{_includedir}/cpl_*.h
413 %{_includedir}/cplkeywordparser.h
414 %{_includedir}/gdal*.h
415 %{_includedir}/gvgcpfit.h
416 %{_includedir}/memdataset.h
417 %{_includedir}/ogr_*.h
418 %{_includedir}/ogrsf_frmts.h
419 %{_includedir}/rawdataset.h
420 %{_includedir}/thinplatespline.h
421 %{_includedir}/vrtdataset.h
422 %{_mandir}/man1/gdal-config.1*
423
424 %files static
425 %defattr(644,root,root,755)
426 %{_libdir}/libgdal.a
427
428 %files -n perl-gdal
429 %defattr(644,root,root,755)
430 %dir %{perl_vendorarch}/Geo
431 %{perl_vendorarch}/Geo/GDAL.pm
432 %dir %{perl_vendorarch}/Geo/GDAL
433 %{perl_vendorarch}/Geo/GDAL/Const.pm
434 %{perl_vendorarch}/Geo/OGR.pm
435 %{perl_vendorarch}/Geo/OSR.pm
436 %dir %{perl_vendorarch}/auto/Geo
437 %dir %{perl_vendorarch}/auto/Geo/GDAL
438 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
439 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
440 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
441 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
442 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
443 %dir %{perl_vendorarch}/auto/Geo/OGR
444 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
445 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
446 %dir %{perl_vendorarch}/auto/Geo/OSR
447 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
448 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
449
450 %if %{with php}
451 %files -n php-gdal
452 %defattr(644,root,root,755)
453 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
454 %attr(755,root,root) %{php_extensiondir}/gdal.so
455 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
456 %attr(755,root,root) %{php_extensiondir}/ogr.so
457 %attr(755,root,root) %{php_extensiondir}/osr.so
458 %endif
459
460 %files -n python-gdal
461 %defattr(644,root,root,755)
462 %{py_sitedir}/gdal.py[co]
463 %{py_sitedir}/gdalconst.py[co]
464 %{py_sitedir}/gdalnumeric.py[co]
465 %{py_sitedir}/ogr.py[co]
466 %{py_sitedir}/osr.py[co]
467 %{py_sitedir}/GDAL-*.egg-info
468 %dir %{py_sitedir}/osgeo
469 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
470 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
471 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
472 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
473 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
474 %{py_sitedir}/osgeo/*.py[co]
475
476 %if %{with ruby}
477 %files -n ruby-gdal
478 %defattr(644,root,root,755)
479 %dir %{ruby_sitearchdir}/gdal
480 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdal.so
481 %attr(755,root,root) %{ruby_sitearchdir}/gdal/gdalconst.so
482 %attr(755,root,root) %{ruby_sitearchdir}/gdal/ogr.so
483 %attr(755,root,root) %{ruby_sitearchdir}/gdal/osr.so
484 %endif
This page took 0.092975 seconds and 4 git commands to generate.