]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- release 11 (by relup.sh)
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
c64d9529
JB
5# - MongoCXX (mongo/client/dbclient.h, -lmongoclient -lboost_system -lboost_thread -lboost_regex)
6# - rasterlite2
7# - sfcgal >= 1.2.2
d3d190a4 8# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 9# - libkml (1.3.0 needed, not released yet)
954ec354 10# - wait for newer pcidsk, switch to external again
d3d190a4 11# - csharp, java
9b4989ae
JB
12# - additional, proprietary(?) formats support:
13# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17# - MrSID (http://www.lizardtech.com/developer/)
c64d9529 18# - LuraTech JP2Lura
9b4989ae 19# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 20# - Ingres (--with-ingres=/path)
0316feee 21# - Informix DB (--with-idb)
9b4989ae
JB
22# - DWGdirect (members only? http://www.opendwg.org/)
23# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
c64d9529 24# - Teigha DWG/DGN (https://www.opendesign.com/products/drawings?)
655672e5 25#
26# Conditional build:
d3d190a4 27%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 28%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 29%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 30%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 31%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 32%bcond_without gta # GTA format support
77dfc6fa 33%bcond_without kea # KEA format support
d3d190a4 34%bcond_without mysql # MySQL DB support
0316feee 35%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
36%bcond_without odbc # ODBC DB support
37%bcond_without opencl # OpenCL (GPU) support
c9c08280 38%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
39%bcond_with podofo # PDF support via podofo instead of poppler
40%bcond_without poppler # PDF support via poppler
16d32926 41%bcond_with rasdaman # Rasdaman support
45593023 42%bcond_with spatialite # SpatiaLite support
d3d190a4
JB
43%bcond_without xerces # Xerces support
44%bcond_without java # Java and MDB support
315a1c4a 45
fac7da6f
JB
46%if %{with podofo}
47%undefine with_poppler
48%endif
faf5649c 49Summary: Geospatial Data Abstraction Library
a28c1bee 50Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 51Name: gdal
c64d9529 52Version: 2.4.0
1571fbcd 53Release: 11
faf5649c
JB
54License: BSD-like
55Group: Libraries
84501866 56Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
c64d9529 57# Source0-md5: 794096364a50df4bc7c5b710d997b6b4
f5a12c65 58Patch0: %{name}-perl.patch
ee43bca4 59Patch1: %{name}-poppler.patch
c64d9529 60Patch2: %{name}-pc.patch
779b0eec 61Patch9: %{name}-dds.patch
ce035715 62Patch12: %{name}-rasdaman.patch
0a5f35eb 63Patch13: %{name}-pluginsdir.patch
f9aa527b 64Patch15: libx32.patch
9b5c0fd4 65URL: http://www.gdal.org/
c64d9529
JB
66# 1.x or 2.x supported
67BuildRequires: CharLS-devel
d3d190a4
JB
68%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
69%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
70BuildRequires: autoconf >= 2.52
71BuildRequires: automake
6b59fa88 72BuildRequires: cfitsio-devel
6a3158ac 73%{?with_crnlib:BuildRequires: crnlib-devel}
c64d9529 74BuildRequires: cryptopp-devel
9b4989ae 75BuildRequires: curl-devel
9d161bc4 76BuildRequires: doxygen >= 1.4.2
209aac6b 77%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 78BuildRequires: expat-devel >= 1.95.0
779b0eec 79%{?with_fyba:BuildRequires: fyba-devel}
4537079d 80BuildRequires: freexl-devel >= 1.0
0316feee
JB
81BuildRequires: gcc >= 6:4.1
82BuildRequires: geos-devel >= 3.1.0
b459f4d7 83BuildRequires: giflib-devel >= 4.0
779b0eec 84%{?with_grass:BuildRequires: grass-devel >= 6.4}
c64d9529 85BuildRequires: hdf-devel >= 4.2.5
69051332 86BuildRequires: hdf5-devel
6b59fa88 87BuildRequires: jasper-devel
9b4989ae
JB
88%{?with_java:BuildRequires: jdk}
89%{?with_java:BuildRequires: jpackage-utils}
0316feee 90BuildRequires: json-c-devel >= 0.11
77dfc6fa 91%{?with_kea:BuildRequires: kealib-devel}
8fd908ab 92BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 93BuildRequires: libdap-devel >= 3.10
b3cbf6a3 94BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 95%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 96BuildRequires: libjpeg-devel >= 6b
9b4989ae 97#BuildRequires: libkml-devel >= 1.3.0
e354fe40 98BuildRequires: libpng-devel >= 2:1.2.8
4537079d 99%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 100BuildRequires: libstdc++-devel
954ec354 101BuildRequires: libtiff-devel >= 4.0
69051332 102BuildRequires: libtool
e2b089e1 103BuildRequires: libuuid-devel
9b4989ae 104BuildRequires: libwebp-devel
0316feee 105BuildRequires: libxml2-devel >= 2
c64d9529 106#%{?with_mysql:BuildRequires: mysql-devel >= 4}
952dc496 107%{?with_mysql:BuildRequires: /usr/bin/mysql_config}
80114ba8 108BuildRequires: netcdf-devel >= 4.1
6b59fa88 109BuildRequires: ogdi-devel >= 3.1
c64d9529 110%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
0316feee
JB
111# 8.1.7 for DB support, 10.0.1 for georaster
112%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 113#BuildRequires: pcidsk-devel > 0.3
c64d9529 114BuildRequires: pcre-devel
a0ffd9c4 115BuildRequires: perl-devel
c64d9529 116BuildRequires: pkgconfig >= 1:0.21
fac7da6f 117%{?with_podofo:BuildRequires: podofo-devel}
0077f857 118%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
119# ensure it's compiled with PQescapeStringConn support
120BuildRequires: postgresql-backend-devel >= 8.1.4
121BuildRequires: postgresql-devel >= 8.1.4
122BuildRequires: proj-devel >= 4
9a2dbbce 123BuildRequires: python-devel >= 1:2.5
017b03bb 124BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 125BuildRequires: python-setuptools
c64d9529 126BuildRequires: qhull-devel >= 2012
779b0eec 127%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 128BuildRequires: rpm-pythonprov
9b4989ae 129BuildRequires: rpmbuild(macros) >= 1.344
b88bb9ef 130BuildRequires: sed >= 4.0
9b4989ae 131BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 132BuildRequires: swig-perl
9a2dbbce 133BuildRequires: swig-python >= 1.3
479cb83c 134BuildRequires: texlive-dvips
135BuildRequires: texlive-latex
9831286f 136%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
c64d9529 137%{?with_xerces:BuildRequires: xerces-c-devel >= 3.1.0}
9b4989ae 138BuildRequires: xz-devel
faf5649c 139BuildRequires: zlib-devel >= 1.1.4
c64d9529
JB
140# for ZSTD compression in TIFF
141BuildRequires: zstd-devel
4537079d 142Requires: freexl >= 1.0
0316feee 143Requires: geos >= 3.1.0
c64d9529 144Requires: hdf >= 4.2.5
b3cbf6a3 145Requires: libgeotiff >= 1.2.1
e354fe40 146Requires: libpng >= 2:1.2.8
954ec354 147Requires: libtiff >= 4.0
c64d9529
JB
148%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
149Requires: qhull >= 2012
150%{?with_xerces:Requires: xerces-c >= 3.1.0}
faf5649c
JB
151BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
152
153%description
154GDAL is a translator library for raster geospatial data formats that
155is released under an Open Source license. As a library, it presents a
156single abstract data model to the calling application for all
157supported formats. The related OGR library (which lives within the
158GDAL source tree) provides a similar capability for simple features
159vector data.
f05c79e8 160
d34f2ec8
JR
161%description -l pl.UTF-8
162GDAL to biblioteka konwertująca między formatami rastrowych danych
163dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
164Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
165do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
166(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
167możliwości dla danych wektorowych.
faf5649c 168
6b59fa88
JB
169%package devel
170Summary: GDAL library header files
a28c1bee 171Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 172Group: Development/Libraries
1673a634 173Requires: %{name} = %{version}-%{release}
c64d9529 174Requires: CharLS-devel
d3d190a4
JB
175%{?with_opencl:Requires: OpenCL-devel >= 1.0}
176%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 177Requires: cfitsio-devel
6a3158ac 178%{?with_crnlib:Requires: crnlib-devel}
c64d9529 179Requires: cryptopp-devel
209aac6b
JB
180Requires: curl-devel
181%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 182%{?with_fyba:Requires: fyba-devel}
69051332 183Requires: expat-devel >= 1.95.0
4537079d 184Requires: freexl-devel >= 1.0
0316feee 185Requires: geos-devel >= 3.1.0
209aac6b 186Requires: giflib-devel >= 4.0
c64d9529 187Requires: hdf-devel >= 4.2.5
69051332 188Requires: hdf5-devel
b3cbf6a3 189Requires: jasper-devel
0316feee 190Requires: json-c-devel >= 0.11
77dfc6fa 191%{?with_kea:Requires: kealib-devel}
d4d7a2c6 192Requires: libcsf-devel
4058fbc3 193Requires: libdap-devel >= 3.10
b3cbf6a3 194Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
195%{?with_gta:Requires: libgta-devel}
196Requires: libjpeg-devel >= 6b
e354fe40 197Requires: libpng-devel >= 2:1.2.8
4537079d 198%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 199Requires: libstdc++-devel
954ec354 200Requires: libtiff-devel >= 4.0
209aac6b
JB
201Requires: libuuid-devel
202Requires: libwebp-devel
0316feee 203Requires: libxml2-devel >= 2
952dc496 204%{?with_mysql:Requires: /usr/bin/mysql_config}
9b4989ae 205Requires: netcdf-devel >= 4
b3cbf6a3 206Requires: ogdi-devel >= 3.1
c64d9529 207%{?with_openjpeg:Requires: openjpeg2-devel >= 2.1.0}
954ec354 208#Requires: pcidsk-devel > 0.3
c64d9529 209Requires: pcre-devel
209aac6b 210%{?with_podofo:Requires: podofo-devel}
0077f857 211%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 212Requires: postgresql-devel
209aac6b 213Requires: proj-devel >= 4
c64d9529 214Requires: qhull-devel >= 2012
779b0eec 215%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 216Requires: sqlite3-devel >= 3.0.0
655672e5 217%{?with_odbc:Requires: unixODBC-devel}
c64d9529 218%{?with_xerces:Requires: xerces-c-devel >= 3.1.0}
209aac6b
JB
219Requires: xz-devel
220Requires: zlib-devel >= 1.1.4
c64d9529 221Requires: zstd-devel
6b59fa88
JB
222
223%description devel
224GDAL library header files.
225
d34f2ec8
JR
226%description devel -l pl.UTF-8
227Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
228
229%package static
230Summary: GDAL static libraries
a28c1bee 231Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 232Group: Development/Libraries
1673a634 233Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
234
235%description static
236GDAL static libraries.
237
d34f2ec8 238%description static -l pl.UTF-8
6b59fa88
JB
239Statyczne biblioteki GDAL.
240
a0ffd9c4
JB
241%package -n perl-gdal
242Summary: Perl bindings for GDAL
243Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
244Group: Development/Languages/Perl
245Requires: %{name} = %{version}-%{release}
246
247%description -n perl-gdal
248Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
249
250%description -n perl-gdal -l pl.UTF-8
017b03bb 251Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 252
6b59fa88
JB
253%package -n python-gdal
254Summary: GDAL Python module
a28c1bee 255Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 256Group: Libraries/Python
1673a634 257Requires: %{name} = %{version}-%{release}
315a1c4a 258Requires: python-libs
6b59fa88
JB
259
260%description -n python-gdal
261GDAL Python module.
262
d34f2ec8
JR
263%description -n python-gdal -l pl.UTF-8
264Moduł Pythona GDAL.
6b59fa88 265
faf5649c
JB
266%prep
267%setup -q
268%patch0 -p1
c64d9529 269%patch1 -p1
f1b5abea 270%patch2 -p1
743c2d9c 271%patch9 -p1
743c2d9c 272%patch12 -p1
6f52dc7d 273%patch13 -p1
f9aa527b 274%patch15 -p1
0316feee 275
c64d9529
JB
276# need to regenerate (old ones don't support perl 5.10)
277%{__rm} swig/perl/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
315a1c4a 278
f4952e6f 279# our man path
be8ee7be 280sed -i -e 's#^mandir=.*##g' configure.ac
f4952e6f 281
4058fbc3 282%{__rm} -r man
4ed54fac 283
be8ee7be 284%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.ac
b88bb9ef 285
faf5649c 286%build
e6e33a1a
JR
287%ifarch %{x8664}
288jvm_arch=amd64
289%endif
290%ifarch %{ix86}
291jvm_arch=i386
292%endif
293%ifarch x32
294jvm_arch=x32
295%endif
296
69051332 297%{__libtoolize}
69051332 298%{__aclocal} -I m4
faf5649c 299%{__autoconf}
0a5f35eb 300%{__autoheader}
6b59fa88 301%configure \
e582c3b1 302 --includedir=%{_includedir}/gdal \
5014b82a 303 --datadir=%{_datadir}/gdal \
d4d7a2c6 304 --with-dods-root=/usr \
d3d190a4 305 %{?with_armadillo:--with-armadillo} \
6f52dc7d 306 %{?with_crnlib:--with-dds} \
209aac6b 307 %{?with_epsilon:--with-epsilon} \
0316feee 308 %{?with_grass:--with-grass} \
b88bb9ef 309 %{!?with_gta:--without-gta} \
69051332 310 --with-hide-internal-symbols \
9b4989ae
JB
311 %{?with_java:--with-java=%{java_home}} \
312 --with-liblzma \
77dfc6fa 313 %{!?with_kea:--without-kea} \
fffcf251 314 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 315 %{?with_mysql:--with-mysql} \
0316feee 316 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 317 %{?with_opencl:--with-opencl} \
a0ffd9c4 318 --with-perl \
fac7da6f
JB
319 %{?with_podofo:--with-podofo} \
320 %{?with_poppler:--with-poppler} \
69051332 321 --with-python \
779b0eec 322 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
779b0eec 323 %{?with_fyba:--with-sosi} \
4537079d 324 %{?with_spatialite:--with-spatialite} \
69051332 325 --with-sqlite3 \
9b4989ae 326 --with-webp \
655672e5 327 %{?with_xerces:--with-xerces} \
c64d9529 328 --with-xerces-inc=/usr/include \
80faacbe 329 --with-xerces-lib="-lxerces-c" \
69051332 330 --without-libgrass
954ec354 331# --with-pcidsk=/usr (needs > 0.3)
779b0eec 332# csharp builds, but has no configure option nor install target
faf5649c 333
69051332 334# regenerate where needed
825dc3dc 335%{__make} -j1 -C swig/perl generate
69051332 336
45593023 337%{__make} \
779b0eec
JB
338 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
339 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 340
825dc3dc 341%{__make} -j1 docs
3a591acf 342
f5a12c65
JK
343%{__make} -j1 man
344
faf5649c
JB
345%install
346rm -rf $RPM_BUILD_ROOT
faf5649c 347
825dc3dc 348%{__make} -j1 install install-man \
3a591acf
JB
349 DESTDIR=$RPM_BUILD_ROOT
350
c64d9529
JB
351# TODO: remove libgdal.la when gdal.pc gets maintained Requires.private/Libs.private list
352
388b39cb
ER
353rm -rf _html
354cp -a html _html
faf5649c 355
374370d5
JB
356%py_comp $RPM_BUILD_ROOT%{py_sitedir}
357%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
358%py_postclean
5014b82a 359
017b03bb
ER
360%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
361%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
362%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
363%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
364%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
365
faf5649c
JB
366%clean
367rm -rf $RPM_BUILD_ROOT
368
6b59fa88
JB
369%post -p /sbin/ldconfig
370%postun -p /sbin/ldconfig
371
faf5649c
JB
372%files
373%defattr(644,root,root,755)
c0a384ef 374%doc NEWS PROVENANCE.TXT
4058fbc3
JB
375%attr(755,root,root) %{_bindir}/epsg_tr.py
376%attr(755,root,root) %{_bindir}/esri2wkt.py
377%attr(755,root,root) %{_bindir}/gcps2vec.py
378%attr(755,root,root) %{_bindir}/gcps2wld.py
379%attr(755,root,root) %{_bindir}/gdal2tiles.py
380%attr(755,root,root) %{_bindir}/gdal2xyz.py
4058fbc3 381%attr(755,root,root) %{_bindir}/gdaladdo
6f52dc7d 382%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 383%attr(755,root,root) %{_bindir}/gdalbuildvrt
6f52dc7d 384%attr(755,root,root) %{_bindir}/gdal_calc.py
4058fbc3 385%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 386%attr(755,root,root) %{_bindir}/gdalcompare.py
6f52dc7d 387%attr(755,root,root) %{_bindir}/gdal_contour
4058fbc3 388%attr(755,root,root) %{_bindir}/gdaldem
6f52dc7d 389%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3 390%attr(755,root,root) %{_bindir}/gdalenhance
6f52dc7d
JR
391%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
392%attr(755,root,root) %{_bindir}/gdal_grid
4058fbc3
JB
393%attr(755,root,root) %{_bindir}/gdalident.py
394%attr(755,root,root) %{_bindir}/gdalimport.py
395%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 396%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 397%attr(755,root,root) %{_bindir}/gdalmanage
6f52dc7d 398%attr(755,root,root) %{_bindir}/gdal_merge.py
f4952e6f 399%attr(755,root,root) %{_bindir}/gdalmove.py
6f52dc7d
JR
400%attr(755,root,root) %{_bindir}/gdal_pansharpen.py
401%attr(755,root,root) %{_bindir}/gdal_polygonize.py
402%attr(755,root,root) %{_bindir}/gdal_proximity.py
403%attr(755,root,root) %{_bindir}/gdal_rasterize
404%attr(755,root,root) %{_bindir}/gdal_retile.py
f4952e6f 405%attr(755,root,root) %{_bindir}/gdalserver
6f52dc7d 406%attr(755,root,root) %{_bindir}/gdal_sieve.py
9b4989ae 407%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
408%attr(755,root,root) %{_bindir}/gdaltindex
409%attr(755,root,root) %{_bindir}/gdaltransform
6f52dc7d 410%attr(755,root,root) %{_bindir}/gdal_translate
4058fbc3 411%attr(755,root,root) %{_bindir}/gdalwarp
6f52dc7d
JR
412%attr(755,root,root) %{_bindir}/gnmanalyse
413%attr(755,root,root) %{_bindir}/gnmmanage
4058fbc3
JB
414%attr(755,root,root) %{_bindir}/mkgraticule.py
415%attr(755,root,root) %{_bindir}/nearblack
416%attr(755,root,root) %{_bindir}/ogr2ogr
417%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 418%attr(755,root,root) %{_bindir}/ogrlineref
6f52dc7d 419%attr(755,root,root) %{_bindir}/ogrmerge.py
4058fbc3
JB
420%attr(755,root,root) %{_bindir}/ogrtindex
421%attr(755,root,root) %{_bindir}/pct2rgb.py
422%attr(755,root,root) %{_bindir}/rgb2pct.py
423%attr(755,root,root) %{_bindir}/testepsg
5014b82a 424%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
38239d5e 425%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
0a5f35eb 426%dir %{_libdir}/gdalplugins
6b59fa88 427%{_datadir}/gdal
4058fbc3 428%{_mandir}/man1/gdal2tiles.1*
0316feee 429%{_mandir}/man1/gdal_calc.1*
4058fbc3 430%{_mandir}/man1/gdal_contour.1*
f4952e6f 431%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
432%{_mandir}/man1/gdal_fillnodata.1*
433%{_mandir}/man1/gdal_grid.1*
434%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
435%{_mandir}/man1/gdal_polygonize.1*
436%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
437%{_mandir}/man1/gdal_rasterize.1*
438%{_mandir}/man1/gdal_retile.1*
439%{_mandir}/man1/gdal_sieve.1*
440%{_mandir}/man1/gdal_translate.1*
441%{_mandir}/man1/gdal_utilities.1*
442%{_mandir}/man1/gdaladdo.1*
443%{_mandir}/man1/gdalbuildvrt.1*
0316feee 444%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
445%{_mandir}/man1/gdaldem.1*
446%{_mandir}/man1/gdalinfo.1*
954ec354 447%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
448%{_mandir}/man1/gdalmanage.1*
449%{_mandir}/man1/gdalmove.1*
9b4989ae 450%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
451%{_mandir}/man1/gdaltindex.1*
452%{_mandir}/man1/gdaltransform.1*
453%{_mandir}/man1/gdalwarp.1*
454%{_mandir}/man1/nearblack.1*
455%{_mandir}/man1/ogr2ogr.1*
456%{_mandir}/man1/ogr_utilities.1*
457%{_mandir}/man1/ogrinfo.1*
0316feee 458%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
459%{_mandir}/man1/ogrtindex.1*
460%{_mandir}/man1/pct2rgb.1*
461%{_mandir}/man1/rgb2pct.1*
6f52dc7d
JR
462%{_mandir}/man1/gdal_pansharpen.1*
463%{_mandir}/man1/gnm_utilities.1*
464%{_mandir}/man1/gnmanalyse.1*
465%{_mandir}/man1/gnmmanage.1*
466%{_mandir}/man1/ogrmerge.1*
6b59fa88
JB
467
468%files devel
469%defattr(644,root,root,755)
388b39cb 470%doc _html/*
5014b82a 471%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 472%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 473%{_libdir}/libgdal.la
0316feee 474%{_pkgconfigdir}/gdal.pc
e582c3b1 475%{_includedir}/gdal
5014b82a 476%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
477
478%files static
479%defattr(644,root,root,755)
9b5c0fd4 480%{_libdir}/libgdal.a
6b59fa88 481
a0ffd9c4
JB
482%files -n perl-gdal
483%defattr(644,root,root,755)
484%dir %{perl_vendorarch}/Geo
485%{perl_vendorarch}/Geo/GDAL.pm
486%dir %{perl_vendorarch}/Geo/GDAL
487%{perl_vendorarch}/Geo/GDAL/Const.pm
488%{perl_vendorarch}/Geo/OGR.pm
489%{perl_vendorarch}/Geo/OSR.pm
490%dir %{perl_vendorarch}/auto/Geo
491%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
492%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
493%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4 494%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
6f52dc7d
JR
495%dir %{perl_vendorarch}/auto/Geo/GNM
496%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GNM/GNM.so
a0ffd9c4 497%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
498%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
499%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 500%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 501%{_mandir}/man3/Geo::GDAL.3pm*
6f52dc7d 502%{perl_vendorarch}/Geo/GNM.pm
a0ffd9c4 503
6b59fa88
JB
504%files -n python-gdal
505%defattr(644,root,root,755)
9a2dbbce
JB
506%{py_sitedir}/gdal.py[co]
507%{py_sitedir}/gdalconst.py[co]
508%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
509%{py_sitedir}/ogr.py[co]
510%{py_sitedir}/osr.py[co]
69051332
JB
511%{py_sitedir}/GDAL-*.egg-info
512%dir %{py_sitedir}/osgeo
513%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
514%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
515%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
6f52dc7d 516%attr(755,root,root) %{py_sitedir}/osgeo/_gnm.so
69051332
JB
517%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
518%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
519%{py_sitedir}/osgeo/*.py[co]
This page took 0.128734 seconds and 4 git commands to generate.