]> git.pld-linux.org Git - packages/gdal.git/blame - gdal.spec
- release 5 (by relup.sh)
[packages/gdal.git] / gdal.spec
CommitLineData
954ec354 1# TODO:
8b360036 2# - be reasonable about devel dependencies - you do not need all of them to
cfcb08ee 3# use gdal (probably a gdal module or driver shall not imply devel
4# dependency)
d3d190a4 5# - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
9b4989ae 6# - libkml (1.3.0 needed, not released yet)
954ec354 7# - wait for newer pcidsk, switch to external again
d3d190a4 8# - csharp, java
9b4989ae
JB
9# - additional, proprietary(?) formats support:
10# - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
11# - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
12# - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
13# - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
14# - MrSID (http://www.lizardtech.com/developer/)
15# - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
9b4989ae 16# - Ingres (--with-ingres=/path)
0316feee 17# - Informix DB (--with-idb)
9b4989ae
JB
18# - DWGdirect (members only? http://www.opendwg.org/)
19# - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
655672e5 20#
21# Conditional build:
d3d190a4 22%bcond_without armadillo # Armadillo support for faster TPS transform
779b0eec 23%bcond_without crnlib # DDS support via crunch/crnlib
4537079d 24%bcond_without epsilon # EPSILON wavelet compression support
779b0eec 25%bcond_without fyba # SOSI geodata support using FYBA
0a5f35eb 26%bcond_with grass # GRASS support (note: dependency loop; use gdal-grass.spec instead)
4537079d 27%bcond_without gta # GTA format support
d3d190a4 28%bcond_without mysql # MySQL DB support
0316feee 29%bcond_with oci # ORACLE OCI DB and Georaster support
d3d190a4
JB
30%bcond_without odbc # ODBC DB support
31%bcond_without opencl # OpenCL (GPU) support
c9c08280 32%bcond_without openjpeg # OpenJPEG 2 (JPEG2000) support
4537079d
JB
33%bcond_with podofo # PDF support via podofo instead of poppler
34%bcond_without poppler # PDF support via poppler
779b0eec 35%bcond_without rasdaman # Rasdaman support
4537079d 36%bcond_without spatialite # SpatiaLite support
d3d190a4
JB
37%bcond_without xerces # Xerces support
38%bcond_without java # Java and MDB support
0316feee 39%bcond_without php # PHP binding
38239d5e 40%bcond_with ruby # Ruby binding
315a1c4a 41
fac7da6f
JB
42%if %{with podofo}
43%undefine with_poppler
44%endif
66daf0b1 45%if 0%{!?php_name:1}
ead243f9 46%define php_name php55
66daf0b1 47%endif
faf5649c 48Summary: Geospatial Data Abstraction Library
a28c1bee 49Summary(pl.UTF-8): Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
faf5649c 50Name: gdal
38239d5e 51Version: 2.0.1
c69319f1 52Release: 5
faf5649c
JB
53License: BSD-like
54Group: Libraries
84501866 55Source0: http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
38239d5e 56# Source0-md5: 27022cc4a3e0819ab02a69c2d0867437
f5a12c65 57Patch0: %{name}-perl.patch
9b4989ae 58Patch1: %{name}-python_install.patch
f1b5abea
JB
59Patch2: %{name}-php.patch
60Patch3: %{name}-fpic.patch
0316feee 61Patch5: %{name}-grass.patch
0316feee 62Patch7: %{name}-link.patch
779b0eec
JB
63Patch8: %{name}-fyba.patch
64Patch9: %{name}-dds.patch
779b0eec 65Patch11: %{name}-armadillo.patch
ce035715 66Patch12: %{name}-rasdaman.patch
0a5f35eb 67Patch13: %{name}-pluginsdir.patch
9b5c0fd4 68URL: http://www.gdal.org/
ead243f9 69%{?with_php:BuildRequires: %{php_name}-devel}
d3d190a4
JB
70%{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
71%{?with_armadillo:BuildRequires: armadillo-devel}
69051332
JB
72BuildRequires: autoconf >= 2.52
73BuildRequires: automake
6b59fa88 74BuildRequires: cfitsio-devel
6a3158ac 75%{?with_crnlib:BuildRequires: crnlib-devel}
9b4989ae 76BuildRequires: curl-devel
9d161bc4 77BuildRequires: doxygen >= 1.4.2
209aac6b 78%{?with_epsilon:BuildRequires: epsilon-compressor-devel}
69051332 79BuildRequires: expat-devel >= 1.95.0
779b0eec 80%{?with_fyba:BuildRequires: fyba-devel}
4537079d 81BuildRequires: freexl-devel >= 1.0
0316feee
JB
82BuildRequires: gcc >= 6:4.1
83BuildRequires: geos-devel >= 3.1.0
b459f4d7 84BuildRequires: giflib-devel >= 4.0
779b0eec 85%{?with_grass:BuildRequires: grass-devel >= 6.4}
6b59fa88 86BuildRequires: hdf-devel >= 4.0
69051332 87BuildRequires: hdf5-devel
6b59fa88 88BuildRequires: jasper-devel
9b4989ae
JB
89%{?with_java:BuildRequires: jdk}
90%{?with_java:BuildRequires: jpackage-utils}
0316feee 91BuildRequires: json-c-devel >= 0.11
8fd908ab 92BuildRequires: libcsf-devel >= 2.0-0.041111.6
4058fbc3 93BuildRequires: libdap-devel >= 3.10
b3cbf6a3 94BuildRequires: libgeotiff-devel >= 1.2.1
b88bb9ef 95%{?with_gta:BuildRequires: libgta-devel}
6b59fa88 96BuildRequires: libjpeg-devel >= 6b
9b4989ae 97#BuildRequires: libkml-devel >= 1.3.0
e354fe40 98BuildRequires: libpng-devel >= 2:1.2.8
4537079d 99%{?with_spatialite:BuildRequires: libspatialite-devel}
b3cbf6a3 100BuildRequires: libstdc++-devel
954ec354 101BuildRequires: libtiff-devel >= 4.0
69051332 102BuildRequires: libtool
e2b089e1 103BuildRequires: libuuid-devel
9b4989ae 104BuildRequires: libwebp-devel
0316feee 105BuildRequires: libxml2-devel >= 2
d3d190a4 106%{?with_mysql:BuildRequires: mysql-devel}
80114ba8 107BuildRequires: netcdf-devel >= 4.1
6b59fa88 108BuildRequires: ogdi-devel >= 3.1
c9c08280 109%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
0316feee
JB
110# 8.1.7 for DB support, 10.0.1 for georaster
111%{?with_oci:BuildRequires: oracle-instantclient-devel >= 10.0.1}
954ec354 112#BuildRequires: pcidsk-devel > 0.3
a0ffd9c4 113BuildRequires: perl-devel
fac7da6f 114%{?with_podofo:BuildRequires: podofo-devel}
0077f857 115%{?with_poppler:BuildRequires: poppler-devel >= 0.24}
9b4989ae
JB
116# ensure it's compiled with PQescapeStringConn support
117BuildRequires: postgresql-backend-devel >= 8.1.4
118BuildRequires: postgresql-devel >= 8.1.4
119BuildRequires: proj-devel >= 4
9a2dbbce 120BuildRequires: python-devel >= 1:2.5
017b03bb 121BuildRequires: python-numpy-devel >= 1:1.0.0
9b4989ae 122BuildRequires: python-setuptools
779b0eec 123%{?with_rasdaman:BuildRequires: rasdaman-devel}
479cb83c 124BuildRequires: rpm-pythonprov
315a1c4a 125%{?with_ruby:BuildRequires: rpm-rubyprov}
9b4989ae 126BuildRequires: rpmbuild(macros) >= 1.344
4aafe7c0 127%{?with_ruby:BuildRequires: ruby-devel}
b88bb9ef 128BuildRequires: sed >= 4.0
9b4989ae 129BuildRequires: sqlite3-devel >= 3.0.0
479cb83c 130BuildRequires: swig-perl
0316feee 131BuildRequires: swig-php >= 2.0.12-2
9a2dbbce 132BuildRequires: swig-python >= 1.3
017b03bb 133%{?with_ruby:BuildRequires: swig-ruby}
479cb83c 134BuildRequires: texlive-dvips
135BuildRequires: texlive-latex
9831286f 136%{?with_odbc:BuildRequires: unixODBC-devel >= 2.2.15}
9b4989ae
JB
137%{?with_xerces:BuildRequires: xerces-c-devel >= 2.7.0}
138BuildRequires: xz-devel
faf5649c 139BuildRequires: zlib-devel >= 1.1.4
4537079d 140Requires: freexl >= 1.0
0316feee 141Requires: geos >= 3.1.0
b3cbf6a3 142Requires: libgeotiff >= 1.2.1
e354fe40 143Requires: libpng >= 2:1.2.8
954ec354 144Requires: libtiff >= 4.0
faf5649c
JB
145BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147%description
148GDAL is a translator library for raster geospatial data formats that
149is released under an Open Source license. As a library, it presents a
150single abstract data model to the calling application for all
151supported formats. The related OGR library (which lives within the
152GDAL source tree) provides a similar capability for simple features
153vector data.
f05c79e8 154
d34f2ec8
JR
155%description -l pl.UTF-8
156GDAL to biblioteka konwertująca między formatami rastrowych danych
157dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
158Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
159do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
160(której źródła są dołączone do drzewa źródeł GDAL) daje podobne
161możliwości dla danych wektorowych.
faf5649c 162
6b59fa88
JB
163%package devel
164Summary: GDAL library header files
a28c1bee 165Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GDAL
6b59fa88 166Group: Development/Libraries
1673a634 167Requires: %{name} = %{version}-%{release}
d3d190a4
JB
168%{?with_opencl:Requires: OpenCL-devel >= 1.0}
169%{?with_armadillo:Requires: armadillo-devel}
b3cbf6a3 170Requires: cfitsio-devel
6a3158ac 171%{?with_crnlib:Requires: crnlib-devel}
209aac6b
JB
172Requires: curl-devel
173%{?with_epsilon:Requires: epsilon-compressor-devel}
779b0eec 174%{?with_fyba:Requires: fyba-devel}
69051332 175Requires: expat-devel >= 1.95.0
4537079d 176Requires: freexl-devel >= 1.0
0316feee 177Requires: geos-devel >= 3.1.0
209aac6b 178Requires: giflib-devel >= 4.0
b3cbf6a3 179Requires: hdf-devel >= 4.0
69051332 180Requires: hdf5-devel
b3cbf6a3 181Requires: jasper-devel
0316feee 182Requires: json-c-devel >= 0.11
d4d7a2c6 183Requires: libcsf-devel
4058fbc3 184Requires: libdap-devel >= 3.10
b3cbf6a3 185Requires: libgeotiff-devel >= 1.2.1
209aac6b
JB
186%{?with_gta:Requires: libgta-devel}
187Requires: libjpeg-devel >= 6b
e354fe40 188Requires: libpng-devel >= 2:1.2.8
4537079d 189%{?with_spatialite:Requires: libspatialite-devel}
b3cbf6a3 190Requires: libstdc++-devel
954ec354 191Requires: libtiff-devel >= 4.0
209aac6b
JB
192Requires: libuuid-devel
193Requires: libwebp-devel
0316feee 194Requires: libxml2-devel >= 2
d3d190a4 195%{?with_mysql:Requires: mysql-devel}
9b4989ae 196Requires: netcdf-devel >= 4
b3cbf6a3 197Requires: ogdi-devel >= 3.1
c9c08280 198%{?with_openjpeg:Requires: openjpeg2-devel >= 2.0.0-2}
954ec354 199#Requires: pcidsk-devel > 0.3
209aac6b 200%{?with_podofo:Requires: podofo-devel}
0077f857 201%{?with_poppler:Requires: poppler-devel >= 0.24}
b3cbf6a3 202Requires: postgresql-devel
209aac6b 203Requires: proj-devel >= 4
779b0eec 204%{?with_rasdaman:Requires: rasdaman-devel}
9b4989ae 205Requires: sqlite3-devel >= 3.0.0
655672e5 206%{?with_odbc:Requires: unixODBC-devel}
69051332 207%{?with_xerces:Requires: xerces-c-devel >= 2.7.0}
209aac6b
JB
208Requires: xz-devel
209Requires: zlib-devel >= 1.1.4
6b59fa88
JB
210
211%description devel
212GDAL library header files.
213
d34f2ec8
JR
214%description devel -l pl.UTF-8
215Pliki nagłówkowe biblioteki GDAL.
6b59fa88
JB
216
217%package static
218Summary: GDAL static libraries
a28c1bee 219Summary(pl.UTF-8): Statyczne biblioteki GDAL
6b59fa88 220Group: Development/Libraries
1673a634 221Requires: %{name}-devel = %{version}-%{release}
6b59fa88
JB
222
223%description static
224GDAL static libraries.
225
d34f2ec8 226%description static -l pl.UTF-8
6b59fa88
JB
227Statyczne biblioteki GDAL.
228
a0ffd9c4
JB
229%package -n perl-gdal
230Summary: Perl bindings for GDAL
231Summary(pl.UTF-8): Wiązania Perla do pakietu GDAL
232Group: Development/Languages/Perl
233Requires: %{name} = %{version}-%{release}
234
235%description -n perl-gdal
236Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
237
238%description -n perl-gdal -l pl.UTF-8
017b03bb 239Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
a0ffd9c4 240
ead243f9 241%package -n %{php_name}-gdal
9b4989ae
JB
242Summary: PHP bindings for GDAL library
243Summary(pl.UTF-8): Wiązania PHP do biblioteki GDAL
244Group: Development/Languages/PHP
245Requires: %{name} = %{version}-%{release}
246%{?requires_php_extension}
247
ead243f9 248%description -n %{php_name}-gdal
9b4989ae
JB
249PHP bindings for GDAL library
250
ead243f9 251%description -n %{php_name}-gdal -l pl.UTF-8
9b4989ae
JB
252Wiązania PHP do biblioteki GDAL.
253
6b59fa88
JB
254%package -n python-gdal
255Summary: GDAL Python module
a28c1bee 256Summary(pl.UTF-8): Moduł Pythona GDAL
6b59fa88 257Group: Libraries/Python
1673a634 258Requires: %{name} = %{version}-%{release}
315a1c4a 259Requires: python-libs
6b59fa88
JB
260
261%description -n python-gdal
262GDAL Python module.
263
d34f2ec8
JR
264%description -n python-gdal -l pl.UTF-8
265Moduł Pythona GDAL.
6b59fa88 266
a0ffd9c4
JB
267%package -n ruby-gdal
268Summary: Ruby bindings for GDAL
269Summary(pl.UTF-8): Wiązania języka Ruby do pakietu GDAL
270Group: Development/Languages
271Requires: %{name} = %{version}-%{release}
a0ffd9c4
JB
272
273%description -n ruby-gdal
274Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
275
276%description -n ruby-gdal -l pl.UTF-8
017b03bb
ER
277Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
278osr.
a0ffd9c4 279
faf5649c
JB
280%prep
281%setup -q
282%patch0 -p1
283%patch1 -p1
f1b5abea
JB
284%patch2 -p1
285%patch3 -p1
0316feee 286%patch5 -p1
0316feee 287%patch7 -p1
779b0eec
JB
288%patch8 -p1
289%patch9 -p1
779b0eec
JB
290%patch11 -p1
291%patch12 -p1
0a5f35eb 292%patch13 -p1
0316feee
JB
293
294# need to regenerate (old ones don't support perl 5.10 or php 5.5)
295%{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
296
297%{__sed} -i \
298 -e 's/^CC=gcc/CC=%{__cc}/' \
299 -e 's/^CXX=g++/CXX=%{__cxx}/' \
300 -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
301 -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
302 swig/php/GNUmakefile
315a1c4a
ER
303# Build with fPIC to allow Ruby bindings
304# Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
305# http://trac.osgeo.org/gdal/ticket/1994
306sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
307# Install Ruby bindings to distribution specific directory
308sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
309
310# Install Ruby bindings into the proper place
311sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
312sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
313
f4952e6f
AM
314# our man path
315sed -i -e 's#^mandir=.*##g' configure.in
316
4058fbc3 317%{__rm} -r man
4ed54fac 318
b88bb9ef
JB
319%{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
320
faf5649c 321%build
e6e33a1a
JR
322%ifarch %{x8664}
323jvm_arch=amd64
324%endif
325%ifarch %{ix86}
326jvm_arch=i386
327%endif
328%ifarch x32
329jvm_arch=x32
330%endif
331
69051332 332%{__libtoolize}
69051332 333%{__aclocal} -I m4
faf5649c 334%{__autoconf}
0a5f35eb 335%{__autoheader}
6b59fa88 336%configure \
e582c3b1 337 --includedir=%{_includedir}/gdal \
5014b82a 338 --datadir=%{_datadir}/gdal \
d4d7a2c6 339 --with-dods-root=/usr \
d3d190a4 340 %{?with_armadillo:--with-armadillo} \
779b0eec 341 %{?with_crnlib:--with-dds} \
209aac6b 342 %{?with_epsilon:--with-epsilon} \
0316feee 343 %{?with_grass:--with-grass} \
b88bb9ef 344 %{!?with_gta:--without-gta} \
69051332 345 --with-hide-internal-symbols \
9b4989ae
JB
346 %{?with_java:--with-java=%{java_home}} \
347 --with-liblzma \
fffcf251 348 %{?with_java:--with-mdb --with-jvm-lib-add-rpath --with-jvm-lib=%{java_home}/jre/lib/$jvm_arch/server} \
d3d190a4 349 %{?with_mysql:--with-mysql} \
0316feee 350 %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
d3d190a4 351 %{?with_opencl:--with-opencl} \
a0ffd9c4 352 --with-perl \
9b4989ae 353 %{?with_php:--with-php} \
fac7da6f
JB
354 %{?with_podofo:--with-podofo} \
355 %{?with_poppler:--with-poppler} \
69051332 356 --with-python \
779b0eec 357 %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
4aafe7c0 358 %{?with_ruby:--with-ruby} \
779b0eec 359 %{?with_fyba:--with-sosi} \
4537079d 360 %{?with_spatialite:--with-spatialite} \
69051332 361 --with-sqlite3 \
9b4989ae 362 --with-webp \
655672e5 363 %{?with_xerces:--with-xerces} \
6b59fa88 364 --with-xerces-inc=/usr/include/xercesc \
80faacbe 365 --with-xerces-lib="-lxerces-c" \
38239d5e 366 --with-autoload=%{_libdir}/gdalplugins \
69051332 367 --without-libgrass
954ec354 368# --with-pcidsk=/usr (needs > 0.3)
779b0eec 369# csharp builds, but has no configure option nor install target
faf5649c 370
69051332 371# regenerate where needed
825dc3dc 372%{__make} -j1 -C swig/perl generate
3df9ed7f 373%if %{with ruby}
02b013b1 374%{__make} -j1 -C swig/ruby generate
3df9ed7f 375%endif
69051332 376
779b0eec
JB
377%{__make} -j1 \
378 %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
379 %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
a0ffd9c4 380
825dc3dc 381%{__make} -j1 docs
3a591acf 382
f5a12c65
JK
383%{__make} -j1 man
384
faf5649c
JB
385%install
386rm -rf $RPM_BUILD_ROOT
faf5649c 387
825dc3dc 388%{__make} -j1 install install-man \
3a591acf
JB
389 DESTDIR=$RPM_BUILD_ROOT
390
388b39cb
ER
391rm -rf _html
392cp -a html _html
faf5649c 393
9b4989ae
JB
394%if %{with php}
395# missing in make install
ead243f9
ER
396install -d $RPM_BUILD_ROOT%{php_extensiondir}
397install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
398install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
399install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
400install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
9b4989ae
JB
401install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
402cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
ead243f9 403; Enable gdal extension modules
9b4989ae
JB
404extension=gdal.so
405extension=gdalconst.so
406extension=ogr.so
407extension=osr.so
408EOF
409%endif
410
374370d5
JB
411%py_comp $RPM_BUILD_ROOT%{py_sitedir}
412%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
413%py_postclean
5014b82a 414
017b03bb
ER
415%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
416%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
417%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
418%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
419%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
420
421# some doxygen trash
0316feee
JB
422%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
423%{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
017b03bb 424
faf5649c
JB
425%clean
426rm -rf $RPM_BUILD_ROOT
427
6b59fa88
JB
428%post -p /sbin/ldconfig
429%postun -p /sbin/ldconfig
430
faf5649c
JB
431%files
432%defattr(644,root,root,755)
c0a384ef 433%doc NEWS PROVENANCE.TXT
4058fbc3
JB
434%attr(755,root,root) %{_bindir}/epsg_tr.py
435%attr(755,root,root) %{_bindir}/esri2wkt.py
436%attr(755,root,root) %{_bindir}/gcps2vec.py
437%attr(755,root,root) %{_bindir}/gcps2wld.py
438%attr(755,root,root) %{_bindir}/gdal2tiles.py
439%attr(755,root,root) %{_bindir}/gdal2xyz.py
f4952e6f 440%attr(755,root,root) %{_bindir}/gdal_auth.py
4058fbc3 441%attr(755,root,root) %{_bindir}/gdal_contour
954ec354 442%attr(755,root,root) %{_bindir}/gdal_calc.py
f4952e6f 443%attr(755,root,root) %{_bindir}/gdal_edit.py
4058fbc3
JB
444%attr(755,root,root) %{_bindir}/gdal_fillnodata.py
445%attr(755,root,root) %{_bindir}/gdal_grid
446%attr(755,root,root) %{_bindir}/gdal_merge.py
447%attr(755,root,root) %{_bindir}/gdal_polygonize.py
448%attr(755,root,root) %{_bindir}/gdal_proximity.py
449%attr(755,root,root) %{_bindir}/gdal_rasterize
450%attr(755,root,root) %{_bindir}/gdal_retile.py
451%attr(755,root,root) %{_bindir}/gdal_sieve.py
452%attr(755,root,root) %{_bindir}/gdal_translate
453%attr(755,root,root) %{_bindir}/gdaladdo
454%attr(755,root,root) %{_bindir}/gdalbuildvrt
455%attr(755,root,root) %{_bindir}/gdalchksum.py
0316feee 456%attr(755,root,root) %{_bindir}/gdalcompare.py
4058fbc3
JB
457%attr(755,root,root) %{_bindir}/gdaldem
458%attr(755,root,root) %{_bindir}/gdalenhance
459%attr(755,root,root) %{_bindir}/gdalident.py
460%attr(755,root,root) %{_bindir}/gdalimport.py
461%attr(755,root,root) %{_bindir}/gdalinfo
954ec354 462%attr(755,root,root) %{_bindir}/gdallocationinfo
4058fbc3 463%attr(755,root,root) %{_bindir}/gdalmanage
f4952e6f
AM
464%attr(755,root,root) %{_bindir}/gdalmove.py
465%attr(755,root,root) %{_bindir}/gdalserver
9b4989ae 466%attr(755,root,root) %{_bindir}/gdalsrsinfo
4058fbc3
JB
467%attr(755,root,root) %{_bindir}/gdaltindex
468%attr(755,root,root) %{_bindir}/gdaltransform
469%attr(755,root,root) %{_bindir}/gdalwarp
470%attr(755,root,root) %{_bindir}/mkgraticule.py
471%attr(755,root,root) %{_bindir}/nearblack
472%attr(755,root,root) %{_bindir}/ogr2ogr
473%attr(755,root,root) %{_bindir}/ogrinfo
0316feee 474%attr(755,root,root) %{_bindir}/ogrlineref
4058fbc3
JB
475%attr(755,root,root) %{_bindir}/ogrtindex
476%attr(755,root,root) %{_bindir}/pct2rgb.py
477%attr(755,root,root) %{_bindir}/rgb2pct.py
478%attr(755,root,root) %{_bindir}/testepsg
5014b82a 479%attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
38239d5e 480%attr(755,root,root) %ghost %{_libdir}/libgdal.so.20
0a5f35eb 481%dir %{_libdir}/gdalplugins
6b59fa88 482%{_datadir}/gdal
4058fbc3 483%{_mandir}/man1/gdal2tiles.1*
0316feee 484%{_mandir}/man1/gdal_calc.1*
4058fbc3 485%{_mandir}/man1/gdal_contour.1*
f4952e6f 486%{_mandir}/man1/gdal_edit.1*
4058fbc3
JB
487%{_mandir}/man1/gdal_fillnodata.1*
488%{_mandir}/man1/gdal_grid.1*
489%{_mandir}/man1/gdal_merge.1*
f4952e6f
AM
490%{_mandir}/man1/gdal_polygonize.1*
491%{_mandir}/man1/gdal_proximity.1*
4058fbc3
JB
492%{_mandir}/man1/gdal_rasterize.1*
493%{_mandir}/man1/gdal_retile.1*
494%{_mandir}/man1/gdal_sieve.1*
495%{_mandir}/man1/gdal_translate.1*
496%{_mandir}/man1/gdal_utilities.1*
497%{_mandir}/man1/gdaladdo.1*
498%{_mandir}/man1/gdalbuildvrt.1*
0316feee 499%{_mandir}/man1/gdalcompare.1*
4058fbc3
JB
500%{_mandir}/man1/gdaldem.1*
501%{_mandir}/man1/gdalinfo.1*
954ec354 502%{_mandir}/man1/gdallocationinfo.1*
f4952e6f
AM
503%{_mandir}/man1/gdalmanage.1*
504%{_mandir}/man1/gdalmove.1*
9b4989ae 505%{_mandir}/man1/gdalsrsinfo.1*
4058fbc3
JB
506%{_mandir}/man1/gdaltindex.1*
507%{_mandir}/man1/gdaltransform.1*
508%{_mandir}/man1/gdalwarp.1*
509%{_mandir}/man1/nearblack.1*
510%{_mandir}/man1/ogr2ogr.1*
511%{_mandir}/man1/ogr_utilities.1*
512%{_mandir}/man1/ogrinfo.1*
0316feee 513%{_mandir}/man1/ogrlineref.1*
4058fbc3
JB
514%{_mandir}/man1/ogrtindex.1*
515%{_mandir}/man1/pct2rgb.1*
516%{_mandir}/man1/rgb2pct.1*
6b59fa88
JB
517
518%files devel
519%defattr(644,root,root,755)
388b39cb 520%doc _html/*
5014b82a 521%attr(755,root,root) %{_bindir}/gdal-config
6b59fa88 522%attr(755,root,root) %{_libdir}/libgdal.so
5014b82a 523%{_libdir}/libgdal.la
0316feee 524%{_pkgconfigdir}/gdal.pc
e582c3b1 525%{_includedir}/gdal
5014b82a 526%{_mandir}/man1/gdal-config.1*
6b59fa88
JB
527
528%files static
529%defattr(644,root,root,755)
9b5c0fd4 530%{_libdir}/libgdal.a
6b59fa88 531
a0ffd9c4
JB
532%files -n perl-gdal
533%defattr(644,root,root,755)
534%dir %{perl_vendorarch}/Geo
535%{perl_vendorarch}/Geo/GDAL.pm
536%dir %{perl_vendorarch}/Geo/GDAL
537%{perl_vendorarch}/Geo/GDAL/Const.pm
538%{perl_vendorarch}/Geo/OGR.pm
539%{perl_vendorarch}/Geo/OSR.pm
540%dir %{perl_vendorarch}/auto/Geo
541%dir %{perl_vendorarch}/auto/Geo/GDAL
a0ffd9c4
JB
542%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
543%dir %{perl_vendorarch}/auto/Geo/GDAL/Const
a0ffd9c4
JB
544%attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
545%dir %{perl_vendorarch}/auto/Geo/OGR
a0ffd9c4
JB
546%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
547%dir %{perl_vendorarch}/auto/Geo/OSR
a0ffd9c4 548%attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
38239d5e 549%{_mandir}/man3/Geo::GDAL.3pm*
a0ffd9c4 550
9b4989ae 551%if %{with php}
ead243f9 552%files -n %{php_name}-gdal
9b4989ae
JB
553%defattr(644,root,root,755)
554%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
555%attr(755,root,root) %{php_extensiondir}/gdal.so
556%attr(755,root,root) %{php_extensiondir}/gdalconst.so
557%attr(755,root,root) %{php_extensiondir}/ogr.so
558%attr(755,root,root) %{php_extensiondir}/osr.so
559%endif
560
6b59fa88
JB
561%files -n python-gdal
562%defattr(644,root,root,755)
9a2dbbce
JB
563%{py_sitedir}/gdal.py[co]
564%{py_sitedir}/gdalconst.py[co]
565%{py_sitedir}/gdalnumeric.py[co]
9a2dbbce
JB
566%{py_sitedir}/ogr.py[co]
567%{py_sitedir}/osr.py[co]
69051332
JB
568%{py_sitedir}/GDAL-*.egg-info
569%dir %{py_sitedir}/osgeo
570%attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
571%attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
572%attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
573%attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
574%attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
575%{py_sitedir}/osgeo/*.py[co]
a0ffd9c4 576
4aafe7c0 577%if %{with ruby}
a0ffd9c4
JB
578%files -n ruby-gdal
579%defattr(644,root,root,755)
315a1c4a
ER
580%dir %{ruby_vendorarchdir}/gdal
581%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
582%attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
583%attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
584%attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
4aafe7c0 585%endif
This page took 0.120429 seconds and 4 git commands to generate.