]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
update paths
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732
ER
1# TODO
2# - discard bundled packages (from INSTALL):
3# - JpGraph 1.5.3 (last GPL version)
a659c698
JB
4#
5# Conditional build:
7bc9b641 6%bcond_with order # with experimental order patch
cddf3011 7
dc8c226c 8%define subver pre1
cceed9a6 9%define rel 0.12
7a906e31 10%define php_min_version 5.3.3
b3857e8b 11%include /usr/lib/rpm/macros.php
c96aabf5 12Summary: Eventum Issue / Bug tracking system
9f49cf47 13Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
bb01d732 14Name: eventum
7a906e31 15Version: 3.0.0
dc8c226c 16Release: 0.%{subver}.%{rel}
a881bbb0 17License: GPL v2
6850abd9 18Group: Applications/WWW
cceed9a6 19Source0: https://github.com/eventum/eventum/releases/download/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
dc8c226c 20# Source0-md5: 786930171e278f03baa7b174f52e43d0
82121306 21Source1: %{name}-apache.conf
cd719538
ER
22Source2: %{name}-mail-queue.cron
23Source3: %{name}-mail-download.cron
24Source4: %{name}-reminder.cron
25Source5: %{name}-monitor.cron
26Source6: %{name}-cvs.php
27Source7: %{name}-irc.php
28Source8: %{name}-irc.init
73f6a3e6 29Source9: %{name}-irc.sysconfig
1cce3e61 30Source10: sphinx.crontab
cfcdd0a9
ER
31Source13: %{name}-router-postfix.sh
32Source14: %{name}.logrotate
33Source15: %{name}-lighttpd.conf
d0dabd47
ER
34Source16: http://www.isocra.com/images/updown2.gif
35# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
cc613bc9 36Source17: %{name}.tmpfiles
7a906e31 37#Patch0: %{name}-lf.patch
4f627938 38Patch2: %{name}-order.patch
7a906e31
ER
39#Patch3: group-users.patch
40#Patch4: https://github.com/glensc/eventum/compare/cf_escape.patch
14ff3418 41# packaging patches that probably never go upstream
ac27ba92
ER
42Patch100: %{name}-paths.patch
43Patch101: %{name}-cvs-config.patch
4c823356 44Patch105: %{name}-bot-reconnect.patch
cfcdd0a9 45Patch107: %{name}-gettext.patch
a6016bab
ER
46# some tests
47Patch200: %{name}-fixed-nav.patch
3cf7d1aa 48URL: http://eventum.mysql.org/
447ff246 49BuildRequires: /usr/bin/php
efd26093 50BuildRequires: gettext-tools
7a906e31 51BuildRequires: php(core) >= %{php_min_version}
b3857e8b 52BuildRequires: rpm-php-pearprov >= 4.0.2-98
5500a61e 53BuildRequires: rpmbuild(macros) >= 1.654
4068cb73 54BuildRequires: sed >= 4.0
5b165428 55Requires: %{name}-base = %{version}-%{release}
01d8dfff 56Requires: php(core) >= %{php_min_version}
2f331c68
ER
57Requires: php(filter)
58Requires: php(gd)
59Requires: php(iconv)
60Requires: php(imap)
61Requires: php(json)
62Requires: php(mbstring)
63Requires: php(mysql)
64Requires: php(pcre)
65Requires: php(session)
5dbd4bf5
ER
66Requires: php-Smarty >= 3.1
67Requires: php-Smarty-plugin-gettext
71b01fde
ER
68Requires: php-pear-DB
69Requires: php-pear-Date
71b01fde 70Requires: php-pear-Mail
723da18a 71Requires: php-pear-Mail_Mime
fb0b2f83 72Requires: php-pear-Mail_mimeDecode
71b01fde
ER
73Requires: php-pear-Math_Stats
74Requires: php-pear-Net_DIME
71b01fde 75Requires: php-pear-Net_SMTP
71b01fde
ER
76Requires: php-pear-Net_Socket
77Requires: php-pear-Net_URL
78Requires: php-pear-Net_UserAgent_Detect
3223fb64 79Requires: php-pear-PEAR-core
71b01fde
ER
80Requires: php-pear-Text_Diff
81Requires: php-pear-XML_RPC
bdf85dc8 82Requires: webapps
f399f1c0
ER
83Requires: webserver(access)
84Requires: webserver(alias)
897bdb2c 85Requires: webserver(indexfile)
61351540 86Requires: webserver(php) >= 4.2.0
462ee1a6 87Suggests: localedb
73de38a1 88Suggests: php-pear-Net_LDAP2
bd70ea88 89Conflicts: logrotate < 3.8.0
35fa3cf8 90BuildArch: noarch
bb01d732
ER
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
7f764a78 93%define _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
03410d49
ER
94
95# exclude optional php dependencies
899100ff 96%define _noautophp php-gnupg php-hash php-pecl-http php-tk
03410d49 97
5500a61e 98%define _noautoreq %{_noautophp}
3223fb64 99
1d760108 100%define _libdir %{_prefix}/lib/%{name}
71f56750 101%define _appdir %{_datadir}/%{name}
d1c44829 102%define _smartydir %{php_data_dir}/Smarty
bdf85dc8
ER
103%define _webapps /etc/webapps
104%define _webapp %{name}
8a37ad9d
ER
105%define _webappdir %{_webapps}/%{_webapp}
106%define _sysconfdir /etc/%{name}
bb01d732
ER
107
108%description
109Eventum is a user-friendly and flexible issue tracking system that can
110be used by a support department to track incoming technical support
111requests, or by a software development team to quickly organize tasks
112and bugs. Eventum is used by the MySQL AB Technical Support team, and
113has allowed us to dramatically improve our response times.
114
d8cfa9f0
JR
115%description -l pl.UTF-8
116Eventum to przyjazny dla użytkownika system śledzenia spraw, który
117może być używany przez dział obsługi do śledzenia przychodzących żądań
118obsługi technicznej albo przez zespół tworzący oprogramowanie do
119szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
120Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
4068cb73
JB
121reakcji.
122
d2e501e8
ER
123%package base
124Summary: Eventum base package
9f49cf47 125Summary(pl.UTF-8): Podstawowy pakiet Eventum
d2e501e8 126Group: Applications/WWW
3223fb64
ER
127Requires(postun): /usr/sbin/groupdel
128Requires(postun): /usr/sbin/userdel
5bbd68c9
ER
129Requires(pre): /bin/id
130Requires(pre): /usr/bin/getgid
5bbd68c9 131Requires(pre): /usr/sbin/groupadd
3223fb64 132Requires(pre): /usr/sbin/useradd
9f768793 133Provides: group(eventum)
d080edb6 134Provides: user(eventum)
d2e501e8
ER
135
136%description base
137This package contains base directory structure for Eventum.
138
d8cfa9f0
JR
139%description base -l pl.UTF-8
140Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
1bb5e749 141
ab983aaa 142%package setup
4068cb73 143Summary: Eventum setup package
9f49cf47 144Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
ab983aaa 145Group: Applications/WWW
5b165428 146Requires: %{name} = %{version}-%{release}
ab983aaa
ER
147
148%description setup
149Install this package to configure initial Eventum installation. You
150should uninstall this package when you're done, as it considered
151insecure to keep the setup files in place.
152
d8cfa9f0
JR
153%description setup -l pl.UTF-8
154Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
155pierwszej instalacji. Potem należy go odinstalować, jako że
156pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
4068cb73 157
0da8e1f2 158%package mail-queue
30689148 159Summary: Eventum mail queue process
9f49cf47 160Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
0da8e1f2 161Group: Applications/WWW
5b165428 162Requires: %{name} = %{version}-%{release}
0da8e1f2
ER
163Requires: crondaemon
164
165%description mail-queue
166Beginning with the first release of Eventum, emails are not directly
167sent out from the various scripts, but rather added to a mail queue
168table that is processed by a cron job. If an email cannot be sent, it
169will be marked as such in the mail queue log, and the cron job script
170will re-try to send it again the next time it runs.
171
172This package contains the cron job.
173
d8cfa9f0
JR
174%description mail-queue -l pl.UTF-8
175Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
176różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
177Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
178kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
179następnym razem.
0181746f 180
30689148 181Ten pakiet zawiera zadanie dla crona.
182
ea084bcb 183%package mail-download
30689148 184Summary: Eventum email download
9f49cf47 185Summary(pl.UTF-8): Ściąganie poczty Eventum
ea084bcb 186Group: Applications/WWW
5b165428 187Requires: %{name} = %{version}-%{release}
ea084bcb
ER
188Requires: crondaemon
189
190%description mail-download
191In order for Eventum's email integration feature to work, you need to
192setup a cron job to run the script every so often.
193
194This package contains the cron job.
195
d8cfa9f0
JR
196%description mail-download -l pl.UTF-8
197Aby integracja poczty elektronicznej w Eventum działała, trzeba
198ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
199często.
0181746f
JB
200
201Ten pakiet zawiera zadanie dla crona.
202
cd719538
ER
203%package reminder
204Summary: Eventum Reminder System
9f49cf47 205Summary(pl.UTF-8): System przypominania dla Eventum
cd719538 206Group: Applications/WWW
5b165428 207Requires: %{name} = %{version}-%{release}
cd719538
ER
208Requires: crondaemon
209
210%description reminder
211The reminder system was designed with the objective as serving as a
212safe net for issues that need attention. Depending on what
213configuration you create, you may have several reminders (or alerts)
214be sent out whenever an issue needs attention, for whatever parameter
215you may deem necessary.
216
217This package contains the cron job.
218
d8cfa9f0
JR
219%description reminder -l pl.UTF-8
220System przypominania został zaprojektowany tak, aby służył jako
221bezpieczna sieć dla spraw wymagających uwagi. W zależności od
222konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
223przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
224uważać za potrzebny.
6341f096
JB
225
226Ten pakiet zawiera zadanie dla crona.
227
cd719538
ER
228%package monitor
229Summary: Eventum Heartbeat Monitor
9f49cf47 230Summary(pl.UTF-8): Monitor życia dla Eventum
cd719538 231Group: Applications/WWW
5b165428 232Requires: %{name} = %{version}-%{release}
cd719538 233Requires: crondaemon
2f331c68 234Requires: php(posix)
cd719538
ER
235
236%description monitor
237The heartbeat monitor is a feature designed for the administrator that
238wants to be alerted whenever a common problem in Eventum is detected,
239like the database server not being available anymore, or maybe when
240the recommended permissions for certain configuration files are
241changed.
242
243Please note that before running the heartbeat monitor, you may need to
244customize some of the checks to be appropriate for your own system,
245particularly the permission and file checks on
246Monitor::checkConfiguration().
247
248This package contains the cron job.
249
d8cfa9f0
JR
250%description monitor -l pl.UTF-8
251Monitor życia to funkcjonalność zaprojektowana dla administratora
252chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
253Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
254do plików konfiguracyjnych.
6341f096 255
d8cfa9f0
JR
256Należy zauważyć, że przed uruchomieniem tego monitora może być
257konieczne dostosowanie niektórych testów do systemu, w szczególności
258testów uprawnień i plików w Monitor::checkConfiguration().
6341f096
JB
259
260Ten pakiet zawiera zadanie dla crona.
261
5b165428
ER
262%package route-drafts
263Summary: Eventum Draft Routing
9f49cf47 264Summary(pl.UTF-8): Przekazywanie szkiców dla Eventum
5b165428
ER
265Group: Applications/WWW
266Requires: %{name} = %{version}-%{release}
5b165428
ER
267Requires: eventum(router)
268
269%description route-drafts
71f56750 270The draft routing feature is used to automatically associate a thread
098cbb72
ER
271of drafts into an Eventum issue. By setting up Postfix to deliver
272emails sent to a specific address (usually draft-<number>@<domain>) to
273the above script, users are able to send drafts written in their mail
274client to be stored in Eventum. These drafts will NOT broadcasted to
275the notification list.
5b165428 276
d8cfa9f0
JR
277%description route-drafts -l pl.UTF-8
278Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
098cbb72
ER
279problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
280wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
281skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
282kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
283na listę powiadomień.
5410173f 284
cd719538
ER
285%package route-emails
286Summary: Eventum Email Routing
9f49cf47 287Summary(pl.UTF-8): Przekazywanie poczty dla Eventum
cd719538 288Group: Applications/WWW
5b165428 289Requires: %{name} = %{version}-%{release}
8bc4bcd1 290Requires: eventum(router)
cd719538
ER
291
292%description route-emails
293The email routing feature is used to automatically associate a thread
098cbb72
ER
294of emails into an Eventum issue. By setting up Postfix to deliver
295emails sent to a specific address (usually issue-<number>@<domain>) to
296the above script, users are able to use their email clients to reply
297to emails coming from Eventum, and those replies will be automatically
298associated with the issue and broadcasted to the entire notification
299list.
cd719538 300
d8cfa9f0
JR
301%description route-emails -l pl.UTF-8
302Funkcjonalność przekazywania poczty służy do automatycznego wiązania
098cbb72
ER
303wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
304aby dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
305issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
306używać klientów pocztowych do odpowiadania na listy przychodzące z
307Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
308rozprowadzane do całej listy ogłoszeniowej.
6341f096 309
cd719538
ER
310%package route-notes
311Summary: Eventum Note Routing
9f49cf47 312Summary(pl.UTF-8): Przekazywanie notatek dla Eventum
cd719538 313Group: Applications/WWW
5b165428 314Requires: %{name} = %{version}-%{release}
8bc4bcd1 315Requires: eventum(router)
cd719538
ER
316
317%description route-notes
318The note routing feature is used to automatically associate a thread
098cbb72
ER
319of notes into an Eventum issue. By setting up Postfix to deliver
320emails sent to a specific address (usually note-<number>@<domain>) to
321the above script, users are able to use their email clients to reply
322to internal notes coming from Eventum, and those replies will be
323automatically associated with the issue and broadcasted to the
324notification list staff members.
cd719538 325
d8cfa9f0
JR
326%description route-notes -l pl.UTF-8
327Funkcjonalność przekazywania notatek służy do automatycznego wiązania
098cbb72
ER
328wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
329dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
330note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
331używać klientów pocztowych do odpowiadania na wewnętrzne notatki
332pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
333sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
6341f096 334
a6d2ad69
ER
335%package router-postfix
336Summary: Eventum Mail Routing - Postfix
9f49cf47 337Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
a6d2ad69 338Group: Applications/Mail
5b165428 339Requires: %{name} = %{version}-%{release}
a6d2ad69 340Requires: postfix
8bc4bcd1
ER
341Provides: eventum(router)
342Obsoletes: eventum(router)
a6d2ad69
ER
343
344%description router-postfix
345This package provides way of routing notes and emails back to Eventum
346via Postfix.
347
e1bb3563
ER
348The Postfix configuration instructions you can find from
349<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
350
d8cfa9f0
JR
351%description router-postfix -l pl.UTF-8
352Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
995fa554
JB
353przez Postfiksa.
354
d8cfa9f0 355Opis konfiguracji Postfiksa można znaleźć pod adresem
a659c698
JB
356<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
357
cd719538
ER
358%package irc
359Summary: Eventum IRC Notification Bot
9f49cf47 360Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
cd719538 361Group: Applications/WWW
b79fc4aa 362Requires(post,preun): /sbin/chkconfig
5b165428 363Requires: %{name} = %{version}-%{release}
2f331c68 364Requires: php(sockets)
71f56750 365Requires: php-pear-Net_SmartIRC
e1c0f343 366Requires: rc-scripts >= 0.4.0.18
cd719538
ER
367
368%description irc
369The IRC notification bot is a nice feature for remote teams that want
370to handle issues and want to have a quick and easy way to get simple
371notifications. Right now the bot notifies of the following actions:
372- New Issues
373- Blocked emails
374- Issues that got their assignment list changed
375
376NOTE: You will need to manually edit the bot.php script to set your
377appropriate preferences, like IRC server and channel that the bot
378should join.
379
d8cfa9f0
JR
380%description irc -l pl.UTF-8
381IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
382zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
383uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
384następujących zdarzeniach:
6341f096
JB
385- nowych sprawach
386- zablokowanych listach
d8cfa9f0 387- sprawach, dla których zmieniła się lista powiązań
6341f096 388
d8cfa9f0
JR
389UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
390kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
6341f096 391
abd490e4
ER
392%package cli
393Summary: Eventum command-line interface
9f49cf47 394Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
abd490e4 395Group: Applications/WWW
5b165428 396Requires: %{name}-base = %{version}-%{release}
01d8dfff 397Requires: php(core) >= %{php_min_version}
4a74b463 398Requires: php(phar)
71b01fde 399Requires: php-pear-XML_RPC
abd490e4
ER
400
401%description cli
402The Eventum command-line interface allows you to access most of the
403features of the web interface straight from your command shell.
abd490e4 404
d8cfa9f0
JR
405%description cli -l pl.UTF-8
406Interfejs linii poleceń Eventum pozwala na dostęp do większości
407funkcji interfejsu WWW prosto z linii poleceń powłoki.
958cd5a0 408
5cb2e61d 409%package scm
30689148 410Summary: Eventum SCM integration
9f49cf47 411Summary(pl.UTF-8): Integracja SCM dla Eventum
5cb2e61d 412Group: Applications/WWW
01d8dfff 413Requires: php(core) >= %{php_min_version}
2f331c68 414Requires: php(pcre)
c28270d0 415Suggests: php(openssl)
5cb2e61d
ER
416
417%description scm
418This feature allows your software development teams to integrate your
419Source Control Management system with your Issue Tracking System.
420
421The integration is implemented in such a way that it will be forward
422compatible with pretty much any SCM system, such as CVS.
423
0181746f 424For installation see
a392a259 425</eventum/help.php?topic=scm_integration_installation>.
0181746f 426
d8cfa9f0
JR
427%description scm -l pl.UTF-8
428Ten pakiet pozwala zespołom programistów na integrację systemu
429zarządzania źródłami (SCM - Source Control Management) z systemem
430śledzenia spraw.
0181746f 431
d8cfa9f0
JR
432Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
433prawie każdym systemem SCM, jak np. CVS.
0181746f 434
d8cfa9f0 435Szczegóły na temat instalacji można przeczytać pod
a392a259 436</eventum/help.php?topic=scm_integration_installation>.
5cb2e61d 437
1cce3e61
ER
438%package sphinx
439Summary: Eventum Sphinx Search
440Group: Applications/WWW
441Requires: %{name} = %{version}-%{release}
442Requires: crondaemon
443Requires: sphinx
444
445%description sphinx
446Sphinx search integration for Eventum.
447
448This package contains the cron job.
449
bb01d732 450%prep
dc8c226c 451%setup -qn %{name}-%{version}%{?subver:-%{subver}}
5b165428 452
fa6167ba
ER
453mv docs/examples .
454
f1269a43
ER
455# GPL v2
456rm docs/COPYING
457
9487d524 458# bug fixes / features
7a906e31 459#%patch0 -p1
4f627938 460%{?with_order:%patch2 -p1}
7a906e31
ER
461#%patch3 -p0
462#%patch4 -p1
57e65e62 463
7a906e31 464%{?with_order:cp -p %{SOURCE16} htdocs/images}
422dcc8e 465
a6016bab 466#%patch200 -p1
ac27ba92 467
1cce3e61
ER
468# produce default sphinx config
469# must be run before paths.patch
7a906e31 470%if 0
1cce3e61
ER
471cat <<'EOF' > config/config.php
472<?php
473define('APP_SQL_DBTYPE', 'mysql');
474define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
475define('APP_SQL_DBPORT', 3306);
476define('APP_SQL_DBNAME', 'eventum');
477define('APP_SQL_DBUSER', 'mysql');
478define('APP_SQL_DBPASS', '');
479define('APP_TABLE_PREFIX', 'eventum_');
480EOF
481php config/sphinx.conf.php > config/sphinx.conf
482rm -f config/config.php
7a906e31 483%endif
1cce3e61 484
ac27ba92
ER
485# packaging
486%patch100 -p1
c28270d0 487%patch101 -p1
ac27ba92 488%patch105 -p1
ac27ba92 489%patch107 -p1
0b3b58dd 490
25123ce7 491%{__sed} -i -e "
25123ce7 492s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
ae3e48e6 493" upgrade/{*/,}*.php
c3fd3767 494
5b165428 495# remove backups from patching as we use globs to package files to buildroot
73c437a6 496find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
085e39c0 497
465c3ab7 498%build
ae3e48e6 499%{__make} -C localization
465c3ab7 500
bb01d732
ER
501%install
502rm -rf $RPM_BUILD_ROOT
cfc3bce6 503install -d \
8a37ad9d 504 $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
2b135b34 505 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
c1e74aa1 506 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
685fc383 507 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
89522a33 508 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
761ae7dd 509 $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
73de38a1 510 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
cfc3bce6 511
4a74b463 512%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
ae3e48e6 513 sysconfdir=%{_webappdir} \
7a906e31 514 localedir=%{_localedir} \
ae3e48e6 515 DESTDIR=$RPM_BUILD_ROOT
da8d6134 516
c28270d0
ER
517cp -p scm/helpers.php $RPM_BUILD_ROOT%{_sbindir}
518
fa6167ba
ER
519install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
520cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
521
ae3e48e6 522%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
9cdc5027 523
00e339ff
ER
524cp -a vendor $RPM_BUILD_ROOT%{_appdir}
525
f399f1c0 526touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
1b5aae0f 527cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
87ca28ca 528cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
1b5aae0f 529cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
1cce3e61
ER
530
531install -d $RPM_BUILD_ROOT/etc/sphinx
7a906e31 532#cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
858c6f2a 533cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
ae3e48e6 534
1b5aae0f
ER
535cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
536cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
537cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
538cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
1cce3e61 539cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
ae3e48e6 540
1b5aae0f 541cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
ae3e48e6 542
2b135b34 543install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
1b5aae0f 544cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
31dabce6 545
1b5aae0f 546cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
2b135b34 547
410d72c7 548# postfix router
858c6f2a 549install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
a6d2ad69 550
92bc2f5d 551cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
cc613bc9 552
600d96a0 553%find_lang %{name}
c1e74aa1 554
ae3e48e6 555# scm
7a906e31 556cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
ae3e48e6 557
bb01d732
ER
558%clean
559rm -rf $RPM_BUILD_ROOT
560
01b84746
ER
561%pre
562%addusertogroup http %{name}
563
82121306 564%post
08196fe2
ER
565# greate empty ghost files
566for a in cli.log errors.log irc_bot.log login_attempts.log; do
567 if [ ! -f /var/log/%{name}/$a ]; then
2b135b34 568 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
08196fe2
ER
569 fi
570done
571
00358bba
ER
572# run database update if configured
573test -s %{_webappdir}/config.php && \
847270fe
ER
574%{_appdir}/upgrade/update-database.php || :
575
da8d6134
ER
576# nuke Smarty templates cache after upgrade
577rm -f /var/cache/eventum/*.php
578
4a751c1a
ER
579# Restart webserver on upgrade to get .mo translations reloaded.
580# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
114241d7
ER
581%php_webserver_restart
582
82121306
ER
583%preun
584if [ "$1" = "0" ]; then
dfe0f6d6
ER
585 # nuke cache
586 rm -f /var/cache/eventum/*.php 2>/dev/null || :
587fi
cfc3bce6 588
01b84746 589%pre base
1d760108
ER
590%groupadd -P %{name}-base -g 146 %{name}
591%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
01b84746
ER
592
593%postun base
594if [ "$1" = "0" ]; then
a6d2ad69 595 %userremove %{name}
1f52d1fe 596 %groupremove %{name}
a6d2ad69
ER
597fi
598
94bd779f 599%post setup
8a37ad9d 600chmod 660 %{_webappdir}/{config,private_key}.php
253ca53d 601chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
602
603%postun setup
b4fe195b 604if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
8a37ad9d 605 chmod 640 %{_webappdir}/{config,private_key}.php
253ca53d 606 chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
607fi
608
e1c0f343
ER
609%post irc
610/sbin/chkconfig --add eventum-irc
99bbe3cb 611%service eventum-irc restart "Eventum IRC Bot"
e1c0f343 612
add0e245
ER
613%preun irc
614if [ "$1" = 0 ]; then
615 %service eventum-irc stop
616 /sbin/chkconfig --del eventum-irc
617fi
618
09f58a75 619%triggerin -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 620%webapp_register apache %{_webapp}
1d760108 621
09f58a75 622%triggerun -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 623%webapp_unregister apache %{_webapp}
1d760108 624
87ca28ca 625%triggerin -- apache < 2.2.0, apache-base
bdf85dc8 626%webapp_register httpd %{_webapp}
1d760108 627
87ca28ca 628%triggerun -- apache < 2.2.0, apache-base
bdf85dc8 629%webapp_unregister httpd %{_webapp}
1d760108 630
f399f1c0
ER
631%triggerin -- lighttpd
632%webapp_register lighttpd %{_webapp}
633
634%triggerun -- lighttpd
635%webapp_unregister lighttpd %{_webapp}
636
24cfc386
ER
637%triggerpostun -- %{name} < 3.0.0-0.2
638for f in /etc/cron.d/eventum-*; do
639 # crontabs moved to bin
0ffd10e7 640 %{__sed} -i -e '
24cfc386
ER
641 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
642 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
643 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
644 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
645 ' $f
0ffd10e7 646done
f1269a43 647
600d96a0 648%files -f %{name}.lang
bb01d732 649%defattr(644,root,root,755)
7a906e31 650%doc docs/*
8a37ad9d
ER
651%attr(751,root,root) %dir %{_webappdir}
652%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
653%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
f399f1c0 654%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
e570944f
ER
655%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
656%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
657%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
f399f1c0 658%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
d2e501e8 659
e570944f
ER
660%dir %attr(731,root,http) /var/log/%{name}
661%attr(620,root,http) %ghost /var/log/%{name}/*
3c6aa7a9 662%dir %attr(750,root,root) /var/log/archive/%{name}
8fd047ac 663%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
35f9d6a3 664
7a906e31 665%dir %{_appdir}/bin
7a906e31
ER
666%attr(755,root,root) %{_appdir}/bin/process_all_emails.php
667
ae3e48e6 668%{_appdir}/init.php
cfc3bce6
ER
669%dir %{_appdir}/htdocs
670%{_appdir}/htdocs/*.php
da8d6134 671%{_appdir}/htdocs/*.ico
7bc9b641 672%{_appdir}/htdocs/ajax
cfc3bce6
ER
673%{_appdir}/htdocs/css
674%{_appdir}/htdocs/customer
675%{_appdir}/htdocs/images
676%{_appdir}/htdocs/js
677%{_appdir}/htdocs/manage
7bc9b641 678%{_appdir}/htdocs/misc
cfc3bce6
ER
679%{_appdir}/htdocs/reports
680%{_appdir}/htdocs/rpc
7a906e31 681%{_appdir}/htdocs/components
9748a8c3 682%{_appdir}/templates
847270fe 683
c9165420 684%dir %{_appdir}/upgrade
7a906e31
ER
685%{_appdir}/upgrade/flush_compiled_templates.php
686%{_appdir}/upgrade/*.sql
847270fe 687%attr(755,root,root) %{_appdir}/upgrade/update-database.php
73de38a1 688%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
7a906e31
ER
689%attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
690%attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
847270fe
ER
691%{_appdir}/upgrade/patches
692
ae3e48e6
ER
693%dir %{_appdir}/lib
694%{_appdir}/lib/eventum
695%{_appdir}/lib/jpgraph
696%exclude %{_appdir}/lib/eventum/class.monitor.php
00e339ff
ER
697
698%{_appdir}/vendor
699
fa6167ba
ER
700%{_examplesdir}/%{name}-%{version}
701
73de38a1 702%{systemdtmpfilesdir}/%{name}.conf
e570944f
ER
703%dir %attr(730,root,http) /var/run/%{name}
704%dir %attr(730,root,http) /var/cache/%{name}
ab983aaa 705
d2e501e8
ER
706%files base
707%defattr(644,root,root,755)
708%attr(751,root,root) %dir %{_sysconfdir}
a392a259 709%dir %{_libdir}
cfc3bce6 710%dir %{_appdir}
098cbb72 711%dir /var/lib/%{name}
89522a33 712# saved mail copies
e570944f
ER
713%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
714%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
715%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
d2e501e8 716
ab983aaa
ER
717%files setup
718%defattr(644,root,root,755)
cfc3bce6 719%{_appdir}/htdocs/setup
0da8e1f2
ER
720
721%files mail-queue
722%defattr(644,root,root,755)
7a906e31 723%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
ea084bcb
ER
724%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
725
726%files mail-download
727%defattr(644,root,root,755)
7a906e31 728%attr(755,root,root) %{_appdir}/bin/download_emails.php
ea084bcb 729%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
5cb2e61d 730
cd719538
ER
731%files reminder
732%defattr(644,root,root,755)
7a906e31 733%attr(755,root,root) %{_appdir}/bin/check_reminders.php
cd719538
ER
734%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
735
736%files monitor
737%defattr(644,root,root,755)
ae3e48e6 738%{_appdir}/lib/eventum/class.monitor.php
7a906e31 739%attr(755,root,root) %{_appdir}/bin/monitor.php
cd719538
ER
740%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
741
5b165428
ER
742%files route-drafts
743%defattr(644,root,root,755)
7a906e31 744%attr(755,root,root) %{_appdir}/bin/route_drafts.php
5b165428 745
cd719538
ER
746%files route-emails
747%defattr(644,root,root,755)
7a906e31 748%attr(755,root,root) %{_appdir}/bin/route_emails.php
cd719538
ER
749
750%files route-notes
751%defattr(644,root,root,755)
7a906e31 752%attr(755,root,root) %{_appdir}/bin/route_notes.php
cd719538 753
a6d2ad69
ER
754%files router-postfix
755%defattr(644,root,root,755)
410d72c7 756%attr(755,root,root) %{_libdir}/router-postfix
a6d2ad69 757
cd719538
ER
758%files irc
759%defattr(644,root,root,755)
77b3db3b 760%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
01b84746 761%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
ae3e48e6 762%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
cd719538
ER
763%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
764
abd490e4
ER
765%files cli
766%defattr(644,root,root,755)
ae3e48e6 767%doc cli/eventumrc
4a74b463 768%attr(755,root,root) %{_bindir}/%{name}
abd490e4 769
5cb2e61d
ER
770%files scm
771%defattr(644,root,root,755)
c28270d0 772%attr(751,root,root) %dir %{_sysconfdir}
ca6b8520 773%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
ae3e48e6
ER
774%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
775%attr(755,root,root) %{_sbindir}/eventum-svn-hook
c28270d0 776%attr(755,root,root) %{_sbindir}/helpers.php
1cce3e61
ER
777
778%files sphinx
779%defattr(644,root,root,755)
780%{_webappdir}/sphinx.conf.php
7a906e31 781#%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
1cce3e61 782%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.30222 seconds and 4 git commands to generate.