]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
- apache config
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732 1# TODO
9748a8c3 2# - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
bb01d732
ER
3# - discard bundled packages (from INSTALL):
4# - JpGraph 1.5.3 (last GPL version)
5# - Smarty 2.3.0 (http://smarty.php.net)
6# - PEAR packages
7# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
8# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
9# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
10# - A few other small javascript libraries
11# - Mail Queue Process, cron or separate package (misc/process_mail_queue.php)
12# - Email Download (misc/download_emails.php)
13# - Reminder System (misc/check_reminders.php)
14# - Heartbeat Monitor (misc/monitor.php)
15# - Email Routing Script (misc/route_emails.php)
16# - Note Routing Script (misc/route_notes.php)
17# - IRC Notification Bot (misc/irc/bot.php)
18# - Command-line Interface (misc/cli/eventum)
87d15bba
ER
19
20# snapshot: DATE
21#define _snap 20050114
22
23%if 0%{?_snap}
24%define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
25%else
26%define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
27%endif
28
82121306 29%define _rel 1.15
87d15bba 30
bb01d732
ER
31Summary: Eventum Issue / Bug Tracking System
32Name: eventum
33Version: 1.4
87d15bba 34Release: %{?_snap:0.%{_snap}.}%{_rel}
6850abd9
ER
35License: GPL
36Group: Applications/WWW
87d15bba 37Source0: %{_source}
bb01d732 38# Source0-md5: 361c1355e46a6bbfa54e420964ec92cf
82121306 39Source1: %{name}-apache.conf
17a8bd0d
ER
40Patch0: %{name}-rpm.patch
41Patch1: %{name}-clock-status.patch
bb01d732
ER
42URL: http://dev.mysql.com/downloads/other/eventum/index.html
43BuildRequires: sed >= 4.0
9cdc5027 44Requires: php >= 4.1.0
bb01d732
ER
45Requires: php-pcre
46Requires: php-mysql
47Requires: php-gd
48Requires: php-imap
82121306
ER
49# conflict with non-confdir apache
50Conflicts: apache1 < 1.3.33-1.1
bb01d732
ER
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
82121306 53%define _sysconfdir /etc/%{name}
9748a8c3 54%define _appdir %{_datadir}/%{name}
bb01d732 55
82121306
ER
56%define _apache1dir /etc/apache
57%define _apache2dir /etc/httpd
58
bb01d732
ER
59%description
60Eventum is a user-friendly and flexible issue tracking system that can
61be used by a support department to track incoming technical support
62requests, or by a software development team to quickly organize tasks
63and bugs. Eventum is used by the MySQL AB Technical Support team, and
64has allowed us to dramatically improve our response times.
65
66%prep
87d15bba 67%setup -q %{?_snap:-n %{name}-%{_snap}}
d36b46b9 68%patch0 -p1
17a8bd0d 69%patch1 -p1
bb01d732
ER
70
71%build
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
82121306 76install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{locks,templates_c}}
bb01d732 77
9748a8c3 78cp -a . $RPM_BUILD_ROOT%{_appdir}
bb01d732 79
9748a8c3 80> $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
9cdc5027 81
82121306
ER
82sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
83
84install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
85
bb01d732 86# in doc
9748a8c3 87rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
21efb649 88rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
bb01d732
ER
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
82121306
ER
93%post
94# apache1
95if [ -f %{_apache1dir}/apache.conf ]; then
96 ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
97 if [ -f /var/lock/subsys/apache ]; then
98 /etc/rc.d/init.d/apache restart 1>&2
99 fi
100fi
101# apache2
102if [ -d %{_apache2dir}/httpd.conf ]; then
103 ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
104 if [ -f /var/lock/subsys/httpd ]; then
105 /etc/rc.d/init.d/httpd restart 1>&2
106 fi
107fi
108
109%preun
110if [ "$1" = "0" ]; then
111 # apache1
112 if [ -f %{_apache1dir}/apache.conf ]; then
113 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
114 if [ -f /var/lock/subsys/apache ]; then
115 /etc/rc.d/init.d/apache restart 1>&2
116 fi
117 fi
118 # apache2
119 if [ -d %{_apache2dir}/httpd.conf ]; then
120 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
121 if [ -f /var/lock/subsys/httpd ]; then
122 /etc/rc.d/init.d/httpd restart 1>&2
123 fi
124 fi
125fi
126
bb01d732
ER
127%files
128%defattr(644,root,root,755)
21efb649 129%doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade
82121306
ER
130%dir %{_sysconfdir}
131%attr(640,http,root) %config(noreplace) %{_sysconfdir}/apache.conf
132
9748a8c3
ER
133%dir %{_appdir}
134%attr(640,http,root) %config(noreplace) %{_appdir}/config.inc.php
135%attr(640,http,root) %config(noreplace) %{_appdir}/setup.conf.php
136%{_appdir}/*[!cf].php
137
138%{_appdir}/css
139%{_appdir}/customer
140%{_appdir}/docs
141%{_appdir}/images
142%{_appdir}/js
143%{_appdir}/manage
144%{_appdir}/misc
145%{_appdir}/reports
146%{_appdir}/rpc
147%{_appdir}/setup
148%{_appdir}/templates
149
150%dir %attr(755,http,root) %{_appdir}/locks
151
152%dir %{_appdir}/include
153%{_appdir}/include/customer
154%{_appdir}/include/jpgraph
155%{_appdir}/include/pear
156%{_appdir}/include/Smarty
157%{_appdir}/include/workflow
158%{_appdir}/include/class.*
159%{_appdir}/include/db_access.php
160%{_appdir}/include/jsrsServer.inc.php
161%attr(640,http,root) %{_appdir}/include/private_key.php
162
163%dir %attr(755,http,root) %{_appdir}/logs
164%attr(640,http,root) %{_appdir}/logs/*
165
166%dir %attr(750,http,root) %{_appdir}/templates_c
This page took 0.543493 seconds and 4 git commands to generate.