]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
- updated (2011-04-20)
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732
ER
1# TODO
2# - discard bundled packages (from INSTALL):
3# - JpGraph 1.5.3 (last GPL version)
bb01d732
ER
4# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7# - A few other small javascript libraries
a659c698
JB
8#
9# Conditional build:
422dcc8e 10%bcond_without order # with experimental order patch
cddf3011 11
a7b5a3c7 12%define php_min_version 5.1.2
36ae5d15 13%define subver 4282
68aaad3c 14%define rel 1
b3857e8b 15%include /usr/lib/rpm/macros.php
c96aabf5 16Summary: Eventum Issue / Bug tracking system
9f49cf47 17Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
bb01d732 18Name: eventum
68aaad3c 19Version: 2.3.1
39167c50
ER
20#Release: %{rel}.bzr%{subver}
21Release: %{rel}
6850abd9
ER
22License: GPL
23Group: Applications/WWW
68aaad3c
ER
24Source0: http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
25# Source0-md5: 7eb5055260fcf096bc48b0e6c4758e3b
26#Source0: %{name}-%{version}-dev-r%{subver}.tar.gz
82121306 27Source1: %{name}-apache.conf
cd719538
ER
28Source2: %{name}-mail-queue.cron
29Source3: %{name}-mail-download.cron
30Source4: %{name}-reminder.cron
31Source5: %{name}-monitor.cron
32Source6: %{name}-cvs.php
33Source7: %{name}-irc.php
34Source8: %{name}-irc.init
73f6a3e6 35Source9: %{name}-irc.sysconfig
cfcdd0a9
ER
36Source13: %{name}-router-postfix.sh
37Source14: %{name}.logrotate
38Source15: %{name}-lighttpd.conf
d0dabd47
ER
39Source16: http://www.isocra.com/images/updown2.gif
40# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
ac27ba92 41Patch0: %{name}-lf.patch
4f627938 42Patch2: %{name}-order.patch
36ae5d15 43Patch3: group-users.patch
14ff3418 44# packaging patches that probably never go upstream
ac27ba92
ER
45Patch100: %{name}-paths.patch
46Patch101: %{name}-cvs-config.patch
4c823356 47Patch105: %{name}-bot-reconnect.patch
cfcdd0a9 48Patch107: %{name}-gettext.patch
a6016bab
ER
49# some tests
50Patch200: %{name}-fixed-nav.patch
3cf7d1aa 51URL: http://eventum.mysql.org/
2bbc9c41 52BuildRequires: gettext-devel
b3857e8b 53BuildRequires: rpm-php-pearprov >= 4.0.2-98
d1c44829 54BuildRequires: rpmbuild(macros) >= 1.461
4068cb73 55BuildRequires: sed >= 4.0
5b165428 56Requires: %{name}-base = %{version}-%{release}
7db4d346 57Requires: Smarty >= 2.6.10-4
a7b5a3c7 58Requires: php-common >= 4:%{php_min_version}
36ae5d15 59Requires: php-filter
cf66850b
ER
60Requires: php-gd
61Requires: php-iconv
62Requires: php-imap
63Requires: php-mbstring
64Requires: php-mysql
65Requires: php-pcre
71b01fde
ER
66Requires: php-pear-DB
67Requires: php-pear-Date
71b01fde 68Requires: php-pear-Mail
723da18a 69Requires: php-pear-Mail_Mime
fb0b2f83 70Requires: php-pear-Mail_mimeDecode
71b01fde
ER
71Requires: php-pear-Math_Stats
72Requires: php-pear-Net_DIME
71b01fde 73Requires: php-pear-Net_SMTP
71b01fde
ER
74Requires: php-pear-Net_Socket
75Requires: php-pear-Net_URL
76Requires: php-pear-Net_UserAgent_Detect
3223fb64 77Requires: php-pear-PEAR-core
71b01fde
ER
78Requires: php-pear-Text_Diff
79Requires: php-pear-XML_RPC
098cbb72 80Requires: php-session
465c3ab7 81Requires: smarty-gettext
bdf85dc8 82Requires: webapps
f399f1c0
ER
83Requires: webserver(access)
84Requires: webserver(alias)
897bdb2c 85Requires: webserver(indexfile)
61351540 86Requires: webserver(php) >= 4.2.0
462ee1a6 87Suggests: localedb
0f8c2c4a 88Conflicts: logrotate < 3.7-4
35fa3cf8 89BuildArch: noarch
bb01d732
ER
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
8a0978e0 92%define _noautopear pear(../init.php) pear(init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php)
03410d49
ER
93
94# exclude optional php dependencies
253ca53d 95%define _noautophp php-gnupg php-hash php-pecl-http php-json php-tk
03410d49
ER
96
97%define _noautoreq %{_noautophp} %{_noautopear}
3223fb64 98
1d760108 99%define _libdir %{_prefix}/lib/%{name}
71f56750 100%define _appdir %{_datadir}/%{name}
d1c44829 101%define _smartydir %{php_data_dir}/Smarty
bdf85dc8
ER
102%define _webapps /etc/webapps
103%define _webapp %{name}
8a37ad9d
ER
104%define _webappdir %{_webapps}/%{_webapp}
105%define _sysconfdir /etc/%{name}
bb01d732
ER
106
107%description
108Eventum is a user-friendly and flexible issue tracking system that can
109be used by a support department to track incoming technical support
110requests, or by a software development team to quickly organize tasks
111and bugs. Eventum is used by the MySQL AB Technical Support team, and
112has allowed us to dramatically improve our response times.
113
d8cfa9f0
JR
114%description -l pl.UTF-8
115Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116może być używany przez dział obsługi do śledzenia przychodzących żądań
117obsługi technicznej albo przez zespół tworzący oprogramowanie do
118szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
119Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
4068cb73
JB
120reakcji.
121
d2e501e8
ER
122%package base
123Summary: Eventum base package
9f49cf47 124Summary(pl.UTF-8): Podstawowy pakiet Eventum
d2e501e8 125Group: Applications/WWW
3223fb64
ER
126Requires(postun): /usr/sbin/groupdel
127Requires(postun): /usr/sbin/userdel
5bbd68c9
ER
128Requires(pre): /bin/id
129Requires(pre): /usr/bin/getgid
5bbd68c9 130Requires(pre): /usr/sbin/groupadd
3223fb64 131Requires(pre): /usr/sbin/useradd
9f768793 132Provides: group(eventum)
d080edb6 133Provides: user(eventum)
d2e501e8
ER
134
135%description base
136This package contains base directory structure for Eventum.
137
d8cfa9f0
JR
138%description base -l pl.UTF-8
139Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
1bb5e749 140
ab983aaa 141%package setup
4068cb73 142Summary: Eventum setup package
9f49cf47 143Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
ab983aaa 144Group: Applications/WWW
5b165428 145Requires: %{name} = %{version}-%{release}
ab983aaa
ER
146
147%description setup
148Install this package to configure initial Eventum installation. You
149should uninstall this package when you're done, as it considered
150insecure to keep the setup files in place.
151
d8cfa9f0
JR
152%description setup -l pl.UTF-8
153Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
154pierwszej instalacji. Potem należy go odinstalować, jako że
155pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
4068cb73 156
0da8e1f2 157%package mail-queue
30689148 158Summary: Eventum mail queue process
9f49cf47 159Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
0da8e1f2 160Group: Applications/WWW
5b165428 161Requires: %{name} = %{version}-%{release}
0da8e1f2
ER
162Requires: crondaemon
163
164%description mail-queue
165Beginning with the first release of Eventum, emails are not directly
166sent out from the various scripts, but rather added to a mail queue
167table that is processed by a cron job. If an email cannot be sent, it
168will be marked as such in the mail queue log, and the cron job script
169will re-try to send it again the next time it runs.
170
171This package contains the cron job.
172
d8cfa9f0
JR
173%description mail-queue -l pl.UTF-8
174Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
175różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
177kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
178następnym razem.
0181746f 179
30689148 180Ten pakiet zawiera zadanie dla crona.
181
ea084bcb 182%package mail-download
30689148 183Summary: Eventum email download
9f49cf47 184Summary(pl.UTF-8): Ściąganie poczty Eventum
ea084bcb 185Group: Applications/WWW
5b165428 186Requires: %{name} = %{version}-%{release}
ea084bcb
ER
187Requires: crondaemon
188
189%description mail-download
190In order for Eventum's email integration feature to work, you need to
191setup a cron job to run the script every so often.
192
193This package contains the cron job.
194
d8cfa9f0
JR
195%description mail-download -l pl.UTF-8
196Aby integracja poczty elektronicznej w Eventum działała, trzeba
197ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
198często.
0181746f
JB
199
200Ten pakiet zawiera zadanie dla crona.
201
cd719538
ER
202%package reminder
203Summary: Eventum Reminder System
9f49cf47 204Summary(pl.UTF-8): System przypominania dla Eventum
cd719538 205Group: Applications/WWW
5b165428 206Requires: %{name} = %{version}-%{release}
cd719538
ER
207Requires: crondaemon
208
209%description reminder
210The reminder system was designed with the objective as serving as a
211safe net for issues that need attention. Depending on what
212configuration you create, you may have several reminders (or alerts)
213be sent out whenever an issue needs attention, for whatever parameter
214you may deem necessary.
215
216This package contains the cron job.
217
d8cfa9f0
JR
218%description reminder -l pl.UTF-8
219System przypominania został zaprojektowany tak, aby służył jako
220bezpieczna sieć dla spraw wymagających uwagi. W zależności od
221konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
222przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
223uważać za potrzebny.
6341f096
JB
224
225Ten pakiet zawiera zadanie dla crona.
226
cd719538
ER
227%package monitor
228Summary: Eventum Heartbeat Monitor
9f49cf47 229Summary(pl.UTF-8): Monitor życia dla Eventum
cd719538 230Group: Applications/WWW
5b165428 231Requires: %{name} = %{version}-%{release}
cd719538 232Requires: crondaemon
61351540 233Requires: php(posix)
cd719538
ER
234
235%description monitor
236The heartbeat monitor is a feature designed for the administrator that
237wants to be alerted whenever a common problem in Eventum is detected,
238like the database server not being available anymore, or maybe when
239the recommended permissions for certain configuration files are
240changed.
241
242Please note that before running the heartbeat monitor, you may need to
243customize some of the checks to be appropriate for your own system,
244particularly the permission and file checks on
245Monitor::checkConfiguration().
246
247This package contains the cron job.
248
d8cfa9f0
JR
249%description monitor -l pl.UTF-8
250Monitor życia to funkcjonalność zaprojektowana dla administratora
251chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
252Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
253do plików konfiguracyjnych.
6341f096 254
d8cfa9f0
JR
255Należy zauważyć, że przed uruchomieniem tego monitora może być
256konieczne dostosowanie niektórych testów do systemu, w szczególności
257testów uprawnień i plików w Monitor::checkConfiguration().
6341f096
JB
258
259Ten pakiet zawiera zadanie dla crona.
260
5b165428
ER
261%package route-drafts
262Summary: Eventum Draft Routing
9f49cf47 263Summary(pl.UTF-8): Przekazywanie szkiców dla Eventum
5b165428
ER
264Group: Applications/WWW
265Requires: %{name} = %{version}-%{release}
5b165428
ER
266Requires: eventum(router)
267
268%description route-drafts
71f56750 269The draft routing feature is used to automatically associate a thread
098cbb72
ER
270of drafts into an Eventum issue. By setting up Postfix to deliver
271emails sent to a specific address (usually draft-<number>@<domain>) to
272the above script, users are able to send drafts written in their mail
273client to be stored in Eventum. These drafts will NOT broadcasted to
274the notification list.
5b165428 275
d8cfa9f0
JR
276%description route-drafts -l pl.UTF-8
277Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
098cbb72
ER
278problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
279wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
280skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
281kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
282na listę powiadomień.
5410173f 283
cd719538
ER
284%package route-emails
285Summary: Eventum Email Routing
9f49cf47 286Summary(pl.UTF-8): Przekazywanie poczty dla Eventum
cd719538 287Group: Applications/WWW
5b165428 288Requires: %{name} = %{version}-%{release}
8bc4bcd1 289Requires: eventum(router)
cd719538
ER
290
291%description route-emails
292The email routing feature is used to automatically associate a thread
098cbb72
ER
293of emails into an Eventum issue. By setting up Postfix to deliver
294emails sent to a specific address (usually issue-<number>@<domain>) to
295the above script, users are able to use their email clients to reply
296to emails coming from Eventum, and those replies will be automatically
297associated with the issue and broadcasted to the entire notification
298list.
cd719538 299
d8cfa9f0
JR
300%description route-emails -l pl.UTF-8
301Funkcjonalność przekazywania poczty służy do automatycznego wiązania
098cbb72
ER
302wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
303aby dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
304issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
305używać klientów pocztowych do odpowiadania na listy przychodzące z
306Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
307rozprowadzane do całej listy ogłoszeniowej.
6341f096 308
cd719538
ER
309%package route-notes
310Summary: Eventum Note Routing
9f49cf47 311Summary(pl.UTF-8): Przekazywanie notatek dla Eventum
cd719538 312Group: Applications/WWW
5b165428 313Requires: %{name} = %{version}-%{release}
8bc4bcd1 314Requires: eventum(router)
cd719538
ER
315
316%description route-notes
317The note routing feature is used to automatically associate a thread
098cbb72
ER
318of notes into an Eventum issue. By setting up Postfix to deliver
319emails sent to a specific address (usually note-<number>@<domain>) to
320the above script, users are able to use their email clients to reply
321to internal notes coming from Eventum, and those replies will be
322automatically associated with the issue and broadcasted to the
323notification list staff members.
cd719538 324
d8cfa9f0
JR
325%description route-notes -l pl.UTF-8
326Funkcjonalność przekazywania notatek służy do automatycznego wiązania
098cbb72
ER
327wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
328dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
329note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
330używać klientów pocztowych do odpowiadania na wewnętrzne notatki
331pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
332sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
6341f096 333
a6d2ad69
ER
334%package router-postfix
335Summary: Eventum Mail Routing - Postfix
9f49cf47 336Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
a6d2ad69 337Group: Applications/Mail
5b165428 338Requires: %{name} = %{version}-%{release}
a6d2ad69 339Requires: postfix
8bc4bcd1
ER
340Provides: eventum(router)
341Obsoletes: eventum(router)
a6d2ad69
ER
342
343%description router-postfix
344This package provides way of routing notes and emails back to Eventum
345via Postfix.
346
e1bb3563
ER
347The Postfix configuration instructions you can find from
348<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
349
d8cfa9f0
JR
350%description router-postfix -l pl.UTF-8
351Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
995fa554
JB
352przez Postfiksa.
353
d8cfa9f0 354Opis konfiguracji Postfiksa można znaleźć pod adresem
a659c698
JB
355<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
356
cd719538
ER
357%package irc
358Summary: Eventum IRC Notification Bot
9f49cf47 359Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
cd719538 360Group: Applications/WWW
b79fc4aa 361Requires(post,preun): /sbin/chkconfig
5b165428 362Requires: %{name} = %{version}-%{release}
61351540 363Requires: php(sockets)
71f56750 364Requires: php-pear-Net_SmartIRC
e1c0f343 365Requires: rc-scripts >= 0.4.0.18
cd719538
ER
366
367%description irc
368The IRC notification bot is a nice feature for remote teams that want
369to handle issues and want to have a quick and easy way to get simple
370notifications. Right now the bot notifies of the following actions:
371- New Issues
372- Blocked emails
373- Issues that got their assignment list changed
374
375NOTE: You will need to manually edit the bot.php script to set your
376appropriate preferences, like IRC server and channel that the bot
377should join.
378
d8cfa9f0
JR
379%description irc -l pl.UTF-8
380IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
381zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
382uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
383następujących zdarzeniach:
6341f096
JB
384- nowych sprawach
385- zablokowanych listach
d8cfa9f0 386- sprawach, dla których zmieniła się lista powiązań
6341f096 387
d8cfa9f0
JR
388UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
389kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
6341f096 390
abd490e4
ER
391%package cli
392Summary: Eventum command-line interface
9f49cf47 393Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
abd490e4 394Group: Applications/WWW
5b165428 395Requires: %{name}-base = %{version}-%{release}
9500cdeb 396Requires: php-cli
a7b5a3c7 397Requires: php-common >= 4:%{php_min_version}
71b01fde 398Requires: php-pear-XML_RPC
abd490e4
ER
399
400%description cli
401The Eventum command-line interface allows you to access most of the
402features of the web interface straight from your command shell.
abd490e4 403
d8cfa9f0
JR
404%description cli -l pl.UTF-8
405Interfejs linii poleceń Eventum pozwala na dostęp do większości
406funkcji interfejsu WWW prosto z linii poleceń powłoki.
958cd5a0 407
5cb2e61d 408%package scm
30689148 409Summary: Eventum SCM integration
9f49cf47 410Summary(pl.UTF-8): Integracja SCM dla Eventum
5cb2e61d 411Group: Applications/WWW
5b165428 412Requires: %{name}-base = %{version}-%{release}
bdf85dc8 413Requires: php-cli
a7b5a3c7 414Requires: php-common >= 4:%{php_min_version}
cf66850b 415Requires: php-pcre
5cb2e61d
ER
416
417%description scm
418This feature allows your software development teams to integrate your
419Source Control Management system with your Issue Tracking System.
420
421The integration is implemented in such a way that it will be forward
422compatible with pretty much any SCM system, such as CVS.
423
0181746f 424For installation see
a392a259 425</eventum/help.php?topic=scm_integration_installation>.
0181746f 426
d8cfa9f0
JR
427%description scm -l pl.UTF-8
428Ten pakiet pozwala zespołom programistów na integrację systemu
429zarządzania źródłami (SCM - Source Control Management) z systemem
430śledzenia spraw.
0181746f 431
d8cfa9f0
JR
432Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
433prawie każdym systemem SCM, jak np. CVS.
0181746f 434
d8cfa9f0 435Szczegóły na temat instalacji można przeczytać pod
a392a259 436</eventum/help.php?topic=scm_integration_installation>.
5cb2e61d 437
bb01d732 438%prep
ae3e48e6 439%setup -q
5b165428 440
f1269a43
ER
441# GPL v2
442rm docs/COPYING
443
ae3e48e6
ER
444rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
445rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
446rm upgrade/flush_compiled_templates.php
447rm -r upgrade/{*/,}index.html # not needed in PLD Linux
e1c0f343 448
9487d524 449# bug fixes / features
0b3b58dd 450%patch0 -p1
4f627938 451%{?with_order:%patch2 -p1}
36ae5d15 452%patch3 -p0
57e65e62 453
0039f3e6 454cp -a %{SOURCE16} htdocs/images
422dcc8e 455
a6016bab 456#%patch200 -p1
ac27ba92
ER
457
458# packaging
459%patch100 -p1
460%patch101 -p1
ac27ba92 461%patch105 -p1
ac27ba92 462%patch107 -p1
0b3b58dd 463
25123ce7 464%{__sed} -i -e "
25123ce7 465s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
ae3e48e6 466" upgrade/{*/,}*.php
c3fd3767 467
5b165428 468# remove backups from patching as we use globs to package files to buildroot
73c437a6 469find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
085e39c0 470
465c3ab7 471%build
ae3e48e6 472%{__make} -C localization
465c3ab7 473
bb01d732
ER
474%install
475rm -rf $RPM_BUILD_ROOT
cfc3bce6 476install -d \
8a37ad9d 477 $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
2b135b34 478 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
c1e74aa1 479 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
685fc383 480 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
89522a33 481 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
761ae7dd 482 $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
cfc3bce6 483
ae3e48e6
ER
484%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
485 sysconfdir=%{_webappdir} \
486 DESTDIR=$RPM_BUILD_ROOT
da8d6134 487
ae3e48e6 488%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
9cdc5027 489
f399f1c0 490touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
31dabce6
ER
491cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
492cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
cfcdd0a9 493cp -a %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
ae3e48e6 494
31dabce6
ER
495cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
496cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
497cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
498cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
ae3e48e6 499
77b3db3b 500cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
ae3e48e6 501
2b135b34 502install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
31dabce6
ER
503cp -a %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
504
2b135b34
ER
505cp -a %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
506
410d72c7 507# postfix router
cfcdd0a9 508install %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
a6d2ad69 509
600d96a0 510%find_lang %{name}
c1e74aa1 511
ae3e48e6
ER
512# scm
513install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
514
515# old compat
516ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
517ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
518
519# skip pear for cli
520rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
0777bb86 521cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
ae3e48e6 522
bb01d732
ER
523%clean
524rm -rf $RPM_BUILD_ROOT
525
01b84746
ER
526%pre
527%addusertogroup http %{name}
528
82121306 529%post
08196fe2
ER
530# greate empty ghost files
531for a in cli.log errors.log irc_bot.log login_attempts.log; do
532 if [ ! -f /var/log/%{name}/$a ]; then
2b135b34 533 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
08196fe2
ER
534 fi
535done
536
847270fe
ER
537# database update
538%{_appdir}/upgrade/update-database.php || :
539
da8d6134
ER
540# nuke Smarty templates cache after upgrade
541rm -f /var/cache/eventum/*.php
542
4a751c1a
ER
543# Restart webserver on upgrade to get .mo translations reloaded.
544# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
114241d7
ER
545%php_webserver_restart
546
82121306
ER
547%preun
548if [ "$1" = "0" ]; then
dfe0f6d6
ER
549 # nuke cache
550 rm -f /var/cache/eventum/*.php 2>/dev/null || :
551fi
cfc3bce6 552
01b84746 553%pre base
1d760108
ER
554%groupadd -P %{name}-base -g 146 %{name}
555%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
01b84746
ER
556
557%postun base
558if [ "$1" = "0" ]; then
a6d2ad69 559 %userremove %{name}
1f52d1fe 560 %groupremove %{name}
a6d2ad69
ER
561fi
562
94bd779f 563%post setup
8a37ad9d 564chmod 660 %{_webappdir}/{config,private_key}.php
253ca53d 565chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
566
567%postun setup
568if [ "$1" = "0" ]; then
8a37ad9d 569 chmod 640 %{_webappdir}/{config,private_key}.php
253ca53d 570 chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
571fi
572
e1c0f343
ER
573%post irc
574/sbin/chkconfig --add eventum-irc
99bbe3cb 575%service eventum-irc restart "Eventum IRC Bot"
e1c0f343 576
add0e245
ER
577%preun irc
578if [ "$1" = 0 ]; then
579 %service eventum-irc stop
580 /sbin/chkconfig --del eventum-irc
581fi
582
09f58a75 583%triggerin -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 584%webapp_register apache %{_webapp}
1d760108 585
09f58a75 586%triggerun -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 587%webapp_unregister apache %{_webapp}
1d760108 588
00e0fc89 589%triggerin -- apache < 2.2.0, apache-base
bdf85dc8 590%webapp_register httpd %{_webapp}
1d760108 591
00e0fc89 592%triggerun -- apache < 2.2.0, apache-base
bdf85dc8 593%webapp_unregister httpd %{_webapp}
1d760108 594
f399f1c0
ER
595%triggerin -- lighttpd
596%webapp_register lighttpd %{_webapp}
597
598%triggerun -- lighttpd
599%webapp_unregister lighttpd %{_webapp}
600
f1269a43
ER
601%triggerpostun -- %{name} < 2.2-2.57
602# switching eventum->http user
e570944f
ER
603chgrp http %{_webappdir}/config.php
604chgrp http %{_webappdir}/private_key.php
605chgrp http %{_webappdir}/setup.php
606chgrp http /var/log/%{name}/*
607# update crontab user
608for a in /etc/cron.d/eventum-*; do
000eaea8 609 [ -f "$a" ] || continue
e570944f
ER
610 awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}' $a > $a.rpmtmp && cat $a.rpmtmp > $a
611 rm -f $a.rpmtmp
e570944f 612
0ffd10e7
ER
613 # crontabs moved to crons subdir
614 %{__sed} -i -e '
615 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
616 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
617 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
618 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
619 ' $a
620done
f1269a43 621
600d96a0 622%files -f %{name}.lang
bb01d732 623%defattr(644,root,root,755)
4a751c1a 624%doc docs/* htdocs/setup/schema.sql
8a37ad9d
ER
625%attr(751,root,root) %dir %{_webappdir}
626%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
627%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
f399f1c0 628%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
e570944f
ER
629%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
630%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
631%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
f399f1c0 632%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
d2e501e8 633
e570944f
ER
634%dir %attr(731,root,http) /var/log/%{name}
635%attr(620,root,http) %ghost /var/log/%{name}/*
3c6aa7a9 636%dir %attr(750,root,root) /var/log/archive/%{name}
8fd047ac 637%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
35f9d6a3 638
f1269a43 639%dir %{_appdir}/crons
ae3e48e6 640%{_appdir}/init.php
cfc3bce6
ER
641%dir %{_appdir}/htdocs
642%{_appdir}/htdocs/*.php
da8d6134 643%{_appdir}/htdocs/*.ico
cfc3bce6
ER
644%{_appdir}/htdocs/css
645%{_appdir}/htdocs/customer
646%{_appdir}/htdocs/images
647%{_appdir}/htdocs/js
648%{_appdir}/htdocs/manage
649%{_appdir}/htdocs/reports
650%{_appdir}/htdocs/rpc
651%{_appdir}/htdocs/misc
422dcc8e
ER
652%if %{with order}
653%{_appdir}/htdocs/ajax
654%endif
9748a8c3 655%{_appdir}/templates
847270fe 656
c9165420 657%dir %{_appdir}/upgrade
ae3e48e6 658%{_appdir}/upgrade/init.php
847270fe
ER
659%attr(755,root,root) %{_appdir}/upgrade/update-database.php
660%dir %{_appdir}/upgrade/v*
661%attr(755,root,root) %{_appdir}/upgrade/v*/*.php
662%{_appdir}/upgrade/patches
663
ae3e48e6
ER
664%dir %{_appdir}/lib
665%{_appdir}/lib/eventum
666%{_appdir}/lib/jpgraph
667%exclude %{_appdir}/lib/eventum/class.monitor.php
9748a8c3 668
e570944f
ER
669%dir %attr(730,root,http) /var/run/%{name}
670%dir %attr(730,root,http) /var/cache/%{name}
ab983aaa 671
d2e501e8
ER
672%files base
673%defattr(644,root,root,755)
674%attr(751,root,root) %dir %{_sysconfdir}
a392a259 675%dir %{_libdir}
cfc3bce6 676%dir %{_appdir}
098cbb72 677%dir /var/lib/%{name}
89522a33 678# saved mail copies
e570944f
ER
679%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
680%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
681%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
d2e501e8 682
ab983aaa
ER
683%files setup
684%defattr(644,root,root,755)
cfc3bce6 685%{_appdir}/htdocs/setup
0da8e1f2
ER
686
687%files mail-queue
688%defattr(644,root,root,755)
f1269a43 689%attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
ea084bcb
ER
690%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
691
692%files mail-download
693%defattr(644,root,root,755)
f1269a43 694%attr(755,root,root) %{_appdir}/crons/download_emails.php
ea084bcb 695%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
5cb2e61d 696
cd719538
ER
697%files reminder
698%defattr(644,root,root,755)
f1269a43 699%attr(755,root,root) %{_appdir}/crons/check_reminders.php
cd719538
ER
700%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
701
702%files monitor
703%defattr(644,root,root,755)
ae3e48e6 704%{_appdir}/lib/eventum/class.monitor.php
f1269a43 705%attr(755,root,root) %{_appdir}/crons/monitor.php
cd719538
ER
706%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
707
5b165428
ER
708%files route-drafts
709%defattr(644,root,root,755)
410d72c7 710%attr(755,root,root) %{_appdir}/route_drafts.php
5b165428 711
cd719538
ER
712%files route-emails
713%defattr(644,root,root,755)
410d72c7 714%attr(755,root,root) %{_appdir}/route_emails.php
cd719538
ER
715
716%files route-notes
717%defattr(644,root,root,755)
410d72c7 718%attr(755,root,root) %{_appdir}/route_notes.php
cd719538 719
a6d2ad69
ER
720%files router-postfix
721%defattr(644,root,root,755)
410d72c7 722%attr(755,root,root) %{_libdir}/router-postfix
a6d2ad69 723
cd719538
ER
724%files irc
725%defattr(644,root,root,755)
77b3db3b 726%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
01b84746 727%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
ae3e48e6 728%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
cd719538
ER
729%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
730
abd490e4
ER
731%files cli
732%defattr(644,root,root,755)
ae3e48e6 733%doc cli/eventumrc
d2e501e8 734%attr(755,root,root) %{_bindir}/%{name}
cfc3bce6 735%{_appdir}/cli
abd490e4 736
5cb2e61d
ER
737%files scm
738%defattr(644,root,root,755)
ca6b8520 739%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
bd7564e0
ER
740%attr(755,root,root) %{_libdir}/process_cvs_commits
741%attr(755,root,root) %{_libdir}/process_svn_commits
ae3e48e6
ER
742%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
743%attr(755,root,root) %{_sbindir}/eventum-svn-hook
This page took 0.295096 seconds and 4 git commands to generate.