]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
- fix permissions for log dir
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732 1# TODO
9748a8c3 2# - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
bb01d732
ER
3# - discard bundled packages (from INSTALL):
4# - JpGraph 1.5.3 (last GPL version)
5# - Smarty 2.3.0 (http://smarty.php.net)
6# - PEAR packages
7# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
8# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
9# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
10# - A few other small javascript libraries
11# - Mail Queue Process, cron or separate package (misc/process_mail_queue.php)
12# - Email Download (misc/download_emails.php)
13# - Reminder System (misc/check_reminders.php)
14# - Heartbeat Monitor (misc/monitor.php)
15# - Email Routing Script (misc/route_emails.php)
16# - Note Routing Script (misc/route_notes.php)
17# - IRC Notification Bot (misc/irc/bot.php)
18# - Command-line Interface (misc/cli/eventum)
87d15bba
ER
19
20# snapshot: DATE
21#define _snap 20050114
22
23%if 0%{?_snap}
24%define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
25%else
26%define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
27%endif
28
7a7a10b5 29%define _rel 1.17
87d15bba 30
bb01d732
ER
31Summary: Eventum Issue / Bug Tracking System
32Name: eventum
33Version: 1.4
87d15bba 34Release: %{?_snap:0.%{_snap}.}%{_rel}
6850abd9
ER
35License: GPL
36Group: Applications/WWW
87d15bba 37Source0: %{_source}
bb01d732 38# Source0-md5: 361c1355e46a6bbfa54e420964ec92cf
82121306 39Source1: %{name}-apache.conf
17a8bd0d
ER
40Patch0: %{name}-rpm.patch
41Patch1: %{name}-clock-status.patch
bb01d732
ER
42URL: http://dev.mysql.com/downloads/other/eventum/index.html
43BuildRequires: sed >= 4.0
9cdc5027 44Requires: php >= 4.1.0
bb01d732
ER
45Requires: php-pcre
46Requires: php-mysql
47Requires: php-gd
48Requires: php-imap
7a7a10b5 49#Requires: apache-mod_dir
82121306
ER
50# conflict with non-confdir apache
51Conflicts: apache1 < 1.3.33-1.1
bb01d732
ER
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
82121306 54%define _sysconfdir /etc/%{name}
9748a8c3 55%define _appdir %{_datadir}/%{name}
bb01d732 56
82121306
ER
57%define _apache1dir /etc/apache
58%define _apache2dir /etc/httpd
59
bb01d732
ER
60%description
61Eventum is a user-friendly and flexible issue tracking system that can
62be used by a support department to track incoming technical support
63requests, or by a software development team to quickly organize tasks
64and bugs. Eventum is used by the MySQL AB Technical Support team, and
65has allowed us to dramatically improve our response times.
66
ab983aaa
ER
67%package setup
68Summary: Eventum setup package.
69Group: Applications/WWW
70
71%description setup
72Install this package to configure initial Eventum installation. You
73should uninstall this package when you're done, as it considered
74insecure to keep the setup files in place.
75
bb01d732 76%prep
87d15bba 77%setup -q %{?_snap:-n %{name}-%{_snap}}
d36b46b9 78%patch0 -p1
17a8bd0d 79%patch1 -p1
bb01d732
ER
80
81%build
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
82121306 86install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{locks,templates_c}}
bb01d732 87
9748a8c3 88cp -a . $RPM_BUILD_ROOT%{_appdir}
bb01d732 89
9748a8c3 90> $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
9cdc5027 91
82121306
ER
92sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
93
94install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
95
bb01d732 96# in doc
9748a8c3 97rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
21efb649 98rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
bb01d732
ER
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
82121306
ER
103%post
104# apache1
105if [ -f %{_apache1dir}/apache.conf ]; then
106 ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
107 if [ -f /var/lock/subsys/apache ]; then
108 /etc/rc.d/init.d/apache restart 1>&2
109 fi
110fi
111# apache2
112if [ -d %{_apache2dir}/httpd.conf ]; then
113 ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
114 if [ -f /var/lock/subsys/httpd ]; then
115 /etc/rc.d/init.d/httpd restart 1>&2
116 fi
117fi
118
119%preun
120if [ "$1" = "0" ]; then
121 # apache1
122 if [ -f %{_apache1dir}/apache.conf ]; then
123 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
124 if [ -f /var/lock/subsys/apache ]; then
125 /etc/rc.d/init.d/apache restart 1>&2
126 fi
127 fi
128 # apache2
129 if [ -d %{_apache2dir}/httpd.conf ]; then
130 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
131 if [ -f /var/lock/subsys/httpd ]; then
132 /etc/rc.d/init.d/httpd restart 1>&2
133 fi
134 fi
135fi
136
bb01d732
ER
137%files
138%defattr(644,root,root,755)
21efb649 139%doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade
82121306
ER
140%dir %{_sysconfdir}
141%attr(640,http,root) %config(noreplace) %{_sysconfdir}/apache.conf
142
9748a8c3
ER
143%dir %{_appdir}
144%attr(640,http,root) %config(noreplace) %{_appdir}/config.inc.php
145%attr(640,http,root) %config(noreplace) %{_appdir}/setup.conf.php
146%{_appdir}/*[!cf].php
147
148%{_appdir}/css
149%{_appdir}/customer
150%{_appdir}/docs
151%{_appdir}/images
152%{_appdir}/js
153%{_appdir}/manage
154%{_appdir}/misc
155%{_appdir}/reports
156%{_appdir}/rpc
9748a8c3
ER
157%{_appdir}/templates
158
159%dir %attr(755,http,root) %{_appdir}/locks
160
161%dir %{_appdir}/include
162%{_appdir}/include/customer
163%{_appdir}/include/jpgraph
164%{_appdir}/include/pear
165%{_appdir}/include/Smarty
166%{_appdir}/include/workflow
167%{_appdir}/include/class.*
168%{_appdir}/include/db_access.php
169%{_appdir}/include/jsrsServer.inc.php
170%attr(640,http,root) %{_appdir}/include/private_key.php
171
7a7a10b5 172%dir %attr(755,root,root) %{_appdir}/logs
9748a8c3
ER
173%attr(640,http,root) %{_appdir}/logs/*
174
175%dir %attr(750,http,root) %{_appdir}/templates_c
ab983aaa
ER
176
177%files setup
178%defattr(644,root,root,755)
179%{_appdir}/setup
This page took 0.08001 seconds and 4 git commands to generate.