]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
skip db upgrade if not yet configured
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732
ER
1# TODO
2# - discard bundled packages (from INSTALL):
3# - JpGraph 1.5.3 (last GPL version)
bb01d732
ER
4# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7# - A few other small javascript libraries
a659c698
JB
8#
9# Conditional build:
422dcc8e 10%bcond_without order # with experimental order patch
cddf3011 11
a7b5a3c7 12%define php_min_version 5.1.2
84591a7a 13#define subver RC3
01d8dfff 14%define rel 2
b3857e8b 15%include /usr/lib/rpm/macros.php
c96aabf5 16Summary: Eventum Issue / Bug tracking system
9f49cf47 17Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
bb01d732 18Name: eventum
73de38a1
ER
19Version: 2.3.3
20Release: %{rel}
21#Release: %{rel}.bzr%{subver}
a881bbb0 22License: GPL v2
6850abd9 23Group: Applications/WWW
84591a7a 24Source0: http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
73de38a1
ER
25# Source0-md5: e1a5097d191468061865065678665f0e
26#Source0: %{name}-%{version}-dev-r%{subver}.tar.gz
27#Source0: %{name}-%{version}%{subver}.tar.gz
82121306 28Source1: %{name}-apache.conf
cd719538
ER
29Source2: %{name}-mail-queue.cron
30Source3: %{name}-mail-download.cron
31Source4: %{name}-reminder.cron
32Source5: %{name}-monitor.cron
33Source6: %{name}-cvs.php
34Source7: %{name}-irc.php
35Source8: %{name}-irc.init
73f6a3e6 36Source9: %{name}-irc.sysconfig
1cce3e61 37Source10: sphinx.crontab
cfcdd0a9
ER
38Source13: %{name}-router-postfix.sh
39Source14: %{name}.logrotate
40Source15: %{name}-lighttpd.conf
d0dabd47
ER
41Source16: http://www.isocra.com/images/updown2.gif
42# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
cc613bc9 43Source17: %{name}.tmpfiles
ac27ba92 44Patch0: %{name}-lf.patch
4f627938 45Patch2: %{name}-order.patch
36ae5d15 46Patch3: group-users.patch
14ff3418 47# packaging patches that probably never go upstream
ac27ba92
ER
48Patch100: %{name}-paths.patch
49Patch101: %{name}-cvs-config.patch
4c823356 50Patch105: %{name}-bot-reconnect.patch
cfcdd0a9 51Patch107: %{name}-gettext.patch
a6016bab
ER
52# some tests
53Patch200: %{name}-fixed-nav.patch
3cf7d1aa 54URL: http://eventum.mysql.org/
2bbc9c41 55BuildRequires: gettext-devel
b3857e8b 56BuildRequires: rpm-php-pearprov >= 4.0.2-98
5500a61e 57BuildRequires: rpmbuild(macros) >= 1.654
4068cb73 58BuildRequires: sed >= 4.0
5b165428 59Requires: %{name}-base = %{version}-%{release}
7db4d346 60Requires: Smarty >= 2.6.10-4
01d8dfff 61Requires: php(core) >= %{php_min_version}
36ae5d15 62Requires: php-filter
cf66850b
ER
63Requires: php-gd
64Requires: php-iconv
65Requires: php-imap
899100ff 66Requires: php-json
cf66850b
ER
67Requires: php-mbstring
68Requires: php-mysql
69Requires: php-pcre
71b01fde
ER
70Requires: php-pear-DB
71Requires: php-pear-Date
71b01fde 72Requires: php-pear-Mail
723da18a 73Requires: php-pear-Mail_Mime
fb0b2f83 74Requires: php-pear-Mail_mimeDecode
71b01fde
ER
75Requires: php-pear-Math_Stats
76Requires: php-pear-Net_DIME
71b01fde 77Requires: php-pear-Net_SMTP
71b01fde
ER
78Requires: php-pear-Net_Socket
79Requires: php-pear-Net_URL
80Requires: php-pear-Net_UserAgent_Detect
3223fb64 81Requires: php-pear-PEAR-core
71b01fde
ER
82Requires: php-pear-Text_Diff
83Requires: php-pear-XML_RPC
098cbb72 84Requires: php-session
465c3ab7 85Requires: smarty-gettext
bdf85dc8 86Requires: webapps
f399f1c0
ER
87Requires: webserver(access)
88Requires: webserver(alias)
897bdb2c 89Requires: webserver(indexfile)
61351540 90Requires: webserver(php) >= 4.2.0
462ee1a6 91Suggests: localedb
73de38a1 92Suggests: php-pear-Net_LDAP2
bd70ea88 93Conflicts: logrotate < 3.8.0
35fa3cf8 94BuildArch: noarch
bb01d732
ER
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
5500a61e 97%define _noautoreq_pear ../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.php
03410d49
ER
98
99# exclude optional php dependencies
899100ff 100%define _noautophp php-gnupg php-hash php-pecl-http php-tk
03410d49 101
5500a61e 102%define _noautoreq %{_noautophp}
3223fb64 103
1d760108 104%define _libdir %{_prefix}/lib/%{name}
71f56750 105%define _appdir %{_datadir}/%{name}
d1c44829 106%define _smartydir %{php_data_dir}/Smarty
bdf85dc8
ER
107%define _webapps /etc/webapps
108%define _webapp %{name}
8a37ad9d
ER
109%define _webappdir %{_webapps}/%{_webapp}
110%define _sysconfdir /etc/%{name}
bb01d732
ER
111
112%description
113Eventum is a user-friendly and flexible issue tracking system that can
114be used by a support department to track incoming technical support
115requests, or by a software development team to quickly organize tasks
116and bugs. Eventum is used by the MySQL AB Technical Support team, and
117has allowed us to dramatically improve our response times.
118
d8cfa9f0
JR
119%description -l pl.UTF-8
120Eventum to przyjazny dla użytkownika system śledzenia spraw, który
121może być używany przez dział obsługi do śledzenia przychodzących żądań
122obsługi technicznej albo przez zespół tworzący oprogramowanie do
123szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
124Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
4068cb73
JB
125reakcji.
126
d2e501e8
ER
127%package base
128Summary: Eventum base package
9f49cf47 129Summary(pl.UTF-8): Podstawowy pakiet Eventum
d2e501e8 130Group: Applications/WWW
3223fb64
ER
131Requires(postun): /usr/sbin/groupdel
132Requires(postun): /usr/sbin/userdel
5bbd68c9
ER
133Requires(pre): /bin/id
134Requires(pre): /usr/bin/getgid
5bbd68c9 135Requires(pre): /usr/sbin/groupadd
3223fb64 136Requires(pre): /usr/sbin/useradd
9f768793 137Provides: group(eventum)
d080edb6 138Provides: user(eventum)
d2e501e8
ER
139
140%description base
141This package contains base directory structure for Eventum.
142
d8cfa9f0
JR
143%description base -l pl.UTF-8
144Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
1bb5e749 145
ab983aaa 146%package setup
4068cb73 147Summary: Eventum setup package
9f49cf47 148Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
ab983aaa 149Group: Applications/WWW
5b165428 150Requires: %{name} = %{version}-%{release}
ab983aaa
ER
151
152%description setup
153Install this package to configure initial Eventum installation. You
154should uninstall this package when you're done, as it considered
155insecure to keep the setup files in place.
156
d8cfa9f0
JR
157%description setup -l pl.UTF-8
158Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
159pierwszej instalacji. Potem należy go odinstalować, jako że
160pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
4068cb73 161
0da8e1f2 162%package mail-queue
30689148 163Summary: Eventum mail queue process
9f49cf47 164Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
0da8e1f2 165Group: Applications/WWW
5b165428 166Requires: %{name} = %{version}-%{release}
0da8e1f2
ER
167Requires: crondaemon
168
169%description mail-queue
170Beginning with the first release of Eventum, emails are not directly
171sent out from the various scripts, but rather added to a mail queue
172table that is processed by a cron job. If an email cannot be sent, it
173will be marked as such in the mail queue log, and the cron job script
174will re-try to send it again the next time it runs.
175
176This package contains the cron job.
177
d8cfa9f0
JR
178%description mail-queue -l pl.UTF-8
179Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183następnym razem.
0181746f 184
30689148 185Ten pakiet zawiera zadanie dla crona.
186
ea084bcb 187%package mail-download
30689148 188Summary: Eventum email download
9f49cf47 189Summary(pl.UTF-8): Ściąganie poczty Eventum
ea084bcb 190Group: Applications/WWW
5b165428 191Requires: %{name} = %{version}-%{release}
ea084bcb
ER
192Requires: crondaemon
193
194%description mail-download
195In order for Eventum's email integration feature to work, you need to
196setup a cron job to run the script every so often.
197
198This package contains the cron job.
199
d8cfa9f0
JR
200%description mail-download -l pl.UTF-8
201Aby integracja poczty elektronicznej w Eventum działała, trzeba
202ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203często.
0181746f
JB
204
205Ten pakiet zawiera zadanie dla crona.
206
cd719538
ER
207%package reminder
208Summary: Eventum Reminder System
9f49cf47 209Summary(pl.UTF-8): System przypominania dla Eventum
cd719538 210Group: Applications/WWW
5b165428 211Requires: %{name} = %{version}-%{release}
cd719538
ER
212Requires: crondaemon
213
214%description reminder
215The reminder system was designed with the objective as serving as a
216safe net for issues that need attention. Depending on what
217configuration you create, you may have several reminders (or alerts)
218be sent out whenever an issue needs attention, for whatever parameter
219you may deem necessary.
220
221This package contains the cron job.
222
d8cfa9f0
JR
223%description reminder -l pl.UTF-8
224System przypominania został zaprojektowany tak, aby służył jako
225bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228uważać za potrzebny.
6341f096
JB
229
230Ten pakiet zawiera zadanie dla crona.
231
cd719538
ER
232%package monitor
233Summary: Eventum Heartbeat Monitor
9f49cf47 234Summary(pl.UTF-8): Monitor życia dla Eventum
cd719538 235Group: Applications/WWW
5b165428 236Requires: %{name} = %{version}-%{release}
cd719538 237Requires: crondaemon
1cce3e61 238Requires: php-posix
cd719538
ER
239
240%description monitor
241The heartbeat monitor is a feature designed for the administrator that
242wants to be alerted whenever a common problem in Eventum is detected,
243like the database server not being available anymore, or maybe when
244the recommended permissions for certain configuration files are
245changed.
246
247Please note that before running the heartbeat monitor, you may need to
248customize some of the checks to be appropriate for your own system,
249particularly the permission and file checks on
250Monitor::checkConfiguration().
251
252This package contains the cron job.
253
d8cfa9f0
JR
254%description monitor -l pl.UTF-8
255Monitor życia to funkcjonalność zaprojektowana dla administratora
256chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258do plików konfiguracyjnych.
6341f096 259
d8cfa9f0
JR
260Należy zauważyć, że przed uruchomieniem tego monitora może być
261konieczne dostosowanie niektórych testów do systemu, w szczególności
262testów uprawnień i plików w Monitor::checkConfiguration().
6341f096
JB
263
264Ten pakiet zawiera zadanie dla crona.
265
5b165428
ER
266%package route-drafts
267Summary: Eventum Draft Routing
9f49cf47 268Summary(pl.UTF-8): Przekazywanie szkiców dla Eventum
5b165428
ER
269Group: Applications/WWW
270Requires: %{name} = %{version}-%{release}
5b165428
ER
271Requires: eventum(router)
272
273%description route-drafts
71f56750 274The draft routing feature is used to automatically associate a thread
098cbb72
ER
275of drafts into an Eventum issue. By setting up Postfix to deliver
276emails sent to a specific address (usually draft-<number>@<domain>) to
277the above script, users are able to send drafts written in their mail
278client to be stored in Eventum. These drafts will NOT broadcasted to
279the notification list.
5b165428 280
d8cfa9f0
JR
281%description route-drafts -l pl.UTF-8
282Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
098cbb72
ER
283problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287na listę powiadomień.
5410173f 288
cd719538
ER
289%package route-emails
290Summary: Eventum Email Routing
9f49cf47 291Summary(pl.UTF-8): Przekazywanie poczty dla Eventum
cd719538 292Group: Applications/WWW
5b165428 293Requires: %{name} = %{version}-%{release}
8bc4bcd1 294Requires: eventum(router)
cd719538
ER
295
296%description route-emails
297The email routing feature is used to automatically associate a thread
098cbb72
ER
298of emails into an Eventum issue. By setting up Postfix to deliver
299emails sent to a specific address (usually issue-<number>@<domain>) to
300the above script, users are able to use their email clients to reply
301to emails coming from Eventum, and those replies will be automatically
302associated with the issue and broadcasted to the entire notification
303list.
cd719538 304
d8cfa9f0
JR
305%description route-emails -l pl.UTF-8
306Funkcjonalność przekazywania poczty służy do automatycznego wiązania
098cbb72
ER
307wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308aby dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
309issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310używać klientów pocztowych do odpowiadania na listy przychodzące z
311Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312rozprowadzane do całej listy ogłoszeniowej.
6341f096 313
cd719538
ER
314%package route-notes
315Summary: Eventum Note Routing
9f49cf47 316Summary(pl.UTF-8): Przekazywanie notatek dla Eventum
cd719538 317Group: Applications/WWW
5b165428 318Requires: %{name} = %{version}-%{release}
8bc4bcd1 319Requires: eventum(router)
cd719538
ER
320
321%description route-notes
322The note routing feature is used to automatically associate a thread
098cbb72
ER
323of notes into an Eventum issue. By setting up Postfix to deliver
324emails sent to a specific address (usually note-<number>@<domain>) to
325the above script, users are able to use their email clients to reply
326to internal notes coming from Eventum, and those replies will be
327automatically associated with the issue and broadcasted to the
328notification list staff members.
cd719538 329
d8cfa9f0
JR
330%description route-notes -l pl.UTF-8
331Funkcjonalność przekazywania notatek służy do automatycznego wiązania
098cbb72
ER
332wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
334note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
6341f096 338
a6d2ad69
ER
339%package router-postfix
340Summary: Eventum Mail Routing - Postfix
9f49cf47 341Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
a6d2ad69 342Group: Applications/Mail
5b165428 343Requires: %{name} = %{version}-%{release}
a6d2ad69 344Requires: postfix
8bc4bcd1
ER
345Provides: eventum(router)
346Obsoletes: eventum(router)
a6d2ad69
ER
347
348%description router-postfix
349This package provides way of routing notes and emails back to Eventum
350via Postfix.
351
e1bb3563
ER
352The Postfix configuration instructions you can find from
353<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
d8cfa9f0
JR
355%description router-postfix -l pl.UTF-8
356Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
995fa554
JB
357przez Postfiksa.
358
d8cfa9f0 359Opis konfiguracji Postfiksa można znaleźć pod adresem
a659c698
JB
360<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
cd719538
ER
362%package irc
363Summary: Eventum IRC Notification Bot
9f49cf47 364Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
cd719538 365Group: Applications/WWW
b79fc4aa 366Requires(post,preun): /sbin/chkconfig
5b165428 367Requires: %{name} = %{version}-%{release}
71f56750 368Requires: php-pear-Net_SmartIRC
73de38a1 369Requires: php-sockets
e1c0f343 370Requires: rc-scripts >= 0.4.0.18
cd719538
ER
371
372%description irc
373The IRC notification bot is a nice feature for remote teams that want
374to handle issues and want to have a quick and easy way to get simple
375notifications. Right now the bot notifies of the following actions:
376- New Issues
377- Blocked emails
378- Issues that got their assignment list changed
379
380NOTE: You will need to manually edit the bot.php script to set your
381appropriate preferences, like IRC server and channel that the bot
382should join.
383
d8cfa9f0
JR
384%description irc -l pl.UTF-8
385IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
386zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
387uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
388następujących zdarzeniach:
6341f096
JB
389- nowych sprawach
390- zablokowanych listach
d8cfa9f0 391- sprawach, dla których zmieniła się lista powiązań
6341f096 392
d8cfa9f0
JR
393UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
394kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
6341f096 395
abd490e4
ER
396%package cli
397Summary: Eventum command-line interface
9f49cf47 398Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
abd490e4 399Group: Applications/WWW
5b165428 400Requires: %{name}-base = %{version}-%{release}
01d8dfff 401Requires: php(core) >= %{php_min_version}
9500cdeb 402Requires: php-cli
71b01fde 403Requires: php-pear-XML_RPC
abd490e4
ER
404
405%description cli
406The Eventum command-line interface allows you to access most of the
407features of the web interface straight from your command shell.
abd490e4 408
d8cfa9f0
JR
409%description cli -l pl.UTF-8
410Interfejs linii poleceń Eventum pozwala na dostęp do większości
411funkcji interfejsu WWW prosto z linii poleceń powłoki.
958cd5a0 412
5cb2e61d 413%package scm
30689148 414Summary: Eventum SCM integration
9f49cf47 415Summary(pl.UTF-8): Integracja SCM dla Eventum
5cb2e61d 416Group: Applications/WWW
5b165428 417Requires: %{name}-base = %{version}-%{release}
01d8dfff 418Requires: php(core) >= %{php_min_version}
bdf85dc8 419Requires: php-cli
cf66850b 420Requires: php-pcre
5cb2e61d
ER
421
422%description scm
423This feature allows your software development teams to integrate your
424Source Control Management system with your Issue Tracking System.
425
426The integration is implemented in such a way that it will be forward
427compatible with pretty much any SCM system, such as CVS.
428
0181746f 429For installation see
a392a259 430</eventum/help.php?topic=scm_integration_installation>.
0181746f 431
d8cfa9f0
JR
432%description scm -l pl.UTF-8
433Ten pakiet pozwala zespołom programistów na integrację systemu
434zarządzania źródłami (SCM - Source Control Management) z systemem
435śledzenia spraw.
0181746f 436
d8cfa9f0
JR
437Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
438prawie każdym systemem SCM, jak np. CVS.
0181746f 439
d8cfa9f0 440Szczegóły na temat instalacji można przeczytać pod
a392a259 441</eventum/help.php?topic=scm_integration_installation>.
5cb2e61d 442
1cce3e61
ER
443%package sphinx
444Summary: Eventum Sphinx Search
445Group: Applications/WWW
446Requires: %{name} = %{version}-%{release}
447Requires: crondaemon
448Requires: sphinx
449
450%description sphinx
451Sphinx search integration for Eventum.
452
453This package contains the cron job.
454
bb01d732 455%prep
ae3e48e6 456%setup -q
5b165428 457
f1269a43
ER
458# GPL v2
459rm docs/COPYING
460
ae3e48e6
ER
461rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
462rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
463rm upgrade/flush_compiled_templates.php
464rm -r upgrade/{*/,}index.html # not needed in PLD Linux
e1c0f343 465
9487d524 466# bug fixes / features
0b3b58dd 467%patch0 -p1
4f627938 468%{?with_order:%patch2 -p1}
36ae5d15 469%patch3 -p0
57e65e62 470
1b5aae0f 471cp -p %{SOURCE16} htdocs/images
422dcc8e 472
a6016bab 473#%patch200 -p1
ac27ba92 474
1cce3e61
ER
475# produce default sphinx config
476# must be run before paths.patch
477cat <<'EOF' > config/config.php
478<?php
479define('APP_SQL_DBTYPE', 'mysql');
480define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
481define('APP_SQL_DBPORT', 3306);
482define('APP_SQL_DBNAME', 'eventum');
483define('APP_SQL_DBUSER', 'mysql');
484define('APP_SQL_DBPASS', '');
485define('APP_TABLE_PREFIX', 'eventum_');
486EOF
487php config/sphinx.conf.php > config/sphinx.conf
488rm -f config/config.php
489
ac27ba92
ER
490# packaging
491%patch100 -p1
492%patch101 -p1
ac27ba92 493%patch105 -p1
ac27ba92 494%patch107 -p1
0b3b58dd 495
25123ce7 496%{__sed} -i -e "
25123ce7 497s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
ae3e48e6 498" upgrade/{*/,}*.php
c3fd3767 499
5b165428 500# remove backups from patching as we use globs to package files to buildroot
73c437a6 501find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
085e39c0 502
465c3ab7 503%build
ae3e48e6 504%{__make} -C localization
465c3ab7 505
bb01d732
ER
506%install
507rm -rf $RPM_BUILD_ROOT
cfc3bce6 508install -d \
8a37ad9d 509 $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
2b135b34 510 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
c1e74aa1 511 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
685fc383 512 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
89522a33 513 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
761ae7dd 514 $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
73de38a1 515 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
cfc3bce6 516
ae3e48e6
ER
517%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
518 sysconfdir=%{_webappdir} \
519 DESTDIR=$RPM_BUILD_ROOT
da8d6134 520
ae3e48e6 521%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
9cdc5027 522
f399f1c0 523touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
1b5aae0f
ER
524cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
525cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
526cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
1cce3e61
ER
527
528install -d $RPM_BUILD_ROOT/etc/sphinx
529cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
858c6f2a 530cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
ae3e48e6 531
1b5aae0f
ER
532cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
533cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
534cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
535cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
1cce3e61 536cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
ae3e48e6 537
1b5aae0f 538cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
ae3e48e6 539
2b135b34 540install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
1b5aae0f 541cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
31dabce6 542
1b5aae0f 543cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
2b135b34 544
410d72c7 545# postfix router
858c6f2a 546install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
a6d2ad69 547
73de38a1 548install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
cc613bc9 549
73de38a1 550%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
1b5aae0f 551
600d96a0 552%find_lang %{name}
c1e74aa1 553
ae3e48e6 554# scm
858c6f2a 555install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
ae3e48e6
ER
556
557# old compat
558ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
559ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
560
561# skip pear for cli
562rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
0777bb86 563cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
ae3e48e6 564
bb01d732
ER
565%clean
566rm -rf $RPM_BUILD_ROOT
567
01b84746
ER
568%pre
569%addusertogroup http %{name}
570
82121306 571%post
08196fe2
ER
572# greate empty ghost files
573for a in cli.log errors.log irc_bot.log login_attempts.log; do
574 if [ ! -f /var/log/%{name}/$a ]; then
2b135b34 575 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
08196fe2
ER
576 fi
577done
578
00358bba
ER
579# run database update if configured
580test -s %{_webappdir}/config.php && \
847270fe
ER
581%{_appdir}/upgrade/update-database.php || :
582
da8d6134
ER
583# nuke Smarty templates cache after upgrade
584rm -f /var/cache/eventum/*.php
585
4a751c1a
ER
586# Restart webserver on upgrade to get .mo translations reloaded.
587# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
114241d7
ER
588%php_webserver_restart
589
82121306
ER
590%preun
591if [ "$1" = "0" ]; then
dfe0f6d6
ER
592 # nuke cache
593 rm -f /var/cache/eventum/*.php 2>/dev/null || :
594fi
cfc3bce6 595
01b84746 596%pre base
1d760108
ER
597%groupadd -P %{name}-base -g 146 %{name}
598%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
01b84746
ER
599
600%postun base
601if [ "$1" = "0" ]; then
a6d2ad69 602 %userremove %{name}
1f52d1fe 603 %groupremove %{name}
a6d2ad69
ER
604fi
605
94bd779f 606%post setup
8a37ad9d 607chmod 660 %{_webappdir}/{config,private_key}.php
253ca53d 608chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
609
610%postun setup
611if [ "$1" = "0" ]; then
8a37ad9d 612 chmod 640 %{_webappdir}/{config,private_key}.php
253ca53d 613 chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
614fi
615
e1c0f343
ER
616%post irc
617/sbin/chkconfig --add eventum-irc
99bbe3cb 618%service eventum-irc restart "Eventum IRC Bot"
e1c0f343 619
add0e245
ER
620%preun irc
621if [ "$1" = 0 ]; then
622 %service eventum-irc stop
623 /sbin/chkconfig --del eventum-irc
624fi
625
09f58a75 626%triggerin -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 627%webapp_register apache %{_webapp}
1d760108 628
09f58a75 629%triggerun -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 630%webapp_unregister apache %{_webapp}
1d760108 631
00e0fc89 632%triggerin -- apache < 2.2.0, apache-base
bdf85dc8 633%webapp_register httpd %{_webapp}
1d760108 634
00e0fc89 635%triggerun -- apache < 2.2.0, apache-base
bdf85dc8 636%webapp_unregister httpd %{_webapp}
1d760108 637
f399f1c0
ER
638%triggerin -- lighttpd
639%webapp_register lighttpd %{_webapp}
640
641%triggerun -- lighttpd
642%webapp_unregister lighttpd %{_webapp}
643
f1269a43
ER
644%triggerpostun -- %{name} < 2.2-2.57
645# switching eventum->http user
e570944f
ER
646chgrp http %{_webappdir}/config.php
647chgrp http %{_webappdir}/private_key.php
648chgrp http %{_webappdir}/setup.php
649chgrp http /var/log/%{name}/*
650# update crontab user
651for a in /etc/cron.d/eventum-*; do
000eaea8 652 [ -f "$a" ] || continue
e570944f
ER
653 awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}' $a > $a.rpmtmp && cat $a.rpmtmp > $a
654 rm -f $a.rpmtmp
e570944f 655
0ffd10e7
ER
656 # crontabs moved to crons subdir
657 %{__sed} -i -e '
658 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
659 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
660 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
661 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
662 ' $a
663done
f1269a43 664
600d96a0 665%files -f %{name}.lang
bb01d732 666%defattr(644,root,root,755)
4a751c1a 667%doc docs/* htdocs/setup/schema.sql
8a37ad9d
ER
668%attr(751,root,root) %dir %{_webappdir}
669%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
670%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
f399f1c0 671%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
e570944f
ER
672%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
673%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
674%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
f399f1c0 675%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
d2e501e8 676
e570944f
ER
677%dir %attr(731,root,http) /var/log/%{name}
678%attr(620,root,http) %ghost /var/log/%{name}/*
3c6aa7a9 679%dir %attr(750,root,root) /var/log/archive/%{name}
8fd047ac 680%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
35f9d6a3 681
f1269a43 682%dir %{_appdir}/crons
ae3e48e6 683%{_appdir}/init.php
cfc3bce6
ER
684%dir %{_appdir}/htdocs
685%{_appdir}/htdocs/*.php
da8d6134 686%{_appdir}/htdocs/*.ico
cfc3bce6
ER
687%{_appdir}/htdocs/css
688%{_appdir}/htdocs/customer
689%{_appdir}/htdocs/images
690%{_appdir}/htdocs/js
691%{_appdir}/htdocs/manage
692%{_appdir}/htdocs/reports
693%{_appdir}/htdocs/rpc
694%{_appdir}/htdocs/misc
422dcc8e
ER
695%if %{with order}
696%{_appdir}/htdocs/ajax
697%endif
9748a8c3 698%{_appdir}/templates
847270fe 699
c9165420 700%dir %{_appdir}/upgrade
ae3e48e6 701%{_appdir}/upgrade/init.php
847270fe 702%attr(755,root,root) %{_appdir}/upgrade/update-database.php
73de38a1 703%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
847270fe
ER
704%dir %{_appdir}/upgrade/v*
705%attr(755,root,root) %{_appdir}/upgrade/v*/*.php
706%{_appdir}/upgrade/patches
707
ae3e48e6
ER
708%dir %{_appdir}/lib
709%{_appdir}/lib/eventum
710%{_appdir}/lib/jpgraph
711%exclude %{_appdir}/lib/eventum/class.monitor.php
73de38a1 712%{systemdtmpfilesdir}/%{name}.conf
e570944f
ER
713%dir %attr(730,root,http) /var/run/%{name}
714%dir %attr(730,root,http) /var/cache/%{name}
ab983aaa 715
d2e501e8
ER
716%files base
717%defattr(644,root,root,755)
718%attr(751,root,root) %dir %{_sysconfdir}
a392a259 719%dir %{_libdir}
cfc3bce6 720%dir %{_appdir}
098cbb72 721%dir /var/lib/%{name}
89522a33 722# saved mail copies
e570944f
ER
723%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
724%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
725%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
d2e501e8 726
ab983aaa
ER
727%files setup
728%defattr(644,root,root,755)
cfc3bce6 729%{_appdir}/htdocs/setup
0da8e1f2
ER
730
731%files mail-queue
732%defattr(644,root,root,755)
f1269a43 733%attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
ea084bcb
ER
734%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
735
736%files mail-download
737%defattr(644,root,root,755)
f1269a43 738%attr(755,root,root) %{_appdir}/crons/download_emails.php
ea084bcb 739%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
5cb2e61d 740
cd719538
ER
741%files reminder
742%defattr(644,root,root,755)
f1269a43 743%attr(755,root,root) %{_appdir}/crons/check_reminders.php
cd719538
ER
744%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
745
746%files monitor
747%defattr(644,root,root,755)
ae3e48e6 748%{_appdir}/lib/eventum/class.monitor.php
f1269a43 749%attr(755,root,root) %{_appdir}/crons/monitor.php
cd719538
ER
750%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
751
5b165428
ER
752%files route-drafts
753%defattr(644,root,root,755)
410d72c7 754%attr(755,root,root) %{_appdir}/route_drafts.php
5b165428 755
cd719538
ER
756%files route-emails
757%defattr(644,root,root,755)
410d72c7 758%attr(755,root,root) %{_appdir}/route_emails.php
cd719538
ER
759
760%files route-notes
761%defattr(644,root,root,755)
410d72c7 762%attr(755,root,root) %{_appdir}/route_notes.php
cd719538 763
a6d2ad69
ER
764%files router-postfix
765%defattr(644,root,root,755)
410d72c7 766%attr(755,root,root) %{_libdir}/router-postfix
a6d2ad69 767
cd719538
ER
768%files irc
769%defattr(644,root,root,755)
77b3db3b 770%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
01b84746 771%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
ae3e48e6 772%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
cd719538
ER
773%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
774
abd490e4
ER
775%files cli
776%defattr(644,root,root,755)
ae3e48e6 777%doc cli/eventumrc
d2e501e8 778%attr(755,root,root) %{_bindir}/%{name}
cfc3bce6 779%{_appdir}/cli
abd490e4 780
5cb2e61d
ER
781%files scm
782%defattr(644,root,root,755)
ca6b8520 783%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
bd7564e0
ER
784%attr(755,root,root) %{_libdir}/process_cvs_commits
785%attr(755,root,root) %{_libdir}/process_svn_commits
ae3e48e6
ER
786%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
787%attr(755,root,root) %{_sbindir}/eventum-svn-hook
1cce3e61
ER
788
789%files sphinx
790%defattr(644,root,root,755)
791%{_webappdir}/sphinx.conf.php
792%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
793%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.287284 seconds and 4 git commands to generate.