]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
update paths in cron files
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732
ER
1# TODO
2# - discard bundled packages (from INSTALL):
3# - JpGraph 1.5.3 (last GPL version)
bb01d732
ER
4# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7# - A few other small javascript libraries
a659c698
JB
8#
9# Conditional build:
7bc9b641 10%bcond_with order # with experimental order patch
cddf3011 11
dc8c226c 12%define subver pre1
fa6167ba 13%define rel 0.6
7a906e31 14%define php_min_version 5.3.3
b3857e8b 15%include /usr/lib/rpm/macros.php
c96aabf5 16Summary: Eventum Issue / Bug tracking system
9f49cf47 17Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
bb01d732 18Name: eventum
7a906e31 19Version: 3.0.0
dc8c226c 20Release: 0.%{subver}.%{rel}
a881bbb0 21License: GPL v2
6850abd9 22Group: Applications/WWW
5dbd4bf5 23Source0: https://github.com/eventum/eventum/releases/download/v%{version}-pre1/%{name}-%{version}-%{subver}.tar.gz
dc8c226c 24# Source0-md5: 786930171e278f03baa7b174f52e43d0
82121306 25Source1: %{name}-apache.conf
cd719538
ER
26Source2: %{name}-mail-queue.cron
27Source3: %{name}-mail-download.cron
28Source4: %{name}-reminder.cron
29Source5: %{name}-monitor.cron
30Source6: %{name}-cvs.php
31Source7: %{name}-irc.php
32Source8: %{name}-irc.init
73f6a3e6 33Source9: %{name}-irc.sysconfig
1cce3e61 34Source10: sphinx.crontab
cfcdd0a9
ER
35Source13: %{name}-router-postfix.sh
36Source14: %{name}.logrotate
37Source15: %{name}-lighttpd.conf
d0dabd47
ER
38Source16: http://www.isocra.com/images/updown2.gif
39# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
cc613bc9 40Source17: %{name}.tmpfiles
7a906e31 41#Patch0: %{name}-lf.patch
4f627938 42Patch2: %{name}-order.patch
7a906e31
ER
43#Patch3: group-users.patch
44#Patch4: https://github.com/glensc/eventum/compare/cf_escape.patch
14ff3418 45# packaging patches that probably never go upstream
ac27ba92
ER
46Patch100: %{name}-paths.patch
47Patch101: %{name}-cvs-config.patch
4c823356 48Patch105: %{name}-bot-reconnect.patch
cfcdd0a9 49Patch107: %{name}-gettext.patch
a6016bab
ER
50# some tests
51Patch200: %{name}-fixed-nav.patch
3cf7d1aa 52URL: http://eventum.mysql.org/
447ff246 53BuildRequires: /usr/bin/php
efd26093 54BuildRequires: gettext-tools
7a906e31 55BuildRequires: php(core) >= %{php_min_version}
b3857e8b 56BuildRequires: rpm-php-pearprov >= 4.0.2-98
5500a61e 57BuildRequires: rpmbuild(macros) >= 1.654
4068cb73 58BuildRequires: sed >= 4.0
5b165428 59Requires: %{name}-base = %{version}-%{release}
01d8dfff 60Requires: php(core) >= %{php_min_version}
2f331c68
ER
61Requires: php(filter)
62Requires: php(gd)
63Requires: php(iconv)
64Requires: php(imap)
65Requires: php(json)
66Requires: php(mbstring)
67Requires: php(mysql)
68Requires: php(pcre)
69Requires: php(session)
5dbd4bf5
ER
70Requires: php-Smarty >= 3.1
71Requires: php-Smarty-plugin-gettext
71b01fde
ER
72Requires: php-pear-DB
73Requires: php-pear-Date
71b01fde 74Requires: php-pear-Mail
723da18a 75Requires: php-pear-Mail_Mime
fb0b2f83 76Requires: php-pear-Mail_mimeDecode
71b01fde
ER
77Requires: php-pear-Math_Stats
78Requires: php-pear-Net_DIME
71b01fde 79Requires: php-pear-Net_SMTP
71b01fde
ER
80Requires: php-pear-Net_Socket
81Requires: php-pear-Net_URL
82Requires: php-pear-Net_UserAgent_Detect
3223fb64 83Requires: php-pear-PEAR-core
71b01fde
ER
84Requires: php-pear-Text_Diff
85Requires: php-pear-XML_RPC
bdf85dc8 86Requires: webapps
f399f1c0
ER
87Requires: webserver(access)
88Requires: webserver(alias)
897bdb2c 89Requires: webserver(indexfile)
61351540 90Requires: webserver(php) >= 4.2.0
462ee1a6 91Suggests: localedb
73de38a1 92Suggests: php-pear-Net_LDAP2
bd70ea88 93Conflicts: logrotate < 3.8.0
35fa3cf8 94BuildArch: noarch
bb01d732
ER
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
7f764a78 97%define _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
03410d49
ER
98
99# exclude optional php dependencies
899100ff 100%define _noautophp php-gnupg php-hash php-pecl-http php-tk
03410d49 101
5500a61e 102%define _noautoreq %{_noautophp}
3223fb64 103
1d760108 104%define _libdir %{_prefix}/lib/%{name}
71f56750 105%define _appdir %{_datadir}/%{name}
d1c44829 106%define _smartydir %{php_data_dir}/Smarty
bdf85dc8
ER
107%define _webapps /etc/webapps
108%define _webapp %{name}
8a37ad9d
ER
109%define _webappdir %{_webapps}/%{_webapp}
110%define _sysconfdir /etc/%{name}
bb01d732
ER
111
112%description
113Eventum is a user-friendly and flexible issue tracking system that can
114be used by a support department to track incoming technical support
115requests, or by a software development team to quickly organize tasks
116and bugs. Eventum is used by the MySQL AB Technical Support team, and
117has allowed us to dramatically improve our response times.
118
d8cfa9f0
JR
119%description -l pl.UTF-8
120Eventum to przyjazny dla użytkownika system śledzenia spraw, który
121może być używany przez dział obsługi do śledzenia przychodzących żądań
122obsługi technicznej albo przez zespół tworzący oprogramowanie do
123szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
124Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
4068cb73
JB
125reakcji.
126
d2e501e8
ER
127%package base
128Summary: Eventum base package
9f49cf47 129Summary(pl.UTF-8): Podstawowy pakiet Eventum
d2e501e8 130Group: Applications/WWW
3223fb64
ER
131Requires(postun): /usr/sbin/groupdel
132Requires(postun): /usr/sbin/userdel
5bbd68c9
ER
133Requires(pre): /bin/id
134Requires(pre): /usr/bin/getgid
5bbd68c9 135Requires(pre): /usr/sbin/groupadd
3223fb64 136Requires(pre): /usr/sbin/useradd
9f768793 137Provides: group(eventum)
d080edb6 138Provides: user(eventum)
d2e501e8
ER
139
140%description base
141This package contains base directory structure for Eventum.
142
d8cfa9f0
JR
143%description base -l pl.UTF-8
144Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
1bb5e749 145
ab983aaa 146%package setup
4068cb73 147Summary: Eventum setup package
9f49cf47 148Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
ab983aaa 149Group: Applications/WWW
5b165428 150Requires: %{name} = %{version}-%{release}
ab983aaa
ER
151
152%description setup
153Install this package to configure initial Eventum installation. You
154should uninstall this package when you're done, as it considered
155insecure to keep the setup files in place.
156
d8cfa9f0
JR
157%description setup -l pl.UTF-8
158Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
159pierwszej instalacji. Potem należy go odinstalować, jako że
160pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
4068cb73 161
0da8e1f2 162%package mail-queue
30689148 163Summary: Eventum mail queue process
9f49cf47 164Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
0da8e1f2 165Group: Applications/WWW
5b165428 166Requires: %{name} = %{version}-%{release}
0da8e1f2
ER
167Requires: crondaemon
168
169%description mail-queue
170Beginning with the first release of Eventum, emails are not directly
171sent out from the various scripts, but rather added to a mail queue
172table that is processed by a cron job. If an email cannot be sent, it
173will be marked as such in the mail queue log, and the cron job script
174will re-try to send it again the next time it runs.
175
176This package contains the cron job.
177
d8cfa9f0
JR
178%description mail-queue -l pl.UTF-8
179Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183następnym razem.
0181746f 184
30689148 185Ten pakiet zawiera zadanie dla crona.
186
ea084bcb 187%package mail-download
30689148 188Summary: Eventum email download
9f49cf47 189Summary(pl.UTF-8): Ściąganie poczty Eventum
ea084bcb 190Group: Applications/WWW
5b165428 191Requires: %{name} = %{version}-%{release}
ea084bcb
ER
192Requires: crondaemon
193
194%description mail-download
195In order for Eventum's email integration feature to work, you need to
196setup a cron job to run the script every so often.
197
198This package contains the cron job.
199
d8cfa9f0
JR
200%description mail-download -l pl.UTF-8
201Aby integracja poczty elektronicznej w Eventum działała, trzeba
202ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203często.
0181746f
JB
204
205Ten pakiet zawiera zadanie dla crona.
206
cd719538
ER
207%package reminder
208Summary: Eventum Reminder System
9f49cf47 209Summary(pl.UTF-8): System przypominania dla Eventum
cd719538 210Group: Applications/WWW
5b165428 211Requires: %{name} = %{version}-%{release}
cd719538
ER
212Requires: crondaemon
213
214%description reminder
215The reminder system was designed with the objective as serving as a
216safe net for issues that need attention. Depending on what
217configuration you create, you may have several reminders (or alerts)
218be sent out whenever an issue needs attention, for whatever parameter
219you may deem necessary.
220
221This package contains the cron job.
222
d8cfa9f0
JR
223%description reminder -l pl.UTF-8
224System przypominania został zaprojektowany tak, aby służył jako
225bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228uważać za potrzebny.
6341f096
JB
229
230Ten pakiet zawiera zadanie dla crona.
231
cd719538
ER
232%package monitor
233Summary: Eventum Heartbeat Monitor
9f49cf47 234Summary(pl.UTF-8): Monitor życia dla Eventum
cd719538 235Group: Applications/WWW
5b165428 236Requires: %{name} = %{version}-%{release}
cd719538 237Requires: crondaemon
2f331c68 238Requires: php(posix)
cd719538
ER
239
240%description monitor
241The heartbeat monitor is a feature designed for the administrator that
242wants to be alerted whenever a common problem in Eventum is detected,
243like the database server not being available anymore, or maybe when
244the recommended permissions for certain configuration files are
245changed.
246
247Please note that before running the heartbeat monitor, you may need to
248customize some of the checks to be appropriate for your own system,
249particularly the permission and file checks on
250Monitor::checkConfiguration().
251
252This package contains the cron job.
253
d8cfa9f0
JR
254%description monitor -l pl.UTF-8
255Monitor życia to funkcjonalność zaprojektowana dla administratora
256chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258do plików konfiguracyjnych.
6341f096 259
d8cfa9f0
JR
260Należy zauważyć, że przed uruchomieniem tego monitora może być
261konieczne dostosowanie niektórych testów do systemu, w szczególności
262testów uprawnień i plików w Monitor::checkConfiguration().
6341f096
JB
263
264Ten pakiet zawiera zadanie dla crona.
265
5b165428
ER
266%package route-drafts
267Summary: Eventum Draft Routing
9f49cf47 268Summary(pl.UTF-8): Przekazywanie szkiców dla Eventum
5b165428
ER
269Group: Applications/WWW
270Requires: %{name} = %{version}-%{release}
5b165428
ER
271Requires: eventum(router)
272
273%description route-drafts
71f56750 274The draft routing feature is used to automatically associate a thread
098cbb72
ER
275of drafts into an Eventum issue. By setting up Postfix to deliver
276emails sent to a specific address (usually draft-<number>@<domain>) to
277the above script, users are able to send drafts written in their mail
278client to be stored in Eventum. These drafts will NOT broadcasted to
279the notification list.
5b165428 280
d8cfa9f0
JR
281%description route-drafts -l pl.UTF-8
282Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
098cbb72
ER
283problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
284wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
285skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
286kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
287na listę powiadomień.
5410173f 288
cd719538
ER
289%package route-emails
290Summary: Eventum Email Routing
9f49cf47 291Summary(pl.UTF-8): Przekazywanie poczty dla Eventum
cd719538 292Group: Applications/WWW
5b165428 293Requires: %{name} = %{version}-%{release}
8bc4bcd1 294Requires: eventum(router)
cd719538
ER
295
296%description route-emails
297The email routing feature is used to automatically associate a thread
098cbb72
ER
298of emails into an Eventum issue. By setting up Postfix to deliver
299emails sent to a specific address (usually issue-<number>@<domain>) to
300the above script, users are able to use their email clients to reply
301to emails coming from Eventum, and those replies will be automatically
302associated with the issue and broadcasted to the entire notification
303list.
cd719538 304
d8cfa9f0
JR
305%description route-emails -l pl.UTF-8
306Funkcjonalność przekazywania poczty służy do automatycznego wiązania
098cbb72
ER
307wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
308aby dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
309issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
310używać klientów pocztowych do odpowiadania na listy przychodzące z
311Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
312rozprowadzane do całej listy ogłoszeniowej.
6341f096 313
cd719538
ER
314%package route-notes
315Summary: Eventum Note Routing
9f49cf47 316Summary(pl.UTF-8): Przekazywanie notatek dla Eventum
cd719538 317Group: Applications/WWW
5b165428 318Requires: %{name} = %{version}-%{release}
8bc4bcd1 319Requires: eventum(router)
cd719538
ER
320
321%description route-notes
322The note routing feature is used to automatically associate a thread
098cbb72
ER
323of notes into an Eventum issue. By setting up Postfix to deliver
324emails sent to a specific address (usually note-<number>@<domain>) to
325the above script, users are able to use their email clients to reply
326to internal notes coming from Eventum, and those replies will be
327automatically associated with the issue and broadcasted to the
328notification list staff members.
cd719538 329
d8cfa9f0
JR
330%description route-notes -l pl.UTF-8
331Funkcjonalność przekazywania notatek służy do automatycznego wiązania
098cbb72
ER
332wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
333dostarczał listy wysyłane na pewien adres (zwykle
d8cfa9f0
JR
334note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
335używać klientów pocztowych do odpowiadania na wewnętrzne notatki
336pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
337sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
6341f096 338
a6d2ad69
ER
339%package router-postfix
340Summary: Eventum Mail Routing - Postfix
9f49cf47 341Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
a6d2ad69 342Group: Applications/Mail
5b165428 343Requires: %{name} = %{version}-%{release}
a6d2ad69 344Requires: postfix
8bc4bcd1
ER
345Provides: eventum(router)
346Obsoletes: eventum(router)
a6d2ad69
ER
347
348%description router-postfix
349This package provides way of routing notes and emails back to Eventum
350via Postfix.
351
e1bb3563
ER
352The Postfix configuration instructions you can find from
353<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
354
d8cfa9f0
JR
355%description router-postfix -l pl.UTF-8
356Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
995fa554
JB
357przez Postfiksa.
358
d8cfa9f0 359Opis konfiguracji Postfiksa można znaleźć pod adresem
a659c698
JB
360<http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
361
cd719538
ER
362%package irc
363Summary: Eventum IRC Notification Bot
9f49cf47 364Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
cd719538 365Group: Applications/WWW
b79fc4aa 366Requires(post,preun): /sbin/chkconfig
5b165428 367Requires: %{name} = %{version}-%{release}
2f331c68 368Requires: php(sockets)
71f56750 369Requires: php-pear-Net_SmartIRC
e1c0f343 370Requires: rc-scripts >= 0.4.0.18
cd719538
ER
371
372%description irc
373The IRC notification bot is a nice feature for remote teams that want
374to handle issues and want to have a quick and easy way to get simple
375notifications. Right now the bot notifies of the following actions:
376- New Issues
377- Blocked emails
378- Issues that got their assignment list changed
379
380NOTE: You will need to manually edit the bot.php script to set your
381appropriate preferences, like IRC server and channel that the bot
382should join.
383
d8cfa9f0
JR
384%description irc -l pl.UTF-8
385IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
386zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
387uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
388następujących zdarzeniach:
6341f096
JB
389- nowych sprawach
390- zablokowanych listach
d8cfa9f0 391- sprawach, dla których zmieniła się lista powiązań
6341f096 392
d8cfa9f0
JR
393UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
394kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
6341f096 395
abd490e4
ER
396%package cli
397Summary: Eventum command-line interface
9f49cf47 398Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
abd490e4 399Group: Applications/WWW
5b165428 400Requires: %{name}-base = %{version}-%{release}
01d8dfff 401Requires: php(core) >= %{php_min_version}
4a74b463 402Requires: php(phar)
71b01fde 403Requires: php-pear-XML_RPC
abd490e4
ER
404
405%description cli
406The Eventum command-line interface allows you to access most of the
407features of the web interface straight from your command shell.
abd490e4 408
d8cfa9f0
JR
409%description cli -l pl.UTF-8
410Interfejs linii poleceń Eventum pozwala na dostęp do większości
411funkcji interfejsu WWW prosto z linii poleceń powłoki.
958cd5a0 412
5cb2e61d 413%package scm
30689148 414Summary: Eventum SCM integration
9f49cf47 415Summary(pl.UTF-8): Integracja SCM dla Eventum
5cb2e61d 416Group: Applications/WWW
5b165428 417Requires: %{name}-base = %{version}-%{release}
01d8dfff 418Requires: php(core) >= %{php_min_version}
2f331c68 419Requires: php(pcre)
5cb2e61d
ER
420
421%description scm
422This feature allows your software development teams to integrate your
423Source Control Management system with your Issue Tracking System.
424
425The integration is implemented in such a way that it will be forward
426compatible with pretty much any SCM system, such as CVS.
427
0181746f 428For installation see
a392a259 429</eventum/help.php?topic=scm_integration_installation>.
0181746f 430
d8cfa9f0
JR
431%description scm -l pl.UTF-8
432Ten pakiet pozwala zespołom programistów na integrację systemu
433zarządzania źródłami (SCM - Source Control Management) z systemem
434śledzenia spraw.
0181746f 435
d8cfa9f0
JR
436Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
437prawie każdym systemem SCM, jak np. CVS.
0181746f 438
d8cfa9f0 439Szczegóły na temat instalacji można przeczytać pod
a392a259 440</eventum/help.php?topic=scm_integration_installation>.
5cb2e61d 441
1cce3e61
ER
442%package sphinx
443Summary: Eventum Sphinx Search
444Group: Applications/WWW
445Requires: %{name} = %{version}-%{release}
446Requires: crondaemon
447Requires: sphinx
448
449%description sphinx
450Sphinx search integration for Eventum.
451
452This package contains the cron job.
453
bb01d732 454%prep
dc8c226c 455%setup -qn %{name}-%{version}%{?subver:-%{subver}}
5b165428 456
fa6167ba
ER
457mv docs/examples .
458
f1269a43
ER
459# GPL v2
460rm docs/COPYING
461
9487d524 462# bug fixes / features
7a906e31 463#%patch0 -p1
4f627938 464%{?with_order:%patch2 -p1}
7a906e31
ER
465#%patch3 -p0
466#%patch4 -p1
57e65e62 467
7a906e31 468%{?with_order:cp -p %{SOURCE16} htdocs/images}
422dcc8e 469
a6016bab 470#%patch200 -p1
ac27ba92 471
1cce3e61
ER
472# produce default sphinx config
473# must be run before paths.patch
7a906e31 474%if 0
1cce3e61
ER
475cat <<'EOF' > config/config.php
476<?php
477define('APP_SQL_DBTYPE', 'mysql');
478define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
479define('APP_SQL_DBPORT', 3306);
480define('APP_SQL_DBNAME', 'eventum');
481define('APP_SQL_DBUSER', 'mysql');
482define('APP_SQL_DBPASS', '');
483define('APP_TABLE_PREFIX', 'eventum_');
484EOF
485php config/sphinx.conf.php > config/sphinx.conf
486rm -f config/config.php
7a906e31 487%endif
1cce3e61 488
ac27ba92
ER
489# packaging
490%patch100 -p1
7a906e31 491#%patch101 -p1
ac27ba92 492%patch105 -p1
ac27ba92 493%patch107 -p1
0b3b58dd 494
25123ce7 495%{__sed} -i -e "
25123ce7 496s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
ae3e48e6 497" upgrade/{*/,}*.php
c3fd3767 498
5b165428 499# remove backups from patching as we use globs to package files to buildroot
73c437a6 500find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
085e39c0 501
465c3ab7 502%build
ae3e48e6 503%{__make} -C localization
465c3ab7 504
bb01d732
ER
505%install
506rm -rf $RPM_BUILD_ROOT
cfc3bce6 507install -d \
8a37ad9d 508 $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
2b135b34 509 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
c1e74aa1 510 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
685fc383 511 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
89522a33 512 $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
761ae7dd 513 $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
73de38a1 514 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
cfc3bce6 515
4a74b463 516%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
ae3e48e6 517 sysconfdir=%{_webappdir} \
7a906e31 518 localedir=%{_localedir} \
ae3e48e6 519 DESTDIR=$RPM_BUILD_ROOT
da8d6134 520
fa6167ba
ER
521install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
522cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
523
ae3e48e6 524%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
9cdc5027 525
00e339ff
ER
526cp -a vendor $RPM_BUILD_ROOT%{_appdir}
527
f399f1c0 528touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
1b5aae0f 529cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
87ca28ca 530cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
1b5aae0f 531cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
1cce3e61
ER
532
533install -d $RPM_BUILD_ROOT/etc/sphinx
7a906e31 534#cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
858c6f2a 535cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
ae3e48e6 536
1b5aae0f
ER
537cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
538cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
539cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
540cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
1cce3e61 541cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
ae3e48e6 542
1b5aae0f 543cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
ae3e48e6 544
2b135b34 545install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
1b5aae0f 546cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
31dabce6 547
1b5aae0f 548cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
2b135b34 549
410d72c7 550# postfix router
858c6f2a 551install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
a6d2ad69 552
92bc2f5d 553cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
cc613bc9 554
600d96a0 555%find_lang %{name}
c1e74aa1 556
ae3e48e6 557# scm
7a906e31 558cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
ae3e48e6 559
bb01d732
ER
560%clean
561rm -rf $RPM_BUILD_ROOT
562
01b84746
ER
563%pre
564%addusertogroup http %{name}
565
82121306 566%post
08196fe2
ER
567# greate empty ghost files
568for a in cli.log errors.log irc_bot.log login_attempts.log; do
569 if [ ! -f /var/log/%{name}/$a ]; then
2b135b34 570 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
08196fe2
ER
571 fi
572done
573
00358bba
ER
574# run database update if configured
575test -s %{_webappdir}/config.php && \
847270fe
ER
576%{_appdir}/upgrade/update-database.php || :
577
da8d6134
ER
578# nuke Smarty templates cache after upgrade
579rm -f /var/cache/eventum/*.php
580
4a751c1a
ER
581# Restart webserver on upgrade to get .mo translations reloaded.
582# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
114241d7
ER
583%php_webserver_restart
584
82121306
ER
585%preun
586if [ "$1" = "0" ]; then
dfe0f6d6
ER
587 # nuke cache
588 rm -f /var/cache/eventum/*.php 2>/dev/null || :
589fi
cfc3bce6 590
01b84746 591%pre base
1d760108
ER
592%groupadd -P %{name}-base -g 146 %{name}
593%useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
01b84746
ER
594
595%postun base
596if [ "$1" = "0" ]; then
a6d2ad69 597 %userremove %{name}
1f52d1fe 598 %groupremove %{name}
a6d2ad69
ER
599fi
600
94bd779f 601%post setup
8a37ad9d 602chmod 660 %{_webappdir}/{config,private_key}.php
253ca53d 603chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
604
605%postun setup
b4fe195b 606if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
8a37ad9d 607 chmod 640 %{_webappdir}/{config,private_key}.php
253ca53d 608 chown root:http %{_webappdir}/{config,private_key}.php
94bd779f
ER
609fi
610
e1c0f343
ER
611%post irc
612/sbin/chkconfig --add eventum-irc
99bbe3cb 613%service eventum-irc restart "Eventum IRC Bot"
e1c0f343 614
add0e245
ER
615%preun irc
616if [ "$1" = 0 ]; then
617 %service eventum-irc stop
618 /sbin/chkconfig --del eventum-irc
619fi
620
09f58a75 621%triggerin -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 622%webapp_register apache %{_webapp}
1d760108 623
09f58a75 624%triggerun -- apache1 < 1.3.37-3, apache1-base
bdf85dc8 625%webapp_unregister apache %{_webapp}
1d760108 626
87ca28ca 627%triggerin -- apache < 2.2.0, apache-base
bdf85dc8 628%webapp_register httpd %{_webapp}
1d760108 629
87ca28ca 630%triggerun -- apache < 2.2.0, apache-base
bdf85dc8 631%webapp_unregister httpd %{_webapp}
1d760108 632
f399f1c0
ER
633%triggerin -- lighttpd
634%webapp_register lighttpd %{_webapp}
635
636%triggerun -- lighttpd
637%webapp_unregister lighttpd %{_webapp}
638
24cfc386
ER
639%triggerpostun -- %{name} < 3.0.0-0.2
640for f in /etc/cron.d/eventum-*; do
641 # crontabs moved to bin
0ffd10e7 642 %{__sed} -i -e '
24cfc386
ER
643 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
644 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
645 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
646 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
647 ' $f
0ffd10e7 648done
f1269a43 649
600d96a0 650%files -f %{name}.lang
bb01d732 651%defattr(644,root,root,755)
7a906e31 652%doc docs/*
8a37ad9d
ER
653%attr(751,root,root) %dir %{_webappdir}
654%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
655%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
f399f1c0 656%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
e570944f
ER
657%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
658%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
659%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
f399f1c0 660%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
d2e501e8 661
e570944f
ER
662%dir %attr(731,root,http) /var/log/%{name}
663%attr(620,root,http) %ghost /var/log/%{name}/*
3c6aa7a9 664%dir %attr(750,root,root) /var/log/archive/%{name}
8fd047ac 665%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
35f9d6a3 666
7a906e31 667%dir %{_appdir}/bin
7a906e31
ER
668%attr(755,root,root) %{_appdir}/bin/process_all_emails.php
669
ae3e48e6 670%{_appdir}/init.php
cfc3bce6
ER
671%dir %{_appdir}/htdocs
672%{_appdir}/htdocs/*.php
da8d6134 673%{_appdir}/htdocs/*.ico
7bc9b641 674%{_appdir}/htdocs/ajax
cfc3bce6
ER
675%{_appdir}/htdocs/css
676%{_appdir}/htdocs/customer
677%{_appdir}/htdocs/images
678%{_appdir}/htdocs/js
679%{_appdir}/htdocs/manage
7bc9b641 680%{_appdir}/htdocs/misc
cfc3bce6
ER
681%{_appdir}/htdocs/reports
682%{_appdir}/htdocs/rpc
7a906e31 683%{_appdir}/htdocs/components
9748a8c3 684%{_appdir}/templates
847270fe 685
c9165420 686%dir %{_appdir}/upgrade
7a906e31
ER
687%{_appdir}/upgrade/flush_compiled_templates.php
688%{_appdir}/upgrade/*.sql
847270fe 689%attr(755,root,root) %{_appdir}/upgrade/update-database.php
73de38a1 690%attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
7a906e31
ER
691%attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
692%attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
847270fe
ER
693%{_appdir}/upgrade/patches
694
ae3e48e6
ER
695%dir %{_appdir}/lib
696%{_appdir}/lib/eventum
697%{_appdir}/lib/jpgraph
698%exclude %{_appdir}/lib/eventum/class.monitor.php
00e339ff
ER
699
700%{_appdir}/vendor
701
fa6167ba
ER
702%{_examplesdir}/%{name}-%{version}
703
73de38a1 704%{systemdtmpfilesdir}/%{name}.conf
e570944f
ER
705%dir %attr(730,root,http) /var/run/%{name}
706%dir %attr(730,root,http) /var/cache/%{name}
ab983aaa 707
d2e501e8
ER
708%files base
709%defattr(644,root,root,755)
710%attr(751,root,root) %dir %{_sysconfdir}
a392a259 711%dir %{_libdir}
cfc3bce6 712%dir %{_appdir}
098cbb72 713%dir /var/lib/%{name}
89522a33 714# saved mail copies
e570944f
ER
715%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
716%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
717%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
d2e501e8 718
ab983aaa
ER
719%files setup
720%defattr(644,root,root,755)
cfc3bce6 721%{_appdir}/htdocs/setup
0da8e1f2
ER
722
723%files mail-queue
724%defattr(644,root,root,755)
7a906e31 725%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
ea084bcb
ER
726%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
727
728%files mail-download
729%defattr(644,root,root,755)
7a906e31 730%attr(755,root,root) %{_appdir}/bin/download_emails.php
ea084bcb 731%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
5cb2e61d 732
cd719538
ER
733%files reminder
734%defattr(644,root,root,755)
7a906e31 735%attr(755,root,root) %{_appdir}/bin/check_reminders.php
cd719538
ER
736%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
737
738%files monitor
739%defattr(644,root,root,755)
ae3e48e6 740%{_appdir}/lib/eventum/class.monitor.php
7a906e31 741%attr(755,root,root) %{_appdir}/bin/monitor.php
cd719538
ER
742%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
743
5b165428
ER
744%files route-drafts
745%defattr(644,root,root,755)
7a906e31 746%attr(755,root,root) %{_appdir}/bin/route_drafts.php
5b165428 747
cd719538
ER
748%files route-emails
749%defattr(644,root,root,755)
7a906e31 750%attr(755,root,root) %{_appdir}/bin/route_emails.php
cd719538
ER
751
752%files route-notes
753%defattr(644,root,root,755)
7a906e31 754%attr(755,root,root) %{_appdir}/bin/route_notes.php
cd719538 755
a6d2ad69
ER
756%files router-postfix
757%defattr(644,root,root,755)
410d72c7 758%attr(755,root,root) %{_libdir}/router-postfix
a6d2ad69 759
cd719538
ER
760%files irc
761%defattr(644,root,root,755)
77b3db3b 762%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
01b84746 763%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
ae3e48e6 764%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
cd719538
ER
765%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
766
abd490e4
ER
767%files cli
768%defattr(644,root,root,755)
ae3e48e6 769%doc cli/eventumrc
4a74b463 770%attr(755,root,root) %{_bindir}/%{name}
abd490e4 771
5cb2e61d
ER
772%files scm
773%defattr(644,root,root,755)
ca6b8520 774%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
ae3e48e6
ER
775%attr(755,root,root) %{_sbindir}/eventum-cvs-hook
776%attr(755,root,root) %{_sbindir}/eventum-svn-hook
1cce3e61
ER
777
778%files sphinx
779%defattr(644,root,root,755)
780%{_webappdir}/sphinx.conf.php
7a906e31 781#%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
1cce3e61 782%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.360741 seconds and 4 git commands to generate.