]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- up to 3.4.3
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c 1# TODO:
0f3fad68 2# - extend libx32 patch to work also on 64-bit arch
d1b2e54c
JB
3# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
4# (and default non-verbose makefiles are hiding it!)
5# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
6# (is there any standard way???)
ccca321d
KK
7#
8# Conditional build:
b563f9dc
JB
9%bcond_with bootstrap # use internal versions of some libraries
10%bcond_without gui # don't build gui package
63b5fdd8 11%bcond_with tests # perform "make test"
90b41c6c 12%bcond_without doc # don't build documentation
77f8acdd 13
efafbc62 14Summary: Cross-platform, open-source make system
ac3ea35a 15Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 16Name: cmake
834c9659
JR
17Version: 3.4.3
18Release: 1
efafbc62 19License: BSD
72a696fa 20Group: Development/Building
834c9659
JR
21Source0: http://www.cmake.org/files/v3.4/%{name}-%{version}.tar.gz
22# Source0-md5: 4cb3ff35b2472aae70f542116d616e63
6342daf8 23Patch0: %{name}-lib64.patch
834c9659
JR
24Patch1: %{name}-libx32.patch
25Patch2: %{name}-helpers.patch
26Patch3: %{name}-findruby.patch
27Patch4: %{name}-findruby2.patch
a315a797 28URL: http://www.cmake.org/
33042d59 29%{?with_gui:BuildRequires: QtGui-devel}
466fdfa1 30BuildRequires: jsoncpp-devel >= 1.6.2-2
fef12180 31BuildRequires: libarchive-devel
ece9e155 32BuildRequires: libstdc++-devel
59917d1a 33BuildRequires: ncurses-devel > 5.9-3
0278e558
BS
34%{?with_gui:BuildRequires: qt5-build}
35%{?with_gui:BuildRequires: qt5-qmake}
ece9e155 36BuildRequires: rpmbuild(macros) >= 1.167
90b41c6c 37%{?with_doc:BuildRequires: sphinx-pdg}
ab02ad6a 38%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 39Requires: filesystem >= 3.0-52
efafbc62 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
41
42%description
efafbc62
AG
43CMake is used to control the software compilation process using simple
44platform and compiler independent configuration files. CMake generates
45native makefiles and workspaces that can be used in the compiler
46environment of your choice. CMake is quite sophisticated: it is
47possible to support complex environments requiring system
48configuration, pre-processor generation, code generation, and template
49instantiation.
3fcbc09a 50
520c9eb8
JR
51%description -l pl.UTF-8
52CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 53użyciu prostych plików konfiguracyjnych niezależnych od platformy i
54kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 55których można używać w wybranym środowisku kompilatora. CMake jest
59787775 56dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 57konfiguracji systemu, generowanie preprocesora, generowanie kodu i
58dziedziczenie szablonów.
33042d59 59
fe46a853
JB
60%package doc-html
61Summary: CMake documentation in HTML format
62Summary(pl.UTF-8): Dokumentacja do pakietu CMake w formacie HTML
63Group: Documentation
64
65%description doc-html
66CMake documentation in HTML format.
67
68%description doc-html -l pl.UTF-8
69Dokumentacja do pakietu CMake w formacie HTML.
70
33042d59 71%package gui
b563f9dc
JB
72Summary: Qt GUI for CMake
73Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
74Group: Development/Tools
75Requires: %{name} = %{version}-%{release}
76
b563f9dc
JB
77%description gui
78This package contains the Qt based GUI for CMake.
79
80%description gui -l pl.UTF-8
81Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
82CMake.
72a696fa 83
9ec4f08d 84%package emacs
69d19c08
JB
85Summary: Emacs mode for cmake files
86Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
87Group: Development/Tools
88
89%description emacs
69d19c08
JB
90Emacs mode for cmake files.
91
92%description emacs -l pl.UTF-8
93Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
94
95%package -n bash-completion-%{name}
96Summary: bash-completion for cmake
69d19c08 97Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 98Group: Applications/Shells
69d19c08 99Requires: %{name} = %{version}-%{release}
a9b1845f 100Requires: bash-completion >= 2.0
6465d90a
ER
101%if "%{_rpmversion}" >= "5"
102BuildArch: noarch
103%endif
9ec4f08d
KK
104
105%description -n bash-completion-%{name}
69d19c08
JB
106bash-completion for cmake.
107
108%description -n bash-completion-%{name} -l pl.UTF-8
109Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 110
3fcbc09a 111%prep
923851a2 112%setup -q
286b1479 113%if "%{_lib}" == "lib64"
6342daf8 114%patch0 -p1
286b1479 115%endif
834c9659 116%if "%{_lib}" == "libx32"
9ec4f08d 117%patch1 -p1
834c9659 118%endif
fe667d6f 119%patch2 -p1
04706b61 120%patch3 -p1
834c9659 121%patch4 -p1
3fcbc09a 122
ece9e155 123cat > "init.cmake" <<EOF
286b1479 124SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
125SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
126SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
127EOF
128
b343cdb1
JR
129# cleanup backups after patching, modules are copied as-is
130find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
131
3fcbc09a 132%build
ece9e155
KK
133export CC="%{__cc}"
134export CXX="%{__cxx}"
135export CFLAGS="%{rpmcflags}"
136export CXXFLAGS="%{rpmcxxflags}"
ccca321d 137export LDFLAGS="%{rpmldflags}"
923851a2
AG
138./bootstrap \
139 --prefix=%{_prefix} \
140 --mandir=/share/man \
141 --datadir=/share/cmake \
ece9e155 142 --init=init.cmake \
c342f103 143 %{!?with_bootstrap:--system-libs} \
33042d59 144 %{?with_gui:--qt-gui} \
466fdfa1 145 --qt-qmake=%{_bindir}/qmake-qt4 \
90b41c6c
JR
146 %{?with_doc:--sphinx-html} \
147 %{?with_doc:--sphinx-man} \
923851a2
AG
148 --verbose
149
28f0bd6c 150%{__make} VERBOSE=1
3fcbc09a 151
1fbe3ed6
AM
152%{?with_tests:%{__make} test}
153
3fcbc09a 154%install
efafbc62 155rm -rf $RPM_BUILD_ROOT
72a696fa
JB
156%{__make} install \
157 DESTDIR=$RPM_BUILD_ROOT
158
75cb386f 159%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%files
efafbc62 165%defattr(644,root,root,755)
fe46a853 166%doc Copyright.txt README.rst *.gif
72a696fa
JB
167%attr(755,root,root) %{_bindir}/ccmake
168%attr(755,root,root) %{_bindir}/cmake
08b6790a 169%attr(755,root,root) %{_bindir}/cpack
72a696fa 170%attr(755,root,root) %{_bindir}/ctest
90b41c6c 171%if %{with doc}
08bb5e07
JB
172%{_mandir}/man1/ccmake.1*
173%{_mandir}/man1/cmake.1*
08bb5e07
JB
174%{_mandir}/man1/cpack.1*
175%{_mandir}/man1/ctest.1*
fe46a853
JB
176%{_mandir}/man7/cmake-buildsystem.7*
177%{_mandir}/man7/cmake-commands.7*
cda7a827 178%{_mandir}/man7/cmake-compile-features.7*
fe46a853
JB
179%{_mandir}/man7/cmake-developer.7*
180%{_mandir}/man7/cmake-generator-expressions.7*
181%{_mandir}/man7/cmake-generators.7*
182%{_mandir}/man7/cmake-language.7*
183%{_mandir}/man7/cmake-modules.7*
184%{_mandir}/man7/cmake-packages.7*
185%{_mandir}/man7/cmake-policies.7*
186%{_mandir}/man7/cmake-properties.7*
187%{_mandir}/man7/cmake-qt.7*
188%{_mandir}/man7/cmake-toolchains.7*
189%{_mandir}/man7/cmake-variables.7*
0278e558 190%{_datadir}/cmake/Help
90b41c6c 191%endif
b24a2e64
JB
192# top cmake/Modules dirs belong to filesystem
193%{_datadir}/cmake/Modules/.NoDartCoverage
194%{_datadir}/cmake/Modules/*
195%{_datadir}/cmake/Templates
f13d1e41 196%{_datadir}/cmake/editors
b24a2e64 197%{_datadir}/cmake/include
09f5d631 198%{_aclocaldir}/cmake.m4
33042d59 199
90b41c6c 200%if %{with doc}
fe46a853
JB
201%files doc-html
202%defattr(644,root,root,755)
203%doc Utilities/Sphinx/html/*
90b41c6c 204%endif
fe46a853 205
1a3a9dcd 206%if %{with gui}
33042d59
KK
207%files gui
208%defattr(644,root,root,755)
209%attr(755,root,root) %{_bindir}/cmake-gui
210%{_datadir}/mime/packages/cmakecache.xml
211%{_desktopdir}/CMake.desktop
466fdfa1
AM
212%{_iconsdir}/hicolor/128x128/apps/CMakeSetup.png
213%{_iconsdir}/hicolor/32x32/apps/CMakeSetup.png
08bb5e07 214%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 215%endif
9ec4f08d
KK
216
217%files emacs
218%defattr(644,root,root,755)
219%{_datadir}/emacs/site-lisp/cmake-mode.el
220
221%files -n bash-completion-%{name}
222%defattr(644,root,root,755)
466fdfa1
AM
223%{bash_compdir}/cmake
224%{bash_compdir}/cpack
225%{bash_compdir}/ctest
This page took 0.061327 seconds and 4 git commands to generate.