]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- updated to 2.8.11.2
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
da5de91d
JB
15Version: 2.8.11.2
16Release: 1
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
28f0bd6c 19Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
da5de91d 20# Source0-md5: 6f5d7b8e7534a5d9e1a7664ba63cf882
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
fe667d6f 23Patch2: cmake-findruby.patch
53357b6b 24Patch3: cmake-git.patch
a315a797 25URL: http://www.cmake.org/
33042d59 26%{?with_gui:BuildRequires: QtGui-devel}
fef12180 27BuildRequires: libarchive-devel
ece9e155 28BuildRequires: libstdc++-devel
59917d1a 29BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
30%{?with_gui:BuildRequires: qt4-build}
31%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 32BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 33%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 34Requires: filesystem >= 3.0-52
efafbc62 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
36
37%description
efafbc62
AG
38CMake is used to control the software compilation process using simple
39platform and compiler independent configuration files. CMake generates
40native makefiles and workspaces that can be used in the compiler
41environment of your choice. CMake is quite sophisticated: it is
42possible to support complex environments requiring system
43configuration, pre-processor generation, code generation, and template
44instantiation.
3fcbc09a 45
520c9eb8
JR
46%description -l pl.UTF-8
47CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 48użyciu prostych plików konfiguracyjnych niezależnych od platformy i
49kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 50których można używać w wybranym środowisku kompilatora. CMake jest
59787775 51dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 52konfiguracji systemu, generowanie preprocesora, generowanie kodu i
53dziedziczenie szablonów.
33042d59
KK
54
55%package gui
b563f9dc
JB
56Summary: Qt GUI for CMake
57Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
58Group: Development/Tools
59Requires: %{name} = %{version}-%{release}
60
b563f9dc
JB
61%description gui
62This package contains the Qt based GUI for CMake.
63
64%description gui -l pl.UTF-8
65Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
66CMake.
72a696fa 67
9ec4f08d 68%package emacs
69d19c08
JB
69Summary: Emacs mode for cmake files
70Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
71Group: Development/Tools
72
73%description emacs
69d19c08
JB
74Emacs mode for cmake files.
75
76%description emacs -l pl.UTF-8
77Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
78
79%package -n bash-completion-%{name}
80Summary: bash-completion for cmake
69d19c08 81Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 82Group: Applications/Shells
69d19c08 83Requires: %{name} = %{version}-%{release}
9ec4f08d
KK
84
85%description -n bash-completion-%{name}
69d19c08
JB
86bash-completion for cmake.
87
88%description -n bash-completion-%{name} -l pl.UTF-8
89Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 90
3fcbc09a 91%prep
923851a2 92%setup -q
286b1479 93%if "%{_lib}" == "lib64"
6342daf8 94%patch0 -p1
286b1479 95%endif
9ec4f08d 96%patch1 -p1
fe667d6f 97%patch2 -p1
53357b6b 98%patch3 -p1
3fcbc09a 99
ece9e155 100cat > "init.cmake" <<EOF
286b1479 101SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
102SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
103SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
104EOF
105
3fcbc09a 106%build
ece9e155
KK
107export CC="%{__cc}"
108export CXX="%{__cxx}"
109export CFLAGS="%{rpmcflags}"
110export CXXFLAGS="%{rpmcxxflags}"
ccca321d 111export LDFLAGS="%{rpmldflags}"
923851a2
AG
112./bootstrap \
113 --prefix=%{_prefix} \
114 --mandir=/share/man \
115 --datadir=/share/cmake \
ece9e155 116 --init=init.cmake \
c342f103 117 %{!?with_bootstrap:--system-libs} \
33042d59 118 %{?with_gui:--qt-gui} \
08bb5e07 119 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
120 --verbose
121
28f0bd6c 122%{__make} VERBOSE=1
3fcbc09a 123
1fbe3ed6
AM
124%{?with_tests:%{__make} test}
125
3fcbc09a 126%install
efafbc62 127rm -rf $RPM_BUILD_ROOT
72a696fa
JB
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
130
75cb386f 131%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files
efafbc62 137%defattr(644,root,root,755)
51ed65c6 138%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
139%attr(755,root,root) %{_bindir}/ccmake
140%attr(755,root,root) %{_bindir}/cmake
08b6790a 141%attr(755,root,root) %{_bindir}/cpack
72a696fa 142%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
143%{_mandir}/man1/ccmake.1*
144%{_mandir}/man1/cmake.1*
145%{_mandir}/man1/cmakecommands.1*
146%{_mandir}/man1/cmakecompat.1*
147%{_mandir}/man1/cmakemodules.1*
148%{_mandir}/man1/cmakepolicies.1*
149%{_mandir}/man1/cmakeprops.1*
150%{_mandir}/man1/cmakevars.1*
151%{_mandir}/man1/cpack.1*
152%{_mandir}/man1/ctest.1*
b24a2e64
JB
153# top cmake/Modules dirs belong to filesystem
154%{_datadir}/cmake/Modules/.NoDartCoverage
155%{_datadir}/cmake/Modules/*
156%{_datadir}/cmake/Templates
f13d1e41 157%{_datadir}/cmake/editors
b24a2e64 158%{_datadir}/cmake/include
09f5d631 159%{_aclocaldir}/cmake.m4
33042d59 160
1a3a9dcd 161%if %{with gui}
33042d59
KK
162%files gui
163%defattr(644,root,root,755)
164%attr(755,root,root) %{_bindir}/cmake-gui
165%{_datadir}/mime/packages/cmakecache.xml
166%{_desktopdir}/CMake.desktop
ca760f29 167%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 168%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 169%endif
9ec4f08d
KK
170
171%files emacs
172%defattr(644,root,root,755)
173%{_datadir}/emacs/site-lisp/cmake-mode.el
174
175%files -n bash-completion-%{name}
176%defattr(644,root,root,755)
69d19c08
JB
177/etc/bash_completion.d/cmake
178/etc/bash_completion.d/cpack
179/etc/bash_completion.d/ctest
This page took 0.06109 seconds and 4 git commands to generate.