]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- gui files only --with gui
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
ccca321d 10#
efafbc62 11Summary: Cross-platform, open-source make system
ac3ea35a 12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 13Name: cmake
28f0bd6c 14Version: 2.8.0
9aa6e193 15Release: 2
efafbc62 16License: BSD
72a696fa 17Group: Development/Building
28f0bd6c
KK
18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
19# Source0-md5: 3b3679b8a6afaedc38a8c15dd7ff4fcf
6342daf8 20Patch0: %{name}-lib64.patch
a315a797 21URL: http://www.cmake.org/
33042d59 22%{?with_gui:BuildRequires: QtGui-devel}
ece9e155
KK
23BuildRequires: libstdc++-devel
24BuildRequires: ncurses-devel
33042d59
KK
25%{?with_gui:BuildRequires: qt4-build}
26%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 27BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 28%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
efafbc62 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
30
31%description
efafbc62
AG
32CMake is used to control the software compilation process using simple
33platform and compiler independent configuration files. CMake generates
34native makefiles and workspaces that can be used in the compiler
35environment of your choice. CMake is quite sophisticated: it is
36possible to support complex environments requiring system
37configuration, pre-processor generation, code generation, and template
38instantiation.
3fcbc09a 39
520c9eb8
JR
40%description -l pl.UTF-8
41CMake służy do sterowania procesem kompilacji oprogramowania przy
485d9a7a
KK
42użyciu prostych plików konfiguracyjnych niezależnych od platformy
43i kompilatora. CMake generuje natywne pliki makefile i workspace,
44których można używać w wybranym środowisku kompilatora. CMake jest
45dość przemyślany: może obsłużyć złożone środowiska wymagające
46konfiguracji systemu, generowanie preprocesora, generowanie kodu
47i dziedziczenie szablonów.
33042d59
KK
48
49%package gui
b563f9dc
JB
50Summary: Qt GUI for CMake
51Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
52Group: Development/Tools
53Requires: %{name} = %{version}-%{release}
54
b563f9dc
JB
55%description gui
56This package contains the Qt based GUI for CMake.
57
58%description gui -l pl.UTF-8
59Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
60CMake.
72a696fa 61
3fcbc09a 62%prep
923851a2 63%setup -q
286b1479 64%if "%{_lib}" == "lib64"
6342daf8 65%patch0 -p1
286b1479 66%endif
3fcbc09a 67
ece9e155 68cat > "init.cmake" <<EOF
286b1479 69SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
ece9e155
KK
70EOF
71
3fcbc09a 72%build
ece9e155
KK
73export CC="%{__cc}"
74export CXX="%{__cxx}"
75export CFLAGS="%{rpmcflags}"
76export CXXFLAGS="%{rpmcxxflags}"
ccca321d 77export LDFLAGS="%{rpmldflags}"
923851a2
AG
78./bootstrap \
79 --prefix=%{_prefix} \
80 --mandir=/share/man \
81 --datadir=/share/cmake \
ece9e155 82 --init=init.cmake \
c342f103 83 %{!?with_bootstrap:--system-libs} \
33042d59 84 %{?with_gui:--qt-gui} \
923851a2
AG
85 --verbose
86
28f0bd6c 87%{__make} VERBOSE=1
3fcbc09a
AG
88
89%install
efafbc62 90rm -rf $RPM_BUILD_ROOT
9ecf094d 91install -d $RPM_BUILD_ROOT%{_libdir}/cmake
72a696fa
JB
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
c4bbee29 96rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
efafbc62 102%defattr(644,root,root,755)
51ed65c6 103%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
104%attr(755,root,root) %{_bindir}/ccmake
105%attr(755,root,root) %{_bindir}/cmake
08b6790a 106%attr(755,root,root) %{_bindir}/cpack
72a696fa
JB
107%attr(755,root,root) %{_bindir}/ctest
108%{_mandir}/man1/*.1*
923851a2 109%{_datadir}/cmake
1941b22e 110%dir %{_libdir}/cmake
33042d59 111
1a3a9dcd 112%if %{with gui}
33042d59
KK
113%files gui
114%defattr(644,root,root,755)
115%attr(755,root,root) %{_bindir}/cmake-gui
116%{_datadir}/mime/packages/cmakecache.xml
117%{_desktopdir}/CMake.desktop
118%{_pixmapsdir}/CMakeSetup.png
1a3a9dcd 119%endif
This page took 0.071132 seconds and 4 git commands to generate.