]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- rel 3; look for python 3.5 and 3.4, too
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
aae1b476 15Version: 2.8.12.2
1269f267 16Release: 3
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
28f0bd6c 19Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
aae1b476 20# Source0-md5: 17c6513483d23590cbce6957ec6d1e66
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
de784c58
JB
23Patch2: %{name}-findruby.patch
24Patch3: %{name}-tests.patch
0ea0e364 25Patch4: %{name}-freetype2.patch
a048aac3 26Patch5: %{name}-findruby2.patch
1269f267 27Patch6: %{name}-findpython.patch
a315a797 28URL: http://www.cmake.org/
33042d59 29%{?with_gui:BuildRequires: QtGui-devel}
fef12180 30BuildRequires: libarchive-devel
ece9e155 31BuildRequires: libstdc++-devel
59917d1a 32BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
33%{?with_gui:BuildRequires: qt4-build}
34%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 35BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 36%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 37Requires: filesystem >= 3.0-52
efafbc62 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
39
40%description
efafbc62
AG
41CMake is used to control the software compilation process using simple
42platform and compiler independent configuration files. CMake generates
43native makefiles and workspaces that can be used in the compiler
44environment of your choice. CMake is quite sophisticated: it is
45possible to support complex environments requiring system
46configuration, pre-processor generation, code generation, and template
47instantiation.
3fcbc09a 48
520c9eb8
JR
49%description -l pl.UTF-8
50CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 51użyciu prostych plików konfiguracyjnych niezależnych od platformy i
52kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 53których można używać w wybranym środowisku kompilatora. CMake jest
59787775 54dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 55konfiguracji systemu, generowanie preprocesora, generowanie kodu i
56dziedziczenie szablonów.
33042d59
KK
57
58%package gui
b563f9dc
JB
59Summary: Qt GUI for CMake
60Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
61Group: Development/Tools
62Requires: %{name} = %{version}-%{release}
63
b563f9dc
JB
64%description gui
65This package contains the Qt based GUI for CMake.
66
67%description gui -l pl.UTF-8
68Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
69CMake.
72a696fa 70
9ec4f08d 71%package emacs
69d19c08
JB
72Summary: Emacs mode for cmake files
73Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
74Group: Development/Tools
75
76%description emacs
69d19c08
JB
77Emacs mode for cmake files.
78
79%description emacs -l pl.UTF-8
80Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
81
82%package -n bash-completion-%{name}
83Summary: bash-completion for cmake
69d19c08 84Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 85Group: Applications/Shells
69d19c08 86Requires: %{name} = %{version}-%{release}
a9b1845f 87Requires: bash-completion >= 2.0
6465d90a
ER
88%if "%{_rpmversion}" >= "5"
89BuildArch: noarch
90%endif
9ec4f08d
KK
91
92%description -n bash-completion-%{name}
69d19c08
JB
93bash-completion for cmake.
94
95%description -n bash-completion-%{name} -l pl.UTF-8
96Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 97
3fcbc09a 98%prep
923851a2 99%setup -q
286b1479 100%if "%{_lib}" == "lib64"
6342daf8 101%patch0 -p1
286b1479 102%endif
9ec4f08d 103%patch1 -p1
fe667d6f 104%patch2 -p1
de784c58 105%patch3 -p1
0ea0e364 106%patch4 -p1
a048aac3 107%patch5 -p1
1269f267 108%patch6 -p1
3fcbc09a 109
ece9e155 110cat > "init.cmake" <<EOF
286b1479 111SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
112SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
113SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
114EOF
115
b343cdb1
JR
116# cleanup backups after patching, modules are copied as-is
117find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
118
3fcbc09a 119%build
ece9e155
KK
120export CC="%{__cc}"
121export CXX="%{__cxx}"
122export CFLAGS="%{rpmcflags}"
123export CXXFLAGS="%{rpmcxxflags}"
ccca321d 124export LDFLAGS="%{rpmldflags}"
923851a2
AG
125./bootstrap \
126 --prefix=%{_prefix} \
127 --mandir=/share/man \
128 --datadir=/share/cmake \
ece9e155 129 --init=init.cmake \
c342f103 130 %{!?with_bootstrap:--system-libs} \
33042d59 131 %{?with_gui:--qt-gui} \
08bb5e07 132 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
133 --verbose
134
28f0bd6c 135%{__make} VERBOSE=1
3fcbc09a 136
1fbe3ed6
AM
137%{?with_tests:%{__make} test}
138
3fcbc09a 139%install
efafbc62 140rm -rf $RPM_BUILD_ROOT
72a696fa
JB
141%{__make} install \
142 DESTDIR=$RPM_BUILD_ROOT
143
75cb386f 144%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%files
efafbc62 150%defattr(644,root,root,755)
51ed65c6 151%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
152%attr(755,root,root) %{_bindir}/ccmake
153%attr(755,root,root) %{_bindir}/cmake
08b6790a 154%attr(755,root,root) %{_bindir}/cpack
72a696fa 155%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
156%{_mandir}/man1/ccmake.1*
157%{_mandir}/man1/cmake.1*
158%{_mandir}/man1/cmakecommands.1*
159%{_mandir}/man1/cmakecompat.1*
160%{_mandir}/man1/cmakemodules.1*
161%{_mandir}/man1/cmakepolicies.1*
162%{_mandir}/man1/cmakeprops.1*
163%{_mandir}/man1/cmakevars.1*
164%{_mandir}/man1/cpack.1*
165%{_mandir}/man1/ctest.1*
b24a2e64
JB
166# top cmake/Modules dirs belong to filesystem
167%{_datadir}/cmake/Modules/.NoDartCoverage
168%{_datadir}/cmake/Modules/*
169%{_datadir}/cmake/Templates
f13d1e41 170%{_datadir}/cmake/editors
b24a2e64 171%{_datadir}/cmake/include
09f5d631 172%{_aclocaldir}/cmake.m4
33042d59 173
1a3a9dcd 174%if %{with gui}
33042d59
KK
175%files gui
176%defattr(644,root,root,755)
177%attr(755,root,root) %{_bindir}/cmake-gui
178%{_datadir}/mime/packages/cmakecache.xml
179%{_desktopdir}/CMake.desktop
ca760f29 180%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 181%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 182%endif
9ec4f08d
KK
183
184%files emacs
185%defattr(644,root,root,755)
186%{_datadir}/emacs/site-lisp/cmake-mode.el
187
188%files -n bash-completion-%{name}
189%defattr(644,root,root,755)
a9b1845f
JB
190%{_datadir}/bash-completion/completions/cmake
191%{_datadir}/bash-completion/completions/cpack
192%{_datadir}/bash-completion/completions/ctest
This page took 0.067163 seconds and 4 git commands to generate.