]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- added freetype2 patch (fixes freetype 2.5.1 detection)
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
e3d2f452 15Version: 2.8.12.1
0ea0e364 16Release: 2
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
28f0bd6c 19Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
e3d2f452 20# Source0-md5: 9d38cd4e2c94c3cea97d0e2924814acc
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
de784c58
JB
23Patch2: %{name}-findruby.patch
24Patch3: %{name}-tests.patch
0ea0e364 25Patch4: %{name}-freetype2.patch
a315a797 26URL: http://www.cmake.org/
33042d59 27%{?with_gui:BuildRequires: QtGui-devel}
fef12180 28BuildRequires: libarchive-devel
ece9e155 29BuildRequires: libstdc++-devel
59917d1a 30BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
31%{?with_gui:BuildRequires: qt4-build}
32%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 33BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 34%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 35Requires: filesystem >= 3.0-52
efafbc62 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
37
38%description
efafbc62
AG
39CMake is used to control the software compilation process using simple
40platform and compiler independent configuration files. CMake generates
41native makefiles and workspaces that can be used in the compiler
42environment of your choice. CMake is quite sophisticated: it is
43possible to support complex environments requiring system
44configuration, pre-processor generation, code generation, and template
45instantiation.
3fcbc09a 46
520c9eb8
JR
47%description -l pl.UTF-8
48CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 49użyciu prostych plików konfiguracyjnych niezależnych od platformy i
50kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 51których można używać w wybranym środowisku kompilatora. CMake jest
59787775 52dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 53konfiguracji systemu, generowanie preprocesora, generowanie kodu i
54dziedziczenie szablonów.
33042d59
KK
55
56%package gui
b563f9dc
JB
57Summary: Qt GUI for CMake
58Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
59Group: Development/Tools
60Requires: %{name} = %{version}-%{release}
61
b563f9dc
JB
62%description gui
63This package contains the Qt based GUI for CMake.
64
65%description gui -l pl.UTF-8
66Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
67CMake.
72a696fa 68
9ec4f08d 69%package emacs
69d19c08
JB
70Summary: Emacs mode for cmake files
71Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
72Group: Development/Tools
73
74%description emacs
69d19c08
JB
75Emacs mode for cmake files.
76
77%description emacs -l pl.UTF-8
78Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
79
80%package -n bash-completion-%{name}
81Summary: bash-completion for cmake
69d19c08 82Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 83Group: Applications/Shells
69d19c08 84Requires: %{name} = %{version}-%{release}
a9b1845f 85Requires: bash-completion >= 2.0
9ec4f08d
KK
86
87%description -n bash-completion-%{name}
69d19c08
JB
88bash-completion for cmake.
89
90%description -n bash-completion-%{name} -l pl.UTF-8
91Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 92
3fcbc09a 93%prep
923851a2 94%setup -q
286b1479 95%if "%{_lib}" == "lib64"
6342daf8 96%patch0 -p1
286b1479 97%endif
9ec4f08d 98%patch1 -p1
fe667d6f 99%patch2 -p1
de784c58 100%patch3 -p1
0ea0e364 101%patch4 -p1
3fcbc09a 102
ece9e155 103cat > "init.cmake" <<EOF
286b1479 104SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
105SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
106SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
107EOF
108
3fcbc09a 109%build
ece9e155
KK
110export CC="%{__cc}"
111export CXX="%{__cxx}"
112export CFLAGS="%{rpmcflags}"
113export CXXFLAGS="%{rpmcxxflags}"
ccca321d 114export LDFLAGS="%{rpmldflags}"
923851a2
AG
115./bootstrap \
116 --prefix=%{_prefix} \
117 --mandir=/share/man \
118 --datadir=/share/cmake \
ece9e155 119 --init=init.cmake \
c342f103 120 %{!?with_bootstrap:--system-libs} \
33042d59 121 %{?with_gui:--qt-gui} \
08bb5e07 122 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
123 --verbose
124
28f0bd6c 125%{__make} VERBOSE=1
3fcbc09a 126
1fbe3ed6
AM
127%{?with_tests:%{__make} test}
128
3fcbc09a 129%install
efafbc62 130rm -rf $RPM_BUILD_ROOT
72a696fa
JB
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT
133
75cb386f 134%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
efafbc62 140%defattr(644,root,root,755)
51ed65c6 141%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
142%attr(755,root,root) %{_bindir}/ccmake
143%attr(755,root,root) %{_bindir}/cmake
08b6790a 144%attr(755,root,root) %{_bindir}/cpack
72a696fa 145%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
146%{_mandir}/man1/ccmake.1*
147%{_mandir}/man1/cmake.1*
148%{_mandir}/man1/cmakecommands.1*
149%{_mandir}/man1/cmakecompat.1*
150%{_mandir}/man1/cmakemodules.1*
151%{_mandir}/man1/cmakepolicies.1*
152%{_mandir}/man1/cmakeprops.1*
153%{_mandir}/man1/cmakevars.1*
154%{_mandir}/man1/cpack.1*
155%{_mandir}/man1/ctest.1*
b24a2e64
JB
156# top cmake/Modules dirs belong to filesystem
157%{_datadir}/cmake/Modules/.NoDartCoverage
158%{_datadir}/cmake/Modules/*
159%{_datadir}/cmake/Templates
f13d1e41 160%{_datadir}/cmake/editors
b24a2e64 161%{_datadir}/cmake/include
09f5d631 162%{_aclocaldir}/cmake.m4
33042d59 163
1a3a9dcd 164%if %{with gui}
33042d59
KK
165%files gui
166%defattr(644,root,root,755)
167%attr(755,root,root) %{_bindir}/cmake-gui
168%{_datadir}/mime/packages/cmakecache.xml
169%{_desktopdir}/CMake.desktop
ca760f29 170%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 171%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 172%endif
9ec4f08d
KK
173
174%files emacs
175%defattr(644,root,root,755)
176%{_datadir}/emacs/site-lisp/cmake-mode.el
177
178%files -n bash-completion-%{name}
179%defattr(644,root,root,755)
a9b1845f
JB
180%{_datadir}/bash-completion/completions/cmake
181%{_datadir}/bash-completion/completions/cpack
182%{_datadir}/bash-completion/completions/ctest
This page took 0.10438 seconds and 4 git commands to generate.