]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- added tests patch (fixes some curl-related failures; a few still exist, probably...
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
e3d2f452 15Version: 2.8.12.1
da5de91d 16Release: 1
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
28f0bd6c 19Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
e3d2f452 20# Source0-md5: 9d38cd4e2c94c3cea97d0e2924814acc
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
de784c58
JB
23Patch2: %{name}-findruby.patch
24Patch3: %{name}-tests.patch
a315a797 25URL: http://www.cmake.org/
33042d59 26%{?with_gui:BuildRequires: QtGui-devel}
fef12180 27BuildRequires: libarchive-devel
ece9e155 28BuildRequires: libstdc++-devel
59917d1a 29BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
30%{?with_gui:BuildRequires: qt4-build}
31%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 32BuildRequires: rpmbuild(macros) >= 1.167
ab02ad6a 33%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 34Requires: filesystem >= 3.0-52
efafbc62 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
36
37%description
efafbc62
AG
38CMake is used to control the software compilation process using simple
39platform and compiler independent configuration files. CMake generates
40native makefiles and workspaces that can be used in the compiler
41environment of your choice. CMake is quite sophisticated: it is
42possible to support complex environments requiring system
43configuration, pre-processor generation, code generation, and template
44instantiation.
3fcbc09a 45
520c9eb8
JR
46%description -l pl.UTF-8
47CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 48użyciu prostych plików konfiguracyjnych niezależnych od platformy i
49kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 50których można używać w wybranym środowisku kompilatora. CMake jest
59787775 51dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 52konfiguracji systemu, generowanie preprocesora, generowanie kodu i
53dziedziczenie szablonów.
33042d59
KK
54
55%package gui
b563f9dc
JB
56Summary: Qt GUI for CMake
57Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
58Group: Development/Tools
59Requires: %{name} = %{version}-%{release}
60
b563f9dc
JB
61%description gui
62This package contains the Qt based GUI for CMake.
63
64%description gui -l pl.UTF-8
65Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
66CMake.
72a696fa 67
9ec4f08d 68%package emacs
69d19c08
JB
69Summary: Emacs mode for cmake files
70Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
71Group: Development/Tools
72
73%description emacs
69d19c08
JB
74Emacs mode for cmake files.
75
76%description emacs -l pl.UTF-8
77Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
78
79%package -n bash-completion-%{name}
80Summary: bash-completion for cmake
69d19c08 81Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 82Group: Applications/Shells
69d19c08 83Requires: %{name} = %{version}-%{release}
a9b1845f 84Requires: bash-completion >= 2.0
9ec4f08d
KK
85
86%description -n bash-completion-%{name}
69d19c08
JB
87bash-completion for cmake.
88
89%description -n bash-completion-%{name} -l pl.UTF-8
90Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 91
3fcbc09a 92%prep
923851a2 93%setup -q
286b1479 94%if "%{_lib}" == "lib64"
6342daf8 95%patch0 -p1
286b1479 96%endif
9ec4f08d 97%patch1 -p1
fe667d6f 98%patch2 -p1
de784c58 99%patch3 -p1
3fcbc09a 100
ece9e155 101cat > "init.cmake" <<EOF
286b1479 102SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
103SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
104SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
105EOF
106
3fcbc09a 107%build
ece9e155
KK
108export CC="%{__cc}"
109export CXX="%{__cxx}"
110export CFLAGS="%{rpmcflags}"
111export CXXFLAGS="%{rpmcxxflags}"
ccca321d 112export LDFLAGS="%{rpmldflags}"
923851a2
AG
113./bootstrap \
114 --prefix=%{_prefix} \
115 --mandir=/share/man \
116 --datadir=/share/cmake \
ece9e155 117 --init=init.cmake \
c342f103 118 %{!?with_bootstrap:--system-libs} \
33042d59 119 %{?with_gui:--qt-gui} \
08bb5e07 120 --qt-qmake=/usr/bin/qmake-qt4 \
923851a2
AG
121 --verbose
122
28f0bd6c 123%{__make} VERBOSE=1
3fcbc09a 124
1fbe3ed6
AM
125%{?with_tests:%{__make} test}
126
3fcbc09a 127%install
efafbc62 128rm -rf $RPM_BUILD_ROOT
72a696fa
JB
129%{__make} install \
130 DESTDIR=$RPM_BUILD_ROOT
131
75cb386f 132%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
efafbc62 138%defattr(644,root,root,755)
51ed65c6 139%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
72a696fa
JB
140%attr(755,root,root) %{_bindir}/ccmake
141%attr(755,root,root) %{_bindir}/cmake
08b6790a 142%attr(755,root,root) %{_bindir}/cpack
72a696fa 143%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
144%{_mandir}/man1/ccmake.1*
145%{_mandir}/man1/cmake.1*
146%{_mandir}/man1/cmakecommands.1*
147%{_mandir}/man1/cmakecompat.1*
148%{_mandir}/man1/cmakemodules.1*
149%{_mandir}/man1/cmakepolicies.1*
150%{_mandir}/man1/cmakeprops.1*
151%{_mandir}/man1/cmakevars.1*
152%{_mandir}/man1/cpack.1*
153%{_mandir}/man1/ctest.1*
b24a2e64
JB
154# top cmake/Modules dirs belong to filesystem
155%{_datadir}/cmake/Modules/.NoDartCoverage
156%{_datadir}/cmake/Modules/*
157%{_datadir}/cmake/Templates
f13d1e41 158%{_datadir}/cmake/editors
b24a2e64 159%{_datadir}/cmake/include
09f5d631 160%{_aclocaldir}/cmake.m4
33042d59 161
1a3a9dcd 162%if %{with gui}
33042d59
KK
163%files gui
164%defattr(644,root,root,755)
165%attr(755,root,root) %{_bindir}/cmake-gui
166%{_datadir}/mime/packages/cmakecache.xml
167%{_desktopdir}/CMake.desktop
ca760f29 168%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 169%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 170%endif
9ec4f08d
KK
171
172%files emacs
173%defattr(644,root,root,755)
174%{_datadir}/emacs/site-lisp/cmake-mode.el
175
176%files -n bash-completion-%{name}
177%defattr(644,root,root,755)
a9b1845f
JB
178%{_datadir}/bash-completion/completions/cmake
179%{_datadir}/bash-completion/completions/cpack
180%{_datadir}/bash-completion/completions/ctest
This page took 0.086837 seconds and 4 git commands to generate.