]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- adapterized
[packages/cmake.git] / cmake.spec
CommitLineData
3fcbc09a
AG
1%define name cmake
2%define version 1.4.7
3%define release 1
4
efafbc62
AG
5Summary: Cross-platform, open-source make system
6Name: %name
7Version: %version
8Release: %release
9License: BSD
10Group: Development/Other
11###### Unknown group!
12Url: http://www.cmake.org/HTML/Index.html
13Source0: CMake%{version}-src-unix.tar.bz2
14Patch0: cmake-ncurses.patch
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
16
17%description
efafbc62
AG
18CMake is used to control the software compilation process using simple
19platform and compiler independent configuration files. CMake generates
20native makefiles and workspaces that can be used in the compiler
21environment of your choice. CMake is quite sophisticated: it is
22possible to support complex environments requiring system
23configuration, pre-processor generation, code generation, and template
24instantiation.
3fcbc09a
AG
25
26%prep
27%setup -q -n CMake-%version
28%patch0 -p1
29
30%build
efafbc62 31CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
3fcbc09a
AG
32%configure2_13
33%{__make} \
efafbc62 34 CXXFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
3fcbc09a
AG
35
36%install
efafbc62 37rm -rf $RPM_BUILD_ROOT
3fcbc09a 38%{__make} install DESTDIR=$RPM_BUILD_ROOT
efafbc62 39mv $RPM_BUILD_ROOT%{_prefix}/man $RPM_BUILD_ROOT/%_datadir/
3fcbc09a
AG
40bzip2 $RPM_BUILD_ROOT/%_datadir/man/man1/*
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%files
efafbc62 46%defattr(644,root,root,755)
3fcbc09a
AG
47%doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif
48%_bindir/ccmake
49%_bindir/cmake
50%_bindir/cmaketest
51%_bindir/ctest
52%_mandir/man1/*.1.*
53%_datadir/CMake/Modules
54%_datadir/CMake/Templates
This page took 0.047683 seconds and 4 git commands to generate.