]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- updated to 3.0.2
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
77f8acdd 11
efafbc62 12Summary: Cross-platform, open-source make system
ac3ea35a 13Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 14Name: cmake
fe46a853
JB
15Version: 3.0.2
16Release: 1
efafbc62 17License: BSD
72a696fa 18Group: Development/Building
fe46a853
JB
19Source0: http://www.cmake.org/files/v3.0/%{name}-%{version}.tar.gz
20# Source0-md5: db4c687a31444a929d2fdc36c4dfb95f
6342daf8 21Patch0: %{name}-lib64.patch
9ec4f08d 22Patch1: %{name}-helpers.patch
de784c58
JB
23Patch2: %{name}-findruby.patch
24Patch3: %{name}-tests.patch
a048aac3 25Patch5: %{name}-findruby2.patch
1269f267 26Patch6: %{name}-findpython.patch
a315a797 27URL: http://www.cmake.org/
33042d59 28%{?with_gui:BuildRequires: QtGui-devel}
fef12180 29BuildRequires: libarchive-devel
ece9e155 30BuildRequires: libstdc++-devel
59917d1a 31BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
32%{?with_gui:BuildRequires: qt4-build}
33%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 34BuildRequires: rpmbuild(macros) >= 1.167
fe46a853 35BuildRequires: sphinx-pdg
ab02ad6a 36%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 37Requires: filesystem >= 3.0-52
efafbc62 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
39
40%description
efafbc62
AG
41CMake is used to control the software compilation process using simple
42platform and compiler independent configuration files. CMake generates
43native makefiles and workspaces that can be used in the compiler
44environment of your choice. CMake is quite sophisticated: it is
45possible to support complex environments requiring system
46configuration, pre-processor generation, code generation, and template
47instantiation.
3fcbc09a 48
520c9eb8
JR
49%description -l pl.UTF-8
50CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 51użyciu prostych plików konfiguracyjnych niezależnych od platformy i
52kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 53których można używać w wybranym środowisku kompilatora. CMake jest
59787775 54dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 55konfiguracji systemu, generowanie preprocesora, generowanie kodu i
56dziedziczenie szablonów.
33042d59 57
fe46a853
JB
58%package doc-html
59Summary: CMake documentation in HTML format
60Summary(pl.UTF-8): Dokumentacja do pakietu CMake w formacie HTML
61Group: Documentation
62
63%description doc-html
64CMake documentation in HTML format.
65
66%description doc-html -l pl.UTF-8
67Dokumentacja do pakietu CMake w formacie HTML.
68
33042d59 69%package gui
b563f9dc
JB
70Summary: Qt GUI for CMake
71Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
72Group: Development/Tools
73Requires: %{name} = %{version}-%{release}
74
b563f9dc
JB
75%description gui
76This package contains the Qt based GUI for CMake.
77
78%description gui -l pl.UTF-8
79Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
80CMake.
72a696fa 81
9ec4f08d 82%package emacs
69d19c08
JB
83Summary: Emacs mode for cmake files
84Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
85Group: Development/Tools
86
87%description emacs
69d19c08
JB
88Emacs mode for cmake files.
89
90%description emacs -l pl.UTF-8
91Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
92
93%package -n bash-completion-%{name}
94Summary: bash-completion for cmake
69d19c08 95Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 96Group: Applications/Shells
69d19c08 97Requires: %{name} = %{version}-%{release}
a9b1845f 98Requires: bash-completion >= 2.0
6465d90a
ER
99%if "%{_rpmversion}" >= "5"
100BuildArch: noarch
101%endif
9ec4f08d
KK
102
103%description -n bash-completion-%{name}
69d19c08
JB
104bash-completion for cmake.
105
106%description -n bash-completion-%{name} -l pl.UTF-8
107Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 108
3fcbc09a 109%prep
923851a2 110%setup -q
286b1479 111%if "%{_lib}" == "lib64"
6342daf8 112%patch0 -p1
286b1479 113%endif
9ec4f08d 114%patch1 -p1
fe667d6f 115%patch2 -p1
de784c58 116%patch3 -p1
a048aac3 117%patch5 -p1
1269f267 118%patch6 -p1
3fcbc09a 119
ece9e155 120cat > "init.cmake" <<EOF
286b1479 121SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
122SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
123SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
124EOF
125
b343cdb1
JR
126# cleanup backups after patching, modules are copied as-is
127find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
128
3fcbc09a 129%build
ece9e155
KK
130export CC="%{__cc}"
131export CXX="%{__cxx}"
132export CFLAGS="%{rpmcflags}"
133export CXXFLAGS="%{rpmcxxflags}"
ccca321d 134export LDFLAGS="%{rpmldflags}"
923851a2
AG
135./bootstrap \
136 --prefix=%{_prefix} \
137 --mandir=/share/man \
138 --datadir=/share/cmake \
ece9e155 139 --init=init.cmake \
c342f103 140 %{!?with_bootstrap:--system-libs} \
33042d59 141 %{?with_gui:--qt-gui} \
08bb5e07 142 --qt-qmake=/usr/bin/qmake-qt4 \
fe46a853
JB
143 --sphinx-html \
144 --sphinx-man \
923851a2
AG
145 --verbose
146
28f0bd6c 147%{__make} VERBOSE=1
3fcbc09a 148
1fbe3ed6
AM
149%{?with_tests:%{__make} test}
150
3fcbc09a 151%install
efafbc62 152rm -rf $RPM_BUILD_ROOT
72a696fa
JB
153%{__make} install \
154 DESTDIR=$RPM_BUILD_ROOT
155
75cb386f 156%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%files
efafbc62 162%defattr(644,root,root,755)
fe46a853 163%doc Copyright.txt README.rst *.gif
72a696fa
JB
164%attr(755,root,root) %{_bindir}/ccmake
165%attr(755,root,root) %{_bindir}/cmake
08b6790a 166%attr(755,root,root) %{_bindir}/cpack
72a696fa 167%attr(755,root,root) %{_bindir}/ctest
08bb5e07
JB
168%{_mandir}/man1/ccmake.1*
169%{_mandir}/man1/cmake.1*
08bb5e07
JB
170%{_mandir}/man1/cpack.1*
171%{_mandir}/man1/ctest.1*
fe46a853
JB
172%{_mandir}/man7/cmake-buildsystem.7*
173%{_mandir}/man7/cmake-commands.7*
174%{_mandir}/man7/cmake-developer.7*
175%{_mandir}/man7/cmake-generator-expressions.7*
176%{_mandir}/man7/cmake-generators.7*
177%{_mandir}/man7/cmake-language.7*
178%{_mandir}/man7/cmake-modules.7*
179%{_mandir}/man7/cmake-packages.7*
180%{_mandir}/man7/cmake-policies.7*
181%{_mandir}/man7/cmake-properties.7*
182%{_mandir}/man7/cmake-qt.7*
183%{_mandir}/man7/cmake-toolchains.7*
184%{_mandir}/man7/cmake-variables.7*
b24a2e64
JB
185# top cmake/Modules dirs belong to filesystem
186%{_datadir}/cmake/Modules/.NoDartCoverage
187%{_datadir}/cmake/Modules/*
188%{_datadir}/cmake/Templates
f13d1e41 189%{_datadir}/cmake/editors
b24a2e64 190%{_datadir}/cmake/include
09f5d631 191%{_aclocaldir}/cmake.m4
33042d59 192
fe46a853
JB
193%files doc-html
194%defattr(644,root,root,755)
195%doc Utilities/Sphinx/html/*
196
1a3a9dcd 197%if %{with gui}
33042d59
KK
198%files gui
199%defattr(644,root,root,755)
200%attr(755,root,root) %{_bindir}/cmake-gui
fe46a853 201%{_datadir}/cmake/Help
33042d59
KK
202%{_datadir}/mime/packages/cmakecache.xml
203%{_desktopdir}/CMake.desktop
ca760f29 204%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 205%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 206%endif
9ec4f08d
KK
207
208%files emacs
209%defattr(644,root,root,755)
210%{_datadir}/emacs/site-lisp/cmake-mode.el
211
212%files -n bash-completion-%{name}
213%defattr(644,root,root,755)
a9b1845f
JB
214%{_datadir}/bash-completion/completions/cmake
215%{_datadir}/bash-completion/completions/cpack
216%{_datadir}/bash-completion/completions/ctest
This page took 0.077915 seconds and 4 git commands to generate.