]> git.pld-linux.org Git - packages/alpine.git/blame - alpine.spec
- ported from pine
[packages/alpine.git] / alpine.spec
CommitLineData
ecdbf6cc
PG
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
ecdbf6cc 4# - review patches from pine:
ffdc223c
PG
5# - home_etc support
6# - ....many more
c4ce2c49 7# - separate package with tcl web-frontend
c9e98969 8# - fix as-needed
02477d30 9Summary: University of Washington Pine mail user agent
84f5c30e 10Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
02477d30 11Name: alpine
db14e620 12%define ver 0.9999
14ee7687 13%define patchlevel 79
db14e620 14Version: %{ver}.%{patchlevel}
c9e98969 15Release: 1
ecdbf6cc
PG
16Epoch: 1
17License: Apache License 2.0
02477d30 18Group: Applications/Mail
19f73470
PG
19# Main site:
20#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
21# Source with applied patches from http://staff.washington.edu/chappa/alpine/
db14e620 22Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
14ee7687 23# Source0-md5: d06708e4274887e260a34d82aa437401
ecdbf6cc 24Source1: pico.desktop
e4e766a4
JB
25Source2: %{name}.desktop
26Source3: %{name}.png
4db9f585 27Patch0: %{name}-thread_end.patch
d16122d2 28Patch1: %{name}-index_display.patch
e4e766a4 29URL: http://www.washington.edu/alpine/
c85f8efa
PG
30BuildRequires: autoconf
31BuildRequires: automake
84f5c30e 32BuildRequires: krb5-devel
02477d30 33BuildRequires: ncurses-devel
78a816a8 34BuildRequires: openldap-devel >= 2.4.6
02477d30 35BuildRequires: openssl-devel
02477d30 36BuildRequires: pam-devel
ed75d4f6
PG
37# Only for web-frontend:
38#BuildRequires: tcl-devel
02477d30
AM
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
ecdbf6cc 41%define alpineconfdir /etc/%{name}
c9e98969 42%define filterout_ld -Wl,--as-needed
ecdbf6cc 43
02477d30
AM
44%description
45Alpine -- an Alternatively Licensed Program for Internet News & Email
46-- is a tool for reading, sending, and managing electronic messages.
47Alpine is the successor to Pine and was developed by Computing &
48Communications at the University of Washington. Though originally
49designed for inexperienced email users, Alpine supports many advanced
50features, and an ever-growing number of configuration and
51personal-preference options.
52
84f5c30e
JB
53%description -l pl.UTF-8
54Alpine, czyli Alternatively Licensed Program for Internet News & Email
55(alternatywnie licencjonowany program do newsów i poczty internetowej)
56to narzędzie do czytania, wysyłania i zarządzania wiadomościami
57elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
58wydział Computing & Communications (Obliczeń i komunikacji) na
59Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
60zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
61wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
62ciągle rośnie.
63
ecdbf6cc
PG
64%package -n pico
65Summary: Simple text editor in the style of the Pine Composer
66Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
67Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
68Group: Applications/Editors
69
70%description -n pico
71Pico is a simple, display-oriented text editor based on the Alpine
72message system composer. As with Pine, commands are displayed at the
73bottom of the screen, and context-sensitive help is provided. As
74characters are typed they are immediately inserted into the text.
75
76%description -n pico -l pl.UTF-8
77Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
78alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
79dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
80włączane do tekstu.
81
82%description -n pico -l pt_BR.UTF-8
83Pico é um editor de texto baseado no compositor de mensagens do Alpine.
84Assim como no Pine, comandos são mostrados na parte de baixo da tela,
85e ajuda de acordo com o contexto está disponível.
86
87%package -n pilot
88Summary: Simple file system browser in the style of the Alpine Composer
89Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
90Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
91Group: Applications/Shells
92
93%description -n pilot
94Pilot is a simple, display-oriented file system browser based on the
95Alpine message system composer. As with Alpine, commands are displayed at
96the bottom of the screen, and context-sensitive help is provided.
97
98%description -n pilot -l pl.UTF-8
99Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
100stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
101dole ekranu oraz jest dostępna pomoc kontekstowa.
102
103%description -n pilot -l pt_BR.UTF-8
104Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
105como no Pine, comandos são apresentados na parte de baixo da tela, e
106ajuda de acordo com o contexto está disponível.
107
02477d30 108%prep
db14e620 109%setup -q -n %{name}-%{ver}
4db9f585 110%patch0 -p1
d16122d2 111%patch1 -p1
02477d30
AM
112
113%build
14ee7687
PG
114rm -f libtool missing
115%{__libtoolize}
c85f8efa
PG
116%{__autoconf}
117%{__aclocal} -I m4
118%{__automake}
02477d30
AM
119%configure \
120 --enable-quotas \
ed75d4f6 121 --without-tcl \
02477d30
AM
122 --with-smtp-msa=%{_libdir}/sendmail \
123 --with-spellcheck-prog=aspell \
ecdbf6cc
PG
124 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
125 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
02477d30
AM
126 --with-krb5-dir=%{_prefix} \
127 --with-ldap-dir=%{_prefix} \
128 --with-system-mail-directory=/var/mail
129%{__make}
130
131%install
132rm -rf $RPM_BUILD_ROOT
28b69314 133install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
02477d30
AM
134
135%{__make} install \
136 DESTDIR=$RPM_BUILD_ROOT
137
ecdbf6cc 138install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
28b69314
PG
139install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
140install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
141
02477d30
AM
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%files
146%defattr(644,root,root,755)
ecdbf6cc
PG
147%doc README doc/tech-notes.txt
148%dir %{alpineconfdir}
28b69314 149%attr(755,root,root) %{_bindir}/%{name}
02477d30
AM
150%attr(755,root,root) %{_bindir}/rpload
151%attr(755,root,root) %{_bindir}/rpdump
28b69314 152%{_mandir}/man1/%{name}.1*
ad29b28d
PG
153%{_mandir}/man1/rpload.1*
154%{_mandir}/man1/rpdump.1*
28b69314
PG
155%{_desktopdir}/%{name}.desktop
156%{_pixmapsdir}/%{name}.png
ecdbf6cc
PG
157
158%files -n pico
159%defattr(644,root,root,755)
160%attr(755,root,root) %{_bindir}/pico
161%{_desktopdir}/pico.desktop
162%{_mandir}/man1/pico*
163
164%files -n pilot
165%defattr(644,root,root,755)
166%attr(755,root,root) %{_bindir}/pilot
167%{_mandir}/man1/pilot*
This page took 0.079171 seconds and 4 git commands to generate.