]> git.pld-linux.org Git - packages/alpine.git/blame - alpine.spec
- separated pico and pilot into subpackages (Epoch 1 to allow upgrade from
[packages/alpine.git] / alpine.spec
CommitLineData
ecdbf6cc
PG
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
4# - pine -> alpine config converter
5# - review patches from pine:
6# - maildir support is missing - maybe some fixed patch from http://staff.washington.edu/chappa/pine/ ?
02477d30 7Summary: University of Washington Pine mail user agent
84f5c30e 8Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
02477d30
AM
9Name: alpine
10Version: 0.999
ecdbf6cc
PG
11Release: 0.2
12Epoch: 1
13License: Apache License 2.0
02477d30
AM
14Group: Applications/Mail
15Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
16# Source0-md5: 082de388a998c1faa2385ebdfd6800f5
ecdbf6cc 17Source1: pico.desktop
02477d30 18URL: http://www.washington.edu/alpine
84f5c30e 19BuildRequires: krb5-devel
02477d30
AM
20BuildRequires: ncurses-devel
21BuildRequires: openldap-devel
22BuildRequires: openssl-devel
02477d30 23BuildRequires: pam-devel
84f5c30e 24BuildRequires: tcl-devel
02477d30
AM
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
ecdbf6cc
PG
27%define alpineconfdir /etc/%{name}
28
02477d30
AM
29%description
30Alpine -- an Alternatively Licensed Program for Internet News & Email
31-- is a tool for reading, sending, and managing electronic messages.
32Alpine is the successor to Pine and was developed by Computing &
33Communications at the University of Washington. Though originally
34designed for inexperienced email users, Alpine supports many advanced
35features, and an ever-growing number of configuration and
36personal-preference options.
37
84f5c30e
JB
38%description -l pl.UTF-8
39Alpine, czyli Alternatively Licensed Program for Internet News & Email
40(alternatywnie licencjonowany program do newsów i poczty internetowej)
41to narzędzie do czytania, wysyłania i zarządzania wiadomościami
42elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
43wydział Computing & Communications (Obliczeń i komunikacji) na
44Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
45zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
46wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
47ciągle rośnie.
48
ecdbf6cc
PG
49%package -n pico
50Summary: Simple text editor in the style of the Pine Composer
51Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
52Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
53Group: Applications/Editors
54
55%description -n pico
56Pico is a simple, display-oriented text editor based on the Alpine
57message system composer. As with Pine, commands are displayed at the
58bottom of the screen, and context-sensitive help is provided. As
59characters are typed they are immediately inserted into the text.
60
61%description -n pico -l pl.UTF-8
62Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
63alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
64dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
65włączane do tekstu.
66
67%description -n pico -l pt_BR.UTF-8
68Pico é um editor de texto baseado no compositor de mensagens do Alpine.
69Assim como no Pine, comandos são mostrados na parte de baixo da tela,
70e ajuda de acordo com o contexto está disponível.
71
72%package -n pilot
73Summary: Simple file system browser in the style of the Alpine Composer
74Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
75Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
76Group: Applications/Shells
77
78%description -n pilot
79Pilot is a simple, display-oriented file system browser based on the
80Alpine message system composer. As with Alpine, commands are displayed at
81the bottom of the screen, and context-sensitive help is provided.
82
83%description -n pilot -l pl.UTF-8
84Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
85stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
86dole ekranu oraz jest dostępna pomoc kontekstowa.
87
88%description -n pilot -l pt_BR.UTF-8
89Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
90como no Pine, comandos são apresentados na parte de baixo da tela, e
91ajuda de acordo com o contexto está disponível.
92
02477d30
AM
93%prep
94%setup -q
95
96%build
97%configure \
98 --enable-quotas \
99 --with-smtp-msa=%{_libdir}/sendmail \
100 --with-spellcheck-prog=aspell \
ecdbf6cc
PG
101 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
102 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
02477d30
AM
103 --with-krb5-dir=%{_prefix} \
104 --with-ldap-dir=%{_prefix} \
105 --with-system-mail-directory=/var/mail
106%{__make}
107
108%install
109rm -rf $RPM_BUILD_ROOT
ecdbf6cc 110install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir}}
02477d30
AM
111
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
ecdbf6cc
PG
115install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
116
02477d30
AM
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
ecdbf6cc
PG
122%doc README doc/tech-notes.txt
123%dir %{alpineconfdir}
02477d30 124%attr(755,root,root) %{_bindir}/alpine
02477d30
AM
125%attr(755,root,root) %{_bindir}/rpload
126%attr(755,root,root) %{_bindir}/rpdump
ecdbf6cc
PG
127#%attr(755,root,root) %{_bindir}/mailutil
128#%attr(2755,root,mail) %{_sbindir}/mlock
02477d30 129%{_mandir}/man1/alpine.1*
ecdbf6cc
PG
130#%{_mandir}/man1/rpload.1*
131#%{_mandir}/man1/rpdump.1*
132#%{_mandir}/man1/mailutil.1*
133
134%files -n pico
135%defattr(644,root,root,755)
136%attr(755,root,root) %{_bindir}/pico
137%{_desktopdir}/pico.desktop
138%{_mandir}/man1/pico*
139
140%files -n pilot
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_bindir}/pilot
143%{_mandir}/man1/pilot*
This page took 0.043106 seconds and 4 git commands to generate.