]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- separated pico and pilot into subpackages (Epoch 1 to allow upgrade from
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - alpine should obsolete pine, link pine -> alpine should be made
4 # - pine -> alpine config converter
5 # - review patches from pine:
6 #   - maildir support is missing - maybe some fixed patch from http://staff.washington.edu/chappa/pine/ ?
7 Summary:        University of Washington Pine mail user agent
8 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
9 Name:           alpine
10 Version:        0.999
11 Release:        0.2
12 Epoch:          1
13 License:        Apache License 2.0
14 Group:          Applications/Mail
15 Source0:        ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
16 # Source0-md5:  082de388a998c1faa2385ebdfd6800f5
17 Source1:        pico.desktop
18 URL:            http://www.washington.edu/alpine
19 BuildRequires:  krb5-devel
20 BuildRequires:  ncurses-devel
21 BuildRequires:  openldap-devel
22 BuildRequires:  openssl-devel
23 BuildRequires:  pam-devel
24 BuildRequires:  tcl-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         alpineconfdir   /etc/%{name}
28
29 %description
30 Alpine -- an Alternatively Licensed Program for Internet News & Email
31 -- is a tool for reading, sending, and managing electronic messages.
32 Alpine is the successor to Pine and was developed by Computing &
33 Communications at the University of Washington. Though originally
34 designed for inexperienced email users, Alpine supports many advanced
35 features, and an ever-growing number of configuration and
36 personal-preference options.
37
38 %description -l pl.UTF-8
39 Alpine, czyli Alternatively Licensed Program for Internet News & Email
40 (alternatywnie licencjonowany program do newsów i poczty internetowej)
41 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
42 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
43 wydział Computing & Communications (Obliczeń i komunikacji) na
44 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
45 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
46 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
47 ciągle rośnie.
48
49 %package -n pico
50 Summary:        Simple text editor in the style of the Pine Composer
51 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
52 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
53 Group:          Applications/Editors
54
55 %description -n pico
56 Pico is a simple, display-oriented text editor based on the Alpine
57 message system composer. As with Pine, commands are displayed at the
58 bottom of the screen, and context-sensitive help is provided. As
59 characters are typed they are immediately inserted into the text.
60
61 %description -n pico -l pl.UTF-8
62 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
63 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
64 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
65 włączane do tekstu.
66
67 %description -n pico -l pt_BR.UTF-8
68 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
69 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
70 e ajuda de acordo com o contexto está disponível.
71
72 %package -n pilot
73 Summary:        Simple file system browser in the style of the Alpine Composer
74 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
75 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
76 Group:          Applications/Shells
77
78 %description -n pilot
79 Pilot is a simple, display-oriented file system browser based on the
80 Alpine message system composer. As with Alpine, commands are displayed at
81 the bottom of the screen, and context-sensitive help is provided.
82
83 %description -n pilot -l pl.UTF-8
84 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
85 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
86 dole ekranu oraz jest dostępna pomoc kontekstowa.
87
88 %description -n pilot -l pt_BR.UTF-8
89 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
90 como no Pine, comandos são apresentados na parte de baixo da tela, e
91 ajuda de acordo com o contexto está disponível.
92
93 %prep
94 %setup -q
95
96 %build
97 %configure \
98         --enable-quotas \
99         --with-smtp-msa=%{_libdir}/sendmail \
100         --with-spellcheck-prog=aspell \
101         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
102         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
103         --with-krb5-dir=%{_prefix} \
104         --with-ldap-dir=%{_prefix} \
105         --with-system-mail-directory=/var/mail
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir}}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README doc/tech-notes.txt
123 %dir %{alpineconfdir}
124 %attr(755,root,root) %{_bindir}/alpine
125 %attr(755,root,root) %{_bindir}/rpload
126 %attr(755,root,root) %{_bindir}/rpdump
127 #%attr(755,root,root) %{_bindir}/mailutil
128 #%attr(2755,root,mail) %{_sbindir}/mlock
129 %{_mandir}/man1/alpine.1*
130 #%{_mandir}/man1/rpload.1*
131 #%{_mandir}/man1/rpdump.1*
132 #%{_mandir}/man1/mailutil.1*
133
134 %files -n pico
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/pico
137 %{_desktopdir}/pico.desktop
138 %{_mandir}/man1/pico*
139
140 %files -n pilot
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/pilot
143 %{_mandir}/man1/pilot*
This page took 0.090673 seconds and 4 git commands to generate.