]> git.pld-linux.org Git - packages/alpine.git/blame - alpine.spec
- patchlevel 38 - fixes crashes with some messages
[packages/alpine.git] / alpine.spec
CommitLineData
ecdbf6cc
PG
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
ecdbf6cc 4# - review patches from pine:
ffdc223c
PG
5# - home_etc support
6# - ....many more
c4ce2c49 7# - separate package with tcl web-frontend
02477d30 8Summary: University of Washington Pine mail user agent
84f5c30e 9Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
02477d30 10Name: alpine
db14e620 11%define ver 0.9999
e4800e35 12%define patchlevel 38
db14e620 13Version: %{ver}.%{patchlevel}
ad29b28d 14Release: 1
ecdbf6cc
PG
15Epoch: 1
16License: Apache License 2.0
02477d30 17Group: Applications/Mail
19f73470
PG
18# Main site:
19#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
20# Source with applied patches from http://staff.washington.edu/chappa/alpine/
db14e620 21Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
e4800e35 22# Source0-md5: 77953f8d0fc7f8b2d0aa3787bb0982de
ecdbf6cc 23Source1: pico.desktop
e4e766a4
JB
24Source2: %{name}.desktop
25Source3: %{name}.png
4db9f585 26Patch0: %{name}-thread_end.patch
d16122d2 27Patch1: %{name}-index_display.patch
e4e766a4 28URL: http://www.washington.edu/alpine/
c85f8efa
PG
29BuildRequires: autoconf
30BuildRequires: automake
84f5c30e 31BuildRequires: krb5-devel
02477d30
AM
32BuildRequires: ncurses-devel
33BuildRequires: openldap-devel
34BuildRequires: openssl-devel
02477d30 35BuildRequires: pam-devel
c4ce2c49 36# Only for web-frontend
84f5c30e 37BuildRequires: tcl-devel
02477d30
AM
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
ecdbf6cc
PG
40%define alpineconfdir /etc/%{name}
41
02477d30
AM
42%description
43Alpine -- an Alternatively Licensed Program for Internet News & Email
44-- is a tool for reading, sending, and managing electronic messages.
45Alpine is the successor to Pine and was developed by Computing &
46Communications at the University of Washington. Though originally
47designed for inexperienced email users, Alpine supports many advanced
48features, and an ever-growing number of configuration and
49personal-preference options.
50
84f5c30e
JB
51%description -l pl.UTF-8
52Alpine, czyli Alternatively Licensed Program for Internet News & Email
53(alternatywnie licencjonowany program do newsów i poczty internetowej)
54to narzędzie do czytania, wysyłania i zarządzania wiadomościami
55elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
56wydział Computing & Communications (Obliczeń i komunikacji) na
57Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
58zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
59wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
60ciągle rośnie.
61
ecdbf6cc
PG
62%package -n pico
63Summary: Simple text editor in the style of the Pine Composer
64Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
65Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
66Group: Applications/Editors
67
68%description -n pico
69Pico is a simple, display-oriented text editor based on the Alpine
70message system composer. As with Pine, commands are displayed at the
71bottom of the screen, and context-sensitive help is provided. As
72characters are typed they are immediately inserted into the text.
73
74%description -n pico -l pl.UTF-8
75Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
76alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
77dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
78włączane do tekstu.
79
80%description -n pico -l pt_BR.UTF-8
81Pico é um editor de texto baseado no compositor de mensagens do Alpine.
82Assim como no Pine, comandos são mostrados na parte de baixo da tela,
83e ajuda de acordo com o contexto está disponível.
84
85%package -n pilot
86Summary: Simple file system browser in the style of the Alpine Composer
87Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
88Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
89Group: Applications/Shells
90
91%description -n pilot
92Pilot is a simple, display-oriented file system browser based on the
93Alpine message system composer. As with Alpine, commands are displayed at
94the bottom of the screen, and context-sensitive help is provided.
95
96%description -n pilot -l pl.UTF-8
97Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
98stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
99dole ekranu oraz jest dostępna pomoc kontekstowa.
100
101%description -n pilot -l pt_BR.UTF-8
102Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
103como no Pine, comandos são apresentados na parte de baixo da tela, e
104ajuda de acordo com o contexto está disponível.
105
02477d30 106%prep
db14e620 107%setup -q -n %{name}-%{ver}
4db9f585 108%patch0 -p1
d16122d2 109%patch1 -p1
02477d30
AM
110
111%build
c85f8efa
PG
112%{__autoconf}
113%{__aclocal} -I m4
114%{__automake}
02477d30
AM
115%configure \
116 --enable-quotas \
117 --with-smtp-msa=%{_libdir}/sendmail \
118 --with-spellcheck-prog=aspell \
ecdbf6cc
PG
119 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
120 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
02477d30
AM
121 --with-krb5-dir=%{_prefix} \
122 --with-ldap-dir=%{_prefix} \
123 --with-system-mail-directory=/var/mail
124%{__make}
125
126%install
127rm -rf $RPM_BUILD_ROOT
28b69314 128install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
02477d30
AM
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
ecdbf6cc 133install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
28b69314
PG
134install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
135install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
136
02477d30
AM
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%files
141%defattr(644,root,root,755)
ecdbf6cc
PG
142%doc README doc/tech-notes.txt
143%dir %{alpineconfdir}
28b69314 144%attr(755,root,root) %{_bindir}/%{name}
02477d30
AM
145%attr(755,root,root) %{_bindir}/rpload
146%attr(755,root,root) %{_bindir}/rpdump
28b69314 147%{_mandir}/man1/%{name}.1*
ad29b28d
PG
148%{_mandir}/man1/rpload.1*
149%{_mandir}/man1/rpdump.1*
28b69314
PG
150%{_desktopdir}/%{name}.desktop
151%{_pixmapsdir}/%{name}.png
ecdbf6cc
PG
152
153%files -n pico
154%defattr(644,root,root,755)
155%attr(755,root,root) %{_bindir}/pico
156%{_desktopdir}/pico.desktop
157%{_mandir}/man1/pico*
158
159%files -n pilot
160%defattr(644,root,root,755)
161%attr(755,root,root) %{_bindir}/pilot
162%{_mandir}/man1/pilot*
This page took 0.125932 seconds and 4 git commands to generate.