]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- ported from pine
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - alpine should obsolete pine, link pine -> alpine should be made
4 # - review patches from pine:
5 #   - home_etc support
6 #   - ....many more
7 # - separate package with tcl web-frontend
8 # - fix as-needed
9 Summary:        University of Washington Pine mail user agent
10 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
11 Name:           alpine
12 %define         ver             0.9999
13 %define         patchlevel      79
14 Version:        %{ver}.%{patchlevel}
15 Release:        1
16 Epoch:          1
17 License:        Apache License 2.0
18 Group:          Applications/Mail
19 # Main site:
20 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
21 # Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
22 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
23 # Source0-md5:  d06708e4274887e260a34d82aa437401
24 Source1:        pico.desktop
25 Source2:        %{name}.desktop
26 Source3:        %{name}.png
27 Patch0:         %{name}-thread_end.patch
28 Patch1:         %{name}-index_display.patch
29 URL:            http://www.washington.edu/alpine/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  krb5-devel
33 BuildRequires:  ncurses-devel
34 BuildRequires:  openldap-devel >= 2.4.6
35 BuildRequires:  openssl-devel
36 BuildRequires:  pam-devel
37 # Only for web-frontend:
38 #BuildRequires: tcl-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         alpineconfdir   /etc/%{name}
42 %define         filterout_ld    -Wl,--as-needed
43
44 %description
45 Alpine -- an Alternatively Licensed Program for Internet News & Email
46 -- is a tool for reading, sending, and managing electronic messages.
47 Alpine is the successor to Pine and was developed by Computing &
48 Communications at the University of Washington. Though originally
49 designed for inexperienced email users, Alpine supports many advanced
50 features, and an ever-growing number of configuration and
51 personal-preference options.
52
53 %description -l pl.UTF-8
54 Alpine, czyli Alternatively Licensed Program for Internet News & Email
55 (alternatywnie licencjonowany program do newsów i poczty internetowej)
56 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
57 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
58 wydział Computing & Communications (Obliczeń i komunikacji) na
59 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
60 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
61 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
62 ciągle rośnie.
63
64 %package -n pico
65 Summary:        Simple text editor in the style of the Pine Composer
66 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
67 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
68 Group:          Applications/Editors
69
70 %description -n pico
71 Pico is a simple, display-oriented text editor based on the Alpine
72 message system composer. As with Pine, commands are displayed at the
73 bottom of the screen, and context-sensitive help is provided. As
74 characters are typed they are immediately inserted into the text.
75
76 %description -n pico -l pl.UTF-8
77 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
78 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
79 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
80 włączane do tekstu.
81
82 %description -n pico -l pt_BR.UTF-8
83 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
84 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
85 e ajuda de acordo com o contexto está disponível.
86
87 %package -n pilot
88 Summary:        Simple file system browser in the style of the Alpine Composer
89 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
90 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
91 Group:          Applications/Shells
92
93 %description -n pilot
94 Pilot is a simple, display-oriented file system browser based on the
95 Alpine message system composer. As with Alpine, commands are displayed at
96 the bottom of the screen, and context-sensitive help is provided.
97
98 %description -n pilot -l pl.UTF-8
99 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
100 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
101 dole ekranu oraz jest dostępna pomoc kontekstowa.
102
103 %description -n pilot -l pt_BR.UTF-8
104 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
105 como no Pine, comandos são apresentados na parte de baixo da tela, e
106 ajuda de acordo com o contexto está disponível.
107
108 %prep
109 %setup -q -n %{name}-%{ver}
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 rm -f libtool missing
115 %{__libtoolize}
116 %{__autoconf}
117 %{__aclocal} -I m4
118 %{__automake}
119 %configure \
120         --enable-quotas \
121         --without-tcl \
122         --with-smtp-msa=%{_libdir}/sendmail \
123         --with-spellcheck-prog=aspell \
124         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
125         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
126         --with-krb5-dir=%{_prefix} \
127         --with-ldap-dir=%{_prefix} \
128         --with-system-mail-directory=/var/mail
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
139 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
140 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %doc README doc/tech-notes.txt
148 %dir %{alpineconfdir}
149 %attr(755,root,root) %{_bindir}/%{name}
150 %attr(755,root,root) %{_bindir}/rpload
151 %attr(755,root,root) %{_bindir}/rpdump
152 %{_mandir}/man1/%{name}.1*
153 %{_mandir}/man1/rpload.1*
154 %{_mandir}/man1/rpdump.1*
155 %{_desktopdir}/%{name}.desktop
156 %{_pixmapsdir}/%{name}.png
157
158 %files -n pico
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/pico
161 %{_desktopdir}/pico.desktop
162 %{_mandir}/man1/pico*
163
164 %files -n pilot
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/pilot
167 %{_mandir}/man1/pilot*
This page took 0.383297 seconds and 4 git commands to generate.