]> git.pld-linux.org Git - packages/alpine.git/blame - alpine.spec
- change default thread ending character
[packages/alpine.git] / alpine.spec
CommitLineData
ecdbf6cc
PG
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
ecdbf6cc 4# - review patches from pine:
ffdc223c
PG
5# - home_etc support
6# - ....many more
02477d30 7Summary: University of Washington Pine mail user agent
84f5c30e 8Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
02477d30 9Name: alpine
db14e620 10%define ver 0.9999
28b69314 11%define patchlevel 18
db14e620 12Version: %{ver}.%{patchlevel}
19f73470 13Release: 1
ecdbf6cc
PG
14Epoch: 1
15License: Apache License 2.0
02477d30 16Group: Applications/Mail
19f73470
PG
17# Main site:
18#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19# Source with applied patches from http://staff.washington.edu/chappa/alpine/
db14e620 20Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
28b69314 21# Source0-md5: 888ecef4d50e15e4237f7a7a55793f68
ecdbf6cc 22Source1: pico.desktop
28b69314
PG
23Source2: %{name}.desktop
24Source3: %{name}.png
02477d30 25URL: http://www.washington.edu/alpine
c85f8efa
PG
26BuildRequires: autoconf
27BuildRequires: automake
84f5c30e 28BuildRequires: krb5-devel
02477d30
AM
29BuildRequires: ncurses-devel
30BuildRequires: openldap-devel
31BuildRequires: openssl-devel
02477d30 32BuildRequires: pam-devel
84f5c30e 33BuildRequires: tcl-devel
02477d30
AM
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
ecdbf6cc
PG
36%define alpineconfdir /etc/%{name}
37
02477d30
AM
38%description
39Alpine -- an Alternatively Licensed Program for Internet News & Email
40-- is a tool for reading, sending, and managing electronic messages.
41Alpine is the successor to Pine and was developed by Computing &
42Communications at the University of Washington. Though originally
43designed for inexperienced email users, Alpine supports many advanced
44features, and an ever-growing number of configuration and
45personal-preference options.
46
84f5c30e
JB
47%description -l pl.UTF-8
48Alpine, czyli Alternatively Licensed Program for Internet News & Email
49(alternatywnie licencjonowany program do newsów i poczty internetowej)
50to narzędzie do czytania, wysyłania i zarządzania wiadomościami
51elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
52wydział Computing & Communications (Obliczeń i komunikacji) na
53Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
54zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
55wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
56ciągle rośnie.
57
ecdbf6cc
PG
58%package -n pico
59Summary: Simple text editor in the style of the Pine Composer
60Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
61Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
62Group: Applications/Editors
63
64%description -n pico
65Pico is a simple, display-oriented text editor based on the Alpine
66message system composer. As with Pine, commands are displayed at the
67bottom of the screen, and context-sensitive help is provided. As
68characters are typed they are immediately inserted into the text.
69
70%description -n pico -l pl.UTF-8
71Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
72alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
73dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
74włączane do tekstu.
75
76%description -n pico -l pt_BR.UTF-8
77Pico é um editor de texto baseado no compositor de mensagens do Alpine.
78Assim como no Pine, comandos são mostrados na parte de baixo da tela,
79e ajuda de acordo com o contexto está disponível.
80
81%package -n pilot
82Summary: Simple file system browser in the style of the Alpine Composer
83Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
84Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
85Group: Applications/Shells
86
87%description -n pilot
88Pilot is a simple, display-oriented file system browser based on the
89Alpine message system composer. As with Alpine, commands are displayed at
90the bottom of the screen, and context-sensitive help is provided.
91
92%description -n pilot -l pl.UTF-8
93Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
94stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
95dole ekranu oraz jest dostępna pomoc kontekstowa.
96
97%description -n pilot -l pt_BR.UTF-8
98Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
99como no Pine, comandos são apresentados na parte de baixo da tela, e
100ajuda de acordo com o contexto está disponível.
101
02477d30 102%prep
db14e620 103%setup -q -n %{name}-%{ver}
02477d30
AM
104
105%build
c85f8efa
PG
106%{__autoconf}
107%{__aclocal} -I m4
108%{__automake}
02477d30
AM
109%configure \
110 --enable-quotas \
111 --with-smtp-msa=%{_libdir}/sendmail \
112 --with-spellcheck-prog=aspell \
ecdbf6cc
PG
113 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
114 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
02477d30
AM
115 --with-krb5-dir=%{_prefix} \
116 --with-ldap-dir=%{_prefix} \
117 --with-system-mail-directory=/var/mail
118%{__make}
119
120%install
121rm -rf $RPM_BUILD_ROOT
28b69314 122install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
02477d30
AM
123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
ecdbf6cc 127install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
28b69314
PG
128install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
129install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
130
ecdbf6cc 131
02477d30
AM
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(644,root,root,755)
ecdbf6cc
PG
137%doc README doc/tech-notes.txt
138%dir %{alpineconfdir}
28b69314 139%attr(755,root,root) %{_bindir}/%{name}
02477d30
AM
140%attr(755,root,root) %{_bindir}/rpload
141%attr(755,root,root) %{_bindir}/rpdump
ecdbf6cc
PG
142#%attr(755,root,root) %{_bindir}/mailutil
143#%attr(2755,root,mail) %{_sbindir}/mlock
28b69314 144%{_mandir}/man1/%{name}.1*
ecdbf6cc
PG
145#%{_mandir}/man1/rpload.1*
146#%{_mandir}/man1/rpdump.1*
147#%{_mandir}/man1/mailutil.1*
28b69314
PG
148%{_desktopdir}/%{name}.desktop
149%{_pixmapsdir}/%{name}.png
ecdbf6cc
PG
150
151%files -n pico
152%defattr(644,root,root,755)
153%attr(755,root,root) %{_bindir}/pico
154%{_desktopdir}/pico.desktop
155%{_mandir}/man1/pico*
156
157%files -n pilot
158%defattr(644,root,root,755)
159%attr(755,root,root) %{_bindir}/pilot
160%{_mandir}/man1/pilot*
This page took 0.057307 seconds and 4 git commands to generate.