]> git.pld-linux.org Git - packages/alpine.git/blame - alpine.spec
- chappa's patches added - starts to be usable now
[packages/alpine.git] / alpine.spec
CommitLineData
ecdbf6cc
PG
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
4# - pine -> alpine config converter
5# - review patches from pine:
ffdc223c
PG
6# - home_etc support
7# - ....many more
02477d30 8Summary: University of Washington Pine mail user agent
84f5c30e 9Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
02477d30
AM
10Name: alpine
11Version: 0.999
ffdc223c 12Release: 0.3
ecdbf6cc
PG
13Epoch: 1
14License: Apache License 2.0
02477d30
AM
15Group: Applications/Mail
16Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17# Source0-md5: 082de388a998c1faa2385ebdfd6800f5
ecdbf6cc 18Source1: pico.desktop
ffdc223c
PG
19# http://staff.washington.edu/chappa/alpine/info/all.html
20Patch0: http://staff.washington.edu/chappa/alpine/patches/%{name}-%{version}/all.patch.gz
02477d30 21URL: http://www.washington.edu/alpine
84f5c30e 22BuildRequires: krb5-devel
02477d30
AM
23BuildRequires: ncurses-devel
24BuildRequires: openldap-devel
25BuildRequires: openssl-devel
02477d30 26BuildRequires: pam-devel
84f5c30e 27BuildRequires: tcl-devel
02477d30
AM
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
ecdbf6cc
PG
30%define alpineconfdir /etc/%{name}
31
02477d30
AM
32%description
33Alpine -- an Alternatively Licensed Program for Internet News & Email
34-- is a tool for reading, sending, and managing electronic messages.
35Alpine is the successor to Pine and was developed by Computing &
36Communications at the University of Washington. Though originally
37designed for inexperienced email users, Alpine supports many advanced
38features, and an ever-growing number of configuration and
39personal-preference options.
40
84f5c30e
JB
41%description -l pl.UTF-8
42Alpine, czyli Alternatively Licensed Program for Internet News & Email
43(alternatywnie licencjonowany program do newsów i poczty internetowej)
44to narzędzie do czytania, wysyłania i zarządzania wiadomościami
45elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
46wydział Computing & Communications (Obliczeń i komunikacji) na
47Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
48zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
49wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
50ciągle rośnie.
51
ecdbf6cc
PG
52%package -n pico
53Summary: Simple text editor in the style of the Pine Composer
54Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
55Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
56Group: Applications/Editors
57
58%description -n pico
59Pico is a simple, display-oriented text editor based on the Alpine
60message system composer. As with Pine, commands are displayed at the
61bottom of the screen, and context-sensitive help is provided. As
62characters are typed they are immediately inserted into the text.
63
64%description -n pico -l pl.UTF-8
65Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
66alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
67dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
68włączane do tekstu.
69
70%description -n pico -l pt_BR.UTF-8
71Pico é um editor de texto baseado no compositor de mensagens do Alpine.
72Assim como no Pine, comandos são mostrados na parte de baixo da tela,
73e ajuda de acordo com o contexto está disponível.
74
75%package -n pilot
76Summary: Simple file system browser in the style of the Alpine Composer
77Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
78Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
79Group: Applications/Shells
80
81%description -n pilot
82Pilot is a simple, display-oriented file system browser based on the
83Alpine message system composer. As with Alpine, commands are displayed at
84the bottom of the screen, and context-sensitive help is provided.
85
86%description -n pilot -l pl.UTF-8
87Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
88stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
89dole ekranu oraz jest dostępna pomoc kontekstowa.
90
91%description -n pilot -l pt_BR.UTF-8
92Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
93como no Pine, comandos são apresentados na parte de baixo da tela, e
94ajuda de acordo com o contexto está disponível.
95
02477d30
AM
96%prep
97%setup -q
ffdc223c 98%patch0 -p1
02477d30
AM
99
100%build
101%configure \
102 --enable-quotas \
103 --with-smtp-msa=%{_libdir}/sendmail \
104 --with-spellcheck-prog=aspell \
ecdbf6cc
PG
105 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
106 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
02477d30
AM
107 --with-krb5-dir=%{_prefix} \
108 --with-ldap-dir=%{_prefix} \
109 --with-system-mail-directory=/var/mail
110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
ecdbf6cc 114install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir}}
02477d30
AM
115
116%{__make} install \
117 DESTDIR=$RPM_BUILD_ROOT
118
ecdbf6cc
PG
119install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
120
02477d30
AM
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%files
125%defattr(644,root,root,755)
ecdbf6cc
PG
126%doc README doc/tech-notes.txt
127%dir %{alpineconfdir}
02477d30 128%attr(755,root,root) %{_bindir}/alpine
02477d30
AM
129%attr(755,root,root) %{_bindir}/rpload
130%attr(755,root,root) %{_bindir}/rpdump
ecdbf6cc
PG
131#%attr(755,root,root) %{_bindir}/mailutil
132#%attr(2755,root,mail) %{_sbindir}/mlock
02477d30 133%{_mandir}/man1/alpine.1*
ecdbf6cc
PG
134#%{_mandir}/man1/rpload.1*
135#%{_mandir}/man1/rpdump.1*
136#%{_mandir}/man1/mailutil.1*
137
138%files -n pico
139%defattr(644,root,root,755)
140%attr(755,root,root) %{_bindir}/pico
141%{_desktopdir}/pico.desktop
142%{_mandir}/man1/pico*
143
144%files -n pilot
145%defattr(644,root,root,755)
146%attr(755,root,root) %{_bindir}/pilot
147%{_mandir}/man1/pilot*
This page took 0.060488 seconds and 4 git commands to generate.