]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- fixed xulrunner version
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
c0baf171 22%define enigmail_ver 1.4.1
64b4570d
JB
23%define nspr_ver 4.9
24%define nss_ver 3.13.3
44be9ed4 25
3815090b
ER
26# convert thunderbird release number to platform version: 12.0.x -> 12.0.x
27%define xulrunner_main 12.0
fb7d4f06 28%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#12.0})
4f34f106 29
7d981f69
ER
30%if %{without xulrunner}
31# The actual sqlite version (see RHBZ#480989):
32%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33%endif
34
44be9ed4 35Summary: Icedove - email client
36Summary(pl.UTF-8): Icedove - klient poczty
37Name: icedove
c0baf171 38Version: 12.0.1
3815090b 39Release: 1
44be9ed4 40License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 41Group: X11/Applications/Networking
cadfb931 42Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
c0baf171 43# Source0-md5: 64cacde4cb2b1e8736f1c3a0ea6a02db
44be9ed4 44Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
c0baf171 45# Source1-md5: 0eba75fbcf8f0bb32d538df102fbb8e9
44be9ed4 46Source2: %{name}-branding.tar.bz2
c105f759 47# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 48Source3: %{name}-rm_nonfree.sh
49Source4: %{name}.desktop
50Source5: %{name}.sh
44be9ed4 51Patch0: %{name}-branding.patch
faa5c89d 52Patch1: %{name}-enigmail-shared.patch
fac7e24d 53Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
54Patch3: %{name}-fonts.patch
55Patch4: %{name}-install.patch
5e9bb798 56Patch5: %{name}-hunspell.patch
faa5c89d 57Patch6: %{name}-prefs.patch
9a743685 58Patch7: system-mozldap.patch
a85e0ecb 59Patch8: %{name}-makefile.patch
3815090b
ER
60# this is only workaround, check if it is fixed with newer firefox
61Patch9: bug-722975-workaround.patch
ccc206fe 62Patch10: %{name}-extensiondir.patch
765a3a27 63Patch11: crashreporter.patch
268e7766 64Patch12: no-subshell.patch
5745d706 65URL: http://www.pld-linux.org/Packages/Icedove
6458b220 66BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 67BuildRequires: alsa-lib-devel
44be9ed4 68BuildRequires: automake
51a3b6db 69BuildRequires: bzip2-devel
e820c55e
JB
70BuildRequires: cairo-devel >= 1.10
71BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 72BuildRequires: freetype-devel >= 1:2.1.8
6458b220 73BuildRequires: glib2-devel >= 2.0
e820c55e 74BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 75BuildRequires: hunspell-devel
44be9ed4 76BuildRequires: libIDL-devel >= 0.8.0
6458b220 77%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 78%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 79%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 80BuildRequires: libiw-devel
44be9ed4 81BuildRequires: libjpeg-devel >= 6b
51a3b6db 82BuildRequires: libnotify-devel >= 0.4
e820c55e 83BuildRequires: libpng-devel >= 1.4.1
44be9ed4 84BuildRequires: libstdc++-devel
f4114a7f
ER
85BuildRequires: nspr-devel >= 1:%{nspr_ver}
86BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 87BuildRequires: pango-devel >= 1:1.14.0
e820c55e 88BuildRequires: perl-base >= 1:5.6
1c62cadb 89BuildRequires: pkgconfig
e820c55e 90BuildRequires: python >= 1:2.5
44be9ed4 91BuildRequires: sed >= 4.0
9d1bfad8 92BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 93BuildRequires: startup-notification-devel >= 0.8
44be9ed4 94BuildRequires: xorg-lib-libXext-devel
44be9ed4 95BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 96BuildRequires: xorg-lib-libXt-devel
5745d706 97BuildRequires: yasm
1c62cadb 98BuildRequires: zip
7d981f69 99%if %{with xulrunner}
4f34f106 100BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 101%else
44be9ed4 102Requires: myspell-common
f4114a7f
ER
103Requires: nspr >= 1:%{nspr_ver}
104Requires: nss >= 1:%{nss_ver}
4b6bc367 105Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 106%endif
4f34f106
ER
107Requires(post): mktemp >= 1.5-18
108%if %{with xulrunner}
109%requires_eq_to xulrunner xulrunner-devel
110%endif
44be9ed4 111Obsoletes: mozilla-thunderbird
112Obsoletes: mozilla-thunderbird-dictionary-en-US
113BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
9e366f18
AM
115%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
116
44be9ed4 117# iceweasel/icedove/iceape provide their own versions
44be9ed4 118%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
119%if %{without xulrunner}
120# we don't want these to satisfy packages depending on xulrunner
121%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 122# and as we don't provide them, don't require either
fb7d4f06
JB
123%define _noautoreq libmozalloc.so libxpcom.so libxul.so
124%endif
44be9ed4 125
9e7875fc
ER
126%define topdir %{_builddir}/%{name}-%{version}
127%define objdir %{topdir}/obj-%{_target_cpu}
128
44be9ed4 129%description
6b327de6 130Icedove is an open-source, fast and portable email client.
44be9ed4 131
132%description -l pl.UTF-8
6b327de6
JB
133Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
134poczty.
44be9ed4 135
6578c165 136%package addon-lightning
137Summary: An integrated calendar for Icedove
138Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
139License: MPL 1.1 or GPL v2+ or LGPL v2.1+
140Group: Applications/Networking
141Requires: %{name} = %{version}-%{release}
142
143%description addon-lightning
144Lightning is an calendar extension to Icedove email client.
145
146%description addon-lightning -l pl.UTF-8
147Lightning to rozszerzenie do klienta poczty Icedove dodające
148funkcjonalność kalendarza.
149
44be9ed4 150%package addon-enigmail
151Summary: Extension for the authentication and encryption features provided by GnuPG
152Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
153License: MPL/LGPL
154Group: Applications/Networking
155URL: http://enigmail.mozdev.org/
cd056caa 156Requires: %{name} = %{version}-%{release}
d076d93e 157Requires: gnupg
75991bbb 158Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 159
160%description addon-enigmail
c5e06599 161Enigmail is an extension to the Icedove mail client which allows users
162to access the authentication and encryption features provided by
163GnuPG.
44be9ed4 164
165Main Features:
166- Encrypt/sign mail when sending, decrypt/authenticate received mail
167- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
168- Per-Account based encryption and signing defaults
169- Per-Recipient rules for automated key selection, and
170 enabling/disabling encryption and signing
171- OpenPGP key management interface
172
173%description addon-enigmail -l pl.UTF-8
c5e06599 174Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
175użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
176przez GnuPG.
44be9ed4 177
178Główne możliwości:
179- szyfrowanie/podpisywanie poczty przy wysyłaniu,
180 odszyfrowywanie/uwierzytelnianie poczty odebranej
181- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
182- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
183- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
184 podpisywania dla każdego adresata
185- interfejs do zarządzania kluczami OpenPGP
186
187%prep
983562b1 188%setup -qc
f4114a7f 189mv comm-release mozilla
983562b1 190%setup -q -T -D -a2
191cd mozilla
1c70899a 192%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 193/bin/sh %{SOURCE3}
983562b1 194%patch0 -p1
faa5c89d 195%{?with_enigmail:%patch1 -p1}
73d54cb2 196%{?with_xulrunner:%patch2 -p1}
4ccc2157 197%patch3 -p1
faa5c89d 198%patch4 -p1
983562b1 199%patch6 -p1
9a743685 200%patch7 -p1
f4114a7f 201%patch8 -p2
3815090b
ER
202cd mozilla
203%patch9 -p1
204cd -
ccc206fe 205%patch10 -p2
765a3a27 206%patch11 -p2
268e7766 207%patch12 -p1
44be9ed4 208
209%build
983562b1 210cd mozilla
cadfb931
SP
211cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
212cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 213cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 214
fbac75ca 215cat << EOF > .mozconfig
9e7875fc 216mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 217
fac7e24d 218export CFLAGS="%{rpmcflags}"
73d54cb2 219export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
220
221%if %{with crashreporter}
222export MOZ_DEBUG_SYMBOLS=1
223%endif
224
59c5a0e8 225# Options for 'configure' (same as command-line options).
44be9ed4 226ac_add_options --prefix=%{_prefix}
227ac_add_options --exec-prefix=%{_exec_prefix}
228ac_add_options --bindir=%{_bindir}
229ac_add_options --sbindir=%{_sbindir}
230ac_add_options --sysconfdir=%{_sysconfdir}
231ac_add_options --datadir=%{_datadir}
232ac_add_options --includedir=%{_includedir}
233ac_add_options --libdir=%{_libdir}
234ac_add_options --libexecdir=%{_libexecdir}
235ac_add_options --localstatedir=%{_localstatedir}
236ac_add_options --sharedstatedir=%{_sharedstatedir}
237ac_add_options --mandir=%{_mandir}
238ac_add_options --infodir=%{_infodir}
239%if %{?debug:1}0
59c5a0e8 240ac_add_options --disable-optimize
44be9ed4 241ac_add_options --enable-debug
242ac_add_options --enable-debug-modules
59c5a0e8
SP
243ac_add_options --enable-debugger-info-modules
244ac_add_options --enable-crash-on-assert
44be9ed4 245%else
246ac_add_options --disable-debug
247ac_add_options --disable-debug-modules
59c5a0e8
SP
248ac_add_options --disable-logging
249ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 250%endif
88149483
ER
251ac_add_options --disable-strip
252ac_add_options --disable-strip-libs
44be9ed4 253%if %{with tests}
254ac_add_options --enable-tests
255%else
256ac_add_options --disable-tests
257%endif
6458b220 258ac_add_options --enable-gio
44be9ed4 259%if %{with gnomeui}
260ac_add_options --enable-gnomeui
261%else
262ac_add_options --disable-gnomeui
263%endif
44be9ed4 264ac_add_options --disable-gnomevfs
44be9ed4 265%if %{with ldap}
266ac_add_options --enable-ldap
9a743685 267ac_add_options --with-system-ldap
44be9ed4 268%else
269ac_add_options --disable-ldap
270%endif
765a3a27
ER
271%if %{with crashreporter}
272ac_add_options --enable-crashreporter
273%else
59c5a0e8 274ac_add_options --disable-crashreporter
765a3a27 275%endif
59c5a0e8 276ac_add_options --disable-xterm-updates
59c5a0e8 277ac_add_options --enable-postscript
d076d93e 278%if %{with lightning}
cb0e4412 279ac_add_options --enable-calendar
d076d93e
SP
280%else
281ac_add_options --disable-calendar
282%endif
44be9ed4 283ac_add_options --disable-installer
88149483 284ac_add_options --disable-updater
44be9ed4 285ac_add_options --disable-xprint
cadfb931
SP
286ac_add_options --disable-permissions
287ac_add_options --disable-pref-extensions
44be9ed4 288ac_add_options --enable-canvas
289ac_add_options --enable-crypto
44be9ed4 290ac_add_options --enable-mathml
44be9ed4 291ac_add_options --enable-pango
292ac_add_options --enable-reorder
88149483
ER
293ac_add_options --enable-startup-notification
294ac_add_options --enable-svg
44be9ed4 295ac_add_options --enable-system-cairo
5e9bb798 296ac_add_options --enable-system-hunspell
7d981f69 297ac_add_options --enable-system-sqlite
44be9ed4 298ac_add_options --enable-xft
cadfb931
SP
299ac_add_options --enable-application=mail
300ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 301ac_add_options --enable-xinerama
88149483
ER
302ac_add_options --with-distribution-id=org.pld-linux
303ac_add_options --with-branding=icedove/branding
304%if %{with xulrunner}
fac7e24d
JB
305ac_add_options --enable-shared-js
306ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 307ac_add_options --with-system-libxul
88149483
ER
308%endif
309ac_add_options --with-pthreads
310ac_add_options --with-system-bz2
44be9ed4 311ac_add_options --with-system-jpeg
312ac_add_options --with-system-nspr
313ac_add_options --with-system-nss
314ac_add_options --with-system-png
315ac_add_options --with-system-zlib
44be9ed4 316ac_add_options --enable-single-profile
317ac_add_options --disable-profilesharing
44be9ed4 318ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
319EOF
320
90e998ba 321%{__make} -j1 -f client.mk build \
d076d93e 322 STRIP="/bin/true" \
765a3a27 323 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 324 CC="%{__cc}" \
44be9ed4 325 CXX="%{__cxx}"
326
765a3a27
ER
327%if %{with crashreporter}
328# create debuginfo for crash-stats.mozilla.com
329%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
330%endif
331
44be9ed4 332%if %{with enigmail}
59c5a0e8 333cd mailnews/extensions/enigmail
9e7875fc
ER
334./makemake -r -o %{objdir}
335%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
336 STRIP="/bin/true" \
337 CC="%{__cc}" \
338 CXX="%{__cxx}"
44be9ed4 339%endif
340
341%install
342rm -rf $RPM_BUILD_ROOT
765a3a27 343install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 344
9e7875fc 345cd %{objdir}
ecf04393 346%{__make} -C mail/installer stage-package \
44be9ed4 347 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 348 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 349 PKG_SKIP_STRIP=1
350
9b40a2c3
JB
351%if %{with xulrunner}
352# needed to find mozilla runtime
353ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
354%endif
355
356# Enable crash reporter for Thunderbird application
765a3a27
ER
357%if %{with crashreporter}
358%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
359
360# Add debuginfo for crash-stats.mozilla.com
51a3b6db 361install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
362cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
363%endif
364
ecf04393
ER
365# copy manually lightning files, somewhy they are not installed by make
366cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
367 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
368 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
369
44be9ed4 370# move arch independant ones to datadir
371mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
372mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 373mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 374mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 375mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 376ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
377ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 378ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 379ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 380ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
381%if %{without xulrunner}
382mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
383ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
384%endif
44be9ed4 385
c6ec3c1c
ER
386# dir for arch independant extensions besides arch dependant extensions
387# see mozilla/xpcom/build/nsXULAppAPI.h
388# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
389install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
390
73d54cb2 391%if %{without xulrunner}
63d8f5c3 392%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 393ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
394%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
395ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 396%endif
e6bc19b3 397
44be9ed4 398%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
399ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
400ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
401
52f5507d
ER
402cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
403cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 404
e8f4ba81 405# files created by regxpcom -register in post
52fc61e6
ER
406touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
407touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
408cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
409#!/bin/sh
410umask 022
411# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
412# dangerous if you run this with sudo with keep_env += HOME
413# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
414t=$(mktemp -d)
d50a2a28 415%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
416TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
417rm -rf $t
418EOF
419chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 420
44be9ed4 421%if %{with enigmail}
283702b9
ER
422ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
423install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 424cd mozilla/dist/bin
0516fc42 425#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
426#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
427cp -rfLp components/enig* $ext_dir/components
428cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 429cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
430cp -rfLp components/ipc.xpt $ext_dir/components
431cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
432cd -
52f5507d
ER
433cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
434cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 435%endif
436
9cdc8923
ER
437# never package these. always remove
438# nss
439%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
440# nspr
441%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 442# mozldap
9cdc8923 443%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
444# testpilot quiz
445%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 446
44be9ed4 447%clean
448rm -rf $RPM_BUILD_ROOT
449
450%pretrans
451if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
452 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
453fi
eca54e0f 454for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 455 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
456 install -d %{_datadir}/%{name}
457 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
458 fi
459done
460exit 0
461
e8f4ba81
ER
462%post
463%{_libdir}/%{name}/register || :
464
44be9ed4 465%files
466%defattr(644,root,root,755)
467%attr(755,root,root) %{_bindir}/icedove
468%attr(755,root,root) %{_bindir}/mozilla-thunderbird
469%attr(755,root,root) %{_bindir}/thunderbird
470%dir %{_libdir}/%{name}
765a3a27 471%{_libdir}/%{name}/application.ini
6b327de6
JB
472%{_libdir}/%{name}/blocklist.xml
473%{_libdir}/%{name}/chrome.manifest
44be9ed4 474%dir %{_libdir}/%{name}/components
44be9ed4 475%{_libdir}/%{name}/components/*.js
476%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
477%{_libdir}/%{name}/components/components.manifest
478%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
479%attr(755,root,root) %{_libdir}/%{name}/*.sh
480%attr(755,root,root) %{_libdir}/%{name}/*-bin
481%attr(755,root,root) %{_libdir}/%{name}/icedove
482%attr(755,root,root) %{_libdir}/%{name}/register
483%if %{without xulrunner}
484%{_libdir}/%{name}/platform.ini
485%{_libdir}/%{name}/greprefs.js
486%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 487%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 488%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 489%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 490%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 491%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 492%endif
44be9ed4 493
494# symlinks
495%{_libdir}/%{name}/chrome
496%{_libdir}/%{name}/defaults
44be9ed4 497%{_libdir}/%{name}/isp
9e097178 498%{_libdir}/%{name}/modules
eca54e0f 499%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
500%if %{with xulrunner}
501%{_libdir}/%{name}/xulrunner
502%else
73d54cb2
JB
503%{_libdir}/%{name}/dictionaries
504%{_libdir}/%{name}/hyphenation
505%{_libdir}/%{name}/res
506%endif
44be9ed4 507
224cf96a
JB
508%{_pixmapsdir}/icedove.png
509%{_desktopdir}/icedove.desktop
44be9ed4 510
511%dir %{_datadir}/%{name}
512%{_datadir}/%{name}/chrome
513%{_datadir}/%{name}/defaults
eca54e0f 514%{_datadir}/%{name}/extensions
44be9ed4 515%{_datadir}/%{name}/isp
9e097178 516%{_datadir}/%{name}/modules
eca54e0f 517%{_datadir}/%{name}/searchplugins
73d54cb2
JB
518%if %{without xulrunner}
519%{_datadir}/%{name}/res
520%endif
44be9ed4 521
765a3a27
ER
522%if %{with crashreporter}
523%attr(755,root,root) %{_libdir}/%{name}/crashreporter
524%{_libdir}/%{name}/crashreporter.ini
525%{_libdir}/%{name}/Throbber-small.gif
526%endif
527
44be9ed4 528%dir %{_libdir}/%{name}/extensions
529%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 530
52fc61e6
ER
531# files created by regxpcom -register
532%ghost %{_libdir}/%{name}/components/compreg.dat
533%ghost %{_libdir}/%{name}/components/xpti.dat
534
6578c165 535%if %{with lightning}
536%files addon-lightning
537%defattr(644,root,root,755)
f3b6d696 538%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 542%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
543%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
544%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
545%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 546%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
547%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
548%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
549%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
550%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
551%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 552%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
553%endif
44be9ed4 554
555%if %{with enigmail}
556%files addon-enigmail
557%defattr(644,root,root,755)
f6a43e2f
ER
558%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
559%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
560%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
561%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
562%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
563%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
564%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
565%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
566%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 567%endif
This page took 0.261638 seconds and 4 git commands to generate.