]> git.pld-linux.org Git - packages/cmake.git/blame - cmake.spec
- extend lib64 patch with minor fix for zlib
[packages/cmake.git] / cmake.spec
CommitLineData
d1b2e54c
JB
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
ccca321d
KK
6#
7# Conditional build:
b563f9dc
JB
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
eead9c17 10%bcond_without tests # do not perform "make test"
90b41c6c 11%bcond_without doc # don't build documentation
77f8acdd 12
efafbc62 13Summary: Cross-platform, open-source make system
ac3ea35a 14Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
72a696fa 15Name: cmake
cda7a827 16Version: 3.1.0
aed8617e 17Release: 2
efafbc62 18License: BSD
72a696fa 19Group: Development/Building
cda7a827
AM
20Source0: http://www.cmake.org/files/v3.1/%{name}-%{version}.tar.gz
21# Source0-md5: 188eb7dc9b1b82b363bc51c0d3f1d461
6342daf8 22Patch0: %{name}-lib64.patch
9ec4f08d 23Patch1: %{name}-helpers.patch
de784c58
JB
24Patch2: %{name}-findruby.patch
25Patch3: %{name}-tests.patch
aed8617e 26Patch4: %{name}-bug-0015258.patch
a048aac3 27Patch5: %{name}-findruby2.patch
1269f267 28Patch6: %{name}-findpython.patch
90b41c6c 29Patch7: %{name}-libx32.patch
a315a797 30URL: http://www.cmake.org/
33042d59 31%{?with_gui:BuildRequires: QtGui-devel}
fef12180 32BuildRequires: libarchive-devel
ece9e155 33BuildRequires: libstdc++-devel
59917d1a 34BuildRequires: ncurses-devel > 5.9-3
33042d59
KK
35%{?with_gui:BuildRequires: qt4-build}
36%{?with_gui:BuildRequires: qt4-qmake}
ece9e155 37BuildRequires: rpmbuild(macros) >= 1.167
90b41c6c 38%{?with_doc:BuildRequires: sphinx-pdg}
ab02ad6a 39%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
75cb386f 40Requires: filesystem >= 3.0-52
efafbc62 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3fcbc09a
AG
42
43%description
efafbc62
AG
44CMake is used to control the software compilation process using simple
45platform and compiler independent configuration files. CMake generates
46native makefiles and workspaces that can be used in the compiler
47environment of your choice. CMake is quite sophisticated: it is
48possible to support complex environments requiring system
49configuration, pre-processor generation, code generation, and template
50instantiation.
3fcbc09a 51
520c9eb8
JR
52%description -l pl.UTF-8
53CMake służy do sterowania procesem kompilacji oprogramowania przy
ca760f29 54użyciu prostych plików konfiguracyjnych niezależnych od platformy i
55kompilatora. CMake generuje natywne pliki makefile i workspace,
485d9a7a 56których można używać w wybranym środowisku kompilatora. CMake jest
59787775 57dość wyrafinowany: może obsłużyć złożone środowiska wymagające
ca760f29 58konfiguracji systemu, generowanie preprocesora, generowanie kodu i
59dziedziczenie szablonów.
33042d59 60
fe46a853
JB
61%package doc-html
62Summary: CMake documentation in HTML format
63Summary(pl.UTF-8): Dokumentacja do pakietu CMake w formacie HTML
64Group: Documentation
65
66%description doc-html
67CMake documentation in HTML format.
68
69%description doc-html -l pl.UTF-8
70Dokumentacja do pakietu CMake w formacie HTML.
71
33042d59 72%package gui
b563f9dc
JB
73Summary: Qt GUI for CMake
74Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
33042d59
KK
75Group: Development/Tools
76Requires: %{name} = %{version}-%{release}
77
b563f9dc
JB
78%description gui
79This package contains the Qt based GUI for CMake.
80
81%description gui -l pl.UTF-8
82Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
83CMake.
72a696fa 84
9ec4f08d 85%package emacs
69d19c08
JB
86Summary: Emacs mode for cmake files
87Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
9ec4f08d
KK
88Group: Development/Tools
89
90%description emacs
69d19c08
JB
91Emacs mode for cmake files.
92
93%description emacs -l pl.UTF-8
94Tryb Emacsa dla plików cmake'a.
9ec4f08d
KK
95
96%package -n bash-completion-%{name}
97Summary: bash-completion for cmake
69d19c08 98Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
9ec4f08d 99Group: Applications/Shells
69d19c08 100Requires: %{name} = %{version}-%{release}
a9b1845f 101Requires: bash-completion >= 2.0
6465d90a
ER
102%if "%{_rpmversion}" >= "5"
103BuildArch: noarch
104%endif
9ec4f08d
KK
105
106%description -n bash-completion-%{name}
69d19c08
JB
107bash-completion for cmake.
108
109%description -n bash-completion-%{name} -l pl.UTF-8
110Bashowe dopełnianie parametrów dla cmake'a.
9ec4f08d 111
3fcbc09a 112%prep
923851a2 113%setup -q
286b1479 114%if "%{_lib}" == "lib64"
6342daf8 115%patch0 -p1
286b1479 116%endif
9ec4f08d 117%patch1 -p1
fe667d6f 118%patch2 -p1
de784c58 119%patch3 -p1
aed8617e 120%patch4 -p1
a048aac3 121%patch5 -p1
1269f267 122%patch6 -p1
90b41c6c
JR
123%if "%{_lib}" == "libx32"
124%patch7 -p1
125%endif
3fcbc09a 126
ece9e155 127cat > "init.cmake" <<EOF
286b1479 128SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
9ec4f08d
KK
129SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
130SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
ece9e155
KK
131EOF
132
b343cdb1
JR
133# cleanup backups after patching, modules are copied as-is
134find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
135
3fcbc09a 136%build
ece9e155
KK
137export CC="%{__cc}"
138export CXX="%{__cxx}"
139export CFLAGS="%{rpmcflags}"
140export CXXFLAGS="%{rpmcxxflags}"
ccca321d 141export LDFLAGS="%{rpmldflags}"
923851a2
AG
142./bootstrap \
143 --prefix=%{_prefix} \
144 --mandir=/share/man \
145 --datadir=/share/cmake \
ece9e155 146 --init=init.cmake \
c342f103 147 %{!?with_bootstrap:--system-libs} \
33042d59 148 %{?with_gui:--qt-gui} \
08bb5e07 149 --qt-qmake=/usr/bin/qmake-qt4 \
90b41c6c
JR
150 %{?with_doc:--sphinx-html} \
151 %{?with_doc:--sphinx-man} \
923851a2
AG
152 --verbose
153
28f0bd6c 154%{__make} VERBOSE=1
3fcbc09a 155
1fbe3ed6
AM
156%{?with_tests:%{__make} test}
157
3fcbc09a 158%install
efafbc62 159rm -rf $RPM_BUILD_ROOT
72a696fa
JB
160%{__make} install \
161 DESTDIR=$RPM_BUILD_ROOT
162
75cb386f 163%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
3fcbc09a
AG
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%files
efafbc62 169%defattr(644,root,root,755)
fe46a853 170%doc Copyright.txt README.rst *.gif
72a696fa
JB
171%attr(755,root,root) %{_bindir}/ccmake
172%attr(755,root,root) %{_bindir}/cmake
08b6790a 173%attr(755,root,root) %{_bindir}/cpack
72a696fa 174%attr(755,root,root) %{_bindir}/ctest
90b41c6c 175%if %{with doc}
08bb5e07
JB
176%{_mandir}/man1/ccmake.1*
177%{_mandir}/man1/cmake.1*
08bb5e07
JB
178%{_mandir}/man1/cpack.1*
179%{_mandir}/man1/ctest.1*
fe46a853
JB
180%{_mandir}/man7/cmake-buildsystem.7*
181%{_mandir}/man7/cmake-commands.7*
cda7a827 182%{_mandir}/man7/cmake-compile-features.7*
fe46a853
JB
183%{_mandir}/man7/cmake-developer.7*
184%{_mandir}/man7/cmake-generator-expressions.7*
185%{_mandir}/man7/cmake-generators.7*
186%{_mandir}/man7/cmake-language.7*
187%{_mandir}/man7/cmake-modules.7*
188%{_mandir}/man7/cmake-packages.7*
189%{_mandir}/man7/cmake-policies.7*
190%{_mandir}/man7/cmake-properties.7*
191%{_mandir}/man7/cmake-qt.7*
192%{_mandir}/man7/cmake-toolchains.7*
193%{_mandir}/man7/cmake-variables.7*
90b41c6c 194%endif
b24a2e64
JB
195# top cmake/Modules dirs belong to filesystem
196%{_datadir}/cmake/Modules/.NoDartCoverage
197%{_datadir}/cmake/Modules/*
198%{_datadir}/cmake/Templates
f13d1e41 199%{_datadir}/cmake/editors
b24a2e64 200%{_datadir}/cmake/include
09f5d631 201%{_aclocaldir}/cmake.m4
33042d59 202
90b41c6c 203%if %{with doc}
fe46a853
JB
204%files doc-html
205%defattr(644,root,root,755)
206%doc Utilities/Sphinx/html/*
90b41c6c 207%endif
fe46a853 208
1a3a9dcd 209%if %{with gui}
33042d59
KK
210%files gui
211%defattr(644,root,root,755)
212%attr(755,root,root) %{_bindir}/cmake-gui
fe46a853 213%{_datadir}/cmake/Help
33042d59
KK
214%{_datadir}/mime/packages/cmakecache.xml
215%{_desktopdir}/CMake.desktop
ca760f29 216%{_pixmapsdir}/CMakeSetup32.png
08bb5e07 217%{_mandir}/man1/cmake-gui.1*
1a3a9dcd 218%endif
9ec4f08d
KK
219
220%files emacs
221%defattr(644,root,root,755)
222%{_datadir}/emacs/site-lisp/cmake-mode.el
223
224%files -n bash-completion-%{name}
225%defattr(644,root,root,755)
a9b1845f
JB
226%{_datadir}/bash-completion/completions/cmake
227%{_datadir}/bash-completion/completions/cpack
228%{_datadir}/bash-completion/completions/ctest
This page took 0.365773 seconds and 4 git commands to generate.