]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- do not package README.txt
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
e820c55e 4# - replace gnome-vfs2 with gio
af42cf6d 5# - files:
af42cf6d 6# /usr/lib/icedove/hyphenation/hyph_en_US.dic
c4ddd260 7#
44be9ed4 8# Conditional builds
9%bcond_without enigmail # don't build enigmail - GPG/PGP support
10%bcond_without gnomeui # disable gnomeui support
11%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
12%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
13%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 14%bcond_without lightning # disable Sunbird/Lightning calendar
f4114a7f 15%bcond_without xulrunner # build with xulrunner
765a3a27 16%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 17
44be9ed4 18%if %{without gnome}
19%undefine with_gnomeui
20%undefine with_gnomevfs
21%endif
88149483 22
f4114a7f 23%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
24%undefine crashreporter
25%endif
26
9bdca747 27%define enigmail_ver 1.3.2
af42cf6d
JB
28%define nspr_ver 4.8.8
29%define nss_ver 3.12.10
44be9ed4 30
af42cf6d 31# convert firefox release number to platform version: 7.0.x -> 7.0.x
93c0bbc5 32%define xulrunner_main 8.0
33%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#8.0})
4f34f106 34
7d981f69
ER
35%if %{without xulrunner}
36# The actual sqlite version (see RHBZ#480989):
37%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
38%endif
39
44be9ed4 40Summary: Icedove - email client
41Summary(pl.UTF-8): Icedove - klient poczty
42Name: icedove
93c0bbc5 43Version: 8.0
af42cf6d 44Release: 0.1
44be9ed4 45License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 46Group: X11/Applications/Networking
cadfb931 47Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
93c0bbc5 48# Source0-md5: 332f60036aebdce7dec6ee2b1af4941d
44be9ed4 49Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
9bdca747 50# Source1-md5: 2318d60320dc6c3db3c34d968bb7d533
44be9ed4 51Source2: %{name}-branding.tar.bz2
c105f759 52# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 53Source3: %{name}-rm_nonfree.sh
54Source4: %{name}.desktop
55Source5: %{name}.sh
44be9ed4 56Patch0: %{name}-branding.patch
faa5c89d
SP
57Patch1: %{name}-enigmail-shared.patch
58Patch2: %{name}-gcc.patch
59Patch3: %{name}-fonts.patch
60Patch4: %{name}-install.patch
5e9bb798 61Patch5: %{name}-hunspell.patch
faa5c89d 62Patch6: %{name}-prefs.patch
9a743685 63Patch7: system-mozldap.patch
a85e0ecb 64Patch8: %{name}-makefile.patch
ccc206fe 65Patch10: %{name}-extensiondir.patch
765a3a27 66Patch11: crashreporter.patch
268e7766 67Patch12: no-subshell.patch
5745d706 68URL: http://www.pld-linux.org/Packages/Icedove
071d16e9 69%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
51a3b6db 70BuildRequires: alsa-lib-devel
44be9ed4 71BuildRequires: automake
51a3b6db 72BuildRequires: bzip2-devel
e820c55e
JB
73BuildRequires: cairo-devel >= 1.10
74BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 75BuildRequires: freetype-devel >= 1:2.1.8
76%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
e820c55e 77BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 78BuildRequires: hunspell-devel
44be9ed4 79BuildRequires: libIDL-devel >= 0.8.0
80%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 81%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 82%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 83BuildRequires: libiw-devel
44be9ed4 84BuildRequires: libjpeg-devel >= 6b
51a3b6db 85BuildRequires: libnotify-devel >= 0.4
e820c55e 86BuildRequires: libpng-devel >= 1.4.1
44be9ed4 87BuildRequires: libstdc++-devel
f4114a7f
ER
88BuildRequires: nspr-devel >= 1:%{nspr_ver}
89BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 90BuildRequires: pango-devel >= 1:1.1.0
e820c55e 91BuildRequires: perl-base >= 1:5.6
1c62cadb 92BuildRequires: pkgconfig
e820c55e 93BuildRequires: python >= 1:2.5
44be9ed4 94BuildRequires: sed >= 4.0
9d1bfad8 95BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 96BuildRequires: startup-notification-devel >= 0.8
44be9ed4 97BuildRequires: xorg-lib-libXext-devel
44be9ed4 98BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 99BuildRequires: xorg-lib-libXt-devel
5745d706 100BuildRequires: yasm
1c62cadb 101BuildRequires: zip
7d981f69 102%if %{with xulrunner}
4f34f106 103BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 104%else
44be9ed4 105Requires: myspell-common
f4114a7f
ER
106Requires: nspr >= 1:%{nspr_ver}
107Requires: nss >= 1:%{nss_ver}
4b6bc367 108Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 109%endif
4f34f106
ER
110Requires(post): mktemp >= 1.5-18
111%if %{with xulrunner}
112%requires_eq_to xulrunner xulrunner-devel
113%endif
44be9ed4 114Obsoletes: mozilla-thunderbird
115Obsoletes: mozilla-thunderbird-dictionary-en-US
116BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
9e366f18
AM
118%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
119
44be9ed4 120# iceweasel/icedove/iceape provide their own versions
c072808a 121%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 122%define _noautoprovfiles %{_libdir}/%{name}/components
123# we don't want these to satisfy xulrunner-devel
c072808a 124%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 125# and as we don't provide them, don't require either
c072808a 126%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 127
9e7875fc
ER
128%define topdir %{_builddir}/%{name}-%{version}
129%define objdir %{topdir}/obj-%{_target_cpu}
130
44be9ed4 131%description
6b327de6 132Icedove is an open-source, fast and portable email client.
44be9ed4 133
134%description -l pl.UTF-8
6b327de6
JB
135Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
136poczty.
44be9ed4 137
6578c165 138%package addon-lightning
139Summary: An integrated calendar for Icedove
140Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
141License: MPL 1.1 or GPL v2+ or LGPL v2.1+
142Group: Applications/Networking
143Requires: %{name} = %{version}-%{release}
144
145%description addon-lightning
146Lightning is an calendar extension to Icedove email client.
147
148%description addon-lightning -l pl.UTF-8
149Lightning to rozszerzenie do klienta poczty Icedove dodające
150funkcjonalność kalendarza.
151
44be9ed4 152%package addon-enigmail
153Summary: Extension for the authentication and encryption features provided by GnuPG
154Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
155License: MPL/LGPL
156Group: Applications/Networking
157URL: http://enigmail.mozdev.org/
cd056caa 158Requires: %{name} = %{version}-%{release}
d076d93e 159Requires: gnupg
75991bbb 160Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 161
162%description addon-enigmail
c5e06599 163Enigmail is an extension to the Icedove mail client which allows users
164to access the authentication and encryption features provided by
165GnuPG.
44be9ed4 166
167Main Features:
168- Encrypt/sign mail when sending, decrypt/authenticate received mail
169- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
170- Per-Account based encryption and signing defaults
171- Per-Recipient rules for automated key selection, and
172 enabling/disabling encryption and signing
173- OpenPGP key management interface
174
175%description addon-enigmail -l pl.UTF-8
c5e06599 176Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
177użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
178przez GnuPG.
44be9ed4 179
180Główne możliwości:
181- szyfrowanie/podpisywanie poczty przy wysyłaniu,
182 odszyfrowywanie/uwierzytelnianie poczty odebranej
183- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
184- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
185- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
186 podpisywania dla każdego adresata
187- interfejs do zarządzania kluczami OpenPGP
188
189%prep
983562b1 190%setup -qc
f4114a7f 191mv comm-release mozilla
983562b1 192%setup -q -T -D -a2
193cd mozilla
1c70899a 194%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 195/bin/sh %{SOURCE3}
983562b1 196%patch0 -p1
faa5c89d
SP
197%{?with_enigmail:%patch1 -p1}
198%patch2 -p1
4ccc2157 199%patch3 -p1
faa5c89d 200%patch4 -p1
983562b1 201%patch6 -p1
9a743685 202%patch7 -p1
f4114a7f 203%patch8 -p2
ccc206fe 204%patch10 -p2
765a3a27 205%patch11 -p2
268e7766 206%patch12 -p1
44be9ed4 207
208%build
983562b1 209cd mozilla
cadfb931
SP
210cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 212cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 213
9a743685
ER
214install -d libxul-sdk
215ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 216
fbac75ca 217cat << EOF > .mozconfig
9e7875fc 218mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 219
5745d706 220export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
221export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
765a3a27
ER
222
223%if %{with crashreporter}
224export MOZ_DEBUG_SYMBOLS=1
225%endif
226
59c5a0e8 227# Options for 'configure' (same as command-line options).
44be9ed4 228ac_add_options --prefix=%{_prefix}
229ac_add_options --exec-prefix=%{_exec_prefix}
230ac_add_options --bindir=%{_bindir}
231ac_add_options --sbindir=%{_sbindir}
232ac_add_options --sysconfdir=%{_sysconfdir}
233ac_add_options --datadir=%{_datadir}
234ac_add_options --includedir=%{_includedir}
235ac_add_options --libdir=%{_libdir}
236ac_add_options --libexecdir=%{_libexecdir}
237ac_add_options --localstatedir=%{_localstatedir}
238ac_add_options --sharedstatedir=%{_sharedstatedir}
239ac_add_options --mandir=%{_mandir}
240ac_add_options --infodir=%{_infodir}
241%if %{?debug:1}0
59c5a0e8 242ac_add_options --disable-optimize
44be9ed4 243ac_add_options --enable-debug
244ac_add_options --enable-debug-modules
59c5a0e8
SP
245ac_add_options --enable-debugger-info-modules
246ac_add_options --enable-crash-on-assert
44be9ed4 247%else
248ac_add_options --disable-debug
249ac_add_options --disable-debug-modules
59c5a0e8
SP
250ac_add_options --disable-logging
251ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 252%endif
88149483
ER
253ac_add_options --disable-strip
254ac_add_options --disable-strip-libs
44be9ed4 255%if %{with tests}
256ac_add_options --enable-tests
257%else
258ac_add_options --disable-tests
259%endif
260%if %{with gnomeui}
261ac_add_options --enable-gnomeui
262%else
263ac_add_options --disable-gnomeui
264%endif
265%if %{with gnomevfs}
266ac_add_options --enable-gnomevfs
267%else
268ac_add_options --disable-gnomevfs
269%endif
270%if %{with ldap}
271ac_add_options --enable-ldap
9a743685 272ac_add_options --with-system-ldap
44be9ed4 273%else
274ac_add_options --disable-ldap
275%endif
765a3a27
ER
276%if %{with crashreporter}
277ac_add_options --enable-crashreporter
278%else
59c5a0e8 279ac_add_options --disable-crashreporter
765a3a27 280%endif
59c5a0e8 281ac_add_options --disable-xterm-updates
59c5a0e8 282ac_add_options --enable-postscript
d076d93e 283%if %{with lightning}
cb0e4412 284ac_add_options --enable-calendar
d076d93e
SP
285%else
286ac_add_options --disable-calendar
287%endif
44be9ed4 288ac_add_options --disable-installer
289ac_add_options --disable-jsd
88149483 290ac_add_options --disable-updater
44be9ed4 291ac_add_options --disable-xprint
cadfb931
SP
292ac_add_options --disable-permissions
293ac_add_options --disable-pref-extensions
44be9ed4 294ac_add_options --enable-canvas
295ac_add_options --enable-crypto
44be9ed4 296ac_add_options --enable-mathml
44be9ed4 297ac_add_options --enable-pango
298ac_add_options --enable-reorder
88149483
ER
299ac_add_options --enable-startup-notification
300ac_add_options --enable-svg
44be9ed4 301ac_add_options --enable-system-cairo
5e9bb798 302ac_add_options --enable-system-hunspell
7d981f69 303ac_add_options --enable-system-sqlite
44be9ed4 304ac_add_options --enable-xft
cadfb931
SP
305ac_add_options --enable-application=mail
306ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 307ac_add_options --enable-xinerama
88149483
ER
308ac_add_options --with-distribution-id=org.pld-linux
309ac_add_options --with-branding=icedove/branding
310%if %{with xulrunner}
f4114a7f
ER
311#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
312ac_add_options --with-system-libxul
fbac75ca 313ac_add_options --enable-shared
f4114a7f 314ac_add_options --enable-libxul
fbac75ca 315%else
f4114a7f 316ac_add_options --disable-xul
88149483
ER
317%endif
318ac_add_options --with-pthreads
319ac_add_options --with-system-bz2
44be9ed4 320ac_add_options --with-system-jpeg
321ac_add_options --with-system-nspr
322ac_add_options --with-system-nss
323ac_add_options --with-system-png
324ac_add_options --with-system-zlib
44be9ed4 325ac_add_options --enable-single-profile
326ac_add_options --disable-profilesharing
44be9ed4 327ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
328EOF
329
90e998ba 330%{__make} -j1 -f client.mk build \
d076d93e 331 STRIP="/bin/true" \
765a3a27 332 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 333 CC="%{__cc}" \
44be9ed4 334 CXX="%{__cxx}"
335
765a3a27
ER
336%if %{with crashreporter}
337# create debuginfo for crash-stats.mozilla.com
338%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
339%endif
340
44be9ed4 341%if %{with enigmail}
59c5a0e8 342cd mailnews/extensions/enigmail
9e7875fc
ER
343./makemake -r -o %{objdir}
344%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
345 STRIP="/bin/true" \
346 CC="%{__cc}" \
347 CXX="%{__cxx}"
44be9ed4 348%endif
349
350%install
351rm -rf $RPM_BUILD_ROOT
765a3a27 352install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 353
9e7875fc 354cd %{objdir}
ecf04393 355%{__make} -C mail/installer stage-package \
44be9ed4 356 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 357 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 358 PKG_SKIP_STRIP=1
359
765a3a27
ER
360# Enable crash reporter for Firefox application
361%if %{with crashreporter}
362%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
363
364# Add debuginfo for crash-stats.mozilla.com
51a3b6db 365install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
366cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
367%endif
368
ecf04393
ER
369# copy manually lightning files, somewhy they are not installed by make
370cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
371 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
372 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
373
44be9ed4 374# move arch independant ones to datadir
375mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
376mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 377mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 378mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 379mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
380ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
381ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 382ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 383ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 384ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
385
c6ec3c1c
ER
386# dir for arch independant extensions besides arch dependant extensions
387# see mozilla/xpcom/build/nsXULAppAPI.h
388# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
389install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
390
63d8f5c3 391%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 392ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
393
394%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
395ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
396ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
397
52f5507d
ER
398cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
399cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 400
e8f4ba81 401# files created by regxpcom -register in post
52fc61e6
ER
402touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
403touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
404cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
405#!/bin/sh
406umask 022
407# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
408# dangerous if you run this with sudo with keep_env += HOME
409# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
410t=$(mktemp -d)
d50a2a28 411%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
412TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
413rm -rf $t
414EOF
415chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 416
44be9ed4 417%if %{with enigmail}
283702b9
ER
418ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
419install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 420cd mozilla/dist/bin
0516fc42 421#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
422#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
423cp -rfLp components/enig* $ext_dir/components
424cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 425cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
426cp -rfLp components/ipc.xpt $ext_dir/components
427cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
428cd -
52f5507d
ER
429cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
430cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 431%endif
432
9a743685 433# remove unecessary stuff
9e402408 434#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
0516fc42 435#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
436#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 437
9cdc8923
ER
438# never package these. always remove
439# nss
440%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
441# nspr
442%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 443# mozldap
9cdc8923 444%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 445
44be9ed4 446%clean
447rm -rf $RPM_BUILD_ROOT
448
449%pretrans
450if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
451 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
452fi
6b327de6 453for d in chrome defaults icons isp modules res; do
44be9ed4 454 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
455 install -d %{_datadir}/%{name}
456 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
457 fi
458done
459exit 0
460
e8f4ba81
ER
461%post
462%{_libdir}/%{name}/register || :
463
44be9ed4 464%files
465%defattr(644,root,root,755)
466%attr(755,root,root) %{_bindir}/icedove
467%attr(755,root,root) %{_bindir}/mozilla-thunderbird
468%attr(755,root,root) %{_bindir}/thunderbird
469%dir %{_libdir}/%{name}
765a3a27
ER
470%{_libdir}/%{name}/application.ini
471%{_libdir}/%{name}/platform.ini
6b327de6
JB
472%{_libdir}/%{name}/blocklist.xml
473%{_libdir}/%{name}/chrome.manifest
474%{_libdir}/%{name}/greprefs.js
44be9ed4 475%dir %{_libdir}/%{name}/components
476%attr(755,root,root) %{_libdir}/%{name}/components/*.so
477%{_libdir}/%{name}/components/*.js
478%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
479%{_libdir}/%{name}/components/components.manifest
480%{_libdir}/%{name}/components/interfaces.manifest
0516fc42 481%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
482#%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
283702b9 483%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 484#%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
485%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 486%attr(755,root,root) %{_libdir}/%{name}/*.sh
487%attr(755,root,root) %{_libdir}/%{name}/*-bin
488%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 489%attr(755,root,root) %{_libdir}/%{name}/icedove
cf62736e 490%attr(755,root,root) %{_libdir}/%{name}/plugin-container
e8f4ba81 491%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 492
493# symlinks
494%{_libdir}/%{name}/chrome
495%{_libdir}/%{name}/defaults
496%{_libdir}/%{name}/dictionaries
0516fc42 497#%%{_libdir}/%{name}/greprefs
44be9ed4 498%{_libdir}/%{name}/isp
9e097178 499%{_libdir}/%{name}/modules
44be9ed4 500%{_libdir}/%{name}/res
501
293928f3 502%{_pixmapsdir}/*.png
44be9ed4 503%{_desktopdir}/*.desktop
504
505%dir %{_datadir}/%{name}
506%{_datadir}/%{name}/chrome
507%{_datadir}/%{name}/defaults
0516fc42 508#%%{_datadir}/%{name}/greprefs
44be9ed4 509%{_datadir}/%{name}/isp
9e097178 510%{_datadir}/%{name}/modules
44be9ed4 511%{_datadir}/%{name}/res
c6ec3c1c 512%{_datadir}/%{name}/extensions
44be9ed4 513
765a3a27
ER
514%if %{with crashreporter}
515%attr(755,root,root) %{_libdir}/%{name}/crashreporter
516%{_libdir}/%{name}/crashreporter.ini
517%{_libdir}/%{name}/Throbber-small.gif
518%endif
519
44be9ed4 520%dir %{_libdir}/%{name}/extensions
521%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 522
52fc61e6
ER
523# files created by regxpcom -register
524%ghost %{_libdir}/%{name}/components/compreg.dat
525%ghost %{_libdir}/%{name}/components/xpti.dat
526
6578c165 527%if %{with lightning}
528%files addon-lightning
529%defattr(644,root,root,755)
f3b6d696 530%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
532%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
533%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
536%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
537%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
542%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
543%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 544%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
545%endif
44be9ed4 546
547%if %{with enigmail}
548%files addon-enigmail
549%defattr(644,root,root,755)
f6a43e2f
ER
550%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
552%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
553%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
555%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
556%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
557%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
558%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 559%endif
This page took 0.217159 seconds and 4 git commands to generate.