]> git.pld-linux.org Git - packages/thunderbird.git/blame - icedove.spec
- add -I/usr/include/xulrunner to CFLAGS and CXXFLAGS
[packages/thunderbird.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - fix icedove (building) and installing nss/nspr libs!
283702b9 4# - build with system mozldap
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
9%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
11%bcond_without ldap # disable e-mail address lookups in LDAP directories
6578c165 12%bcond_without lightning # disable sunbird calendar
f4114a7f 13%bcond_without xulrunner # build with xulrunner
765a3a27 14%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 15
44be9ed4 16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
88149483 20
f4114a7f 21%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
22%undefine crashreporter
23%endif
24
f4114a7f
ER
25%define enigmail_ver 1.1.2
26%define nspr_ver 4.8.8
27%define nss_ver 3.12.10
44be9ed4 28
7d981f69
ER
29%if %{without xulrunner}
30# The actual sqlite version (see RHBZ#480989):
31%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
32%endif
33
44be9ed4 34Summary: Icedove - email client
35Summary(pl.UTF-8): Icedove - klient poczty
36Name: icedove
a61ac19b 37Version: 6.0.2
f4114a7f 38Release: 0.1
44be9ed4 39License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 40Group: X11/Applications/Networking
cadfb931 41Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
a61ac19b 42# Source0-md5: 917a667fe21cfd103092dbc23a112192
44be9ed4 43Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
f4aadbdb 44# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
44be9ed4 45Source2: %{name}-branding.tar.bz2
c105f759 46# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 47Source3: %{name}-rm_nonfree.sh
48Source4: %{name}.desktop
49Source5: %{name}.sh
44be9ed4 50Patch0: %{name}-branding.patch
faa5c89d
SP
51Patch1: %{name}-enigmail-shared.patch
52Patch2: %{name}-gcc.patch
53Patch3: %{name}-fonts.patch
54Patch4: %{name}-install.patch
5e9bb798 55Patch5: %{name}-hunspell.patch
faa5c89d 56Patch6: %{name}-prefs.patch
9a743685 57Patch7: system-mozldap.patch
a85e0ecb 58Patch8: %{name}-makefile.patch
ccc206fe 59Patch10: %{name}-extensiondir.patch
765a3a27 60Patch11: crashreporter.patch
268e7766 61Patch12: no-subshell.patch
44be9ed4 62%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
5745d706 63URL: http://www.pld-linux.org/Packages/Icedove
51a3b6db 64BuildRequires: alsa-lib-devel
44be9ed4 65BuildRequires: automake
51a3b6db 66BuildRequires: bzip2-devel
44be9ed4 67BuildRequires: freetype-devel >= 1:2.1.8
68%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
69BuildRequires: gtk+2-devel >= 1:2.0.0
5e9bb798 70BuildRequires: hunspell-devel
44be9ed4 71BuildRequires: libIDL-devel >= 0.8.0
72%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 73%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 74%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 75BuildRequires: libiw-devel
44be9ed4 76BuildRequires: libjpeg-devel >= 6b
51a3b6db 77BuildRequires: libnotify-devel >= 0.4
44be9ed4 78BuildRequires: libpng-devel >= 1.2.0
79BuildRequires: libstdc++-devel
f4114a7f
ER
80BuildRequires: nspr-devel >= 1:%{nspr_ver}
81BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 82BuildRequires: pango-devel >= 1:1.1.0
1c62cadb 83BuildRequires: pkgconfig
44be9ed4 84BuildRequires: sed >= 4.0
9d1bfad8 85BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 86BuildRequires: startup-notification-devel >= 0.8
44be9ed4 87BuildRequires: xorg-lib-libXext-devel
44be9ed4 88BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 89BuildRequires: xorg-lib-libXt-devel
5745d706 90BuildRequires: yasm
1c62cadb 91BuildRequires: zip
b1ced411 92Requires(post): mktemp >= 1.5-18
7d981f69 93%if %{with xulrunner}
f6b6d331 94BuildRequires: xulrunner-devel
7d981f69 95%else
44be9ed4 96Requires: myspell-common
f4114a7f
ER
97Requires: nspr >= 1:%{nspr_ver}
98Requires: nss >= 1:%{nss_ver}
4b6bc367 99Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 100%endif
44be9ed4 101Obsoletes: mozilla-thunderbird
102Obsoletes: mozilla-thunderbird-dictionary-en-US
103BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
9e366f18
AM
105%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
106
44be9ed4 107# iceweasel/icedove/iceape provide their own versions
c072808a 108%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 109%define _noautoprovfiles %{_libdir}/%{name}/components
110# we don't want these to satisfy xulrunner-devel
c072808a 111%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 112# and as we don't provide them, don't require either
c072808a 113%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 114
9e7875fc
ER
115%define topdir %{_builddir}/%{name}-%{version}
116%define objdir %{topdir}/obj-%{_target_cpu}
117
44be9ed4 118%description
119Icedove is an open-source,fast and portable email client.
120
121%description -l pl.UTF-8
122Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
123
6578c165 124%package addon-lightning
125Summary: An integrated calendar for Icedove
126Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
127License: MPL 1.1 or GPL v2+ or LGPL v2.1+
128Group: Applications/Networking
129Requires: %{name} = %{version}-%{release}
130
131%description addon-lightning
132Lightning is an calendar extension to Icedove email client.
133
134%description addon-lightning -l pl.UTF-8
135Lightning to rozszerzenie do klienta poczty Icedove dodające
136funkcjonalność kalendarza.
137
44be9ed4 138%package addon-enigmail
139Summary: Extension for the authentication and encryption features provided by GnuPG
140Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
141License: MPL/LGPL
142Group: Applications/Networking
143URL: http://enigmail.mozdev.org/
cd056caa 144Requires: %{name} = %{version}-%{release}
d076d93e 145Requires: gnupg
75991bbb 146Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 147
148%description addon-enigmail
c5e06599 149Enigmail is an extension to the Icedove mail client which allows users
150to access the authentication and encryption features provided by
151GnuPG.
44be9ed4 152
153Main Features:
154- Encrypt/sign mail when sending, decrypt/authenticate received mail
155- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
156- Per-Account based encryption and signing defaults
157- Per-Recipient rules for automated key selection, and
158 enabling/disabling encryption and signing
159- OpenPGP key management interface
160
161%description addon-enigmail -l pl.UTF-8
c5e06599 162Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
163użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
164przez GnuPG.
44be9ed4 165
166Główne możliwości:
167- szyfrowanie/podpisywanie poczty przy wysyłaniu,
168 odszyfrowywanie/uwierzytelnianie poczty odebranej
169- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
170- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
171- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
172 podpisywania dla każdego adresata
173- interfejs do zarządzania kluczami OpenPGP
174
175%prep
983562b1 176%setup -qc
f4114a7f 177mv comm-release mozilla
983562b1 178%setup -q -T -D -a2
179cd mozilla
1c70899a 180%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 181/bin/sh %{SOURCE3}
983562b1 182%patch0 -p1
faa5c89d
SP
183%{?with_enigmail:%patch1 -p1}
184%patch2 -p1
4ccc2157 185%patch3 -p1
faa5c89d 186%patch4 -p1
5e9bb798 187%patch5 -p1
983562b1 188%patch6 -p1
9a743685 189%patch7 -p1
f4114a7f 190%patch8 -p2
ccc206fe 191%patch10 -p2
765a3a27 192%patch11 -p2
268e7766 193%patch12 -p1
44be9ed4 194
195%build
983562b1 196cd mozilla
cadfb931
SP
197cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
198cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 199cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 200
9a743685
ER
201install -d libxul-sdk
202ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 203
fbac75ca 204cat << EOF > .mozconfig
9e7875fc 205mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 206
5745d706 207export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
208export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
765a3a27
ER
209
210%if %{with crashreporter}
211export MOZ_DEBUG_SYMBOLS=1
212%endif
213
59c5a0e8 214# Options for 'configure' (same as command-line options).
44be9ed4 215ac_add_options --prefix=%{_prefix}
216ac_add_options --exec-prefix=%{_exec_prefix}
217ac_add_options --bindir=%{_bindir}
218ac_add_options --sbindir=%{_sbindir}
219ac_add_options --sysconfdir=%{_sysconfdir}
220ac_add_options --datadir=%{_datadir}
221ac_add_options --includedir=%{_includedir}
222ac_add_options --libdir=%{_libdir}
223ac_add_options --libexecdir=%{_libexecdir}
224ac_add_options --localstatedir=%{_localstatedir}
225ac_add_options --sharedstatedir=%{_sharedstatedir}
226ac_add_options --mandir=%{_mandir}
227ac_add_options --infodir=%{_infodir}
228%if %{?debug:1}0
59c5a0e8 229ac_add_options --disable-optimize
44be9ed4 230ac_add_options --enable-debug
231ac_add_options --enable-debug-modules
59c5a0e8
SP
232ac_add_options --enable-debugger-info-modules
233ac_add_options --enable-crash-on-assert
44be9ed4 234%else
235ac_add_options --disable-debug
236ac_add_options --disable-debug-modules
59c5a0e8
SP
237ac_add_options --disable-logging
238ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 239%endif
88149483
ER
240ac_add_options --disable-strip
241ac_add_options --disable-strip-libs
44be9ed4 242%if %{with tests}
243ac_add_options --enable-tests
244%else
245ac_add_options --disable-tests
246%endif
247%if %{with gnomeui}
248ac_add_options --enable-gnomeui
249%else
250ac_add_options --disable-gnomeui
251%endif
252%if %{with gnomevfs}
253ac_add_options --enable-gnomevfs
254%else
255ac_add_options --disable-gnomevfs
256%endif
257%if %{with ldap}
258ac_add_options --enable-ldap
9a743685 259ac_add_options --with-system-ldap
44be9ed4 260%else
261ac_add_options --disable-ldap
262%endif
765a3a27
ER
263%if %{with crashreporter}
264ac_add_options --enable-crashreporter
265%else
59c5a0e8 266ac_add_options --disable-crashreporter
765a3a27 267%endif
59c5a0e8 268ac_add_options --disable-xterm-updates
59c5a0e8 269ac_add_options --enable-postscript
d076d93e 270%if %{with lightning}
cb0e4412 271ac_add_options --enable-calendar
d076d93e
SP
272%else
273ac_add_options --disable-calendar
274%endif
44be9ed4 275ac_add_options --disable-installer
276ac_add_options --disable-jsd
88149483 277ac_add_options --disable-updater
44be9ed4 278ac_add_options --disable-xprint
cadfb931
SP
279ac_add_options --disable-permissions
280ac_add_options --disable-pref-extensions
44be9ed4 281ac_add_options --enable-canvas
282ac_add_options --enable-crypto
44be9ed4 283ac_add_options --enable-mathml
44be9ed4 284ac_add_options --enable-pango
285ac_add_options --enable-reorder
88149483
ER
286ac_add_options --enable-startup-notification
287ac_add_options --enable-svg
44be9ed4 288ac_add_options --enable-system-cairo
5e9bb798 289ac_add_options --enable-system-hunspell
7d981f69 290ac_add_options --enable-system-sqlite
44be9ed4 291ac_add_options --enable-xft
cadfb931
SP
292ac_add_options --enable-application=mail
293ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 294ac_add_options --enable-xinerama
88149483
ER
295ac_add_options --with-distribution-id=org.pld-linux
296ac_add_options --with-branding=icedove/branding
297%if %{with xulrunner}
f4114a7f
ER
298#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
299ac_add_options --with-system-libxul
fbac75ca 300ac_add_options --enable-shared
f4114a7f 301ac_add_options --enable-libxul
fbac75ca 302%else
f4114a7f 303ac_add_options --disable-xul
88149483
ER
304%endif
305ac_add_options --with-pthreads
306ac_add_options --with-system-bz2
44be9ed4 307ac_add_options --with-system-jpeg
308ac_add_options --with-system-nspr
309ac_add_options --with-system-nss
310ac_add_options --with-system-png
311ac_add_options --with-system-zlib
44be9ed4 312ac_add_options --enable-single-profile
313ac_add_options --disable-profilesharing
44be9ed4 314ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
315EOF
316
90e998ba 317%{__make} -j1 -f client.mk build \
d076d93e 318 STRIP="/bin/true" \
765a3a27 319 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 320 CC="%{__cc}" \
44be9ed4 321 CXX="%{__cxx}"
322
765a3a27
ER
323%if %{with crashreporter}
324# create debuginfo for crash-stats.mozilla.com
325%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
326%endif
327
44be9ed4 328%if %{with enigmail}
59c5a0e8 329cd mailnews/extensions/enigmail
9e7875fc
ER
330./makemake -r -o %{objdir}
331%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
332 STRIP="/bin/true" \
333 CC="%{__cc}" \
334 CXX="%{__cxx}"
44be9ed4 335%endif
336
337%install
338rm -rf $RPM_BUILD_ROOT
765a3a27 339install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 340
9e7875fc 341cd %{objdir}
ecf04393 342%{__make} -C mail/installer stage-package \
44be9ed4 343 DESTDIR=$RPM_BUILD_ROOT \
344 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
345 PKG_SKIP_STRIP=1
346
765a3a27
ER
347# Enable crash reporter for Firefox application
348%if %{with crashreporter}
349%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
350
351# Add debuginfo for crash-stats.mozilla.com
51a3b6db 352install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
353cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
354%endif
355
ecf04393
ER
356# copy manually lightning files, somewhy they are not installed by make
357cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
358 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
359 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
360
44be9ed4 361# move arch independant ones to datadir
362mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
363mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
364mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
44be9ed4 365mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 366mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 367mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
368ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
369ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
370ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
44be9ed4 371ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 372ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 373ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
374
c6ec3c1c
ER
375# dir for arch independant extensions besides arch dependant extensions
376# see mozilla/xpcom/build/nsXULAppAPI.h
377# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
378install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
379
63d8f5c3 380%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 381ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
382
383%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
384ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
385ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
386
52f5507d
ER
387cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
388cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 389
e8f4ba81 390# files created by regxpcom -register in post
52fc61e6
ER
391touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
392touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
393cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
394#!/bin/sh
395umask 022
396# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
397# dangerous if you run this with sudo with keep_env += HOME
398# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
399t=$(mktemp -d)
d50a2a28 400%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
401TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
402rm -rf $t
403EOF
404chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 405
44be9ed4 406%if %{with enigmail}
283702b9
ER
407ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
408install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6
ER
409cd mozilla/dist/bin
410cp -rfLp chrome/enigmail.jar $ext_dir/chrome
411cp -rfLp chrome/enigmime.jar $ext_dir/chrome
412cp -rfLp components/enig* $ext_dir/components
413cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 414cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
415cp -rfLp components/ipc.xpt $ext_dir/components
416cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
417cd -
52f5507d
ER
418cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
419cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 420%endif
421
9a743685 422# remove unecessary stuff
63d8f5c3 423%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
424%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
425%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 426
9cdc8923
ER
427# never package these. always remove
428# nss
429%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
430# nspr
431%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 432# mozldap
9cdc8923 433%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 434
44be9ed4 435%clean
436rm -rf $RPM_BUILD_ROOT
437
438%pretrans
439if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
440 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
441fi
9e097178 442for d in chrome defaults greprefs icons isp modules res; do
44be9ed4 443 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
444 install -d %{_datadir}/%{name}
445 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
446 fi
447done
448exit 0
449
e8f4ba81
ER
450%post
451%{_libdir}/%{name}/register || :
452
44be9ed4 453%files
454%defattr(644,root,root,755)
455%attr(755,root,root) %{_bindir}/icedove
456%attr(755,root,root) %{_bindir}/mozilla-thunderbird
457%attr(755,root,root) %{_bindir}/thunderbird
458%dir %{_libdir}/%{name}
765a3a27
ER
459%{_libdir}/%{name}/application.ini
460%{_libdir}/%{name}/platform.ini
44be9ed4 461%dir %{_libdir}/%{name}/components
462%attr(755,root,root) %{_libdir}/%{name}/components/*.so
463%{_libdir}/%{name}/components/*.js
464%{_libdir}/%{name}/components/*.xpt
283702b9
ER
465%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
466%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
467%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
44be9ed4 468%attr(755,root,root) %{_libdir}/%{name}/*.sh
469%attr(755,root,root) %{_libdir}/%{name}/*-bin
470%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 471%attr(755,root,root) %{_libdir}/%{name}/icedove
e8f4ba81 472%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 473
474# symlinks
475%{_libdir}/%{name}/chrome
476%{_libdir}/%{name}/defaults
477%{_libdir}/%{name}/dictionaries
478%{_libdir}/%{name}/greprefs
44be9ed4 479%{_libdir}/%{name}/isp
9e097178 480%{_libdir}/%{name}/modules
44be9ed4 481%{_libdir}/%{name}/res
482
293928f3 483%{_pixmapsdir}/*.png
44be9ed4 484%{_desktopdir}/*.desktop
485
486%dir %{_datadir}/%{name}
487%{_datadir}/%{name}/chrome
488%{_datadir}/%{name}/defaults
489%{_datadir}/%{name}/greprefs
44be9ed4 490%{_datadir}/%{name}/isp
9e097178 491%{_datadir}/%{name}/modules
44be9ed4 492%{_datadir}/%{name}/res
c6ec3c1c 493%{_datadir}/%{name}/extensions
44be9ed4 494
765a3a27
ER
495%if %{with crashreporter}
496%attr(755,root,root) %{_libdir}/%{name}/crashreporter
497%{_libdir}/%{name}/crashreporter.ini
498%{_libdir}/%{name}/Throbber-small.gif
499%endif
500
44be9ed4 501%dir %{_libdir}/%{name}/extensions
502%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 503
52fc61e6
ER
504# files created by regxpcom -register
505%ghost %{_libdir}/%{name}/components/compreg.dat
506%ghost %{_libdir}/%{name}/components/xpti.dat
507
6578c165 508%if %{with lightning}
509%files addon-lightning
510%defattr(644,root,root,755)
f3b6d696
ER
511%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
512%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
513%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
514%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
515%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
516%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
517%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
518%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
519%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
520%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
521%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
522%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
523
6578c165 524%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
525%endif
44be9ed4 526
527%if %{with enigmail}
528%files addon-enigmail
529%defattr(644,root,root,755)
f6a43e2f
ER
530%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
531%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
532%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
533%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
534%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
535%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
536%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
537%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
538%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 539%endif
This page took 0.113641 seconds and 4 git commands to generate.