packages/rpm.git
4 years agoMake %{__python} expand to /usr/bin/python2 auto/th/rpm-5.4.15-28
Jacek Konieczny [Sat, 28 Nov 2015 12:46:47 +0000 (13:46 +0100)]
Make %{__python} expand to /usr/bin/python2

This will make switching the to Python 3 in future (if we decide to)
much easier.

Release: 28

4 years agoOptimize python dependency generation auto/th/rpm-5.4.15-27
Jacek Konieczny [Mon, 23 Nov 2015 19:51:16 +0000 (20:51 +0100)]
Optimize python dependency generation

Run the python dependency helper only for the most important files:
- python scripts
- only the first pyc/pyo found in /usr/lib*/python and
  /usr/share*/python
- the PKG-INFO file in the egg-info directory

This should be enough to extract all the dependencies in most python
packages.

Release: 27

4 years agodisable fetch sources in python api, just to get parsed spec
Elan Ruusamäe [Wed, 4 Nov 2015 22:05:22 +0000 (00:05 +0200)]
disable fetch sources in python api, just to get parsed spec

http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2015-November/024529.html

4 years ago_enable_debug_packages is build time macro. does not belong here
Elan Ruusamäe [Fri, 25 Sep 2015 15:57:48 +0000 (18:57 +0300)]
_enable_debug_packages is build time macro. does not belong here

4 years ago- rel 25; but leave --param=ssp-buffer-size=4 as is auto/th/rpm-5.4.15-25
Arkadiusz Miśkiewicz [Fri, 18 Sep 2015 20:06:17 +0000 (22:06 +0200)]
- rel 25; but leave --param=ssp-buffer-size=4 as is

4 years ago- rel 24; switch from -fstack-protector --param=ssp-buffer-size=4 to -fstack-protecto... auto/th/rpm-5.4.15-24
Arkadiusz Miśkiewicz [Fri, 18 Sep 2015 20:00:34 +0000 (22:00 +0200)]
- rel 24; switch from -fstack-protector --param=ssp-buffer-size=4 to -fstack-protector-strong (few articles 'why' linked at lists.pld-linux.org/mailman/pipermail/pld-devel-en/2015-September/024499.html)

4 years agodo not define __php and php_pear_dir, those are defined by macros.build auto/th/rpm-5.4.15-23
Elan Ruusamäe [Thu, 3 Sep 2015 13:57:38 +0000 (16:57 +0300)]
do not define __php and php_pear_dir, those are defined by macros.build

4 years agodrop find-php-provides and find-php-requires
Elan Ruusamäe [Thu, 3 Sep 2015 08:13:06 +0000 (11:13 +0300)]
drop find-php-provides and find-php-requires

these are dead old and if installed leads to confusion

4 years agodo not add versioned ruby(abi) dep just because package contains .gemspec auto/th/rpm-5.4.15-22
Elan Ruusamäe [Tue, 25 Aug 2015 07:54:32 +0000 (10:54 +0300)]
do not add versioned ruby(abi) dep just because package contains .gemspec

4 years agoadd /sys to netsharedpath (for example docker)
Elan Ruusamäe [Fri, 29 May 2015 19:44:11 +0000 (22:44 +0300)]
add /sys to netsharedpath (for example docker)

4 years ago- rel 21; use ha.pool.sks-keyservers.net keyserver instead of home jbj machine auto/th/rpm-5.4.15-21
Arkadiusz Miśkiewicz [Thu, 28 May 2015 07:16:20 +0000 (09:16 +0200)]
- rel 21; use ha.pool.sks-keyservers.net keyserver instead of home jbj machine

4 years ago- final fix for noarch packages with incorrect platform auto/th/rpm-5.4.15-20
Jan Rękorajski [Fri, 3 Apr 2015 19:55:41 +0000 (21:55 +0200)]
- final fix for noarch packages with incorrect platform
- rel 20

4 years ago- cleaned up noarch from x32 fix auto/th/rpm-5.4.15-19
Jan Rękorajski [Thu, 2 Apr 2015 18:54:00 +0000 (20:54 +0200)]
- cleaned up noarch from x32 fix
- rel 19

4 years ago- fix "noarch packages from x32 unusable on ix86" issue
Jan Rękorajski [Thu, 2 Apr 2015 18:20:28 +0000 (20:20 +0200)]
- fix "noarch packages from x32 unusable on ix86" issue

5 years agopythonprov: do not require python-distribute auto/th/rpm-5.4.15-18
Jacek Konieczny [Tue, 31 Mar 2015 11:47:58 +0000 (13:47 +0200)]
pythonprov: do not require python-distribute

distribute is obsolete, use current setuptools instead.

By happy accident, the 'P: python-setuptools' in our current
python-distribute package will help migration.

Release: 18

5 years agoRedefining _target_cpu does not work as intended, reverting. Release 17 auto/th/rpm-5.4.15-17
Marcin Banasiak [Sat, 28 Mar 2015 15:47:09 +0000 (16:47 +0100)]
Redefining _target_cpu does not work as intended, reverting. Release 17

5 years agoRevert "Don't hardcode target cpu in _target_platform on x32. Release 16"
Marcin Banasiak [Sat, 28 Mar 2015 15:45:38 +0000 (16:45 +0100)]
Revert "Don't hardcode target cpu in _target_platform on x32. Release 16"

This reverts commit 23d3e66f10520042b1d3695faeca5f13858909aa.

5 years agoDon't hardcode target cpu in _target_platform on x32. Release 16 auto/th/rpm-5.4.15-16
Marcin Banasiak [Sat, 28 Mar 2015 11:31:55 +0000 (12:31 +0100)]
Don't hardcode target cpu in _target_platform on x32. Release 16

Hardcoding target cpu in _target_platform macro breaks noarch packages
and makes them unusable on hosts that do not support x86_64-... platform
(e.g. i686).

RPM redefines _target_cpu while building noarch packages, so this change
sets _target_cpu for x32 and makes _target_platform use _target_cpu.

5 years ago- one more fix for rubygems dep generator auto/th/rpm-5.4.15-15
Jan Rękorajski [Mon, 23 Mar 2015 20:49:37 +0000 (21:49 +0100)]
- one more fix for rubygems dep generator
- rel 15

5 years agocaret anchor can be matched once
Elan Ruusamäe [Mon, 23 Mar 2015 04:58:09 +0000 (04:58 +0000)]
caret anchor can be matched once

5 years ago- fix rubygem dependency generator auto/th/rpm-5.4.15-14
Jan Rękorajski [Sun, 22 Mar 2015 20:24:08 +0000 (21:24 +0100)]
- fix rubygem dependency generator
- rel 14

5 years ago- force rpm to prefer x32 color on x32 auto/th/rpm-5.4.15-13
Jan Rękorajski [Sun, 1 Mar 2015 16:45:58 +0000 (17:45 +0100)]
- force rpm to prefer x32 color on x32

5 years ago- cpu-os-macros README update
Jan Rękorajski [Sun, 1 Mar 2015 16:45:38 +0000 (17:45 +0100)]
- cpu-os-macros README update

5 years agorpm did not found pythonegg provides on x32.
Witold Filipczyk [Fri, 27 Feb 2015 15:25:17 +0000 (15:25 +0000)]
rpm did not found pythonegg provides on x32.

For example for python-markupsafe.

5 years ago- x32 rebuild auto/th/rpm-5.4.15-12
Jan Rękorajski [Tue, 24 Feb 2015 21:44:13 +0000 (22:44 +0100)]
- x32 rebuild
- release 12 (by relup.sh)

5 years ago- added cppcompat patch (make rpmdb.h C++ compatible)
Jakub Bogusz [Mon, 16 Feb 2015 20:34:30 +0000 (21:34 +0100)]
- added cppcompat patch (make rpmdb.h C++ compatible)

5 years agodisable header verification
Elan Ruusamäe [Wed, 11 Feb 2015 17:33:12 +0000 (19:33 +0200)]
disable header verification

5 years agoFix rpm 4.6 compatibility mode. Release 10. auto/th/rpm-5.4.15-10
Marcin Banasiak [Mon, 2 Feb 2015 23:07:35 +0000 (00:07 +0100)]
Fix rpm 4.6 compatibility mode. Release 10.

Added patch with a hack that changes behaviour of headerGet() in rpm 4.6
compatibility mode in order to set the correct value of iteration index.
RPM 5 implementation of headerGet() sets it to 0 whereas rpmtdNext() expects
it to be -1 initially.

5 years agoDo not assume about file output too much auto/th/rpm-5.4.15-9
Jacek Konieczny [Tue, 27 Jan 2015 10:15:57 +0000 (11:15 +0100)]
Do not assume about file output too much

'file' output for a not stripped ELF binary not necessarily
ends with ', not stripped'. icedtea7 build would fail on
find-debuginfo.sh with current 'file', as file output for 'libjvm.so'
ends with ', too many notes (256)'.

Release: 9

5 years ago- rel 8 auto/th/rpm-5.4.15-8
Jan Rękorajski [Sun, 25 Jan 2015 21:14:59 +0000 (22:14 +0100)]
- rel 8

5 years ago- adapt rpm.org fixes for CVE-2013-6435 and CVE-2014-8118
Jan Rękorajski [Sun, 25 Jan 2015 21:01:45 +0000 (22:01 +0100)]
- adapt rpm.org fixes for CVE-2013-6435 and CVE-2014-8118

5 years ago- updated x32 macros with sensible values
Jan Rękorajski [Sun, 25 Jan 2015 09:44:05 +0000 (09:44 +0000)]
- updated x32 macros with sensible values

5 years ago- assure order of files withing ar archive is preserved
Jan Rękorajski [Sun, 25 Jan 2015 09:43:31 +0000 (09:43 +0000)]
- assure order of files withing ar archive is preserved

5 years ago- add support for x32 arch; new color for multiarch and (x32bit) deps
Jan Rękorajski [Sun, 25 Jan 2015 09:36:57 +0000 (09:36 +0000)]
- add support for x32 arch; new color for multiarch and (x32bit) deps

5 years ago- define the right compiler for x32
Jan Rękorajski [Sun, 25 Jan 2015 09:34:50 +0000 (09:34 +0000)]
- define the right compiler for x32

5 years ago- add platform definitions and macros for x32
Jan Rękorajski [Sun, 25 Jan 2015 09:33:58 +0000 (09:33 +0000)]
- add platform definitions and macros for x32
- install multiarch macros for x86 archs

5 years ago- pld specific macros must not override arch target ones
Jan Rękorajski [Sun, 25 Jan 2015 09:32:01 +0000 (09:32 +0000)]
- pld specific macros must not override arch target ones

5 years agoinclude x32 macros for x86_64 auto/th/rpm-5.4.15-7
Elan Ruusamäe [Thu, 8 Jan 2015 08:38:17 +0000 (10:38 +0200)]
include x32 macros for x86_64

5 years agoconvert cpu-os-macros to ar archive instead of untracked .tar.gz
Elan Ruusamäe [Wed, 7 Jan 2015 15:56:04 +0000 (17:56 +0200)]
convert cpu-os-macros to ar archive instead of untracked .tar.gz

archive macros in an ar archive instead since it's ascii rather than
binary, making it easier merge changes, deal with conflicts etc...

idea from proyvind:
https://abf.io/openmandriva/rpm/commits/master/cpu-os-macros.a

5 years ago- check-files cleanup
Jakub Bogusz [Wed, 7 Jan 2015 18:09:49 +0000 (19:09 +0100)]
- check-files cleanup

5 years agoadd rpmdbchk tool from proyvind
Elan Ruusamäe [Wed, 7 Jan 2015 12:59:42 +0000 (14:59 +0200)]
add rpmdbchk tool from proyvind

5 years ago- updated gettext BR
Jan Rękorajski [Sun, 28 Dec 2014 18:23:15 +0000 (19:23 +0100)]
- updated gettext BR

5 years agomove gem_helper.rb to pld repo instead of patching it several times
Elan Ruusamäe [Thu, 18 Dec 2014 19:16:25 +0000 (21:16 +0200)]
move gem_helper.rb to pld repo instead of patching it several times

Merge branch 'gem_helper'

5 years agomerge rpm-5.4.9-ruby1.9-fixes.patch into gem_helper.rb
Elan Ruusamäe [Thu, 18 Dec 2014 19:12:37 +0000 (21:12 +0200)]
merge rpm-5.4.9-ruby1.9-fixes.patch into gem_helper.rb

5 years agoapply gem_helper-spec-arg.patch to gem_helper.rb
Elan Ruusamäe [Thu, 18 Dec 2014 18:31:53 +0000 (20:31 +0200)]
apply gem_helper-spec-arg.patch to gem_helper.rb

5 years agoadd gem_helper.rb from rpm-5.4.15/scripts/gem_helper.rb
Elan Ruusamäe [Thu, 18 Dec 2014 18:09:46 +0000 (20:09 +0200)]
add gem_helper.rb from rpm-5.4.15/scripts/gem_helper.rb

5 years ago- build requires rpm-build-macros 1.699 for kernel macros auto/th/rpm-5.4.15-6
Jan Rękorajski [Wed, 10 Dec 2014 20:42:32 +0000 (21:42 +0100)]
- build requires rpm-build-macros 1.699 for kernel macros
- rel 6

5 years agoprocess .gemspec from current %ruby_gemdir (/usr/share/gems) auto/th/rpm-5.4.15-5
Elan Ruusamäe [Mon, 8 Dec 2014 18:52:20 +0000 (20:52 +0200)]
process .gemspec from current %ruby_gemdir (/usr/share/gems)

5 years agorediff
Elan Ruusamäe [Mon, 8 Dec 2014 14:53:14 +0000 (16:53 +0200)]
rediff

5 years agomove ruby rpmfc changes to ruby patch
Elan Ruusamäe [Mon, 8 Dec 2014 14:49:15 +0000 (16:49 +0200)]
move ruby rpmfc changes to ruby patch

refs b10643ac91ae601333286a815fcb3586aa66c24b

this patching patches is getting super annoying!

5 years ago- fix rpm-ignore-missing-macro-files patch auto/th/rpm-5.4.15-4
Jan Rękorajski [Sun, 7 Dec 2014 21:23:57 +0000 (22:23 +0100)]
- fix rpm-ignore-missing-macro-files patch

5 years ago- ignore non-existing files and backups specified in %{load:...}
Jan Rękorajski [Sun, 7 Dec 2014 21:10:58 +0000 (22:10 +0100)]
- ignore non-existing files and backups specified in %{load:...}
  statement in macro files
- rel 4

5 years ago- typelib macros don't exist, don't try to load them
Jan Rękorajski [Sun, 7 Dec 2014 20:49:38 +0000 (21:49 +0100)]
- typelib macros don't exist, don't try to load them

5 years ago- build with system pcre auto/th/rpm-5.4.15-3
Jan Rękorajski [Sun, 16 Nov 2014 15:46:59 +0000 (16:46 +0100)]
- build with system pcre
- rel 3

5 years ago- use DSA for package signatures for temporary compatibility with antique crap auto/th/rpm-5.4.15-2
Jan Rękorajski [Sat, 15 Nov 2014 18:26:00 +0000 (19:26 +0100)]
- use DSA for package signatures for temporary compatibility with antique crap
- rel 2

5 years agowith system_pcre bcond (for bootstrapping)
Elan Ruusamäe [Tue, 4 Nov 2014 05:35:41 +0000 (07:35 +0200)]
with system_pcre bcond (for bootstrapping)

5 years ago- rel 1 auto/th/rpm-5.4.15-1
Jan Rękorajski [Thu, 30 Oct 2014 11:22:37 +0000 (12:22 +0100)]
- rel 1

5 years ago- BR update
Jakub Bogusz [Sun, 26 Oct 2014 12:17:00 +0000 (13:17 +0100)]
- BR update

5 years ago- now db6.1 as an alternative for db5.2
Jakub Bogusz [Sun, 26 Oct 2014 11:54:21 +0000 (12:54 +0100)]
- now db6.1 as an alternative for db5.2

5 years ago- updated to 5.4.15
Jan Rękorajski [Sat, 25 Oct 2014 12:18:36 +0000 (14:18 +0200)]
- updated to 5.4.15

5 years agokeep old Perl identification string for compatibility with old file auto/th/rpm-5.4.14-6
Kacper Kornet [Tue, 7 Oct 2014 16:28:45 +0000 (17:28 +0100)]
keep old Perl identification string for compatibility with old file

5 years agouse correct string returned by file for Perl scripts
Kacper Kornet [Tue, 7 Oct 2014 15:57:38 +0000 (16:57 +0100)]
use correct string returned by file for Perl scripts

5 years agoplatform: Squash Extra Blank Lines
Elan Ruusamäe [Tue, 15 Jul 2014 09:41:11 +0000 (12:41 +0300)]
platform: Squash Extra Blank Lines

5 years agorpm-build pretrans needs coreutils auto/th/rpm-5.4.14-5
Elan Ruusamäe [Tue, 10 Jun 2014 14:22:23 +0000 (17:22 +0300)]
rpm-build pretrans needs coreutils

5 years agorubygems.rb: ruby-2.0 compatible packaging fixes (missing version in noarch packages) auto/th/rpm-5.4.14-4
Elan Ruusamäe [Sun, 1 Jun 2014 19:14:24 +0000 (22:14 +0300)]
rubygems.rb: ruby-2.0 compatible packaging fixes (missing version in noarch packages)

5 years agoadd rubygems.rb as source instead of patching it with 5 patches
Elan Ruusamäe [Sat, 31 May 2014 19:06:51 +0000 (22:06 +0300)]
add rubygems.rb as source instead of patching it with 5 patches

6 years agonoarch apidocs
Elan Ruusamäe [Sun, 30 Mar 2014 15:56:49 +0000 (18:56 +0300)]
noarch apidocs

6 years agodo not "leak" only comments to platform file
Elan Ruusamäe [Thu, 27 Mar 2014 20:08:30 +0000 (22:08 +0200)]
do not "leak" only comments to platform file

it does look confusing when i686 file contains only comment "x86-64 things"

6 years agoadd selinux to devel and static subpackages
Kacper Kornet [Wed, 26 Mar 2014 01:47:52 +0000 (01:47 +0000)]
add selinux to devel and static subpackages

6 years agoDirectory for target macros shouldn't be hardcoded during build
Bartek Szady [Sun, 16 Mar 2014 08:26:50 +0000 (09:26 +0100)]
Directory for target macros shouldn't be hardcoded during build

6 years agogem_helper: when writing .gemspec exit, otherwise code continues to compile ext auto/th/rpm-5.4.14-2
Elan Ruusamäe [Sun, 22 Dec 2013 18:13:57 +0000 (20:13 +0200)]
gem_helper: when writing .gemspec exit, otherwise code continues to compile ext

6 years ago- rel 1 auto/th/rpm-5.4.14-1
Jan Rękorajski [Sat, 16 Nov 2013 07:51:03 +0000 (08:51 +0100)]
- rel 1

6 years ago- patch also c++ version of the rpmqv.c
Jan Rękorajski [Fri, 15 Nov 2013 11:48:44 +0000 (12:48 +0100)]
- patch also c++ version of the rpmqv.c

6 years ago- started update to 5.4.14
Jan Rękorajski [Thu, 14 Nov 2013 11:45:31 +0000 (12:45 +0100)]
- started update to 5.4.14
- removed patches applied upstream

6 years agorpm-perlprov R Encode module (for pod doc builds) auto/th/rpm-5.4.13-7
Elan Ruusamäe [Sun, 3 Nov 2013 16:29:06 +0000 (18:29 +0200)]
rpm-perlprov R Encode module (for pod doc builds)

6 years ago- revert change introduced in 5.4.11/12 that breaks gpg calls; rel 6 auto/th/rpm-5.4.13-6
Jan Rękorajski [Thu, 24 Oct 2013 07:31:44 +0000 (09:31 +0200)]
- revert change introduced in 5.4.11/12 that breaks gpg calls; rel 6

GPG key name/ID passed as cmd to rpmCheckPassPhrase is enclosed in
doble quotes, while poptParseArgvString cleaned up command line
before converting to argv list, argvSplit does not, and passes
gpg name/ID to gpg as "\"XXXXX\"" (doble, escaped quoting),
thus making it unverifiable;

6 years ago- fix memory leak auto/th/rpm-5.4.13-5
Jan Rękorajski [Wed, 23 Oct 2013 11:31:53 +0000 (13:31 +0200)]
- fix memory leak
- rel 5

6 years ago- port rpmspec tool from rpm.org, usefull to see how spec will look like after parsing auto/th/rpm-5.4.13-4
Jan Rękorajski [Tue, 22 Oct 2013 19:08:12 +0000 (21:08 +0200)]
- port rpmspec tool from rpm.org, usefull to see how spec will look like after parsing
- rel 4

6 years ago- db_buffer_small patch is needed with db6.0 too (up to 3 retries needed:
Jakub Bogusz [Sun, 13 Oct 2013 12:57:08 +0000 (14:57 +0200)]
- db_buffer_small patch is needed with db6.0 too (up to 3 retries needed:
  it seems that pget doesn't report whole requred size at the first time)

6 years ago- added rpm-double_check_unpackaged_subdirs patch (do a strict check when Bloom filte...
Jakub Bogusz [Sun, 13 Oct 2013 08:34:04 +0000 (10:34 +0200)]
- added rpm-double_check_unpackaged_subdirs patch (do a strict check when Bloom filter succeeds
  also when checking for unpackaged subdirs)
- disable silent-rules
- release 3

6 years ago- removed outdated db5.3 patch
Jakub Bogusz [Sun, 29 Sep 2013 16:11:53 +0000 (18:11 +0200)]
- removed outdated db5.3 patch
- added db60 bcond

6 years agofix regression overwriting variables from /etc/os-release auto/th/rpm-5.4.13-2
Elan Ruusamäe [Mon, 23 Sep 2013 21:53:17 +0000 (00:53 +0300)]
fix regression overwriting variables from /etc/os-release

http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2013-September/023647.html
http://rpm5.org/community/rpm-devel/5550.html
http://rpm5.org/community/rpm-devel/5552.html

6 years ago- remove superfluous -lexpat option during lua building
Kacper Kornet [Mon, 23 Sep 2013 18:55:37 +0000 (19:55 +0100)]
- remove superfluous -lexpat option during lua building

6 years ago- rel 1 auto/th/rpm-5.4.13-1
Jan Rękorajski [Mon, 23 Sep 2013 16:48:48 +0000 (18:48 +0200)]
- rel 1

6 years ago- added patches to fix regressions in 5.4.13
Jan Rękorajski [Mon, 23 Sep 2013 16:21:56 +0000 (18:21 +0200)]
- added patches to fix regressions in 5.4.13

6 years ago- revert change which causes debuginfo to fail like this:
Jan Rękorajski [Mon, 23 Sep 2013 16:20:14 +0000 (18:20 +0200)]
- revert change which causes debuginfo to fail like this:
Failed to produce debuginfo: debug format not supported: .init

6 years ago- xmalloc() is no longer exported by the rpm libraries, which leads to
Jan Rękorajski [Mon, 23 Sep 2013 16:18:36 +0000 (18:18 +0200)]
- xmalloc() is no longer exported by the rpm libraries, which leads to
  problems with undefined symbols in perl bindings

6 years ago- remove noautoreqdep, it's not used since packages NAME dependencies
Jan Rękorajski [Mon, 23 Sep 2013 15:39:12 +0000 (17:39 +0200)]
- remove noautoreqdep, it's not used since packages NAME dependencies
  been disabled years ago and dropped in rpm5

6 years ago5.4.13 tarball; builds
Elan Ruusamäe [Mon, 26 Aug 2013 22:15:48 +0000 (01:15 +0300)]
5.4.13 tarball; builds

6 years ago- rel 3
Jan Rękorajski [Tue, 13 Aug 2013 18:16:10 +0000 (20:16 +0200)]
- rel 3

6 years ago- make sure that the output buffer gets truncated after use, otherwise
Jan Rękorajski [Tue, 13 Aug 2013 18:09:23 +0000 (20:09 +0200)]
- make sure that the output buffer gets truncated after use, otherwise
  new output will be appended to it and it all being printed each time

6 years ago- fix the syntax of the python initialization code that resulted in
Jan Rękorajski [Tue, 13 Aug 2013 18:08:01 +0000 (20:08 +0200)]
- fix the syntax of the python initialization code that resulted in
  neither the output redirection working nor the rpm python module being loaded

6 years ago- fix a regression in rpmlua where it no longer overrides the luaB_print()
Jan Rękorajski [Tue, 13 Aug 2013 18:03:52 +0000 (20:03 +0200)]
- fix a regression in rpmlua where it no longer overrides the  luaB_print()
  function with the one provided by rpm_print()

6 years ago- fix for Bloom filter giving false positives dependency checks
Jan Rękorajski [Tue, 13 Aug 2013 17:58:29 +0000 (19:58 +0200)]
- fix for Bloom filter giving false positives dependency checks
  breaking package install order, patch by Jacek Konieczny, see
  http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2013-August/023630.html

6 years ago-j1 for 'make install'
Jacek Konieczny [Wed, 7 Aug 2013 09:16:39 +0000 (11:16 +0200)]
-j1 for 'make install'

6 years agoBR: beecrypt >= 4.2.0
Jacek Konieczny [Wed, 7 Aug 2013 08:54:40 +0000 (10:54 +0200)]
BR: beecrypt >= 4.2.0

compiling with beecrypt 4.1.2 gives:
./rpmbc.h:19:26: fatal error: beecrypt/md4.h: No such file or directory

6 years ago'--without selinux' build fix
Jacek Konieczny [Wed, 7 Aug 2013 08:43:08 +0000 (10:43 +0200)]
'--without selinux' build fix

6 years ago- fix regression auto/th/rpm-5.4.12-2
Jan Rękorajski [Thu, 1 Aug 2013 17:23:48 +0000 (19:23 +0200)]
- fix regression
- rel 2

6 years ago- rel 1 auto/th/rpm-5.4.12-1
Jan Rękorajski [Mon, 29 Jul 2013 18:03:50 +0000 (20:03 +0200)]
- rel 1

6 years ago- updated system lua dependency
Jan Rękorajski [Mon, 29 Jul 2013 15:32:29 +0000 (17:32 +0200)]
- updated system lua dependency
- remove bundled libs

This page took 0.4546 seconds and 4 git commands to generate.