]> git.pld-linux.org Git - packages/rpm.git/commitdiff
apply gem_helper-spec-arg.patch to gem_helper.rb
authorElan Ruusamäe <glen@delfi.ee>
Thu, 18 Dec 2014 18:31:53 +0000 (20:31 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 18 Dec 2014 18:31:53 +0000 (20:31 +0200)
gem_helper-spec-arg.patch [deleted file]
gem_helper.rb
rpm.spec

diff --git a/gem_helper-spec-arg.patch b/gem_helper-spec-arg.patch
deleted file mode 100644 (file)
index 7ddb32f..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- rpm-5.4.10/scripts/gem_helper.rb   2013-06-21 09:45:34.619165559 +0300
-+++ rpm-5.4.14/scripts/gem_helper.rb   2013-12-21 19:05:33.801507110 +0200
-@@ -6,8 +6,9 @@
- #++
- require 'optparse'
-+require 'rubygems'
--if ARGV[0] == "build" or ARGV[0] == "install"
-+if ARGV[0] == "build" or ARGV[0] == "install" or ARGV[0] == "spec"
-   require 'yaml'
-   require 'zlib'
-@@ -65,9 +66,18 @@
-         body[iv.to_s.gsub(/^@/,'')] = header.instance_variable_get(iv)
-   end
--  require 'rubygems'
-   spec = Gem::Specification.from_yaml(YAML.dump(header))
-+  if ARGV[0] == "spec"
-+    # Write the .gemspec specification (in Ruby)
-+    file_name = spec.full_name.untaint + '.gemspec'
-+    File.open(file_name, "w") do |file|
-+      file.puts spec.to_ruby_for_cache
-+    end
-+    print "Wrote: %s\n" % file_name
-+    exit(0)
-+  end
-+
-   if ARGV[0] == "install"
-     system("gem %s %s.gem" % [ARGV.join(' '), spec.full_name])
-     if !keepcache
index 66615752063fbddd5556a6bca1b655800e7a210a..65f45e431def207aab1c29e08098ae3d36a56dc9 100755 (executable)
@@ -6,8 +6,9 @@
 #++
 
 require 'optparse'
+require 'rubygems'
 
-if ARGV[0] == "build" or ARGV[0] == "install"
+if ARGV[0] == "build" or ARGV[0] == "install" or ARGV[0] == "spec"
   require 'yaml'
   require 'zlib'
 
@@ -62,9 +63,18 @@ if ARGV[0] == "build" or ARGV[0] == "install"
   file_data.close()
   body = header.instance_variable_get :@ivars
 
-  require 'rubygems'
   spec = Gem::Specification.from_yaml(YAML.dump(header))
 
+  if ARGV[0] == "spec"
+    # Write the .gemspec specification (in Ruby)
+    file_name = spec.full_name.untaint + '.gemspec'
+    File.open(file_name, "w") do |file|
+      file.puts spec.to_ruby_for_cache
+    end
+    print "Wrote: %s\n" % file_name
+    exit(0)
+  end
+
   if ARGV[0] == "install"
     system("gem %s %s.gem" % [ARGV.join(' '), spec.full_name])
     if !keepcache
index e2c401f3a7307a2da6d00d9329703491c9000926..dcba25827cc5c03d3a6dfcd90016e739b4820143 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -160,7 +160,6 @@ Patch67:    %{name}-repackage-dont-force-max-compression.patch
 Patch70:       python-%{name}sense-missingok.patch
 Patch71:       %{name}-changelog-encoding.patch
 Patch72:       %{name}-preserve-tag-type.patch
-Patch73:       gem_helper-spec-arg.patch
 Patch74:       %{name}-fix-internal-lua-build.patch
 Patch75:       %{name}-double_check_file_deps.patch
 Patch77:       %{name}-lua-expat.patch
@@ -917,7 +916,6 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch70 -p1
 %patch71 -p1
 %patch72 -p1
-%patch73 -p1
 %patch74 -p1
 %patch75 -p1
 %patch77 -p0
This page took 0.047041 seconds and 4 git commands to generate.