]> git.pld-linux.org Git - packages/rpm.git/commitdiff
Don't hardcode target cpu in _target_platform on x32. Release 16 auto/th/rpm-5.4.15-16
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Sat, 28 Mar 2015 11:31:55 +0000 (12:31 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Sat, 28 Mar 2015 11:31:55 +0000 (12:31 +0100)
Hardcoding target cpu in _target_platform macro breaks noarch packages
and makes them unusable on hosts that do not support x86_64-... platform
(e.g. i686).

RPM redefines _target_cpu while building noarch packages, so this change
sets _target_cpu for x32 and makes _target_platform use _target_cpu.

cpu-os-macros.a
rpm.spec

index abeed44a21b09fce1b5c91334b25526688f55d14..1d9bb52c54845a6a4f982e08425d0a66dc3acc29 100644 (file)
@@ -632,7 +632,7 @@ k6-linux.macros/0           0     0     644     708       `
 #      Multilibs
 %_multilibno           1
 %_multilibpatt         (/%{_lib}|/usr/%{_lib}(|/gconv)|/usr/local/%{_lib}|/usr/X11R6/%{_lib}|/opt/%{_lib})/[^/]*\\.([oa]|la|so[0-9.]*)$
-/668            0           0     0     644     1091      `
+/668            0           0     0     644     1120      `
 # Per-platform rpm configuration file.
 
 #==============================================================================
@@ -641,7 +641,8 @@ k6-linux.macros/0           0     0     644     708       `
 %_arch                 x32
 %_os                   linux
 %_gnu                  -gnux32
-%_target_platform      x86_64-%{_target_vendor}-%{_target_os}%{?_gnu}
+%_target_cpu           x86_64
+%_target_platform      %{_target_cpu}-%{_target_vendor}-%{_target_os}%{?_gnu}
 %optflags              %{?__common_cflags_with_ssp:%{__common_cflags_with_ssp} -fPIC}%{!?__common_cflags_with_ssp:-O2 -g} -mtune=generic -march=x86-64 %{!?nospecflags:%{?specflags_x32}}
 
 #==============================================================================
@@ -662,7 +663,6 @@ k6-linux.macros/0           0     0     644     708       `
 
 # ---- 0x1 - x86, 0x2 - x86_64 (rpm default), 0x4 - x32
 %_prefer_color         0x4
-
 /686            0           0     0     644     725       `
 # Per-platform rpm configuration file.
 
index 245db149b2ed788621b08ab6f7f7e8e4609f6bfe..384382c28ca50f22c961275accdd8f520c0bc07b 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -51,7 +51,7 @@ Summary(ru.UTF-8):    Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
 Version:       5.4.15
-Release:       15
+Release:       16
 License:       LGPL v2.1
 Group:         Base
 # http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.15-0.20140824.src.rpm
This page took 0.140887 seconds and 4 git commands to generate.