]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- fix a regression in rpmlua where it no longer overrides the luaB_print()
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 13 Aug 2013 18:03:52 +0000 (20:03 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 13 Aug 2013 18:03:52 +0000 (20:03 +0200)
  function with the one provided by rpm_print()

rpm-5.4.12-fix-rpmlua-print.patch [new file with mode: 0644]
rpm.spec

diff --git a/rpm-5.4.12-fix-rpmlua-print.patch b/rpm-5.4.12-fix-rpmlua-print.patch
new file mode 100644 (file)
index 0000000..4129ec4
--- /dev/null
@@ -0,0 +1,22 @@
+--- rpm-5.4.12/misc/librpmmisc.vers.rpmluaprint~       2013-08-08 18:23:58.367842414 +0200
++++ rpm-5.4.12/misc/librpmmisc.vers    2013-08-08 18:20:25.019996866 +0200
+@@ -36,6 +36,7 @@ LIBRPMMISC_0
+     lua_gettop;
+     lua_isnumber;
+     lua_isstring;
++    lua_setglobal;
+     luaL_argerror;
+     luaL_checklstring;
+     luaL_error;
+--- rpm-5.4.12/rpmio/rpmlua.c.rpmluaprint~     2013-08-08 18:23:06.755942297 +0200
++++ rpm-5.4.12/rpmio/rpmlua.c  2013-08-08 18:23:32.325390087 +0200
+@@ -207,8 +207,8 @@ rpmlua rpmluaNew(void)
+ #else
+     lua_pushglobaltable(L);
+ #endif
+-    lua_pushliteral(L, "print");
+     lua_pushcfunction(L, rpm_print);
++    lua_setglobal(L, "print");
+ #if defined(LUA_GLOBALSINDEX)
+     lua_rawset(L, LUA_GLOBALSINDEX);
index 4b6eeef7a229797ba1b62eaebd84432e1e7f459b..6763d70e62d4f8a96c7b1369ee7dd972110a68b7 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -268,6 +268,7 @@ Patch1041:  %{name}-5.4.9-disable-l10ndir.patch
 Patch1042:     %{name}-5.4.9-fix-rpm_qa-pattern.patch
 # warning: introduces memory leak
 Patch1043:     %{name}-5.4.12-copy-Value-string.patch
+Patch1044:     %{name}-5.4.12-fix-rpmlua-print.patch
 
 URL:           http://rpm5.org/
 BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
@@ -941,6 +942,7 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 %patch1041 -p1
 %patch1042 -p1
 %patch1043 -p1
+%patch1044 -p1
 %patch68 -p1
 %patch69 -p1
 
This page took 0.041613 seconds and 4 git commands to generate.