]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blame - perl-Test-Simple.spec
- updated to 1.302183
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
CommitLineData
fa6965b3 1#
2# Conditional build:
ea031d13 3%bcond_without tests # do not perform "make test"
fa6965b3 4#
f536906b 5%define pdir Test
6%define pnam Simple
fc1a045f 7Summary: Test::Simple - basic utilities for writing tests
90486546 8Summary(pl.UTF-8): Test::Simple - podstawowe narzędzia do pisania testów
51379aa6 9Name: perl-Test-Simple
11eb9a6a
JB
10# NOTE: perl 5.32 provides 1.302175
11Version: 1.302183
5240b5af 12%define fver %(echo %{version} | tr -d _)
15c3dff6 13Release: 1
23b30915 14# same as perl
15License: GPL v1+ or Artistic
a117f839 16Group: Development/Languages/Perl
5240b5af 17Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
11eb9a6a 18# Source0-md5: b9bd0b573de649893dbd1d746691cd0a
d1b9ec6b 19URL: https://metacpan.org/release/Test-Simple
44b4b73a 20%{?with_tests:BuildRequires: perl-Test-Harness >= 2.03}
4a2430a6 21BuildRequires: perl-devel >= 1:5.8.0
b20888db 22BuildRequires: rpm-perlprov >= 4.1-13
32a85d49 23BuildRequires: rpmbuild(macros) >= 1.745
46ebbc6a
JB
24# see lib/Test/Builder/Tester.pm /VERSION
25Provides: perl-Test-Builder-Tester = %{version}
26# see lib/Test/Tester.pm /VERSION
27Provides: perl-Test-Tester = %{version}
e9c35293
JB
28# see lib/Test/use/ok.pm /VERSION
29Provides: perl-Test-use-ok = %{version}
30# obsolete only versions up to last standalone release to avoid obsoleting perl-modules
31# Test::Builder::Tester 1.01
32# Test::Tester 0.109
33# Test::use::ok 0.11
3b71b361
JB
34Obsoletes: perl-Test-Builder-Tester < 1.02
35Obsoletes: perl-Test-Tester < 0.110
e9c35293 36Obsoletes: perl-Test-use-ok < 0.12
a117f839
SZ
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
11eb9a6a 40%define _noautoreq_perl threads threads::shared
aa8c7784 41
a117f839 42%description
8a2bd24c
ER
43AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
44me to Detroit, but don't make me write tests!
673d528c 45 -- perldoc Test::Tutorial
fc1a045f 46
81044a38
JB
47Test::Simple is an extremely simple, extremely basic module for
48writing tests suitable for CPAN modules and other pursuits. If you
49wish to do more complicated testing, use the Test::More module (a
50drop-in replacement for this one).
a117f839 51
81044a38
JB
52The purpose of Test::More is to provide a wide range of testing
53utilities. Various ways to say "ok" with better diagnostics,
54facilities to skip tests, test future features and compare complicated
55data structures. While you can do almost anything with a simple "ok()"
56function, it doesn't provide good diagnostic output.
fc1a045f 57
bb31a059 58%description -l pl.UTF-8
8a2bd24c 59AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
bb31a059
JR
60mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
61testów!
673d528c 62 -- perldoc Test::Tutorial
81044a38 63
bb31a059
JR
64Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
65pisania testów pasujących do modułów CPAN i innych. Do bardziej
66skomplikowanych testów lepiej używać modułu Test::More (zastępującego
81044a38
JB
67ten).
68
bb31a059
JR
69Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
70testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
71ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
72porównywaniu skomplikowanych struktur danych. O ile można zrobić
73prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
81044a38 74diagnostycznego.
a117f839
SZ
75
76%prep
5240b5af 77%setup -q -n %{pdir}-%{pnam}-%{fver}
c7067acc 78%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
a117f839
SZ
79
80%build
b20888db 81%{__perl} Makefile.PL \
037eba0e 82 INSTALLDIRS=vendor
a117f839
SZ
83%{__make}
84
ea031d13 85%{?with_tests:%{__make} test}
fa6965b3 86
a117f839
SZ
87%install
88rm -rf $RPM_BUILD_ROOT
89
ea031d13 90%{__make} install \
91 DESTDIR=$RPM_BUILD_ROOT
a117f839 92
5240b5af 93%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
8a2bd24c 94
a117f839
SZ
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%files
99%defattr(644,root,root,755)
46ebbc6a 100%doc Changes README
68765220 101%{perl_vendorlib}/ok.pm
1125d11b 102%{perl_vendorlib}/Test/Builder
5240b5af
JB
103%{perl_vendorlib}/Test/Builder.pm
104%{perl_vendorlib}/Test/More.pm
105%{perl_vendorlib}/Test/Simple.pm
68765220
AM
106%{perl_vendorlib}/Test/Tester
107%{perl_vendorlib}/Test/Tester.pm
108%{perl_vendorlib}/Test/use
109%{perl_vendorlib}/Test2.pm
110%{perl_vendorlib}/Test2
5240b5af
JB
111%{_mandir}/man3/Test::Builder*.3pm*
112%{_mandir}/man3/Test::More.3pm*
113%{_mandir}/man3/Test::Simple.3pm*
68765220 114%{_mandir}/man3/Test::Tester*.3pm*
5240b5af 115%{_mandir}/man3/Test::Tutorial.3pm*
68765220
AM
116%{_mandir}/man3/Test::use::ok.3pm*
117%{_mandir}/man3/Test2*.3pm*
118%{_mandir}/man3/ok.3pm*
This page took 0.068334 seconds and 4 git commands to generate.