]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blame - perl-Test-Simple.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
CommitLineData
fa6965b3 1#
2# Conditional build:
ea031d13 3%bcond_without tests # do not perform "make test"
fa6965b3 4#
f536906b 5%define pdir Test
6%define pnam Simple
fc1a045f 7Summary: Test::Simple - basic utilities for writing tests
90486546 8Summary(pl.UTF-8): Test::Simple - podstawowe narzędzia do pisania testów
51379aa6 9Name: perl-Test-Simple
d1b9ec6b 10Version: 1.302140
5240b5af 11%define fver %(echo %{version} | tr -d _)
15c3dff6 12Release: 1
23b30915 13# same as perl
14License: GPL v1+ or Artistic
a117f839 15Group: Development/Languages/Perl
5240b5af 16Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
d1b9ec6b
JB
17# Source0-md5: 2a3eba9fbafe80a24ce75b604ab045f1
18URL: https://metacpan.org/release/Test-Simple
44b4b73a 19%{?with_tests:BuildRequires: perl-Test-Harness >= 2.03}
4a2430a6 20BuildRequires: perl-devel >= 1:5.8.0
b20888db 21BuildRequires: rpm-perlprov >= 4.1-13
46ebbc6a
JB
22# see lib/Test/Builder/Tester.pm /VERSION
23Provides: perl-Test-Builder-Tester = %{version}
24# see lib/Test/Tester.pm /VERSION
25Provides: perl-Test-Tester = %{version}
e9c35293
JB
26# see lib/Test/use/ok.pm /VERSION
27Provides: perl-Test-use-ok = %{version}
28# obsolete only versions up to last standalone release to avoid obsoleting perl-modules
29# Test::Builder::Tester 1.01
30# Test::Tester 0.109
31# Test::use::ok 0.11
3b71b361
JB
32Obsoletes: perl-Test-Builder-Tester < 1.02
33Obsoletes: perl-Test-Tester < 0.110
e9c35293 34Obsoletes: perl-Test-use-ok < 0.12
a117f839
SZ
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
aa8c7784 38%define _noautoreq 'perl(threads)' 'perl(threads::shared)'
aa8c7784 39
a117f839 40%description
8a2bd24c
ER
41AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
42me to Detroit, but don't make me write tests!
673d528c 43 -- perldoc Test::Tutorial
fc1a045f 44
81044a38
JB
45Test::Simple is an extremely simple, extremely basic module for
46writing tests suitable for CPAN modules and other pursuits. If you
47wish to do more complicated testing, use the Test::More module (a
48drop-in replacement for this one).
a117f839 49
81044a38
JB
50The purpose of Test::More is to provide a wide range of testing
51utilities. Various ways to say "ok" with better diagnostics,
52facilities to skip tests, test future features and compare complicated
53data structures. While you can do almost anything with a simple "ok()"
54function, it doesn't provide good diagnostic output.
fc1a045f 55
bb31a059 56%description -l pl.UTF-8
8a2bd24c 57AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
bb31a059
JR
58mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
59testów!
673d528c 60 -- perldoc Test::Tutorial
81044a38 61
bb31a059
JR
62Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
63pisania testów pasujących do modułów CPAN i innych. Do bardziej
64skomplikowanych testów lepiej używać modułu Test::More (zastępującego
81044a38
JB
65ten).
66
bb31a059
JR
67Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
68testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
69ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
70porównywaniu skomplikowanych struktur danych. O ile można zrobić
71prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
81044a38 72diagnostycznego.
a117f839
SZ
73
74%prep
5240b5af 75%setup -q -n %{pdir}-%{pnam}-%{fver}
c7067acc 76%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
a117f839
SZ
77
78%build
b20888db 79%{__perl} Makefile.PL \
037eba0e 80 INSTALLDIRS=vendor
a117f839
SZ
81%{__make}
82
ea031d13 83%{?with_tests:%{__make} test}
fa6965b3 84
a117f839
SZ
85%install
86rm -rf $RPM_BUILD_ROOT
87
ea031d13 88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT
a117f839 90
5240b5af 91%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
8a2bd24c 92
a117f839
SZ
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%files
97%defattr(644,root,root,755)
46ebbc6a 98%doc Changes README
68765220 99%{perl_vendorlib}/ok.pm
1125d11b 100%{perl_vendorlib}/Test/Builder
5240b5af
JB
101%{perl_vendorlib}/Test/Builder.pm
102%{perl_vendorlib}/Test/More.pm
103%{perl_vendorlib}/Test/Simple.pm
68765220
AM
104%{perl_vendorlib}/Test/Tester
105%{perl_vendorlib}/Test/Tester.pm
106%{perl_vendorlib}/Test/use
107%{perl_vendorlib}/Test2.pm
108%{perl_vendorlib}/Test2
5240b5af
JB
109%{_mandir}/man3/Test::Builder*.3pm*
110%{_mandir}/man3/Test::More.3pm*
111%{_mandir}/man3/Test::Simple.3pm*
68765220 112%{_mandir}/man3/Test::Tester*.3pm*
5240b5af 113%{_mandir}/man3/Test::Tutorial.3pm*
68765220
AM
114%{_mandir}/man3/Test::use::ok.3pm*
115%{_mandir}/man3/Test2*.3pm*
116%{_mandir}/man3/ok.3pm*
This page took 0.089462 seconds and 4 git commands to generate.