]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blame - perl-Test-Simple.spec
- handle also perl-Test-use-ok merge; release 3
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
CommitLineData
fa6965b3 1#
2# Conditional build:
ea031d13 3%bcond_without tests # do not perform "make test"
fa6965b3 4#
c95e63f0 5%include /usr/lib/rpm/macros.perl
f536906b 6%define pdir Test
7%define pnam Simple
fc1a045f 8Summary: Test::Simple - basic utilities for writing tests
90486546 9Summary(pl.UTF-8): Test::Simple - podstawowe narzędzia do pisania testów
51379aa6 10Name: perl-Test-Simple
68765220 11Version: 1.302062
5240b5af 12%define fver %(echo %{version} | tr -d _)
e9c35293 13Release: 3
23b30915 14# same as perl
15License: GPL v1+ or Artistic
a117f839 16Group: Development/Languages/Perl
5240b5af 17Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
68765220 18# Source0-md5: d869f6754eccc38484da7e21e9c7bbcc
81044a38 19URL: http://search.cpan.org/dist/Test-Simple/
44b4b73a 20%{?with_tests:BuildRequires: perl-Test-Harness >= 2.03}
4a2430a6 21BuildRequires: perl-devel >= 1:5.8.0
b20888db 22BuildRequires: rpm-perlprov >= 4.1-13
46ebbc6a
JB
23# see lib/Test/Builder/Tester.pm /VERSION
24Provides: perl-Test-Builder-Tester = %{version}
25# see lib/Test/Tester.pm /VERSION
26Provides: perl-Test-Tester = %{version}
e9c35293
JB
27# see lib/Test/use/ok.pm /VERSION
28Provides: perl-Test-use-ok = %{version}
29# obsolete only versions up to last standalone release to avoid obsoleting perl-modules
30# Test::Builder::Tester 1.01
31# Test::Tester 0.109
32# Test::use::ok 0.11
3b71b361
JB
33Obsoletes: perl-Test-Builder-Tester < 1.02
34Obsoletes: perl-Test-Tester < 0.110
e9c35293 35Obsoletes: perl-Test-use-ok < 0.12
a117f839
SZ
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
aa8c7784 39%define _noautoreq 'perl(threads)' 'perl(threads::shared)'
aa8c7784 40
a117f839 41%description
8a2bd24c
ER
42AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
43me to Detroit, but don't make me write tests!
673d528c 44 -- perldoc Test::Tutorial
fc1a045f 45
81044a38
JB
46Test::Simple is an extremely simple, extremely basic module for
47writing tests suitable for CPAN modules and other pursuits. If you
48wish to do more complicated testing, use the Test::More module (a
49drop-in replacement for this one).
a117f839 50
81044a38
JB
51The purpose of Test::More is to provide a wide range of testing
52utilities. Various ways to say "ok" with better diagnostics,
53facilities to skip tests, test future features and compare complicated
54data structures. While you can do almost anything with a simple "ok()"
55function, it doesn't provide good diagnostic output.
fc1a045f 56
bb31a059 57%description -l pl.UTF-8
8a2bd24c 58AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
bb31a059
JR
59mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
60testów!
673d528c 61 -- perldoc Test::Tutorial
81044a38 62
bb31a059
JR
63Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
64pisania testów pasujących do modułów CPAN i innych. Do bardziej
65skomplikowanych testów lepiej używać modułu Test::More (zastępującego
81044a38
JB
66ten).
67
bb31a059
JR
68Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
69testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
70ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
71porównywaniu skomplikowanych struktur danych. O ile można zrobić
72prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
81044a38 73diagnostycznego.
a117f839
SZ
74
75%prep
5240b5af 76%setup -q -n %{pdir}-%{pnam}-%{fver}
c7067acc 77%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
a117f839
SZ
78
79%build
b20888db 80%{__perl} Makefile.PL \
037eba0e 81 INSTALLDIRS=vendor
a117f839
SZ
82%{__make}
83
ea031d13 84%{?with_tests:%{__make} test}
fa6965b3 85
a117f839
SZ
86%install
87rm -rf $RPM_BUILD_ROOT
88
ea031d13 89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
a117f839 91
5240b5af 92%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
8a2bd24c 93
a117f839
SZ
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%files
98%defattr(644,root,root,755)
46ebbc6a 99%doc Changes README
68765220 100%{perl_vendorlib}/ok.pm
1125d11b 101%{perl_vendorlib}/Test/Builder
5240b5af
JB
102%{perl_vendorlib}/Test/Builder.pm
103%{perl_vendorlib}/Test/More.pm
104%{perl_vendorlib}/Test/Simple.pm
68765220
AM
105%{perl_vendorlib}/Test/Tester
106%{perl_vendorlib}/Test/Tester.pm
107%{perl_vendorlib}/Test/use
108%{perl_vendorlib}/Test2.pm
109%{perl_vendorlib}/Test2
5240b5af
JB
110%{_mandir}/man3/Test::Builder*.3pm*
111%{_mandir}/man3/Test::More.3pm*
112%{_mandir}/man3/Test::Simple.3pm*
68765220 113%{_mandir}/man3/Test::Tester*.3pm*
5240b5af 114%{_mandir}/man3/Test::Tutorial.3pm*
68765220
AM
115%{_mandir}/man3/Test::use::ok.3pm*
116%{_mandir}/man3/Test2*.3pm*
117%{_mandir}/man3/ok.3pm*
This page took 0.076843 seconds and 4 git commands to generate.