]> git.pld-linux.org Git - packages/perl-Test-Simple.git/blame - perl-Test-Simple.spec
- obsolete only standalone versions of perl-Test-Builder-Tester and perl-Test-Tester...
[packages/perl-Test-Simple.git] / perl-Test-Simple.spec
CommitLineData
fa6965b3 1#
2# Conditional build:
ea031d13 3%bcond_without tests # do not perform "make test"
fa6965b3 4#
c95e63f0 5%include /usr/lib/rpm/macros.perl
f536906b 6%define pdir Test
7%define pnam Simple
fc1a045f 8Summary: Test::Simple - basic utilities for writing tests
90486546 9Summary(pl.UTF-8): Test::Simple - podstawowe narzędzia do pisania testów
51379aa6 10Name: perl-Test-Simple
68765220 11Version: 1.302062
5240b5af 12%define fver %(echo %{version} | tr -d _)
46ebbc6a 13Release: 2
23b30915 14# same as perl
15License: GPL v1+ or Artistic
a117f839 16Group: Development/Languages/Perl
5240b5af 17Source0: http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{fver}.tar.gz
68765220 18# Source0-md5: d869f6754eccc38484da7e21e9c7bbcc
81044a38 19URL: http://search.cpan.org/dist/Test-Simple/
44b4b73a 20%{?with_tests:BuildRequires: perl-Test-Harness >= 2.03}
4a2430a6 21BuildRequires: perl-devel >= 1:5.8.0
b20888db 22BuildRequires: rpm-perlprov >= 4.1-13
46ebbc6a
JB
23# see lib/Test/Builder/Tester.pm /VERSION
24Provides: perl-Test-Builder-Tester = %{version}
25# see lib/Test/Tester.pm /VERSION
26Provides: perl-Test-Tester = %{version}
3b71b361
JB
27# obsolete only versions up to last standalone (Test::Builder::Tester 1.01, Test::Tester 0.109) to avoid obsoleting perl-modules
28Obsoletes: perl-Test-Builder-Tester < 1.02
29Obsoletes: perl-Test-Tester < 0.110
a117f839
SZ
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
aa8c7784 33%define _noautoreq 'perl(threads)' 'perl(threads::shared)'
aa8c7784 34
a117f839 35%description
8a2bd24c
ER
36AHHHHHHH!!!! NOT TESTING! Anything but testing! Beat me, whip me, send
37me to Detroit, but don't make me write tests!
673d528c 38 -- perldoc Test::Tutorial
fc1a045f 39
81044a38
JB
40Test::Simple is an extremely simple, extremely basic module for
41writing tests suitable for CPAN modules and other pursuits. If you
42wish to do more complicated testing, use the Test::More module (a
43drop-in replacement for this one).
a117f839 44
81044a38
JB
45The purpose of Test::More is to provide a wide range of testing
46utilities. Various ways to say "ok" with better diagnostics,
47facilities to skip tests, test future features and compare complicated
48data structures. While you can do almost anything with a simple "ok()"
49function, it doesn't provide good diagnostic output.
fc1a045f 50
bb31a059 51%description -l pl.UTF-8
8a2bd24c 52AAAAAAAA!!! NIE TESTOWANIE! Wszystko tylko nie testowanie! Bijcie
bb31a059
JR
53mnie, biczujcie mnie, wyślijcie do Detroit, ale nie każcie pisać
54testów!
673d528c 55 -- perldoc Test::Tutorial
81044a38 56
bb31a059
JR
57Test::Simple jest bardzo prostym, bardzo podstawowym modułem do
58pisania testów pasujących do modułów CPAN i innych. Do bardziej
59skomplikowanych testów lepiej używać modułu Test::More (zastępującego
81044a38
JB
60ten).
61
bb31a059
JR
62Celem Test::More jest dostarczenie szerokiego zakresu narzędzi do
63testowania. Różne sposoby powiedzenia "ok" z lepszą diagnostyką,
64ułatwienia przy pomijaniu testów, testowaniu przyszłych możliwości i
65porównywaniu skomplikowanych struktur danych. O ile można zrobić
66prawie wszystko prostą funkcją "ok()", nie daje ona dobrego wyjścia
81044a38 67diagnostycznego.
a117f839
SZ
68
69%prep
5240b5af 70%setup -q -n %{pdir}-%{pnam}-%{fver}
c7067acc 71%{__perl} -nli -e 'print unless /^\s+sleep\s+\d+;\s*/' Makefile.PL
a117f839
SZ
72
73%build
b20888db 74%{__perl} Makefile.PL \
037eba0e 75 INSTALLDIRS=vendor
a117f839
SZ
76%{__make}
77
ea031d13 78%{?with_tests:%{__make} test}
fa6965b3 79
a117f839
SZ
80%install
81rm -rf $RPM_BUILD_ROOT
82
ea031d13 83%{__make} install \
84 DESTDIR=$RPM_BUILD_ROOT
a117f839 85
5240b5af 86%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Tutorial.pod
8a2bd24c 87
a117f839
SZ
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%files
92%defattr(644,root,root,755)
46ebbc6a 93%doc Changes README
68765220 94%{perl_vendorlib}/ok.pm
1125d11b 95%{perl_vendorlib}/Test/Builder
5240b5af
JB
96%{perl_vendorlib}/Test/Builder.pm
97%{perl_vendorlib}/Test/More.pm
98%{perl_vendorlib}/Test/Simple.pm
68765220
AM
99%{perl_vendorlib}/Test/Tester
100%{perl_vendorlib}/Test/Tester.pm
101%{perl_vendorlib}/Test/use
102%{perl_vendorlib}/Test2.pm
103%{perl_vendorlib}/Test2
5240b5af
JB
104%{_mandir}/man3/Test::Builder*.3pm*
105%{_mandir}/man3/Test::More.3pm*
106%{_mandir}/man3/Test::Simple.3pm*
68765220 107%{_mandir}/man3/Test::Tester*.3pm*
5240b5af 108%{_mandir}/man3/Test::Tutorial.3pm*
68765220
AM
109%{_mandir}/man3/Test::use::ok.3pm*
110%{_mandir}/man3/Test2*.3pm*
111%{_mandir}/man3/ok.3pm*
This page took 0.099605 seconds and 4 git commands to generate.